כיצד להתקין את חבילות ה- LMDE שלנו תוך 3 שניות

מנצל את המאמר האחרון על מה פרסמתי גיבוי מנטה, אני רוצה להראות לך שלוש דרכים קלות להתקין מחדש את החבילות בהן אנו משתמשים כאשר אנו מתקינים מחדש את LMDE.

למעשה, למעט הטופס הראשון, ניתן להשתמש באחרים גם ב דביאן, כמו ב אובונטו.

התקנה תוך 3 שניות

בְּצוּרָה גְרָפִית.

זו הדרך הכי אוהבת את זה, הכל גרפי ובלי לגעת במסוף. ב LMDE y linuxmint, יש כלי נהדר שנקרא גיבוי מנטה, שבין היתר אנו יכולים להשתמש בו כדי לשמור את החבילות שלנו ובהמשך להתקין אותן מחדש.

במקרה של LMDE, אם אנו מעדכנים את החבילה פיתון מתאים לגרסה 0.8.0, לא נוכל להשתמש גיבוי מנטה בגלל בעיית תלות. היא תחזיר את השגיאה הבאה:

Traceback (most recent call last):
File "/usr/lib/linuxmint/mintBackup/mintBackup.py", line 87, in <module>
class MessageDialog(apt.FetchProgress):
AttributeError: 'module' object has no attribute 'FetchProgress'

אני מקווה שהחבר'ה מ מנטה תקן את זה בקרוב.

דרך הטרמינל.

דרך הקונסולה אנו יכולים לעשות זאת בשתי דרכים, שבסופו של דבר, זהות.

בשני שלבים.

dpkg --get-selections | awk '$2 ~ /^install$/ {print $1}' > lista_de_paquetes.txt

ברגע שיש לנו גישה למאגרים והכל מוגדר ומתעדכן, אנחנו רק צריכים לשים את זה:

cat lista_de_paquetes.txt | xargs sudo aptitude install -y

בשני שלבים.

dpkg --get-selections "*" > /home/user/Desktop/lista_de_paquetes.txt

לאחר ההתקנה מחדש אנו מבצעים זאת:

dpkg --set-selections  < /home/user/Desktop/lista_de_paquetes.txt

ואז אנחנו רצים:

apt-get -u dselect-upgrade

אני חושב שזה מיותר להבהיר שאנחנו חייבים להגדיר את המאגרים בצורה נכונה .. פשוט נכון?


השאירו את התגובה שלכם

כתובת הדוא"ל שלך לא תפורסם. שדות חובה מסומנים *

*

*

  1. אחראי לנתונים: מיגל אנחל גטון
  2. מטרת הנתונים: בקרת ספאם, ניהול תגובות.
  3. לגיטימציה: הסכמתך
  4. מסירת הנתונים: הנתונים לא יועברו לצדדים שלישיים אלא בהתחייבות חוקית.
  5. אחסון נתונים: מסד נתונים המתארח על ידי Occentus Networks (EU)
  6. זכויות: בכל עת תוכל להגביל, לשחזר ולמחוק את המידע שלך.

  1.   אומץ דיג'ו

    או שאתה גם רושם את כל התוכניות שהיו לך בעבר ועושה

    sudo apt-get -y להטמיע את כל החבילות שנמחקו

    אני באמת לא יודע אם ל- LMDE יש מטרה זהה לזה של Linux MInt, להיות מחוץ לקופסה

    1.    אומץ דיג'ו

      * להתקין

  2.   הוקאסיטו דיג'ו

    למרות שזה קצת "מחוץ לנושא", רציתי להזהיר אותך כי המועמדים לשחרור יצאו ב- Linux Mint Debian 201108 עבור GNOME ו- XFCE. אני מקווה שנעשו לא מעט שיפורים ... 🙂

    1.    elav <° לינוקס דיג'ו

      ובכן, כן, מה קורה כשפורסמה הבשורה המצוינת הזו, היינו לא מקוונים .. תודה.

  3.   מיטקו דיג'ו

    בדיוק גיליתי אותך ותודה.
    אתמול התקנתי את ה- LMDE של 64 סיביות ואני מסתדר מצוין, אבל יש לי 2 דברים קטנים לגלות-

    1 - התחבר כשורש במצב גרפי

    2. הגדר את VLC כנגן הווידאו המוגדר כברירת מחדל

    אני חושב שאקבל את זה מלוח הבקרה המועדף על היישומים או על ידי פתיחה עם יישום אחר / שימוש ביישום זה כברירת מחדל. מחובר כשורש.

    עשיתי סודו נאוטילוס למקרה ושום דבר בכלל.

    PS1: ב -64 ביט אם תמצית החבילות עובדת טוב.
    PS2: אני צריך להתקין גם את MAME SDL ואת היין 64 האחרון שעבורו הייתי רוצה ש- PPA יתקיים, מכיוון שהגדרת התוכנה מאוחר יותר אינה מעדכנת אותך אוטומטית.
    PS3: אני משתמש במנהל ההתקן של בטא AMD AMD_Catalyst_Preview_driver_OpenGL_4.2_beta_support_8.88.8-x86.x86_64.run, Cocoon, https://getcocoon.com/, כדי לראות סדרות ממוקמות גיאוגרפיות ב- Firefox, Chrome - שיש להתקין -, Firefox Flash סיוע עם 64 סיביות של Flash, Zindus, Qbittorrent, Opera, סיומת aletras.oxt וסקריפט הקבלה כדי לשלוט במטמון ה- RAM העודף של המשימה. שמגיע גם לתגובה ממך.

    אני מצפה לחלק החמישי של ההדרכה עם הצעות אלה ו / או אחרות

  4.   לאכול עם דיג'ו

    הלו!
    דבר אחד, עלינו לשנות את הקישור הראשון ששולח את המאמר MintBackup לזה: https://blog.desdelinux.net/mintbackup-realiza-un-respaldo-de-tus-paquetes/
    אני לא יודע למה, זה מקשר לספריית משנה "/ wp-content / themes" ...

    1.    KZKG ^ גאארה דיג'ו

      בוצע, תוקן 😉

  5.   נחום דיג'ו

    שלום, מאז הגרסה הקודמת של LMDE amd64 נתקלתי בבעיות עם חבילות ושגיאות שבורות בעת טעינת מאגרים, ניסיתי פתרונות רבים ואף אחד מהם לא עובד ... אני כבר לא יודע מה לעשות, רציתי להתקין את Gnome-shell וזה לא נתן לי כי החבילה מקולקלת. ראיתי איך לפתור את החבילות השבורות עם פקודות כמו: sudo dpkg – purge –force-remove-reinstreq

    ואני מקבל את השגיאה הבאה:

    dpkg: error: – purge דורש לפחות פרמטר שם חבילה אחד

    הקלד dpkg - עזרה בהתקנה והתקנת חבילות [*];
    השתמש ב- dselect או aptitude לניהול חבילות ידידותי יותר;
    הקלד dpkg -עזרה לרשימה של הגדרות ניפוי באגים dpkg;
    הקלד dpkg –force-help לרשימת אפשרויות לכפות על דברים;
    הקלד dpkg-deb –עזרה לעזרה במניפולציה של קבצי .deb;

    אפשרויות המסומנות ב- [*] מפיקות פלט ארוך,
    סנן אותו עם 'פחות' או עם 'יותר'!

    אם מישהו יכול לעזור לי בזה 🙂