הפשט פגיעות של BT המאפשרת להאקרים להתחבר למכשירים סמוכים

התקפה של בלוטות '

פגיעות שנחשפה לאחרונה ב את התקן האלחוטי Bluetooth יכול לאפשר להאקרים להתחבר למכשירים מרחוק באזור מסוים וגישה ליישומי משתמשים.

הפגיעות, נקראת Blurtooth, פורט לפני מספר ימים על ידי גוף התעשייה Bluetooth SIG המפקח על פיתוח התקן. והאם ה- Bluetooth נמצא במיליארדי מכשירים ברחבי העולם, החל מסמארטפונים וכלה במכשירי IoT "האינטרנט של הדברים".

הפגיעות של Blurtooth זה התגלה על ידי חוקרים מ- EPFL École Polytechnique Fédérale de Lausanne ומאוניברסיטת Purdue בשוויץ.

בעולם הטכנולוגיה הצרכנית, הוא משמש בדרך כלל להפעלת חיבורים לטווח קצר למשימות כגון זיווג אוזניות אלחוטיות לטלפון.

אבל Bluetooth תומך גם בהעברת נתונים ארוכת טווח במרחקים של עד כמה מאות מטרים, טווח שהאקרים יוכלו לנצל באמצעות Blurtooth להפעלת התקפות.

הפגיעות מנצלת חולשה באופן בו Bluetooth מאמת את אבטחת החיבורים.

בדרך כלל, על המשתמש לאשר ידנית בקשת חיבור לפני שהמכשיר שלהם מקושר למערכת אחרת, אך Blurtooth מאפשר לעקוף את ההגנה הזו.

מאז האקר או מישהו עם מספיק ידע לנצל את הפגיעות  יכול להגדיר מערכת זדונית כדי להתחזות למכשיר Bluetooth שהמשתמש כבר היה אושרכגון האוזניות האלחוטיות שלהם וגישה ליישומים התומכים ב- Bluetooth במחשב המשתמש.

ההתקפות של Blurtooth מבוססות על תכונת אבטחה מובנית של Bluetooth המכונה CTKD. בדרך כלל, פונקציה זו הוא משמש כדי לעזור להצפין חיבורים. אבל האקר יכול לנצל אותו על מנת להשיג את מפתח האימות עבור מכשיר שאושר בעבר, וזה מה שמאפשר לזייף נקודות קצה לגיטימיות ובכך לעקוף את הצורך של המשתמש לאשר חיבורים נכנסים.

הטווח האלחוטי המוגבל של Bluetooth מפחית את האיום הנובע מפגיעות. שתי המהדורות של הטכנולוגיה המושפעת, אנרגיה נמוכה וקצב בסיסי, תומכות רק בחיבורים למרחקים של עד 300 מטר בערך. אך התמיכה הנרחבת בשתי מהדורות Bluetooth אלה במכשירי הצריכה פירושה שמספר גדול של מסופים עלול להיות פגיע.

גוף התעשייה עבור Bluetooth SIG הצהיר כי חלק מהמכשירים המשתמשים בגרסאות Bluetooth 4.0 עד 5.0 מושפעים. הגרסה החדשה יותר 5.2, שעדיין לא אומצה באופן נרחב, ככל הנראה אינה פגיעה, בעוד שבגרסה 5.1 יש תכונות מובנות מסוימות שיצרני מכשירים יכולים לאפשר לחסום התקפות Blurtooth.

בשורת האבטחה, Bluetooth SIG היא אמרה כי היא "מתקשרת באופן נרחב" לגבי פגיעותם עם יצרני המכשירים כדי להאיץ את תגובת התעשייה. הקבוצה "מעודדת אותם לשלב במהירות את התיקונים הדרושים." עדיין לא ברור מתי התיקונים יהיו זמינים או אילו מכשירים יזדקקו להם.

ה- Bluetooth SIG פרסם ביום שישי את ההצהרה הבאה:

ברצוננו לספק קצת הבהרה לגבי הפגיעות של BLURtooth. ההצהרה הציבורית הראשונית של Bluetooth SIG הצביעה על כך שהפגיעות עלולה להשפיע על מכשירים המשתמשים בגירסאות 4.0 עד 5.0 של מפרט ה- Bluetooth הראשי.

עם זאת, כעת תוקן כדי לציין רק את גרסאות 4.2 ו- 5.0. כמו כן, הפגיעות של BLURtooth אינה משפיעה על כל המכשירים המשתמשים בגרסאות אלה.

כדי להיות פתוח למתקפה, על מכשיר לתמוך גם ב- BR / EDR וגם ב- LE בו זמנית, לתמוך בגזירת מפתח חוצה-הובלה ולמנף מפתחות מציצים ונגזרים באופן ספציפי. הפתרון לבעיה זו מתואר במפרט Bluetooth הבסיסי 5.1 ואילך, ו- Bluetooth SIG המליץ ​​לחברים עם מוצרים פגיעים לשלב שינוי זה בעיצובים ישנים יותר, במידת האפשר.

לבסוף מוזכר שמשתמשים יכולים לעקוב אחרי האם המכשיר שלהם קיבל תיקון להתקפות BLURtooth על ידי בדיקת הערות השחרור של הקושחה ומערכת ההפעלה.  CVE-2020-15802.


תוכן המאמר עומד בעקרונותינו של אתיקה עריכתית. כדי לדווח על שגיאה לחץ כאן.

היה הראשון להגיב

השאירו את התגובה שלכם

כתובת הדוא"ל שלך לא תפורסם. שדות חובה מסומנים *

*

*

  1. אחראי לנתונים: מיגל אנחל גטון
  2. מטרת הנתונים: בקרת ספאם, ניהול תגובות.
  3. לגיטימציה: הסכמתך
  4. מסירת הנתונים: הנתונים לא יועברו לצדדים שלישיים אלא בהתחייבות חוקית.
  5. אחסון נתונים: מסד נתונים המתארח על ידי Occentus Networks (EU)
  6. זכויות: בכל עת תוכל להגביל, לשחזר ולמחוק את המידע שלך.