プログラムの以前のバージョンに戻す方法

ダウングレード信号

多くの場合、パッケージをインストールし、それを更新した後、何らかの理由で新しいバージョンが気に入らないか、単に期待どおりに機能しないことがわかります。 このため、多くの場合、以前のバージョンをインストールする必要がありますが、このために以前のバージョンをアンインストールして再インストールする必要はありませんが、実行することはできます。 ダウングレード、更新前にインストールした以前のバージョンに簡単な方法で戻ります。

このためには、お気に入りのディストリビューションにあるパッケージ管理ツールのいくつかを処理する必要があります。 あなたのディストロがで動作するかどうかに応じて パッケージマネージャー または、ダウングレードプロセスはそれぞれの場合で異なる可能性があります。 そのため、最もよく使用され、よく知られているディストリビューションの場合のいくつかの実用的な例を使用して説明します。 プロセスが単純であり、これらのツールと保存されているパッケージキャッシュを利用できることがわかります。

Arch LinuxおよびArchベース(Pacmanを使用):

Archディストリビューションから、またはそれに基づいて、つまりPacmanパッケージマネージャーを使用して実行する場合の手順は次のとおりです。

ls /var/cache/pacman/pkg/ | grep nombre_paquete

ここで、package_nameは、以前のバージョンに戻すパッケージの名前です。 これが完了すると、キャッシュバージョンが取得され、前のバージョンが見つかったら、Pacmanを使用して再度インストールできます。

sudo pacman -U /var/cache/pacman/pkg/nombre_paquete-version.pkg.tar.xz

OpenSUSEとそれに基づく:

openSUSEとそれに基づくすべてのディストリビューションには、Zypperを使用します。 手順は同じです。最初にキャッシュを検索してから、必要なバージョンをインストールします。

cat /var/log/zypp/history | grep nombre_paquete

sudo zypper -in -f nombre_paquete-version

Debianおよび派生物(APT):

私たちは今、他の大きなグループと一緒に行きます。DebianとUbuntu自体に基づいたディストリビューションで、それに基づいて、たくさんあります。 まず、次のキャッシュバージョンを確認します。

sudo apt-cache showpkg nombre_paquete
そして今、私たちはあなたが望むバージョンをインストールしようとしています。あなたの場合はpackage_nameで、xzは希望のバージョンです(例:7.53)。
sudo apt install nombre_paquete=x.z

お役に立てば幸いです…


記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

コメントを最初に

コメントを残す

あなたのメールアドレスが公開されることはありません。 必須フィールドには付いています *

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。