Debianテストに最新のXfceパッケージをインストールする

最近 私は彼らにコメントしました のいくつかのコンポーネントの最新バージョンをインストールしました Xfce 番号の下で少しずつ出てきているArchlinuxで 4.9 そして、それらは最終バージョンにあるものより前のバージョンになること 4.10

さて、私は今いるので Debianテスト 取り残されたくなかったので、すでにインストールしました。

  • xfce4-パネル 4.9.0
  • xfce4-appfinder-4.9.3
  • libxfce4ui-4.9.0

どのように見てみましょう。

必要なパッケージをインストールします。

にコンパイルするには Debianの これらのパッケージ Xfce いくつかの必要なパッケージをインストールする必要があります。 ターミナルを開いて、次のように配置します。

[コード]

ビルドエッセンシャルlibx11-devpkg-config libxfce4util-dev libgarcon-1-0-dev libxfce4ui-1-dev exo-utils libexo-1-dev libwnck-dev intltool

[/コード]

取り付け

例を挙げる xfce4-appfinder. Xfce4-パネル 例として取り上げません。インストール後、解決中のエラーが発生したため、前のパネルを元に戻す必要がありました。 ただし、手順は他のアプリケーションでも同じです。 これを行うには、ターミナルを開いて次のように入力します。

[コード]

$ wget -c http://archive.xfce.org/src/xfce/xfce4-appfinder/4.9/xfce4-appfinder-4.9.3.tar.bz2
$ bzip2 -dc xfce4-appfinder-4.9.3.tar.bz2 | tar -xv
$ cd xfce4-appfinder-4.9.3

[/コード]

最初に行うことは、ファイルをダウンロードすることです。 次に、それを解凍して、インストールするファイルが配置されているフォルダーに移動します。 次は何ですか?

[コード]

$ ./configure
作る
$ sudo make install

[/コード]

通常、私は次のようにします。

$ ./configure && make && sudo make install

しかし、あなたはより良い 。/設定 パッケージをインストールする必要があるかどうかを確認する前に。 これで十分です。 今、私はパネルで何が起こるかを調べています、それをインストールしたとき、それを実行しようとするとこのエラーが発生しました:

xfce4-panel:シンボルルックアップエラー:xfce4-panel:未定義のシンボル:xfce_panel_plugin_mode_get_type


記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

2コメント、あなたのコメントを残してください

コメントを残す

あなたのメールアドレスが公開されることはありません。 必須フィールドには付いています *

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。

  1.   ギスカード

    これらのパッケージはどのようなニュースをもたらしますか? スクリーンショットを置いて、どのように見えるかを確認できますか?
    ありがとう

  2.   勇気

    Arch hehhehにインストールするのと同じです