LMDE <°LinuxでSynapticに会いましょう

で開始するユーザーの間で最も頻繁な質問のXNUMXつ GNU / Linuxのは、プログラムをインストールまたはアンインストールする方法と、インストールできるパッケージの種類です。 このタスクを実行する最も簡単な方法のXNUMXつを、 シナプス、また、それが何であるか、そしてそれをどのように使用できるかについて簡単に説明します。

通常は Windows、プログラムをインストールするには、拡張子がファイルのファイル .exeファイル そして私達はただ使用する必要があります 次へ»次へ シリアル番号が奇数で、逆のプロセス(アンインストール)の場合は、 コントロールパネル»プログラムの追加/削除.

の場合 GNU / Linuxの、私たちが私たちと呼ぶことができるものもあります .exeファイル もちろん、それらには別の名前と構造があります。 通常、のパッケージのほとんどは GNU / Linuxの それらはリポジトリに格納され、さまざまなツールを使用してそれらを管理します。 おそらく最も人気のある、または知られているのは debファイル。回転数 両方を管理できます シナプス、当初はのインターフェースでした APT.

Synaptic:APTのインターフェース

と連携 シナプス とても簡単です。 インターフェイスは複雑ではなく、新しいユーザーがすべてのオプションを使用または変更する必要はほとんどありません。 一般に、デフォルトで提供されるため、最も一般的なタスクを実行できます。

シナプス 彼のようでした プログラムの追加/削除 de Windows。 その操作のために、私たちは構成している必要があります(の場合 Debianの およびその派生物)ファイル内の、インストールするパッケージが配置されているリポジトリへのパス /etc/apt/sources.list。 そのファイルから、 シナプス パッケージにアクセスするために必要なパスを取得します。

インターフェースを知る。

のインターフェースを追加するのは良いことです シナプス en LinuxMint、とは異なります Debianの。 何らかの理由で LinuxMintボタンは含まれていません すべての更新を確認する。 しかし、インターフェースに戻りましょう。

上部には メニューバー そのうちのいくつかのオプションは後で見ることになります。 もう少し下に、次のボタンがあります。

  • 再充電: パッケージリストを更新します。
  • 適用: パッケージにインストールまたはアンインストールのマークを付けるときは、このボタンを使用して変更を適用します。
  • プロパティ: パッケージの特性、説明、依存関係が表示されます。
  • 検索: 特定のパラメータに従ってパッケージを検索するためのいくつかのオプションを含むダイアログが表示されます。

クイックアクセスボタン

以下に、インターフェースをXNUMXつの列に分割します。 左側は、選択したセクションに応じたオプションです。 ボタンセクションを呼び出します。 セクション、ステータス、オリジン、フィルター、検索結果.

  • セクション: カテゴリ別に整理されたパッケージを表示します。 に関連するパッケージを検索したい場合 Gnomeデスクトップ環境、たとえば、セクションに移動する必要があります Gnomeの.
  • 状態: このセクションでは、アップグレード可能なパッケージ、廃止されたパッケージ、インストールされたパッケージ、または残りのパッケージを確認します。
  • 起源: パッケージの出所(リポジトリ)を表示します。 言い換えれば、彼らはどこから来たのか。
  • フィルター: このセクションでは、特定のフィルターを適用して、さまざまなタイプの情報を取得できます。 壊れたパッケージがここに表示されることを知っておくことが重要です。
  • Resultados de labúsqueda: 正確には、その名前が示すように、検索結果をで表示します シナプス.

シナプスセクション

反対側には、Synapticを介してインストールできるパッケージのリストがあります。 それらのいずれかを選択して右クリックすると、次のような特定のオプションを選択できます。

  • チェックを外す: 以前にパッケージを選択した場合は、パッケージのチェックを外します。
  • インストールを確認してください: インストールするパッケージを確認してください。
  • 再インストールするマーク: それでは、パッケージを選択して再インストールします。
  • 更新するマーク:パッケージにアップデートがある場合は、このオプションで選択します。
  • 削除するマーク:選択したパッケージのみを削除します。
  • 完全に削除するために確認してください:推奨される依存関係を持つ選択したパッケージを削除します。 推奨される依存関係は、残りの構成になります。
  • プロパティ:上部のボタンと同じです。
  • インストールに推奨されるマーク:インストールするパッケージの推奨される依存関係を選択します。
  • インストールを提案するマーク:インストールするパッケージの推奨される依存関係を選択します。

利用可能なパッケージのリスト

その他のオプション

これを知っていると、私たちはすでに一緒に働くことができます シナプス、ただし、リポジトリのソースを変更するなど、他のこともできます。 私たちが使用するミラーが遅いか遅い場合に役立つ何か。 このために私たちは 構成»リポジトリ.

表示されるオプションウィンドウでは、リポジトリを管理するために必要なのは3つのタブだけです。 最初に、で使用するブランチを取得します LinuxMint (メイン、アップストリーム、インポート、バックポート、ロメオ)。 チェック/チェックを外すだけでファイルが編集されます /etc/apt/sources.list.

ソフトウェアの起源

XNUMX番目のタブには、そうでないリポジトリが含まれています ミント、つまり、 サードパーティパッケージ として Debianの PPA de Ubuntuの またはと互換性のある任意のソース LMDE.

サードパーティソフトウェア

また、XNUMX番目のタブでは、自動更新をアクティブにして、実行するたびにアクティブにすることができます。

自動更新

さらに?

あなたがそれを必要とするならば、 シナプス また、を設定する必要があります ネットワークプロキシディストリビューション デフォルトで使用したいもの。 このために私たちは 設定»設定.

について少し説明するには ディストリビューション、ファイルを見ると /etc/apt/sources.list、使用するXNUMXつのレイアウトがあります(色付きのテキストに注意してください)。

deb http://packages.linuxmint.com/ Debianの 主な上流輸入
deb http://ftp.debian.org/debian テスト 主な貢献は無料ではありません
deb http://security.debian.org/ テスト/メインコントリビュートを非フリーで更新
deb http://www.debian-multimedia.org テスト メインの非無料

デフォルトでは、 シナプス 常に最高の分布を取ります。つまり、パケットが入った場合 ピジン 2.8のリポジトリ ミント (Debianの) およびバージョン2.9 Debian(テスト)、プログラムはバージョン2.9のインストールを提案します。

もちろん、これは、次のオプションを使用して使用するディストリビューションを手動で選択した場合に変更できます。 のバージョンを優先する:

ディストリビューションを選択
また、プロキシを使用してhttp経由で接続する場合は、手動で設定することもできます。

ネットワークプロキシ

パッケージを管理し、更新してインストールするためのツールは他にもあります。 Ubuntuの たとえば、あなたの ソフトウェアセンター、そして、 LMDE 非常に似ていますが、特定の方法で シナプス それはより完全です。


記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

2コメント、あなたのコメントを残してください

コメントを残す

あなたのメールアドレスが公開されることはありません。 必須フィールドには付いています *

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。

  1.   ヨナタン

    どうもありがとうございました。真実は私がLinuxを始めたばかりであり、このツールが不可欠であるということです。 彼女をよく知るのは良いことです

  2.   クラロ

    Linux mint 17Quianaが公式サイトからリポジトリを更新しようとするのを防ぐ方法を知る必要があります
    そして、私のsources.listに含まれているのは、Ubuntu 14.04ですでにテストされ、Mintと互換性のある新しい更新アドレスですが、(apt-get update)の場合、次のように表示されます。

    エラー http://ubuntu.mes.edu.cu 信頼できる提案されたInRelease

    エラー http://packages.linuxmint.com qiana InRelease

    エラー http://archive.ubuntu.com 信頼できるInRelease

    エラー http://archive.ubuntu.com trusty-InReleaseを更新します

    エラー http://security.ubuntu.com 信頼できるセキュリティInRelease

    エラー http://ubuntu.mes.edu.cu 信頼できるセキュリティInRelease

    エラー http://ubuntu.mes.edu.cu trusty-InReleaseを更新します

    エラー http://ubuntu.mes.edu.cu 信頼できるInRelease

    エラー http://archive.ubuntu.com 信頼できるRelease.gpg
    「archive.ubuntu.com」を解決できませんでした
    エラー http://security.ubuntu.com trusty-security Release.gpg
    「security.ubuntu.com」を解決できませんでした
    エラー http://ubuntu.mes.edu.cu 信頼できる提案されたRelease.gpg
    「ubuntu.mes.edu.cu」を解決できませんでした
    エラー http://packages.linuxmint.com qiana Release.gpg
    「packages.linuxmint.com」を解決できませんでした
    エラー http://ubuntu.mes.edu.cu trusty-security Release.gpg
    「ubuntu.mes.edu.cu」を解決できませんでした
    エラー http://ubuntu.mes.edu.cu 信頼できる更新Release.gpg
    「ubuntu.mes.edu.cu」を解決できませんでした
    エラー http://archive.ubuntu.com 信頼できる更新Release.gpg
    「archive.ubuntu.com」を解決できませんでした
    エラー http://ubuntu.mes.edu.cu 信頼できるRelease.gpg
    「ubuntu.mes.edu.cu」を解決できませんでした
    エラー http://extra.linuxmint.com qiana InRelease

    エラー http://extra.linuxmint.com qiana Release.gpg
    「extra.linuxmint.com」を解決できませんでした
    エラー http://archive.canonical.com 信頼できるInRelease

    エラー http://archive.canonical.com 信頼できるRelease.gpg
    「archive.canonical.com」を解決できませんでした
    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/InRelease

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/InRelease

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/InRelease

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/InRelease

    W:取得できません http://packages.linuxmint.com/dists/qiana/InRelease

    W:取得できません http://extra.linuxmint.com/dists/qiana/InRelease

    W:取得できません http://archive.ubuntu.com/ubuntu/dists/trusty/InRelease

    W:取得できません http://archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease

    W:取得できません http://security.ubuntu.com/ubuntu/dists/trusty-security/InRelease

    W:取得できません http://archive.canonical.com/ubuntu/dists/trusty/InRelease

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/Release.gpg 「ubuntu.mes.edu.cu」を解決できませんでした

    W:取得できません http://packages.linuxmint.com/dists/qiana/Release.gpg 「packages.linuxmint.com」を解決できませんでした

    W:取得できません http://archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg 「archive.ubuntu.com」を解決できませんでした

    W:取得できません http://archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg 「archive.ubuntu.com」を解決できませんでした

    W:取得できません http://security.ubuntu.com/ubuntu/dists/trusty-security/Release.gpg 「security.ubuntu.com」を解決できませんでした

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/Release.gpg 「ubuntu.mes.edu.cu」を解決できませんでした

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/Release.gpg 「ubuntu.mes.edu.cu」を解決できませんでした

    W:取得できません http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/Release.gpg 「ubuntu.mes.edu.cu」を解決できませんでした

    W:取得できません http://extra.linuxmint.com/dists/qiana/Release.gpg 「extra.linuxmint.com」を解決できませんでした

    W:取得できません http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg 「archive.canonical.com」を解決できませんでした

    W:一部のインデックスファイルのダウンロードに失敗しました。 それらは無視されているか、古いものが代わりに使用されています。
    E:ロックできませんでした/ var / lib / dpkg / lock-open(11:リソースが一時的に利用できません)
    E:管理ディレクトリ(/ var / lib / dpkg /)をロックできませんでした。他のプロセスが使用している可能性がありますか?

    ***************この問題を解決する方法は? **************************
    助けてください