ScribusをDebianJessie / Sidにインストールする[エラーlibtiff4]

こんにちは友人、私はしばらくの間GNU / Linuxユーザーであり、私のお気に入りのプログラムのXNUMXつは Scribusの、しかし私が最後にフォーマットしてから Debianの、私はそれを見るまで、それをインストールするタスクを自分自身に与えていませんでした ホセロッドの記事。 だから今日はあなたとどのように共有したい Debian Jessie / SidにScribusをインストールする libtiff5ライブラリを使用します。

問題

さて、要点まで、私はプロセスを開始するために自分のsources.listをチェックし始めました:

debhttp://debian.scribus.net/debian/テストメインdebhttp://debian.tagancha.org/debian/テストメインdeb-srchttp://debian.scribus.net/debian/テストメインdeb-src http://debian.tagancha.org/debian/メインのテスト

パッケージを確認してください 「Scribus-archive-keyring」 インストールされました。

そして私は走った:

$ sudo aptitude install scribus icc-profiles

それが私に返したもの:

次の新しいパッケージがインストールされます:icc-profiles icc-profiles-free {a} libhyphen0 {a} libpodofo0.9.2 {ab} scribus {b} 0個の更新されたパッケージ、5個の新しいパッケージがインストールされ、0個が削除され、0個が更新されません。 50.7MBのファイルをダウンロードする必要があります。 開梱後、99.6MBが使用されます。 次のパッケージの依存関係は満たされていません:libpodofo0.9.2:依存関係:libtiff4(> 3.9.5-3〜)ですが、インストールできません。 scribus:依存:libtiff4(> 3.9.5-3〜)ですが、インストールできません。 次のアクションにより、これらの依存関係が解決されます。現在のバージョンで次のパッケージを保持します。1)libpodofo0.9.2 [インストールされていません] 2)scribus [インストールされていません]このソリューションを受け入れますか? [Y / n / q /?] Qこれらの依存関係を解決するためのすべての努力を放棄するキャンセル。

痛い! … それは痛い

少し調べて、 Scribusの ライブラリに依存します libtiff4(3.9.7-3)、これは、私のシステムでは、 廃止されたライブラリ、バージョンをインストールしたので libtiff5(4.0.3-9)

DebianにScribusをインストールする:Libff4廃止

DebianにScribusをインストールする:Libff4廃止

リポジトリを変更してみてください...

deb http://debian.scribus.net/debian/不安定なメインdebhttp://debian.tagancha.org/debian/不安定なメインdeb-srchttp://debian.scribus.net/debian/不安定なメインdeb-src http://debian.tagancha.org/debian/不安定なメイン

…しかし、それは役に立たなかった。 ScribusをDebianにインストールする方法

解決。 簡単、 見える 私はのパッケージが Scribusの パラ Debian シド に依存します libtiff5 (libtiff4からではありません ???? )、それから私はパッケージをダウンロードしました scribusscribus-templateとscribus-ng から packages.debian.org:

さて、インストールする時が来ました スクリバス* .deb、 私の場合:

$ dpkg -i scribus_1.4.2.dfsg.3 + r18267-2_amd64.deb以前に選択されていないscribusパッケージを選択します。 (データベースの読み取り... 162350 1.4.2ファイルまたはディレクトリが現在インストールされています。)scribus_3.dfsg.18267 + r2-64_amd1.4.2.debを解凍する準備をしています... scribus(3.dfsg.18267 + r2-0)を解凍しています)... dpkg:依存関係の問題によりscribusの構成が妨げられます:scribusはlibhyphen2.7.1(> = 0)に依存します。 ただし、 `libhyphen0.9.0 'パッケージはインストールされていません。 scribusはlibpodofo0.9.0に依存します。 ただし、パッケージ `libpodofoXNUMX 'はインストールされていません。
最後の間違い

必要 libhyphen0 y libpodofo0.9.0、したがって、適性からそれらをインストールした後:

$ dpkg -i scribus_1.4.2.dfsg.3 + r18267-2_amd64.deb $ dpkg -i scribus-template_1.2.4.1-2_all.deb $ dpkg -i scribus-ng_1.4.0.dfsg + r17300-1_all.deb

完了...プログラムを実行します Scribusの

Scribusの

Scribusの

注:パッケージの名前は、パッケージをダウンロードするときのアーキテクチャによって異なります。 ここで

記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

7コメント、あなたのコメントを残してください

コメントを残す

あなたのメールアドレスが公開されることはありません。 必須フィールドには付いています *

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。

  1.   ホセロッド

    これは編集に非常に適したツールです。

    ちなみに、バッテリーは限界です! 😛

  2.   Debianist

    Scribusをインストールするのはとても面倒ですか?? !!。 通常のDebianリポジトリ(stable、testing、sid、それは問題ではありません、scribusはそれらすべてに含まれています)を持ってapt-getscribusを実行するのは簡単ではなかったでしょう??? !!!! 多くのリポジトリを混合するときは注意してください...そうすると、これらのことが起こります。

    1.    いくつかのXNUMXつ

      私は同じことを考えていました🙂

    2.    ローダー

      この記事は公開されるべきではなかったので、後でインストールされた廃止されたライブラリの表示をサポートできなくなった場合でも、安定したDebianになります...

    3.    eliotime3000

      それはたまたまこれらのプログラムの最新バージョンにはまっています(皮肉なことに、DebianJessieはScribusとDebianSIDで最新であるため、表示されるこのエラーは、両方のパッケージバージョンに冗長性があることを意味しますrepos)。

      1.    ローダー

        すでに言ったように、debian安定版がやや古いバージョンを持つことをサポートしていない場合はどうなりますか?...リポジトリの混合は言うまでもなく、それが災害の鍵です。

  3.   m

    そして... Debian。