[Archlinux] GRUB Legacy აღარ არის მხარდაჭერილი

GRUB 2

გუშინ გამოცხადდა ArchLinux– ის ახალი ამბების გვერდირომ GRUB 2.x საცავში იყო გადატანილი [ძირითადი], Სად არის ძირითადი პაკეტები არჩლინუქსის მიერ. ამრიგად GRUB Legacy მხარდაჭერა (ვერსია 0.9x) დამთავრდა, და პაკეტი გადაიტანეს აურა (არქის მომხმარებელი საცავი).

გაითვალისწინეთ რომ თუ გაქვთ GRUB Legacyდა დაინსტალირებულს შეუძლია გააგრძელოს მისი გამოყენება პრობლემების გარეშესტაბილურია ბოლოს და ბოლოს), მაგრამ გუნდი არჩლინუქსი გირჩევთ განაახლოთ GRUB-2ან ცვლილება სხვის ერთს ბულდოადერები რომ ჯერ კიდევ აქვთ მხარდაჭერა. თუ არა, მე ვაპირებ გამოვიყენო LILO ან Syslinux ¬¬ ».

მომხმარებლებს სთხოვენ კონსულტაციები la GRUB სექცია წელს Arch Wikiდან დეტალური ინსტალაციის ინსტრუქციები.

ისე, წინასწარ ამას გეუბნები ტესტი უკვე გავაკეთე GRUB 2-ითდა იარე არანაირი პრობლემა. მე გიტოვებთ განახლების ძირითად ინსტრუქციას GRUB-2.

პირველი ჩვენ უნდა დააინსტალირეთ GRUB 2. ამისათვის ჩვენ ვიყენებთ როგორც root:

pacman -S grub-bios

ეს შეამჩნევთ, რომ ეს გამოწვეულია წაშალეთ GRUB Legacy რადგან ის ეწინააღმდეგება GRUB-2. ინსტალაციის დასრულებისას უნდა შევასრულოთ ეს ბრძანება:

pacman -S os-prober

Გვჭირდება os- პრობერი ამისთვის GRUB-2 აღიაროს სხვა ოპერაციული სისტემები, როგორიცაა Windows, მაგალითად. ამის გასაშვებად შემდეგია:

grub-mkconfig -o /boot/grub/grub.cfg

ეს შექმნის კონფიგურაციის ფაილს GRUB-2. გასასვლელში დარწმუნდი რა ჩანს ყველა თქვენი სისტემა. ბოლოს, ჩვენ დავაყენებთ GRUB-2 in MBR ბრძანებით:

grub-install /dev/sda

თუ თქვენს შემთხვევაში ასე არ არის sda (კარგია, როგორც წესი, ასეა), აირჩიე შესაბამისი დისკი.

დღეს ყველაფერია. გნახავ


სტატიის შინაარსი იცავს ჩვენს პრინციპებს სარედაქციო ეთიკა. შეცდომის შესატყობინებლად დააჭირეთ ღილაკს აქ.

16 კომენტარი დატოვე შენი

დატოვე კომენტარი

თქვენი ელფოსტის მისამართი გამოქვეყნებული არ იყო. აუცილებელი ველები აღნიშნულია *

*

*

  1. მონაცემებზე პასუხისმგებელი: მიგელ ანგელ გატონი
  2. მონაცემთა მიზანი: სპამის კონტროლი, კომენტარების მართვა.
  3. ლეგიტიმაცია: თქვენი თანხმობა
  4. მონაცემთა კომუნიკაცია: მონაცემები არ გადაეცემა მესამე პირებს, გარდა სამართლებრივი ვალდებულებისა.
  5. მონაცემთა შენახვა: მონაცემთა ბაზა, რომელსაც უმასპინძლა Occentus Networks (EU)
  6. უფლებები: ნებისმიერ დროს შეგიძლიათ შეზღუდოთ, აღადგინოთ და წაშალოთ თქვენი ინფორმაცია.

  1.   გადი დიჯო

    GRUB2, ჩემი აზრით, გაცილებით ნაკლებია ჩხუბი, ვიდრე მისი წინამორბედი და მისი კონფიგურაციისთვის კარგი ინტერფეისებია. საინტერესოა, რომ არჩს, რომელიც ყოველთვის ჭრის პირას, ჯერ ოფიციალურად არ გამოუყენებია.

  2.   ელემენტი ნულოვანი (მგელი) დიჯო

    ისე, მე მათ შორის ვარ, ვინც Grub Legacy- ს სიმარტივეს ამჯობინებს. პირადად მე მას ისე დავტოვებ, როგორც არის.

  3.   იბრძოდა დიჯო

    ბევრად უფრო მომწონს ბურგი იმის გამო, რომ ის მხარს უჭერს თემებს და მეტ პერსონალიზაციას

  4.   ვპგაბრიელი დიჯო

    ამის დრო დადგა თაღთან.

  5.   სათანადო დიჯო

    GRUB Legacy საუკეთესო xD

    1.    msx დიჯო

      თქვენ წარმოდგენა არ გაქვთ.
      Arch ჰგავს Debian– ის ან Gentoo– ს მინიმალურ ინსტალაციას: თქვენ აყენებთ მინი ბირთვს და იქიდან აშენებთ თქვენს სისტემას. ამ პარადიგმის შემდეგ, თუ გჭირდებათ უფრო მძლავრი / სრული ჩამტვირთავი დაყენება, ამას გააკეთებთ თქვენი სურვილისამებრ: შეგიძლიათ დააყენოთ GRUB2, SysLinux ან ნებისმიერი სხვა.
      სიმართლე ისაა, რომ მე არ გავყევი დისკუსიას Legacy- ის ჩანაცვლებაში GRUB2- ის ჩართვის შესახებ, ასე რომ, ვერ ვილაპარაკებ ამ ცვლილების მიზეზებზე, მაგრამ გამაოცა, რომ მათ ეს გააკეთეს, ალბათ თვლიან, რომ დროა უფრო თანამედროვე bootloader .
      ამასთან, როგორც ზემოთ აღვნიშნეთ, GRUB Legacy- ის სიმარტივეს არაფერი ცვლის.

      იცით GRUB2 სიღრმისეულად? ეს sucks, ეს არის ოპერაციული სისტემა თავისთავად, და თავზე მახინჯი და გააკეთა ყველაზე რთული გზა, ჩვენ არ გვსურს ეს.

      GRUB2– ის გამოყენების მხოლოდ ორ მიზეზს ვფიქრობ:
      1. თქვენი აპარატურის კონფიგურაციას არ უჭერს მხარს Legacy, ამიტომ გჭირდებათ GRUB2, რომელიც თანამედროვე და მოდულურია, მხარს უჭერს ყველა სახის ტექნიკასა და პროგრამულ უზრუნველყოფას.
      2. დისტრო საბოლოო მომხმარებლისთვისაა და გსურთ საწყისი მენიუ გქონდეთ სულელური მისასალმებელი აჟიოტაჟით და ყველა იმ საგნით, რაც ხალხს მოსწონს.

      გარწმუნებთ, რომ GRUB99 SOBRA– ს სახლის / კერძო ობიექტების 2% -ში - ასე რომ, დიდი ასოებით - Legacy ან თუნდაც ლილო ბრწყინვალედ ასრულებენ თავიანთ მისიას.

      სამწუხაროა მხოლოდ ის, რომ მათ გადაწყვიტეს GRUB2 გამოიყენონ Syslinux– ის ნაცვლად, რომელიც შესანიშნავი ჩატვირთვისაა.

      1.    msx დიჯო

        წინა პოსტი არის @wpgabriel- ისთვის, დამავიწყდა, რომ სისტემა, რომელსაც FromLinux იყენებს, ახლის ბოლოს ახარისხებს ახალ ჩანაწერებს პასუხის ნაცვლად

  6.   Chango დიჯო

    მე მომწონს grub2, ის ავტომატიზირებს უამრავ დავალებას, მაგრამ მე მიყვარს ჩემი დისტრიბუცია ლილოთი და მისი "lilosetup" GUI- ით. მარტივი, მსუბუქი და სწრაფი. მეჩვენება, რომ "უკანასკნელი" არ არის საინტერესო პარამეტრი სტაბილური, ფუნქციონალური ძებნისას და ეს არ იყენებს ბოროტად გამოყენებულ რესურსებს (ამ უკანასკნელისგან გამორიცხული bootleaders). რატომ არის ნოსტალგია მაგალითად Gnome2 და KDE 3.5?

    1.    სათანადო დიჯო

      მე ასევე გამოვიყენე LILO (Slackware– ში ეს ნაგულისხმევია) მანამ, სანამ არ მინდოდა სხვა დისტრიბუციების დაყენება და LILO– ს ჰქონდა შეცდომა სახელწოდებით "გრძელი" ბირთვები, მე ვიპოვნე პატჩი, შევეცადე დამეპატარა, არ შემეძლო დრო არ მქონდა იმის დანახვა, თუ რატომ არ იმუშავა და მე მარტივი გზა დავაყენე GRUB Legacy და პრობლემა მოგვარდა :)

      1.    Chango დიჯო

        დღეს ეს პრობლემა შემექმნა, ბლოგში წავიკითხე, რომ თქვენს მიერ ნახსენები შეცდომა მოგვარებულია ახალი ვერსიით (23.2). იმის ნაცვლად, რომ პირდაპირ patch- ზე მე შევქმენი ახალი პაკეტი SalixOS slkbuild- ით, და lilo- ს განახლების შემდეგ, მე გადავაყენე ჩატვირთვისას lilosetup და voila. ცხადია, იგი იგივე მუშაობს, თუ ამის გაკეთება გსურთ lilo -v ბრძანებით. თუ თქვენ დაინტერესებული ხართ, შეგიძლიათ მიიღოთ სკრიპტი: http://salix.enialis.net/x86_64/13.37/source/a/lilo/

        მე მომწონს lilo რადგან lilosetup– ით ადვილად ვაყენებ კონფიგურაციას ჩემთვის საჭირო მასალის გარეშე, მასალის გარეშე, რასაც grub ამატებს (როგორიცაა უსაფრთხო რეჟიმი ან მეხსიერების ტესტის საშუალებები, რომლებიც თითქმის არასდროს გამოიყენება). მე მესმის თქვენი: grub legacy და grub2 აცდუნებთ ავტომატიკას, განსაკუთრებით კონფლიქტურ ფანჯარასთან $ 7 და მისი მტვირთავით ...

        1.    Chango დიჯო

          უი! დამავიწყდა გითხრათ, რომ ამ მორგებული პაკეტის მისაღებად გჭირდებათ lilo- ს ახალი ვერსია, რომელშიც მიიღებთ:

          ftp://ftp.slackware.at/slackware64-current/slackware64/a/lilo-23.2-x86_64-1.txz

          და გახსოვდეთ, რომ შეცვალეთ 22.8-დან 23.2-მდე slkbuild- ში. თუ გჭირდებათ 32 ბიტიანი ვერსია, გადმოწერთ მას შესაბამისი მიმდინარე რეპოდან და თუ შეცვლით slkbuild– ს შესაბამისი არქიტექტურით.

          1.    სათანადო დიჯო

            მე უკვე მოშორებული ვიყავი Slackware- ს, მაგრამ სასიამოვნოა იმის ცოდნა, რომ ახალი ვერსიის პაკეტი აღარ არის.

            ულოცავენ.

  7.   kik1n დიჯო

    აღსანიშნავია, რომ ახალი Arch iso გამოვიდა და ახალი ამბებით

  8.   რძიანი28 დიჯო

    ისე, როგორც მე ვხედავ უმარტივეს ვარიანტს, თქვენ თქვით, მე ეს სახელმძღვანელო გავაკეთე, მაგრამ ვიკი კარგად არის ინფორმირებული.
    ულოცავენ.

  9.   ელექტრონი 222რუკო 22 დიჯო

    ჩაკრაში საცავებში ტესტირება უკვე შესაძლებელია და ის განახლდა უპრობლემოდ

  10.   ელენა დიჯო

    ეჭვი მეპარებოდა, მაგრამ ამის გაკეთება ჩემთვის ძალიან ადვილი იყო! მისალმება! ^^