AceStream-ді Linux-қа қалай орнатуға болады және өліп қалмай

Бізде спортты жақсы көретіндер және қазіргі кездегі барлық спорттық арналарды көре алмайтындар үшін, әдетте, оны тамашалау үшін әртүрлі парақтарды пайдалану керек. онлайн матчтар, олардың көпшілігі сұрайды AceStream орнатыңыз, ол Linux-те орнату үшін біршама күрделі болады.

Бұл нұсқаулықта біз қалай үйретеміз Linux-те AceStream орнатыңыз талпынудан өлмей, қазіргі кездегі ең көп кездесетін мәселелердің шешімдерін бере отырып. Оны пайдалану және сіз қол жеткізетін мазмұн сіздің толық жауапкершілігіңізде.

AceStream дегеніміз не?

AceStream Бұл а мультимедиялық платформа Интернеттегі аудиовизуалды репродукцияны жоғары деңгейге шығарған жеткілікті инновациялық. Ол үшін мультимедиялық файлдарды жүктеудің әмбебап менеджері енгізілді, ол P2P технологияларын қолданады, деректерді сақтау мен берудің тиімді процесіне кепілдік береді.

Ace Stream бағдарламалық жасақтамасы бізге бірнеше артықшылықтар ұсынады, оларда мыналарды атап өтуге болады:

  • Аудио және сурет сапасы жоғары онлайн-хабарларды (теледидарлар, жекелеген ағындар, фильмдер, мультфильмдер және т.б.) қарау мүмкіндігі.
  • Интернетте музыканы ешқандай сапасын жоғалтпайтын форматта тыңдаңыз.
  • Торренттерді желіден қараңыз, оның толық жүктелгенін күтудің қажеті жоқ.
  • Қашықтағы құрылғылардағы (Apple TV, Chromecast және т.б.) мазмұнды AirPlay, Google Cast және басқалары сияқты байланыс протоколдары арқылы қарау.
  • Әр түрлі қосымшалармен интеграциялауға мүмкіндік береді. Linux-те AceStream орнатыңыз

AceStream-ді Linux-қа қалай орнатуға болады

AceStream-ді Linux-қа орнату үшін сіз қолданатын дистрофияға байланысты әр түрлі қадамдарды орындау керек, біз Arch Linux және Ubuntu-ға назар аударамыз, бірақ болашақта оны басқа дистрибьюторларға орната аламыз деп үміттенеміз.

Arch Linux және туынды құралдарына AceStream орнатыңыз

Бұл мақаланы жасауымның басты себебі: көптеген адамдар AceStream-ді Arch Linux, Antergos, Manjaros және туындыларына орнатуда қиындықтарға тап болды, басты себебі плагиннің pkgbuild acestream-mozilla-плагин Орнату кезінде қате пайда болады, шешім өте қарапайым.

Біз орнатамыз acestream-mozilla-плагин ол бізді де орнатады аксестрим қозғалтқышы y ағынды ойыншы туралы деректер көбею үшін қандай пакеттер қажет? Firefox-тан AceStream.

Алдымен біз терминалды ашып, келесі команданы орындауымыз керек:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Ол орнату үшін қажет тәуелділікті орнатуға жол бермейтін тексеру мәселесін шешеді acestream-mozilla-плагин.

Содан кейін біз келесі команданы орындаймыз

yaourt -S acestream-mozilla-plugin

Бірнеше рет бізден әртүрлі тәуелділіктер орнатқыңыз келетін-келмейтіні сұралады, бәріне «иә» деп жауап беру керек.

AceStream-ді Ubuntu және туынды құралдарына орнатыңыз

AceStream-ді Ubuntu 14.04 және туынды құралдарына орнатыңыз

Ubuntu және оның туындыларын 14.04 нұсқасына дейін қолданушылар үшін AceStream-ті орнату өте қарапайым болады, олар тек келесі командаларды терминалдан орындайды:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get жаңарту sudo apt-get install acestream-full

AceStream-ді Ubuntu 16.04 және туынды құралдарына орнатыңыз

Сәл көп күресуге тура келетіндер Ubuntu 16.04 және туындыларын қолданады, өйткені acestream бұл нұсқаны қолдамайды, бірақ осының арқасында мақала, Мен оны орната алдым.

Алдымен біз ресми репозиторийлерден жүктей алмайтын кейбір тәуелділіктерді жүктеп, орнатамыз, дистрибьюторыңыздың архитектурасына сәйкес келетіндерін орнатыңыз:

64 биттік сәулет:

  1. Жүктеп алыңыз және орнатыңыз libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb мұны келесі сілтеме арқылы жасауға болады: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Келесі тәуелділіктер көрсетілген ретпен жүктеп алыңыз және орнатыңыз:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Сіз әрқайсысын келесі сілтемеден жүктей аласыз: https://drive.google.com/folderview?id= … e_web#list

32бит сәулеті:

  1. Жүктеп алыңыз және орнатыңыз libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb мұны келесі сілтеме арқылы жасауға болады: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Келесі тәуелділіктер көрсетілген ретпен жүктеп алыңыз және орнатыңыз: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Сіз әрқайсысын келесі сілтемеден жүктей аласыз: https://drive.google.com/folderview?id= … e_web#list

Содан кейін біз 14.04 нұсқасы сияқты AceStream-ді әдеттегідей орнатуды жалғастыруымыз керек, терминал ашып, іске қосамыз:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get жаңарту sudo apt-get install acestream-full

Кейбір жағдайларда қызметті бастау қажет acestream-engine.service, бұл үшін біз терминалдан келесі командаларды орындаймыз:

systemctl acestream-engine.service іске қосу systemctl acestream-engine.service қосыңыз

Осы оқулық арқылы сіз P2P технологиясының барлық мүмкіндіктерін пайдаланатын мультимедиялық жіберудің керемет хаттамасынан ләззат аласыз деп үміттенеміз.


Мақаланың мазмұны біздің ұстанымдарымызды ұстанады редакторлық этика. Қате туралы хабарлау үшін нұқыңыз Мұнда.

41 пікір, өз пікіріңізді қалдырыңыз

Пікіріңізді қалдырыңыз

Сіздің электрондық пошта мекен-жайы емес жарияланады. Міндетті өрістер таңбаланған *

*

*

  1. Деректерге жауапты: Мигель Анхель Гатан
  2. Деректердің мақсаты: СПАМ-ны басқару, түсініктемелерді басқару.
  3. Заңдылық: Сіздің келісіміңіз
  4. Деректер туралы ақпарат: заңды міндеттемелерді қоспағанда, деректер үшінші тұлғаларға жіберілмейді.
  5. Деректерді сақтау: Occentus Networks (ЕО) орналастырған мәліметтер базасы
  6. Құқықтар: Сіз кез-келген уақытта ақпаратты шектей, қалпына келтіре және жоя аласыз.

  1.   Хулио Сезар Кампосы дижо

    Жазба, бірақ, ең болмағанда, Archlinux-те, бұл сізге қажет: «systemctl start acestream-engine.service» және «systemctl acestream-engine.service-ті жұмыс істейді».

    1.    лагарто дижо

      Сіз оны firefox-тан тексердіңіз бе, әлде басқа браузер қолдандыңыз ба?

  2.   UserDebian дижо

    Оны Debian 9-да қалай жұмыс істеуге болатындығын білетін адам бар ма?

  3.   Хулио Сезар Кампосы дижо

    Archlinux-тағы Firefox

  4.   гекокс дижо

    Алдыңғы пікірім жарияланған-шықпағанын білмеймін ... қайталаймын! Терминалда лақап команданы қанша сағатта орындайтынымды білмеймін, мен -noconfirm қоямын, ал соңында ол жұмыс істемейді !!
    пайдасыз басқа жазба!

    Манжароға орнату әрекеті

    1.    лагарто дижо

      Құрметті, ол сізге жұмыс істемеді, ол мен үшін өте жақсы жұмыс істеді, бәрібір мына 2 команданы орындап көріңіз:
      «Systemctl start acestream-engine.service» және «systemctl acestream-engine.service-ті қосады»

  5.   Жозе дижо

    жақсы

    Мен барлық қадамдарды қиындықсыз орындадым. Қызметті терминалдан бастауға тырысқанда, ол маған екі сәтсіздік әкелді;
    systemctl acestream-engine.service іске қосу
    Acestream-engine.service іске қосылмады: acestream-engine.service бірлігі табылмады.
    systemctl acestream-engine.service мүмкіндігін қосыңыз
    Операция орындалмады: Мұндай файл немесе каталог жоқ

    1.    густаво дижо

      Дәл осындай жағдай менің басымда болды. терминал маған сол командаларды сол сәтсіздіктермен бірге жібереді.

  6.   Хуан М. дижо

    Пост үшін үлкен рахмет! Егер сіз Ubuntu 16.10 64 битін қолдансаңыз, сіз «acestream-player-data_3.0.2-1.1_amd64.deb» бағдарламасын орната алмайсыз. Олар алдымен мына пакеттерді жүктеп, орнатуы керек:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Мүмкін, репостағы басқа тәуелділік қажет.
    Рахмет!

  7.   Miles дижо

    Жақсы.
    Acestream-mozilla-плагині көптеген басқа NPAPI плагиндері сияқты Firefox 52-де жұмысын тоқтатты.

  8.   дарко дижо

    Тағы бір өте жақсы және қарапайым нұсқа - докерді пайдалану және амалдық жүйенің агностикасы болу. Ацепроксияны қолдану арқылы сіз оны көбейте аласыз -

    Мен орындалуын жеңілдету үшін шағын оқулық пен сценарий жаздым.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   Дэвид Мартин дижо

    Оны Ubuntu 16.04-тен орнату бөлігінде, сол файлдарды жүктеңіз және орнатыңыз дегенде, олар қалай орнатылады? Оларды жүктегенде және шығарған кезде, кейбіреулері тек libreoffice типіндегі файл, ал басқалары оларды қалай «орнатуды» білмеймін.
    Алдын ала рахмет және сәлем.
    Давид.

  10.   вафе дижо

    Не пернелер қайтадан жұмыс істемейді, немесе пакеттерде қате бар, бірақ arch және manjaro-да оны орнату мүмкін емес.
    Тәуелділікті (qwebquit) немесе осыған ұқсас нәрсені орнатуға тырысқанда, ол циклге енеді және амал жоқ.
    Шешімін біреу тапты?
    Gracias

    1.    Алехандро дижо

      Сәлеметсіз бе, arch Linux жүйесінде орнату үшін сіз келесі әрекеттерді орындауыңыз керек:
      - 'acestream-launcher' пакетін Yaourt-дан 'yaourt -S acestream-launcher' көмегімен орнатыңыз (біз бұдан әрі қосатын пакет сізге автоматты түрде жүктеледі)
      - Acestream-engine.service қосыңыз, біз терминалға кіреміз және ROOT режимінде келесілерді қоямыз
      -systemctl іске қосу acestream-engine.service
      -systemctl acestream-engine.service мүмкіндігін қосады
      Осыдан кейін компьютерді қайта іске қостым, қажет болатынын білмеймін, бірақ мүмкін болған жағдайда
      -Бұл жеткілікті болуы керек, бірақ Arch-дің соңғы жаңартуларында олар бір нәрсені бұрап тастады және ол жұмыс істемейді, сондықтан олар уақытша шешім іздеді, яғни файлды жүктеп алу, бұл келесі:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      Дерек көзі: https://aur.archlinux.org/packages/acestream-launcher/ (түсініктемелер бойынша)
      жүктелгеннен кейін, біз терминалға барып, оны жүктеген қалтаға барамыз,
      Біз оны 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz' көмегімен орнатамыз, осымен жүру керек, бірінші рет ешқашан болмайды, сондықтан мен екінші рет басамын, бірінші рет әрқашан қате жібереді, бәрі сол

      PS: sudo pacman -U және -S емес екенін түсіндіріңіз, себебі бұл makepkg-ден алынған жергілікті пакет.

      1.    вафе дижо

        Қызығушылығыңыз үшін көп рахмет.
        Мен мұны бірнеше рет сынап көрдім, тәуелділіктерді және қондырғыдағы бумаларға түсініктемелерді жатқа білемін. Мен іске қосу құрылғысымен сіздің кеңестеріңізді орындаймын және менің сәттілігімді көремін. Мен саған айтамын.
        Мен өз алғысымды қайталаймын

        Фелипе

        1.    вафе дижо

          Бір жағынан немесе ол жұмыс істемейді. Түсініктемелерде сіз жасаған сілтемені қолданып көрдім, бірақ ол оны шешпейді, сілтемені таниды, маған бағдарламаны таңдау мүмкіндігін береді, мен acestream-launcher таңдаймын, бірақ VLC ашылмайды.
          Консольде ол маған келесі жауапты береді.

          Файл «/usr/lib/python3.6/site-packages/psutil/баптандыру.py », жол 1231, _send_signal
          os.kill (self.pid, sig)

          Бізге жаңа жаңартуларды күтуге тура келеді.
          Көмегіңе рахмет.

  11.   вафе дижо

    Жаңа жаңартудан кейін консольде келесі жауап бар.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Acestream қозғалтқышы жұмыс істейді.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | іске қосу кезіндегі қателік
    Бақылау (соңғы қоңырау соңғы):
    «Core.c» файлы, 1590-жол, в
    «Core.c» файлы, 144-жол, в
    «Core.c» файлы, 2-жол, в
    ImportError: __m2crypto атын импорттай алмайды
    Acestream үшін аутентификациялау қателігі!
    Media Player жұмыс істемейді ...

    Біз жақсарып жатырмыз, енді ол ағынды ағымды таниды, бірақ либрипто күресті жалғастыруда.

    1.    вафе дижо

      Сіз жіберген сілтемеде сіз ұсынған пакетті орнатып көрдім.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      Бұл проблеманы тиімді шешеді, vlc ашылады және Acestream жұмыс істейді.
      Көмегіңіз үшін үлкен рахмет

      1.    Алехандро дижо

        Сәлеметсіз бе, кешіктіргеніңіз үшін кешіріңіз, оның сізге істемей қалғаны өте таңқаларлық болды, мен Арх плазмасындамын, оның сізге көмектескеніне қуаныштымын, біз сол үшін

        Федора деген басқа таралымда менде бар, Windows xD-ге арналған шарапты имитациялайтын акстрим, егер сіз басқа дистрибуцияға немесе Арқаның өзіне барсаңыз, мені таң қалдыратыны - бұл тіпті Debian-да да оларда бұл пакеттер жоқ ...

      2.    01 дижо

        Сәлеметсіз бе, файл қалай орнатылған, мен әлі жаңадан келген адаммын, сәлемдесемін

        1.    вафе дижо

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Ол оны жоғарыдағы түсініктемеде келтіреді

  12.   химабтар дижо

    Кеше мен оны Kde Neon 5.8-де жылдам пакет ретінде орнаттым және оның маған қаншалықты қарапайым және жылдам жұмыс істейтініне таң қалдым. Егер сіз мақаланы жаңартсаңыз жақсы болар еді, өйткені салыстыру жоқ, процесс әлдеқайда жеңілдетілген.

    sudo apt install snapd → snap бумасын басқару жүйесін орнатыңыз (егер сізде ол жоқ болса)
    бағдарламаның репозиторийде бар-жоғын тексеру үшін acestream → іздеу (барлық ubuntu туындыларында болуы керек)
    sudo snap орнату acestreamplayer

    тілекпен

    1.    Антонио Манзано дижо

      Сіздікі жөн. Мен оны тек kubuntu 17.10-да орнаттым, өйткені бұл жерде пайда болатын әдіс мүлдем мүмкін емес.

      1.    Папито дижо

        i386 архитектурасы үшін жарамсыз

    2.    sie9k дижо

      Оны Lubuntu 16.04.4-те орнатудың жалғыз әдісі болды, бірақ мен үшін конфигурация файлын сақтаудың ешқандай мүмкіндігі жоқ және мен Serviio-мен қатар жұмыс істейтін параметрді конфигурациялауым керек. Оны түзету туралы ойларыңыз бар ма?

  13.   Хосе Антонио дижо

    Өте жақсы жазба. Linux жаңадан бастаушылары үшін міндетті түрде оқылатын веб-парақ.

  14.   жаңа бастаушыға питер дижо

    Оны AntiX 16 үшін қалай орнатар едіңіз (бұл Linux таратылымы)?

    Мен Arch Linux және оның туындылары сияқты сынап көрдім, бірақ мен жаңадан келгенмін, сондықтан қателесуім керек

  15.   Алехандро дижо

    Сәлеметсіз бе, жоғарыдағы әріптес комментарийде жазған sna пакеттерімен бірге бұл таралымдар үшін ғана емес, көптеген адамдарға оңай болды. Осы пакеттерге сәйкес келетін таратылымдар:
    https://snapcraft.io/

    Debian-да бұл келесідей болар еді:
    -sudo apt орнату snapd
    - жедел орнату өзегі
    - акустикалық ойыншыны бірден орнату
    Архта және туындыларда:
    -судо пакман -S snapd
    -sudo systemctl қосу - енді snapd.socket
    - акустикалық ойыншыны бірден орнату

    Архта (плазмада) орнатылған бумалар пайда болуы үшін қайта іске қосу керек болды, егер ол пайда болмаса, не істеу керектігін білесіз.

    Ubuntu және туынды құралдарында бұл жоғарыда KDE неонымен жазылған түсініктемелерде орнатқан серіктес сияқты болады деп ойлаймын.

    Gnome-де Debian-мен өте жағымсыз болып көрінетіні және GTK-мен жақсы интеграцияланбағандығы қызық, бірақ Arch plazma-да ол өте жақсы интеграцияланған, ең бастысы, бұл эстетикадан тыс көрінеді.

    1.    Уильям дижо

      бұл сізге қозғалтқыш орнатады ма?
      Мен емес

      1.    Алехандро дижо

        Сәлеметсіз бе, жоқ, ол оны орнатпайды және қажет емес, өйткені барлық пакеттерде барлық тәуелділіктер бар, ол иә немесе иә болып жұмыс істеуі керек.

    2.    txuber дижо

      Сәлем Алехандро, маған көмектесе аласың ба?
      [txuber @ manjaro ~] $ sudo systemctl қосу –қазір snapd.socket
      Бірлікті қосу мүмкін болмады: \ xe2 \ x80 \ x93now.service бірлік файлы жоқ.
      manjaro туралы Manjaro XFCE Edition (17.0.4) x64

      1.    Алехандро дижо

        Сәлеметсіз бе, Манжаро - бұл таза Arch емес және заттар аздап өзгеруі мүмкін, ол қазірдің өзінде қосулы болуы мүмкін және мұны істеудің қажеті жоқ, сіз бұл қадамды өткізіп жіберіп көрдіңіз деп ойлаймын ...

  16.   Debian дижо

    Орнатқаннан кейін не істеу керек? Ace-ойнатқыш орнатылмағандықтан, мен оны қалай жұмыс істейтінін білмеймін.
    Маған біреу көмектеседі?

    1.    вафе дижо

      Егер сіз орнатқан ацестрим-іске қосқыш болса, сілтемені басқанда acestream сізден қандай қосымшамен сілтемені ашқыңыз келетінін сұрайды, сіз оны VLC-мен айтамыз, және бұл ace-player функцияларын орындайтын нәрсе

      1.    Debian дижо

        Сәлем. Ең алдымен, көрсеткен көмегіңіз үшін көп рахмет. Мен түсініктеме беремін. Мен Debian 9-да gnome-мен аксессивтік жедел пакетті орнаттым. Мен өзім қалаған аренада болғанда, мен ацстрим сілтемесін бассам, маған екі опция беретін терезе пайда болады, біріншісі - егер мен мұны бассам ештеңе істемейді, ал екіншісі - басқа қосымшаны таңдаймын, мен оны беремін таңдау үшін, бірақ орнатылған қосымшалар ашылмайды, менің үй папкам ашылады, сондықтан мен vlc-ті қалай таңдау керектігін білмеймін.

        А құттықтау.

        1.    Алехандро дижо

          Acestream-launcher-де ол жақсы жүрмейді, сіз Snap пакетімен орнатқаныңыз жөн, өйткені мен жоғарыдағы түсініктемеде түсіндіремін.

  17.   жаңа бастаушыға питер дижо

    Snapd пакетін орнатуға тырысамын, бірақ бұл маған мүмкіндік бермейді:

    sudo apt орнату snapd
    Пакеттер тізімін оқу ... Дайын
    Тәуелділік ағашын құру
    Күй туралы ақпаратты оқу ... Дайын
    E: Snapd пакетін табу мүмкін болмады

    мен не істеймін?

  18.   Альф дижо

    Көп рахмет, бұл мен Windows-та қолданған бағдарламалардың бірі және оны Linux-де алғым келді

  19.   Оскар дижо

    Химабтар мен Алехандроға рахмет! Ubuntu 17.10-мен тамаша
    sudo apt орнату snapd
    жедел көзді табу
    sudo snap орнату acestreamplayer
    Міне, сол!
    Керемет нәрсе - сіз ресми сайтқа кіресіз және олар сізге 2014 жылдан бастап форумға хабарлама жібереді! Олар тек Ubuntu 13.04 дейін айтады!

  20.   Марко Баррия дижо

    жақсы, алдыңғы пікірлерде айтылғандай, ол snapd файлында тамаша жұмыс істейді:

    sudo pacman -S snapd
    sudo systemctl snapd.socket мүмкіндігін қосады
    қайта жүктеу
    sudo snap орнату acestreamplayer
    қайта жүктеу

    және дайын:

  21.   mchavez дижо

    сәлем!