이제 HTML 5를 통해 Linux에서 Netflix를 시청할 수 있습니다.

넷플릭스 html5

논쟁 : HTML 5의 DRM

이제 Google Chrome 브라우저의 최신 개발 버전에서만 기본적으로 Linux 데스크톱에서 Netflix 비디오 콘텐츠를 재생할 수 있습니다. 왜? 무엇이 바뀌 었습니까?

올해 초 웹 표준기구 인 '월드 와이드 웹 컨소시엄 (통칭 W3C)'은 다음과 같은 사양을 통해 HTML5에서 보호 된 콘텐츠 ( 'DRM') 지원을 도입하려는 계획을 논란의 여지없이 추진했습니다. 통화 미디어 암호화 암호화 된 미디어 확장 (EME).

Google은 EME를 "암호화 된 멀티미디어 정보의 재생을 허용하기 위해 인터넷 애플리케이션이 DRM 시스템과 상호 작용할 수있게 해주는 JavaScript API"라고 설명합니다. 이것은 Silverlight 또는 Adobe flash와 같은 설치하기 위해 매우 무겁고 복잡한 타사 플러그인을 사용할 필요없이 작동합니다.

Netflix는 작년 5 월 EME를 사용하여 Windows 8.1 및 Safari (Yosemite 만 해당)에서 HTMLXNUMX 비디오 재생을 지원한다고 발표했습니다. Google은 플러그인이 필요없는 DRM 지원의 주요 지원자 중 하나이므로 Chrome은 기본적으로 EME를 지원합니다.

Linux에서 Netflix (HTML 5)를 시청하기 위해 따라야 할 단계

1.- 최신 다운로드 Google 크롬 베타 또는 Chromium (버전 38).

2.- 사용자 에이전트 변경 Mozilla / 5.0 (Windows NT 6.3, Win64, x64)

3.- Netflix 계정 ( '재생 설정'섹션)에서 'HTML5 선호'옵션을 선택합니다.

리눅스의 넷플릭스

4.- Netflix를 엽니 다.

Ubuntu 14.04 LTS 만

Ubuntu 14.04 LTS를 사용하는 경우 'libnss3'라이브러리도 최신 버전으로 업데이트해야합니다.

Ubuntu 3 LTS (14.04 비트) 용 libnss32
Ubuntu 3 LTS (14.04 비트) 용 libnss64

Ubuntu 버전에 해당하는 파일을 다운로드 한 후에는 압축을 풀고 다음 명령을 사용하여 .deb 파일을 설치하기 만하면됩니다.

sudo dpkg -i * libnss3

기사의 내용은 우리의 원칙을 준수합니다. 편집 윤리. 오류를보고하려면 여기에.

27 코멘트, 당신의 것을 남겨주세요

코멘트를 남겨주세요

귀하의 이메일 주소는 공개되지 않습니다.

*

*

  1. 데이터 책임자 : Miguel Ángel Gatón
  2. 데이터의 목적 : 스팸 제어, 댓글 관리.
  3. 합법성 : 귀하의 동의
  4. 데이터 전달 : 법적 의무에 의한 경우를 제외하고 데이터는 제 XNUMX 자에게 전달되지 않습니다.
  5. 데이터 저장소 : Occentus Networks (EU)에서 호스팅하는 데이터베이스
  6. 권리 : 귀하는 언제든지 귀하의 정보를 제한, 복구 및 삭제할 수 있습니다.

  1.  

    음, 안정적인 Chrome에이 기능이 통합되기를 바랍니다.

  2.   샤이니키레

    그리고 Firefox;-; 나는 77에서 piperlight를 계속 사용할 것입니다. 나는 결코 chrome \ chromium을 사용하지 않을 것입니다 : '(

    1.    엘리오타임3000

      여기에 내 의견 Firefox 및 쥐 스틱 W3C에서 MPAA의.

  3.   페데리코 마누엘 에체 베리 추

    그것은 나를 위해 작동하지 않았다, 그는 내게 말한다

    지금 Microsoft Silverlight 플러그인을 설치하십시오. XNUMX 분이면됩니다.

    안부

    1.    리눅스를 사용하자

      이 팁은 Linux 용이며, Win을 사용하는 것 같습니다 (댓글의 오른쪽 상단에 표시됨).
      포옹! 폴.

      1.    엘리오타임3000

        최근에 오늘 밤마다 Chromium을 사용하는 Windows에서 시도해 봤는데 사실은 HTML5에서 작동한다는 것입니다. 제 경우에는 Chromium에 Chrome 베타 / 카나리아 [또는 개발자]와 같은 H.264 또는 MPEG-4 코덱이 포함되어 있지 않기 때문에 독점 코덱이 없음을 나타내는 오류입니다.

  4.   승리자

    Chrome의 베타와 Chromium의 38에 대해 설명하십시오. 그리고 Chromium 34가 작동하지 않기 때문에 사실이어야합니다. 포스터가 나옵니다. 지금 Microsoft Silverlight 애드온을 설치하십시오. XNUMX 분이면됩니다.
    그래서 지금은 Chromium이나 Firefox가 망할 EME를 만들 때까지 조금 더 기다릴 것입니다. 그러나 그것은 좋은 소식입니다. 그리고 마침내 저는 제 할머니의 컴퓨터를 포맷 할 수있게 될 것입니다. (그녀가 와인을 여는 것을 기억하기에는 너무 많습니다.)

  5.   페르난도

    파이프 라이트로 저는 고화질을 볼 수 없었습니다. 이 방법이 더 잘 작동한다고 믿습니다.

  6.   페르난도

    pipelight를 사용하면 HD를 볼 수 없었습니다.이 방법이 더 잘 작동하기를 바랍니다.

  7.   노에 도밍게스

    이미 표시된 모든 작업을 수행했지만 작동하지 않습니다.
    버전 38이 불안정하고 제공하는 사용자 에이전트가 있습니다. 테스트 했습니까?

    1.    리눅스를 사용하자

      네. 그것은 나를 위해 작동합니다 ... 🙂

  8.   엘리오타임3000

    시도해 보겠습니다.하지만 먼저 다음 사항에 대해 경고해야합니다.

    Netflix에는 다음 요구 사항이 필요합니다. H.264 코덱 (또는 MPEG-4) 및 EME-DRM. 그들 없이는 HTML5에서 Netflix를 즐길 수 없습니다.

    이제 이러한 기대를 충족 할 수있는 브라우저는 Internet Explorer (안타깝게도), Google Chrome (DRM이 있음에도 불구하고 앞서 언급 한 코덱을 거부했기 때문에 Chromium이 아님) 및 Opera Blink의 3 가지 브라우저 만 있다는 점입니다. .

    어쨌든 확실하지 않은 경우 html5test.com을 살펴보고 브라우저에 HTML5에서 Netflix를 테스트하기위한 요구 사항이 있는지 확인하십시오. Linux 사용자의 경우 대부분 Chrome 만 Netflix에서 HTML5와 함께 작동합니다.

    감사합니다, MPAAMozilla 재단을 괴롭히다 그 철학과 사명을 의심하게 만들었습니다.

  9.   곤살로 트루 히요

    내가 가진 문제였던 user-agent를 조심하십시오.
    Mozilla / 5.0 (Windows NT 6.3, Win64, x64) AppleWebKit / 537.36 (KHTML, like Gecko) Chrome / 38.0.2114.2 Safari / 537.36

    사용자 에이전트 전환기 플러그인을 사용하십시오. 운!

  10.   Ognomir

    이제 Netflix를 설치하는 것만 큼 간단합니다.
    http://ricardo.monroy.tk/watch-netflix-on-linux

  11.   페르난도 디아즈

    방금 시도했는데 Chrome에서는 완벽하게 작동하지만 사용자 에이전트를 수정할 필요없이 Chromium에서는 작동하지 않습니다.

    1.    로베르토 리베이로

      그러나 그들은 그들이 사용하는 버전을 말하지 않습니다.
      내 경우에는 두 가지 방법으로 성공하지 못했습니다.
      첫 번째는 Debian 7의 Chrome 버전 39.0.2171.71 (64 비트), 두 번째는 pipelight 및 에이전트 스위치입니다.

      또한 내 netflix 프로필에서는 HTML로 선택할 수 없습니다.

      1.    야일

        chorome 39 (64 비트)를 사용하는 xubuntu에서 작동

        ????

  12.   메가 제소

    그것은 나를 위해 작동하지 않았습니다. 어떻게 할 수 있습니까? 이건 테스트입니다.

    1.    메가 제소

      작동했지만 사용자 에이전트는 있지만 HTML5 옵션이 나타나지 않습니다.

    2.    메가 제소

      아직 안돼 UA 테스트 중

  13.   Bacosqui 저장

    이 항목에 대한 세부 정보가 있습니다. 설치해야하는 것은 Chrome의 안정적인 버전입니다. 제 경우에는 이미 44 비트 버전 64가 있습니다. 이 기사를 게시 한 후 머리가 아팠고 여러 블로그를 읽고 약 7 개월 동안 넷플릭스 서비스 비용을 지불 한 후, 넷플릭스를보기 위해 빌어 먹을 윈도우 XNUMX을 설치하려고 할 정도로 실망 스러웠습니다 (우리 가족은 시리즈가 있고 니카라과에서 솔직 해지자 Claro tv의 기본 케이블 TV 서비스는 짜증납니다). 이 모든 끝에 오늘 말씀 드렸듯이 안정적인 버전의 Chrome을 설치해 보았습니다. 다른 작업 없이도 어떻게 작동하는지 확인하는 것이 아름답습니다. 모두에게 인사 드리며 저와 똑같은 효과가 있기를 바랍니다.

    1.    리눅스를 사용하자

      기여해 주셔서 감사합니다!
      포옹! 폴

  14.   크리스

    라이브러리를 설치하려고 할 때 오류가 발생합니다.
    어떤 종속성이 누락되었는지 알고 있습니까?
    감사
    dpkg : 오류 처리 패키지 libnss3-1d : i386 (–install) :
    종속성 문제-구성되지 않은 상태로 남음
    처리하는 동안 오류가 발생했습니다.
    libnss3
    libnss3-nssdb
    libnss3 : i386
    libnss3-1d : i386

    1.    리눅스를 사용하자

      여보세요! 우선 답변이 늦어서 죄송합니다.
      Ask From Linux 서비스 (http://ask.desdelinux.net) 이러한 유형의 상담을 수행합니다. 그렇게하면 전체 커뮤니티의 도움을받을 수 있습니다.
      포옹! 폴

  15.   홍옥

    🙂 하하하 이해가 안 돼요

  16.   데이비드

    나는 askdelinux에 갔고 나는 아무 말도하지 않았고 응답하지 않았다. 넷플릭스를 볼 수없는 3 개월
    쿠분투 14.04 개 중 32 개가 있는데 방법이 없습니다….
    어쨌든

  17.   익명

    Linux mint 57.0 kde에서 64 비트 용 Firefox Quantum 18.3 (64 비트)을 사용하고 있으며 아무것도 설치하지 않고 Netflix를 볼 수 있습니다. 환경 설정 메뉴에서 DRM을 활성화하기 만하면됩니다.