Wi-Fi 장치에 Windows 용 드라이버 만있는 경우 어떻게해야합니까?

연구 센터와 많은 작업 센터에서 Wi-Fi 네트워크가 인기를 얻고 있기 때문에이 문제를 해결하기로 결정했습니다.하지만 PC의 Wi-Fi 장치에 Windows 용 드라이버 만 있으면 어떻게해야합니까?

이러한 상황이 발생하면 Linux 사용자는 두려워 할 필요가 없습니다. Windows 용 드라이버로 장치를 작동 할 수있는 ndiswrapper라는 응용 프로그램이 있습니다.

데비안 6과 그 파생물을 사용하는 방법은 다음과 같습니다.

1 : ndiswrapper 설치

$ sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9 wireless-tools

2 : 파일 복사 .INF y .SYS 예를 들어 / home / tu_user와 같이 PC의 폴더에 CD로 제공됩니다.

3 : 드라이버 설치

$ sudo ndiswrapper -i nombre-driver.inf

그런 다음 드라이버가 올바르게 설치되었는지 확인하십시오.

$ ndiswrapper -l

마지막으로 ndiswrapper 드라이버를 설치하십시오.

$ sudo modprobe ndiswrapper

이 명령을 실행할 때 ndiswrapper 모듈이 없다는 오류가 발생하면 (일반적으로 bigmem 커널이 설치되어있을 때 발생하며 최근에 저에게 발생했습니다)

$ sudo apt-get install module-assistant

$ sudo m-a a-i ndiswrapper

이 옵션을 사용하면 모듈 (또는 사용중인 커널 용 드라이버)을 다시 컴파일합니다.

그때

$ sudo modprobe ndiswrapper

장치가 제대로 작동하는지 확인하려면

$ sudo iwconfig

다음과 같은 내용이 화면에 나타납니다.

lo 무선 확장이 없습니다. eth0 무선 확장이 없습니다. wlan0 IEEE 802.11bgn ESSID : 꺼짐 / 임의 모드 : 관리 형 액세스 포인트 : 연결되지 않은 Tx- 전원 = 20dBm 재시도 긴 제한 : 7 RTS thr : 꺼짐 단편 thr : 꺼짐 암호화 키 : 꺼짐 전원 관리 : 켜짐 pan0 무선 확장 없음.

이제 모든 것이 정상이므로 시스템이 시작될 때 ndiswrapper 드라이버를로드합니다.

$ sudo ndiswrapper -m

무선 인터페이스를 활성화하려면

$ sudo ifconfig wlan0 up

후자는 자동으로 설정하지 않는 한 시스템을 시작할 때마다 수행해야합니다..

참고 : Linux X64를 사용하는 경우 드라이버도 X64 아키텍처 용이어야합니다.

ndiswrapper 프로그램은 USB 또는 PCI가 될 수있는 무선 WIFI 장치의 드라이버를 위해 설계되었지만 다른 문서에서는 winmodems 및 기타 하드웨어에 대해서도 동일한 작업을 수행 할 수 있다고 말합니다. 시도하지 않았으며 해당 필드를 독자.

그리고 이제 무선 네트워크를 즐기려면 Wi-Fi 레이더와 같은 네트워크를 감지하는 프로그램을 설치해야하지만 이는 또 다른 기사입니다.

다음에서 가져온 기사 구틀.


기사의 내용은 우리의 원칙을 준수합니다. 편집 윤리. 오류를보고하려면 여기에.

16 코멘트, 당신의 것을 남겨주세요

코멘트를 남겨주세요

귀하의 이메일 주소는 공개되지 않습니다. 필수 필드가 표시되어 있습니다 *

*

*

  1. 데이터 책임자 : Miguel Ángel Gatón
  2. 데이터의 목적 : 스팸 제어, 댓글 관리.
  3. 합법성 : 귀하의 동의
  4. 데이터 전달 : 법적 의무에 의한 경우를 제외하고 데이터는 제 XNUMX 자에게 전달되지 않습니다.
  5. 데이터 저장소 : Occentus Networks (EU)에서 호스팅하는 데이터베이스
  6. 권리 : 귀하는 언제든지 귀하의 정보를 제한, 복구 및 삭제할 수 있습니다.

  1.   오스카

    이 솔루션이 Wheezy에서도 작동합니까?

  2.   블레어 파스칼

    아주 좋아요. 다행히도 내 WiFi 카드는 그다지 고통스럽지 않았습니다. Wicd 용 NetworkManager 만 변경합니다. 안타깝게도 드라이버가 최적으로 작동하지 않습니다.

  3.   Elynx

    팁 고마워!

  4.   B1tBlu3

    감사합니다, 도움이 될 것입니다!

  5.   Elendilnarsil

    한 번만이 절차에 의지해야했고 Mandriva 2011과 함께했고 열심히 노력했습니다.

  6.   카를로스-Xfce

    2006 년 XNUMX 월 Sony Vaio 노트북에는 Wi-Fi 용 스위치가 있습니다. Sony Vaio 및 Toshiba 모델 모두에서 이러한 스위치는 쉽게 손상되고 Wi-Fi를 손상시키는 쓰레기입니다. 그것은 나를 얼마나 괴롭 혔습니까!

    최근에 D-Link 브랜드에서 Wifi 용 어댑터, 모델 DWA-125N을 구입했습니다. 그리고 빌어 먹을 스위치는 기본적으로 네트워크를 비활성화했습니다! 나는 많은 고통을 겪었지만 그것을 고치는 방법을 찾았습니다.

    요즘. 이 Wi-Fi 어댑터 덕분에 D-Link 브랜드가 Linux 용 드라이버를 제공하기 때문에 독점 드라이버를 사용하지 않고도 뛰어난 무선 연결을 즐길 수 있습니다. 🙂

  7.   Truko22

    흥미 롭습니다. 필요할 때 정보를 저장하세요 😀 대단히 감사합니다.

  8.   괴짜

    나는 또한 일부 배포판에서 약간 충돌하는 broadcom 4318과 함께이 대안을 사용했지만 수락 한 드라이버는 Windows xp와 호환되어야했습니다.

    이제 조금 더 알게 되었으니, 케이블을 통해 펌웨어 -b43-installer를 설치하여 패키지를 다운로드하고 짜잔!

  9.   Rainbow_fly

    흠, 이것이 아치에서도 유효할까요?

  10.   MSX

    하지만 ... 커널에서 지원하지 않는 최신 HW Wi-Fi가 있습니까?

  11.   니라

    여보세요! 완전히 주제에서 벗어난 빠른 질문입니다. 사이트를 모바일 친화적으로 만드는 방법을 알고 있습니까? 내 아이폰에서 볼 때 내 사이트가 이상하게 보입니다. 이 문제를 해결할 수있는 테마 또는 플러그인을 찾으려고합니다.

    추천 사항이 있으시면 공유하십시오.

    많은 감사합니다!

  12.   카를로스-Xfce

    엘라 브, 어디야? 저는 Facebook, Twitter 또는 Google+가 없기 때문에 이것이 제가 여러분에게 연락 할 수있는 유일한 방법입니다.

    Thunar와 함께 나에게 이상한 일이 일어났습니다. 그의 속눈썹이 나왔습니다! 그러나 이상한 점은 한동안 (작년) Xubuntu 12.10에서 아무것도 업데이트하지 않았다는 것입니다. 특히 마우스 휠을 클릭 할 때 정말 이상하게 느껴집니다.

    그것에 대한 기사를 할 수 있습니까?

    감사합니다. 새해 복 많이 받으세요.

    1.    엘라 브

      Hahahaha, Thunar는 정말 속눈썹이 있습니까? 오 !! 나는 하 하하하 몰랐어 .. 친구 미안해. KDE가 나를 Conqi의 동굴에 가두어 놓아주지 않았기 때문에 Xfce에 대해 계속 쓰려면 가상 머신을 설치해야한다 ..

      1.    카를로스-Xfce

        안녕. 응답 해주셔서 감사합니다, Elav. 이봐, 이상한 일이 벌어지고있어, 내 속눈썹이 더 이상 Thunar에서 나오지 않아. 그리고 여전히 이상한 점 : Iron 브라우저에서는 이제 이전 YouTube 인터페이스처럼 보이지만 Firefox에서는 새로운 인터페이스가 보입니다. 난 이해가 안 돼요.

        글쎄요, 제가 당신에게 요청한 것에 대해 걱정하지 마세요. KDE가 당신에게 새롭고 흥미로운 세상을 가져다 줄 것이라고 생각합니다. 내가 사용하는이 노트북은 2006 년에 출시되었고 Xfce를 사용하면 매력적으로 작동하기 때문에 아직 기회를주지 않았습니다.

        다음 시간까지! 나는 곧 새로운 기사에서 당신을 다시 읽을 수 있기를 바랍니다.

        1.    엘라 브

          네, 모든 게 이상 하죠? 😕

  13.   헬 버트 카마초

    안녕하세요 저는 Linux를 처음 사용하지만 드라이버를 설치할 때 다음 오류가 발생합니다 $ sudo ndiswrapper -i net8192cu.inf
    net8192cu.inf를 열 수 없음 : /usr/sbin/ndiswrapper-1.9 줄 162에 파일 또는 디렉터리가 없습니다.