Буу: Аны Debian Wheezy-ге орнотуп, эч нерседен коркпой орнотуңуз (жаңыртылды)

Кийинки окула турган бул билдирүү жакшыртылган мурунку кийинки, бул, сыягы, орнотууга байланыштуу бир топ түшүнүксүз болду буу, жана аны орнотууну каалагандардын көпчүлүгүнө кыйын болду.

Бирок, бул жерде мен ушунча аракет кылып тапкан бир ыкма бар (ал сизге орнотуу ыкмасын эсиңизге салат) Iceweasel репосунан Debian Mozilla, бирок акыры, ал иштейт):

  1. Биз көпарх функциясын өзүбүзгө кошобуз Debian:sudo apt-get install multiarch-support
  2. Орнотуу үчүн репонун кол тамгасын кошобуз:
    wget -O- -q http://repo.steampowered.com/steam/signature.gpg | gpg --import gpg --check-sigs --fingerprint - ачкыч /usr/share/keyrings/debian-keyring.gpg B05498B7 gpg --export -a B05498B7 | sudo apt-key кошуу -

    Кошуу /etc/apt/sources.list кийинки:

    deb http://repo.steampowered.com/steam precise steam

  3. Төмөнкүнү иштетиңиз:sudo apt-get install -t precise steam steam-launcher
  4. Эгерде алар көз карандылыкты сурашса:sudo apt-get -f install

Libc6 көйгөйүн чечүү

Биринчи болуп чыга турган Steam көйгөйү, негизинен, Libc6 китепканасынан көзкарандылык, ал үчүн жок дегенде 2.15 нускасын талап кылат. Көйгөйлөрдү болтурбоо үчүн, Libc6 китепканаларын гана куткарабыз Дебиан Джесси менен төмөнкү жол-жобо (кыска, бирок иштей турган):

  1. Биз төмөнкү сапты кошобуз /etc/apt/sources.list:deb http://ftp.us.debian.org/debian/ testing main contrib non-free
  2. Биз каталогду түзөбүз, анда файлды түзүп, дисти жаңыртууга жол бербөө үчүн пингдеги артыкчылыктарын көрсөтөт / etc / apt / preferences нано менен:
    Пакет: * Pin: Origin repo.steampowered.com Pin-Priority: 400 Package: * Pin: release a = test Pin-Priority: -10
  3. Жаңыртылган libc6 орнотуу үчүн төмөнкү буйрукту аткарабыз:apt-get -t testing install libc6

Ошентип, бизде Steam көйгөйсүз иштеп жатат

Кандай болсо дагы, мен бул ыкманы репо каталогуна экскурсия жасаганымдын аркасында таптым SteamOS, негизделген Debian Wheezy. Биз мындай артыкчылыкты текке кетире албагандыктан, мен бул окуу куралын жасоону чечтим, эми мындан ары көз карандылыктын кереги жок болуп калат Ubuntu Ал сыяктуу эч нерсе.

Кандай болсо дагы, Debian Wheezyде Steam'дан жана келечектеги котормолордон ырахат алыңыз (эми ооба).

буу

Stebian Debian 7.5 "Wheezy" (64 бит), бактылуу менин нетбукка орнотулган.

Debian Jessie (жана SID) филиалында репо бар эркин эмес a буу, эгерде сиз ошол дистрофиянын ушул версияларын колдонсоңуз, анда Debianга ишенүүнү туура көрөсүз. Мындан тышкары, бул окуу куралы тексттин аягында сайттан чаптоо.

Макаланын мазмуну биздин принциптерге карманат редакциялык этика. Ката жөнүндө кабарлоо үчүн чыкылдатыңыз бул жерде.

20 комментарий, өзүңүздүкүн калтырыңыз

Комментарий калтырыңыз

Сиздин электрондук почта дареги жарыяланбайт. Милдеттүү талаалар менен белгиленет *

*

*

  1. Маалыматтар үчүн жооптуу: Мигель Анхель Гатан
  2. Маалыматтын максаты: СПАМды көзөмөлдөө, комментарийлерди башкаруу.
  3. Мыйзамдуулук: Сиздин макулдугуңуз
  4. Маалыматтарды берүү: Маалыматтар үчүнчү жактарга юридикалык милдеттенмелерден тышкары билдирилбейт.
  5. Маалыматтарды сактоо: Occentus Networks (ЕС) тарабынан уюштурулган маалыматтар базасы
  6. Укуктар: Каалаган убакта маалыматыңызды чектеп, калыбына келтирип жана жок кыла аласыз.

  1.   @Jlcmux ал мындай деди:

    SteamOS жөнүндө эмнелерди билесиз?

    1.    eliotime3000 ал мындай деди:

      Буга чейин бета нускасында турган жана, анын үстүнө, жакында Debian Wheezy 7.5 менен жетишкен.

    2.    Cristianhcd ал мындай деди:

      өнөктөштөр жана алардын буу машиналары менен бир нерсе жасабасаңыз, ийгиликсиз болот, OS жөн гана пакеттердин сериясын орнотуу каражаты болуп саналат.

      Өркүндөтүүлөр AMD / Nvidia драйверлеринин колдоосунда байкалат, бирок дагы деле болсо убада кылынган нерседен алыс, бул олуттуу көйгөй, себеби орточо колдонуучу буусун же буусун OS орнотуп, компьютерине орнотот, ал эми аппараттык жабдыктары бар буу машинасына орнотпойт » күбөлүк "

  2.   cr0t0 ал мындай деди:

    Debian 7.4те мен аны орноткон элем https://github.com/GhostSquad57/Steam-Installer-for-Wheezy Бирок left4dead 2де Гамма көйгөйлөрү бар болчу, ал өтө сейрек кездешчү жана мен чечим таба алган жокмун. On Lubuntu 14.04 чыкылдатып & ойнотуу. Мен кайтып келем кымбаттуу Уиззи.

    1.    eliotime3000 ал мындай деди:

      Ооба, Steam орнотуу ыкмасы түздөн-түз Debian Wheezy үчүн оптималдаштырылган SteamOS репосунан алынган, эч кандай көйгөйсүз.

  3.   атсыз ал мындай деди:

    буу пакети тестирлөөдөн өтүп жатат, кимде-ким туруктуу болсо, аны орнотуу үчүн репосту тестирлөөгө алмаштырып, андан ары татаалдашпай туруктуу абалга кайтып келиши мүмкүн.

    1.    eliotime3000 ал мындай деди:

      Ооба, Steam нускасын SteamOS репо түздөн-түз алдым, анткени Debian Wheezy менен иштөө бир топ оптималдаштырылган, ошондуктан сиз жүктөп алган оюндарды иштетүүгө мүмкүнчүлүк берет же ALSA менен көйгөйлөр жок.

  4.   Альберто Вилла ал мындай деди:

    Эгер биздин компаста E7 менен WinXNUMX деген кызыктуу нерсе бар болсо, анда аны GRUB менен орнотуу боюнча окуу куралын жасашкандыр?

    1.    Альберто Вилла ал мындай деди:

      Steam OS дегеним. Баса, салкын .. бул менин кайда жайгаштырганымды көрсөтөт ... (OS) .. бирок бул иштөө компьютери ¬¬

    2.    eliotime3000 ал мындай деди:

      Кирген SteamOS орноткучу Расмий ISOБул кошумча OS колдогон GRUB менен келет. Ошондой эле, SteamOS орноткучу дээрлик Debian менен бирдей, андыктан аны Windows менен катар орнотсоңуз, көйгөй жаралбайт.

      UEFI тарапта, UEFI жана аны кантип орнотуу жөнүндө сүйлөшкөн эки вебсайт бар UEFI менен Debian Wheezy (y бул жерде дагы бир ыкма бар сага жардам бере алат).

  5.   Alfonso ал мындай деди:

    Мен Debian 7ге Steam орноттум, көйгөй - программаны ачууга аракет кылып жатканда менден өтүп кетүүнү суранат, бирок ал Steam атын эмес, компьютердин колдонуучу атын алып келет. Конфигурациялай турган файл барбы? Колдонуучунун атын өзгөртүүгө жол бербейт.

    ыракмат

    1.    eliotime3000 ал мындай деди:

      Steam терезеси сизге кандайча көрүнөт? Кирүү формасы же колдонуучудан өтүнүчүн сураган терминал (же консол) сыяктуубу?

      1.    Alfonso ал мындай деди:

        Терминал пайда болот.

  6.   eliotime3000 ал мындай деди:

    Эгерде терминал пайда болсо, анда ушул эки сапты терминалыңызда иштетип коюңуз:

    wget http://dl.dropbox.com/u/29081229/Steam/debian_install.sh

    sh ./debian_install.sh

    Ошентип, колдонуучунун паролунун көйгөйү пайда болбойт (адатта, Ubuntu репосунан чыккан Jockey көз карандылыгы орнотулбай калганда пайда болот).

    1.    Alfonso ал мындай деди:

      Мен буга чейин кадамдарды жасап, дагы деле болсо алардын катарындамын. Орнотуудан чыгаруу керекпи?

    2.    Alfonso ал мындай деди:

      Менден төмөнкү программаларды орнотууну суранат:

      libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

      Бирок мен аны жасоого аракет кылганда: "пакеттердин аткарылбаган көз карандылыктары бар" деген легенда пайда болот.

  7.   Хэнк ал мындай деди:

    Салам, дос, мен Debian Jessieде буу орнотуп, мыкты иштегендин эң оңой жолу үчүн миң мертебе рахмат

    рахмат.

  8.   robermgs ал мындай деди:

    Бууга түзөтүү киргизген apt-get install -t дәл буу буусун иштетүүчү буйрукта, ал ушул сыяктуу apt-get install -t буу буусун учуруу сыяктуу саламдашуу болот

  9.   Небус ал мындай деди:

    Салам, тилекке каршы, мен ушул кадамда адашып калдым:

    "Биз каталогду түзөбүз, анда ал ning менен файлды / etc / apt / preferences түзүп, аралыктан жаңыртылбашы үчүн пингдеги артыкчылыктарын көрсөтөт:"

    Файлдын мазмуну мен үчүн түшүнүктүү, бирок файлды etc / apt / preferences ичиндеги айрым каталогдун ичинде түзүшүңүз керекпи? Мен "Биз каталог түзөбүз ..." деп койсом, менде күмөн бар
    Ал файл кандай аталышка ээ болушу керек? Анан кандай кеңейтүү?

    ^^ Бууга ээ болгондон тышкары, эгерде мен эч нерсени жүктөбөстөн, каргышка калган libc6-ну орнотуп алсам, анда бул сени кудайлардын курмандык чалынуучу жайына айландырмак! xP бул бактылуу lib, мен иштөөгө аракет кылгым келген көптөгөн аудио жана видео колдонмолор тарабынан талап кылынат, бирок азыр тобокелге барбай калдым.

    Алдын ала рахмат!

  10.   Aquadrago ал мындай деди:

    Салам, ишке киргизгичти иштеткенде менде төмөнкү ката пайда болду:

    Топтом тизмеси окулуп жатат ... Бүттү
    E: APT :: Default-Release үчүн "так" мааниси жараксыз, анткени мындай чыгарылыш булактарда жок

    Кантип чечсем болот?