Brother лазер принтерлерин Linuxко кантип орнотсо болот

Бүгүнкү күндө GNU / Linux дистрибьютерлеринин көпчүлүгү эң заманбап жабдууларды колдоого алышат, бирок дагы деле болсо, биздин сүйүктүү иштетүү тутумубуз алардын чечилишине дал келбешине жолтоо болгон кээ бир жабдык өндүрүүчүлөр бар. Көпчүлүктүн бактыга жараша, бул Brother брендин принтерлерин колдонгон бизде андай эмес, анткени алардын Linux үчүн жергиликтүү драйверлери бар.

Учурда менде Brother DCP-L2550DN лазер принтериБул эң сонун принтер эмес, бирок мага тез арада, сапаттуу басып чыгарууга жана чыгымдардын күтүүлөрүн канааттандырса, анда бул жабдуу колдонгон арзан Brother TN2410 жана TN2420 картридждерин алуу да оңой. Linux Mintде мен аябай жакшы иштеп жатам, бирок даамдуу болгонумда, аны иштетүү үчүн кадимкидей бир аз кыйналдым, ошондуктан ушул сыяктуу шаймандары бар колдонуучулар жасашы керек болгон процедураны түшүндүрүп берген оң.

Бул бренддин принтери бар колдонуучулардын биринчи кылышы керек бир тууган Linux айдоочулар баракчасы жана драйверлерди белгилүү бир принтер моделине жүктөп алыңыз, алар компания тарабынан таратылган ар кандай жабдыктар боюнча бөлүштүрүлөт (CUPS, LPR, Scanner, ADS, лазердик принтерлер жана башкалар). Драйверлердин ар бир категориясы бизге байланыштуу өнүмдөрдүн чечимин сунуштайт, мисалы, ошол эле айдоочу Brother DCP-L2510D, Brother HL-L2310D жана Brother MFC-L2710DN принтерлери үчүн иштей алат.

Brother бизге өзүнүн драйверин орнотуу баракчасында бизде болгон бөлүштүрүүгө, аппараттык моделге жана анын архитектурасына ылайык колдонуу үчүн атайын колдонмону сунуштайт, ошондой эле принтердин туура иштешин, конфигурациясын текшерүүгө мүмкүнчүлүк берет кагаз түрү, ал тургай, сиздин картридждердин абалы.

Жалпысынан процесс жөнөкөй, биз Brother драйверлер барагына кирип, биздин аппараттык камсыздоого жана дистрибьютерибизге ылайыктуу драйверди жүктөп алып, төмөнкү пакет менен базалык пакеттерди орнотобуз:

sudo apt install brother-cups-wrapper-extrabrother-lpr-drivers-extra

Андан кийин компьютерибизди өчүрүп-күйгүзүп, драйверлерди Brother колдоо баракчасы көрсөтпөгөндүктөн орнотобуз, кээ бир учурларда Системалар / Административдик / Принтерлер бөлүмүнө өтүшүбүз керек (сиздин дистрибуцияңызга ылайык) жана сиз жаңы орноткон принтерди тандаңыз, ушундай жол менен биз принтерибизди тубаса колдоно алабыз.


Макаланын мазмуну биздин принциптерге карманат редакциялык этика. Ката жөнүндө кабарлоо үчүн чыкылдатыңыз бул жерде.

17 комментарий, өзүңүздүкүн калтырыңыз

Комментарий калтырыңыз

Сиздин электрондук почта дареги жарыяланбайт. Милдеттүү талаалар менен белгиленет *

*

*

  1. Маалыматтар үчүн жооптуу: Мигель Анхель Гатан
  2. Маалыматтын максаты: СПАМды көзөмөлдөө, комментарийлерди башкаруу.
  3. Мыйзамдуулук: Сиздин макулдугуңуз
  4. Маалыматтарды берүү: Маалыматтар үчүнчү жактарга юридикалык милдеттенмелерден тышкары билдирилбейт.
  5. Маалыматтарды сактоо: Occentus Networks (ЕС) тарабынан уюштурулган маалыматтар базасы
  6. Укуктар: Каалаган убакта маалыматыңызды чектеп, калыбына келтирип жана жок кыла аласыз.

  1.   жашыруун ал мындай деди:

    Hello:
    Мен бир тууган dcp 7065dnди manjaro gnome колдоном жана айдоочулар AURда.
    Бул принтерлерде адатта rpm жана deblin драйверлери бар, archlinux жана туундулар үчүн адатта AUR бар, ал эми gentoo үчүн бир тууган катмар бар.
    Салам.

    1.    кескелдирик ал мындай деди:

      натыйжалуу

  2.   DAC ал мындай деди:

    Айдоочулар акысыз программалык камсыздообу - ачык булакпы?

    1.    кескелдирик ал мындай деди:

      Бул учурда, алар Linux үчүн драйверлер, бирок булактар ​​жеткиликсиз (алар ачык булак эмес), тилекке каршы

  3.   Барбара ал мындай деди:

    Алардын айткандарына караганда, жок дегенде бир тууган Рикого караганда көбүрөөк колдоого ээ. Менде Ricoh көп функциясы бар SP310spnw мыкты, бирок аны Linuxта колдонууга келгенде, баш оору көп болуп, басып чыгаруу бөлүгүн гана колдонсо болот. Ricoh колдоосу дээрлик жокко эсе жана Linux үчүн драйверлери бар деп айтылганы менен, аларды орноткондо ката кетирет, анткени ... CUPS иштеп жатат !!! Менде дээрлик бир жылдан бери бар, бирок мен дароо Рикого электрондук почта билдирүүсүн жөнөтүп, ылайыктуу айдоочуларды түзүүнүн жолун сурадым, бүгүнкү күнгө чейин алар электрондук катты алгандыгын мойнуна алышкан жок. Мен сканерлеш үчүн башка OS колдонушум керек.

  4.   Alberto ал мындай деди:

    Мен абдан арзан Brother lazer HL-2135W wifi колдоном жана ал Linuxта көп жылдардан бери жакшы иштеп келе жатат. Абдан бактылуу.

  5.   Puigdemont 64 бит ал мындай деди:

    1210w эскирген pkgbuild программасын колдонуп орнотулган жана аны өзгөртсө, анда айрым цитаталар жок, бирок ал жакшы иштейт.

  6.   Гиль ал мындай деди:

    Brotherди сатып албаңыз, HPди сатып алыңыз, мен анын себебин түшүндүрүп берем: Ооба, алардын GNU / Linux үчүн драйверлери бар, бирок алар менчик. Эгерде X жылдан кийин айдоочуларды жаңы ядролорго жаңыртууну токтотуп, иштебей калышса, сизди жатып алып, эч ким кодду өзгөртө албайт, анткени бизде жок. Жумушта биз бир тууган DCP7065dn колдонобуз.
    HP менен этият болуңуз, анткени анда HP LaserJet Pro CP1025nw сыяктуу акысыз айдоочусу жок принтери бар. Жаңы принтер же жаңы Windows же Mac OS лицензиясын сатып алуу үчүн келечекте опузалап талап кылбоо үчүн акысыз айдоочулары барларды гана сатып алыңыз (алар үчүн ар дайым айдоочулары бар).
    Эч кандай шартта SHARP принтерин сатып албаңыз, бизде MX 2310U копир / принтери бар: биринчи кезекте анын Linux үчүн драйвер орнотуучусу (http://www.sharp.es/cps/rde/xchg/es/hs.xsl/-/html/centro-de-descargas.htm?p=&q=MX-2310U&lang=ES&cat=0&type=1214&type=1215&os=&emu=) файлдын атын өзгөртүү боюнча бир нече каталар бар, алар скриптти жакшы иштеши үчүн тийүүгө аргасыз кылат, экинчиден, бизде ар бир кызматкер үчүн колдонуучу коду менен конфигурацияланган тармак бар жана Linux драйверинде кодду коё турган жер жок болуп чыкты (in Windows yes in Job Management - Колдонуучунун аныктыгын текшерүү - Колдонуучу). Ошентип, мен аны GNU / Linux колдоно албайм жана PPD файлын өзгөртүү сыяктуу айла-амалдарды жасадым (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) жана шифрлөө үчүн тескери инженерияны колдонгон драйверди сынап көрүңүз (https://github.com/benzea/cups-sharp).
    Артыкчылык тартиби: акысыз айдоочу менен HP, менчик айдоочу менен HP, менчик айдоочу менен Brother, эч кандай учурда Sharp.

  7.   фернан ал мындай деди:

    Hello:
    Алар иштеши үчүн бинардык файл талап кылынат, мисалы, бир тууган dcp 7065dn учурда, мен айдоочунун бир бөлүгүн колдоном, эгерде ал акысыз программалык камсыздоо болсо, бирок акысыз эмес, бир туугандык экилик керек.
    Салам.

  8.   Гиль ал мындай деди:

    Акысыз драйверлери жок принтерлерди сатып алуудан алыс болуңуз, антпесе алар иштеп жаткан компаниянын колунда болот, эгерде ал сиз колдонуп жаткан операциялык тутумдар менен бир убакта драйверин жаңыртпаса, анда ал башка тутумду же башка принтерди сатып алууга мажбур болот.
    Акысыз драйверлери бар HP жакшы, HP LaserJet CP 1025nw сыяктуу менчик драйверлери бар HP бар экенинен абайлаңыз, бир тууганымда алардын менчик драйвери бар, бирок жок дегенде алар бар. Андан да жаманы SHARP көчүрмө-принтерлер, алардын GNU / Linux үчүн драйверинде сизге берилген кодду тармакка чыгаруу сыяктуу мүмкүнчүлүктөрү жок, бул компания ар бири тарабынан жасалган көчүрмөлөрдү көзөмөлдөөнү кааласа, аларды Linuxтан колдонууга жол бербейт, Мисалы, мен Sharp MX 2310U принтерин PPD модификациялоо менен иштей алган жокмун (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) же тескери иштелип чыккан айдоочу менен (https://github.com/benzea/cups-sharp).

  9.   Koopa ал мындай деди:

    Куттуу күн. (Күн, түн ж.б.) Бул тармак принтерлери үчүн сканерди орнотууда жана конфигурациялоодо мага кимдир бирөө жетекчилик бере алабы? же алдын ала сиңирилген маалыматты кайдан тапсам болорун айтып бериңиз. Мен иштеген жерде бир нече Brother көп функционалдуу моделдери колдонулат жана драйверлер орнотулганда принтердин конфигурациясы жөнөкөй, бирок кээде система (адатта zorin os 9 lite) тармактагы айрым сканерлерди автоматтык түрдө аныктайт, бирок кээде жок. Бул сканерди кол менен кантип кошуу керектигин (көп функционалдуу сканерди белгилүү бир IP менен таануу кандайча айтылат) кимдир бирөө айтып беришин суранам. Мен издеп көрдүм, эң көп жетишилген нерсе - IP сканердин аты жөнөкөй сканерлөө тизмесинде пайда болот, бирок эч нерсе сканерленбейт. Мага samsung multifunctions менен дагы ушундай нерсе болот, бирок алар бир туугандарга караганда simplescan тизмесинде көп кездешет. Менин көзүмчө, компьютер сканерди байкап калат, ал эми анын жанындагы компьютер байкабайт; анткени алар бир тармакта.

  10.   Nasher_87 (ARG) ал мындай деди:

    Бир суроо, бул мен үчүн акылсыздык, анткени мен буга чейин билип койгом, бирок мен аны сурайын, Lexmark принтерлери (Z11 LPT жана X75 бардыгы биригип) Linuxто туура иштейби? мен издегенимден эч нерсе жок, Ubuntu 9.10до Z11 иштеп, эски ядро ​​коюп ал иштейби?
    Салам эл

    PS: алар акарат келтириши мүмкүн, мен ага татыктуумун 😉

    1.    Гиль ал мындай деди:

      Муну байкап көрүңүз: виртуалдык кутуга Ubuntu 9.10 орнотуп, ошол жерден принтериңизге басып чыгарууга аракет кылыңыз. Эгер ал иштеген болсо, анда сиз аны Linuxтан Linuxка чейин бөлүшүп, өзүңүздөн басып чыгарууга же өзүңүз менен PDF форматында басып чыгарууга аракет кылып, pdfs файлын Ubuntu 9.10 дан алып кетүү үчүн эки тутумдун ортосундагы жалпы папкага басууга болот.
      Бул менчик драйверлердин көйгөйү, Windowsта дагы ушундай болот, сиз 15 жыл мурун Windows XP менен бир нерсе сатып алдыңыз жана win7 же 10 үчүн айдоочу жок.
      Эч качан менчик айдоочулар менен эч нерсе сатып албаңыз, эгер акысыз айдоочулар менен болгон мелдеште бир нерсе болсо, жакшылап тандаңыз.

  11.   жашыруун ал мындай деди:

    Маалымат үчүн рахмат, кийинчерээк бир тууган принтерди wifi аркылуу кантип туташтыруу боюнча окуу куралын жасап берсеңиз болмок ... менин оюмча бул MFC9330CDW. Алдын ала рахмат

  12.   Пакито мырза ал мындай деди:

    Менде HL-L2340DW бир тууган бар жана мен ага Wifi аркылуу туташам. Принтерди USB аркылуу туташтыруу үчүн эч кандай көйгөй болгон жок, бирок Wifi менен иштей албай койду.

    Brother сизге, жок дегенде, Ubuntu үчүн, айдоочуну орнотуу куралы деп сунуштайт, ал керектөөчүнүн өзү (же дээрлик бир нерсе жасашы керек) деп эсептейт. Маселе, аны кантип жасоону билишиңиз керек. Менин оюмча, Гуглду бир аз кыдырып чыккандан кийин, бир тууган сизге ушул жерде түшүндүрүп бергенин көрдүм:

    http://support.brother.com/g/b/downloadhowtobranchprint.aspx?c=es&dlid=dlf006893_000&flang=4&lang=es&os=127&prod=dcpj315w_eu_as&type3=625&printable=true

    Маселе URIге эмне коюуну билүүдө ... Ошентип, издөөнү улантып, мен бул макалада бир jose1080i жазган комментарийден жооп таптым:

    https://www.pedrocarrasco.org/como-configurar-una-impresora-wifi-en-linux/

    Аны жакшыраак түшүндүрүүгө болбойт.

    Салам.

  13.   Вифизм ал мындай деди:

    Бардык Brother үлгүлөрүндө иштебейт, туурабы? Менде кара жана ак түстөгү лазер бар жана жол жок

  14.   Энрике Галлегос ал мындай деди:

    Мен Linux Mint 19 Cinnamon 64-битин колдоном, Brother HL-1110 компактуу монохромдуу лазер принтерин сатып алдым жана Wifi ордуна жүрөгүмдү жылыткандан кийин (ал USB аркылуу жүрөт), ал администрацияда пайда болот, ал тургай документтерди жылдырат, бирок алар бош болуп калат Басып чыгаруу үчүн, менде "виндолдар" болушу керек, ал кайда жакшы жүрөт.