Basis Programméiere mat Pseint (Deel 3)

Dëst ass eng Fortsetzung vum Tutorial Basis Programméiere mat Pseint (Deel 2), dës Kéier wäert ech erkläre wat néideg ass fir ze programméieren.

OPGAVE

D'Aufgab ass e Prozess an deem eng Variabel erstallt an / oder geännert gëtt, bezitt sech op se mat hirem Identifizéierer mat deem mir op säi Gedächtnisraum zougoen.

d'Syntax vun der Aufgab ass:

[variable]<- [expresion];
[variable]=[expresion];

Wou [Variabel] d'Variabel ass déi de Wäert kritt fir [Ausdrock] ze evaluéieren. Déi zwee si valabel sou datt et egal ass wéi eng benotzt gëtt (wa se PSeInt korrekt konfiguréiert hunn), awer menger Meenung no erstellen ech déi éischt als déi richteg.

Wann [Variabel] net virun der Aufgab existéiert, gouf [Variabel] erstallt, wann et existéiert gëtt de virege Wäert zerstéiert an deen neie gëtt op seng Plaz gesat. Aus dësem Grond gëtt d'Kaartung als destruktiv Operatioun ugesinn.

LIESEN

Liesen ass de Prozess an deem eng Date oder Daten vum Benotzer gefrot gi fir déi Daten an enger Variabel ze späicheren.

seng Syntax ass:

Leer variable_1,variable_2,...,variable_n;

wou [Variabel_ {1,2, n}] d'Variabel oder d'Variabelen sinn déi de Wäert vum Benotzer kritt, am Fall wou méi wéi eng Variabel ugefrot gëtt, da freet se fir d'éischt fir déi éischt, duerno fir déi zweet a sou weider bis hunn all d'Wäerter kritt.

Dëst ass och eng destruktiv Funktioun.

SCHREIFEN

Schreiwen ass de Prozess an deem e String vun Zeechen an / oder een oder méi Variabelen um Écran geschriwwe gëtt

d'Syntax ass:

Escribir expresion_1,expresion_2,...,expresion_n;

wou [expersion_ {1,2, n}] d'Charaktersträicher an / oder Variabelen sinn déi ugewise ginn.

Schreiwe zousätzlech fir d'Daten ze kréien, déi op den Ecran gesat ginn, kritt och d'Instruktioun "Ouni iwwersprangen" oder "Ouni erofgoen", déi de Linnesprong vermeiden.

Schreiwe füügt keng Plazen tëscht den Argumenter bäi, dat heescht wann et gesat gëtt:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

an dësem Fall wäert et «olamundo» weisen, well tëscht «a» a «b» gëtt et keng Zeecheketten, déi de Raum tëscht a a b uginn, sou datt se richteg ugewisen ass, sou geschriwwen:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

an dësem Fall füügt »bäi wat eng Zeecheschnouer ass déi e Raum huet deen de Raum tëscht« Welle »a« Welt »ass an da weist et« Wellewelt »mam Raum.

WANN DANN

Dëst ass e Saz deen eng gegebene Bedingung evaluéiert an d'Wahrhaftegkeet an / oder Falschkeet vun deem Zoustand kontrolléiert, dat ass, wann d'Konditioun erfëllt ass oder net.

Seng Syntax ass:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

D'Klausel «Anescht» ass net obligatoresch, an dësem Fall wann d'Konditioun falsch ass, ignoréiert d'Instruktioune a fuert weider wéi wann de Saz net existéiert, an dësem Fall bleift et:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Egal ob d '"Feeler" Klausel placéiert gouf oder net, hänkt vun de Besoine vun deem Programm of.

ACCORDING

De Saz wéi en eng streng numeresch Variabel evaluéiert déi méi wéi 2 Optiounen als Optioun gëtt, dëst ass den Ënnerscheed vun "Wann-Dann" zënter der viregter kann nëmmen 2 Optiounen ginn.

D'Syntax ass:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Wéi Dir no "Nummer1" gesitt, gëtt et en ":" an duerno ginn d'Instruktioune fir auszeféieren am Fall gesat datt "numeresch Variabel = Nummer1", am zweete Beispill ass et "Nummer2, Nummer3" dat heescht datt wann "numeresch Variabel = Nummer2 oder Nummer3" da ginn "Instruktiounen" ausgefouert, dëst ass nëtzlech wann 2 Méiglechkeeten déi selwecht Instruktiounen ausféiere mussen.

Et gëtt och d'Klausel "An enger anerer Manéier" déi ausgefouert gëtt am Fall wou keng vun de Méiglechkeeten erfëllt ass.

WÉI

Et ass eng repetitive Funktioun déi als éischt eng Bedingung evaluéiert an dann, wann se erfëllt ass, eng Serie vun Instruktiounen ausféiert, da bewäert se d'Conditioun nei a wann et richteg ass, féiert se déiselwecht Instruktiounen aus a weider esou bis d'Konditioun falsch ass .

wann d'Konditioun vun Ufank un falsch ass, gëtt se ni ausgefouert a wann et ëmmer richteg ass gëtt se an enger onendlecher Loop gesat, fir de leschten an den Instruktiounen ze vermeiden muss et eppes sinn dat iergendwann eng Konditioun falsifizéiert ze sinn fäeg d'Loop ze beenden.

seng Syntax ass:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

WIDDERHUELEN-BIS

Dëst ass eng Funktioun ganz ähnlech wéi déi virdrun, awer am Géigesaz zu der viregter kontrolléiert dës d'Konditioun um Enn, dat heescht, de Kommando gëtt op d'mannst 1 Kéier ausgefouert, och amplaz d'Instruktioun auszeféieren wann et richteg ass, et féiert se aus wann d'Konditioun net erfëllt ass, awer wann Dir wëllt datt se ausgefouert gëtt wann d'Konditioun erfëllt ass, benotzt "while" amplaz "bis".

seng Syntax ass:

Repetir
[Instrucciones] hasta que [condicion]

FIR

Dës Ausso féiert eng Instruktioun eng bestëmmend Unzuel vun Zäiten fir eng Variabel, am Géigesaz zu de Virgänger, ännert dësen Zyklus de Wäert vun der Variabel a Fro selwer, wéi och eng ganz staark Syntax ze hunn.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Variabel" ass d'Variabel déi "Ufankswäert" kritt an d'Instruktioune ausféiert, da füügt "Variabel" plus "Schrëtt" bäi an féiert d'Instruktiounen nach eng Kéier aus bis "Variabel" gläich "Endwert".

wann "mat [Schrëtt]" ewechgeholl gëtt da wësst et datt "Schrëtt" gläich wéi 1 ass, och wann [Schrëtt] net spezifizéiert ass an "Ufankswäert" méi grouss ass wéi "Schlusswäert" geet et duerch ëmgedréint Uerdnung, dat heescht, "Schrëtt" ass -1

SUBPROCESS / FUNKTIOUN

E Fuedem oder eng Funktioun ass e Programm an engem aneren an datt dëst Ënnerprogramm een ​​oder méi Wäerter kritt, se bedreift an en aneren zréckbréngt. Seng Syntax ass

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

wou "Retour Variabel" d'Variabel ass, déi de Wäert enthält, zréckginn vun der "Funktiouns Numm" Funktioun, déi d'Parameteren "arg_1, arg_2, arg_n" krut fir dës auszeféieren

ANERER

Dëst si Funktiounen déi nëmme komplementär zu deenen anere sinn an net eng komplex Syntax hunn, well se nëmme komplementär Funktiounen sinn.

Kloer Écran

Dës Funktioun läscht den Ecran vun all Objet am Dolmetscher

Waart Schlëssel

Dës Funktioun waart op de Benotzer op e Schlëssel dréckt fir mam Programm weidergoen

Waart x {Zweetens Millisekonnen}

dës Funktioun waart eng Zäit a Sekonnen oder Millisekonne fir mam Programm weidergoen

PS: sorry fir d'Verspéidung awer ech war beschäftegt mat anere Saache fir datt ech net konnt schreiwen


Den Inhalt vum Artikel hält sech un eis Prinzipie vun redaktionnell Ethik. Fir e Feeler ze mellen klickt hei.

10 Kommentaren, loosst ären

Gitt Äre Kommentar

Är Email Adress gëtt net publizéiert ginn. Néideg Felder sinn markéiert mat *

*

*

  1. Responsabel fir d'Daten: Miguel Ángel Gatón
  2. Zweck vun den Donnéeën: Kontroll SPAM, Kommentarmanagement.
  3. Legitimatioun: Är Zoustëmmung
  4. Kommunikatioun vun den Donnéeën: D'Donnéeë ginn net un Drëttubidder matgedeelt ausser duerch legal Verpflichtung.
  5. Datenspeicher: Datebank gehost vun Occentus Networks (EU)
  6. Rechter: Zu all Moment kënnt Dir Är Informatioun limitéieren, recuperéieren an läschen.

  1.   Guille sot

    Hutt Dir keng Funktiounen fir Schlësselen ze fänken ouni d'Ausféierung ze stoppen? Fir eppes mat Bewegung ze maachen, déi méi 9 Joer al sinn, och wann en Hangman Spill och lëschteg ka programméieren.

    Prozess eppes_digo
    a <-1;
    saitlech <-30;
    erof <-5;
    Wärend a = 1 Do
    Clear Screen;
    c <-1;
    Linn <- "";
    Erëmfannen
    Linn <-linn + "";
    c <-c + 1;
    Bis c = lateral
    Zeil <-linn + "X";
    c <-1;
    Erëmfannen
    Schreiwen " ";
    c <-c + 1;
    Bis c = down-1
    Zeil schreiwen;
    Erëmfannen
    Schreiwen " ";
    c 2 Dann
    erof <-down-1;
    Enn jo
    "s":
    Wann ënner <15 Dann
    erof 2 Dunn
    lateral <-lateral-1;
    Enn jo
    "d":
    Wa säitlech <50 Dann
    lateral <-lateral + 1;
    Enn jo
    "0":
    a <-2;
    Enn Sekonnen
    Enn Wärend
    EndProzess

  2.   Guille sot

    Gutt net wann Dir eropgeet, besser d'Linn 23 an 28 änneren
    -23 Bis c = 15
    +23 Bis c = 18
    y
    -28 Wann erof> 2 Dann
    +28 Wann erof> 3 Dann

    1.    xnmm sot

      Merci fir de Bäitrag awer et huet e puer Probleemer wéi datt Dir e Saz an engem aneren opmaacht awer et muss am Saz ophalen wou et ugefaang huet, ech mengen, et kann een net setzen

      Prozess eppes
      a <- 0;
      virliesen;
      wann a net gläich wéi 25 ass
      wärend a net gläich wéi 0 do ass
      virliesen;
      Enn jo
      Enn wärend

      wéi Dir d'Loop gesitt wärend Dir an der "wann dann" Ausso ufänkt awer ausserhalb dovun ass, ass sou eppes net méiglech.

      Ech schätzen nach ëmmer de Bäitrag
      Enn Prozess

      1.    Guille sot

        Merci, awer ech mengen et ass méi e Problem de Code hei ze setzen, datt ech net weess wéi een en am Code-Typ setzt an et kënnt eraus ouni Indentatioun.

        De Programm funktionnéiert gutt. D'Variabel "a" benotze ech einfach fir aus der Loop erauszekommen wann de Benotzer eng Null tippt. Dir kéint eng Sortie () oder eng Paus setzen; an der Bedingung gesäit et dran an ech späicheren d'Variabel. Si sinn Optiounen.

        Merci.

      2.    Guille sot

        Ech probéieren Tabs z'änneren fir Plazen an d'Etiketten por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille sot

        Dat ass voller Importfeeler aus mengem Code, ech probéieren nach eng Kéier mat Tabs:
        Dëst wier d'Datei algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille sot

        Interessant ass de Kommentar mat Codenetikelen giess, geläscht, wat tëscht geet, zum Beispill tëscht Zeilen
        Erëmfannen
        Schreiwen " ";
        c
        nom c gëtt et eng
        an da geet et weider mat 3 Dann
        erof
        Insgesamt ass dëst net zouverléisseg fir no wéi eng Coden ze setzen.

  3.   Guille sot

    Ech änneren d'Symboler vun der Uerdnung op = fir ze kucken wéi.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille sot

      Et hält en Deel vum Code iessen, de Code Tag feelt, et sollt d'Schreiwe loossen wéi et ass.

      1.    xnmm sot

        Salut sorry wann ech net gesinn hunn datt Dir virdrun geäntwert hutt awer gutt
        well Dir kënnt de Code net gutt verëffentlechen, well Dir schéckt mir en net per Mail, sou datt Dir net sou vill Wendungen zu der Matière gitt.