Apmācība: instalējiet .tar.gz un .tar.bz2 pakotnes

Sākumā, palaižot Linux un meklējot programmu, ir normāli, ka atrodam .deb vai .rpm un daudzos gadījumos atrodam programmas ar paplašinājumu .tar.gz y .tar.bz2Šie faili ir saspiesti un parasti satur norādījumus, kā to instalēt neatkarīgi no programmas.

Šo divu veidu pakotņu instalēšana ir tieši tāda pati

Vispirms mēs ievadām mapi, kurā mums ir fails, ja mapē ir vairāki vārdi, mums tie ir jāievieto ar "" vai ja tas nemeklē mapes ar katru vārdu

cd mape, kurā atrodas fails cd "mape, kurā atrodas fails"

Iekšpusē mēs izpakojam failu

tar -zxvf faila nosaukums.tar.gz tar -jxvf faila nosaukums.tar.bz2

Mēs konfigurējam

. / Konfigurēt

Mēs taisām (apkopojam)

padarīt

Tagad veiciet instalēšanu

padarīt instalēt

Dažreiz tas mums var radīt kļūdu ./configure, tādā gadījumā tas nav nepieciešams kompilācija un ar izpildi mums ir daudz, terminālā mēs to darām

Kā
saistīto rakstu:
Komandas, lai pārzinātu sistēmu (identificētu aparatūru un dažas programmatūras konfigurācijas)
programmas nosaukums

Vai arī mēs izveidojam palaišanas programmu.


Raksta saturs atbilst mūsu principiem redakcijas ētika. Lai ziņotu par kļūdu, noklikšķiniet uz šeit.

102 komentāri, atstājiet savus

Atstājiet savu komentāru

Jūsu e-pasta adrese netiks publicēta.

*

*

  1. Atbildīgais par datiem: Migels Ángels Gatóns
  2. Datu mērķis: SPAM kontrole, komentāru pārvaldība.
  3. Legitimācija: jūsu piekrišana
  4. Datu paziņošana: Dati netiks paziņoti trešām personām, izņemot juridiskus pienākumus.
  5. Datu glabāšana: datu bāze, ko mitina Occentus Networks (ES)
  6. Tiesības: jebkurā laikā varat ierobežot, atjaunot un dzēst savu informāciju.

  1.   moskosovs teica

    Wena, +1

  2.   pienācīgs teica

    faktiski pareizā lieta, kas jāatslēdz, ir
    tar -zxvf fails.tar.gz
    tar-jxvf fails.tar.bz2

    un konfigurēšanai ir bezgalīgas iespējas (atkarībā no programmatūras), lai pielāgotu instalāciju

    ./configure –help

    Ar to viņi redzēs dažādas papildu iespējas, instalējot programmu.
    Ne visos izplatījumos programmu instalēšanai tiek izmantots / usr / local, tas arī jāpiemin.

    Jūs aizmirsāt pieminēt, kā atinstalēt šādā veidā instalētu programmu. Papildus katras arhitektūras optimizācijas definēšanai.

    Jebkurā gadījumā, laba iniciatīva, bet jūs palaidāt garām daudz ... pārāk daudz informācijas, lai dalītos.

    Sveicieni

    1.    Drosme teica

      Tas ir kaut kas, ko es gandrīz nekad neesmu izmantojis, lielāko daļu programmu atrodu oficiālajos krātuvēs.

      Patiesība par dekompresēšanu ir tāda, ka man tā vienmēr ir bijusi laba.

      Es to uzrakstīju tāpēc, ka mani pieskrūvē visi tie, kas saka: “Kad jūs to noņemat, izlasiet instrukcijas.

      Jebkurā gadījumā es uzskatu .tar.gz kā pēdējo līdzekli, ja deb / rpm paketē vai krātuvēs tāda nav

      1.    pienācīgs teica

        "Patiesība par dekompresēšanu ir tāda, ka man tā vienmēr ir bijusi laba."
        mēs piekrītam, es to neapstrīdu, bet tas nenozīmē, ka tas ir pareizi rīkoties. Ne visi rajoni atslogo "saprātīgi", dažiem ir jāpievieno vairāk parametru.

        1.    Drosme teica

          Cilvēks, tā nav mana vaina, ka ir nenormāli distrosi hahahaha

          1.    pienācīgs teica

            KISS cilvēks ... KISS

          2.    Drosme teica

            Cilvēks, KISS nav debīls, jūs to jau zināt ar Slackware hahahaha

          3.    pienācīgs teica

            xD
            Tāpēc es jums to saku

            Vienkārši! = Viegli.

  3.   yoyo teica

    +1 pareizai

    1.    Pepe teica

      Viens pakaļu vairāk nekā otrs. Šie "ģēniji" ir ārpus tēmas.

  4.   523 teica

    Ja mainīsit "make install" uz "checkinstall" (to var instalēt ar aptitude, tas atrodas krātuvēs), tas instalēs programmu, bet arī:
    -Izveidojiet .deb, lai to varētu instalēt arī turpmāk
    -Iestādītā programma parādīsies Synaptic, tāpēc jūs varat to viegli atinstalēt no turienes

    1.    Drosme teica

      Arch lietotājiem tas ir saistīts ar piemērotību ...

  5.   jelpasažieris teica

    Atvainojiet par manu nezināšanu, bet vai svešzemju lietotne atrisina visas šīs problēmas?

    1.    pienācīgs teica

      Nē, jo citplanētieši strādā ar kompilētām pakotnēm un tar.gz vai tar.bz2 ir saspiesti faili ar pirmkodu.

  6.   92 teica

    Apmācību par to īsti nevar izdarīt, lielākoties vismaz qt pakotnes tiek apkopotas citos, vēl dīvainākos veidos.

    1.    hypersayan_x teica

      Tieši to pašu es gribēju teikt.
      Tie, kas izmanto qmake no Qt, ir vairāk vai mazāk šādi:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      Un es pievienoju vēl vienu gadījumu, kas ir cmakes:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      Vai arī ir citi, kuriem vienkārši jāpalaiž make && sudo make install.
      Tie ir visizplatītākie gadījumi, taču ir daudz vairāk variantu: s

      1.    mcder3 teica

        Ir gadījumi, kad dažas QT veiktas lietojumprogrammas neatnes makefile. Tāpēc ir pienācis laiks tos izveidot ar šādu rindiņu:

        qmake - makefile

        Sveicieni

  7.   jelpasažieris teica

    Apskatīsim, vai es paskaidrošu, kad man ir jāizmanto tar.gz vai tar.bz2. Viss, ko es daru, lai ģenerētu .deb vai all.deb, izmantojot alien, ir sudo alien install + pakotnes nosaukums. Vai tas nav tas pats, kas apkopot?

    1.    hypersayan_x teica

      Nē, kompilēšana ir programmas pirmkoda pārveidošana mašīnkodā.
      Savukārt tas, ko jūs darāt ar citplanētiešiem, ir pārsaiņošana, kas pārveido viena izplatīšanas paketes formātu par cita izplatījuma paketes formātu.
      Lai padarītu to vienkāršāku, ir tā, it kā jums būtu saspiests fails RAR un vēlaties to pārveidot par ZIP, jūs atspiestu failu RAR un atkal saspiestu ZIP, tieši to dara ārvalstnieks.

  8.   StuMx teica

    Kompilācija tiek veikta marķējumā, nevis konfigurācijā. Konfigurācijas fails ir skripts, kas pārbauda, ​​vai sistēma atbilst visām atkarībām, lai sastādītu programmu, un pēc tam tas ģenerē make failu (kas nosaka to, kā tas tiks kompilēts) atbilstoši mūsu sistēmai.

    1.    Drosme teica

      Tagad es to noņemu, jo šis raksts jau ir ilgs laiks, kopš es to uzrakstīju aprīlī vai maijā. Es to nepārbaudīju, gandrīz noņemot kādu sliktu vārdu, neko citu

  9.   jelpasažieris teica

    Sveiki
    Es domāju, ka es sevi ļoti labi nepaskaidroju. Alien pārveido paketi rpm tikai par .deb, ja ņemat programmas avota kodu, vai tas būtu gz, vai bz2, tas pārveido to par pašinstalējošu atkļūdotāju. Tāpēc mans jautājums. Esmu bijis uz Linux neilgu laiku, pacenties.

  10.   Marco teica

    atvainojiet manu nezināšanu, bet šie soļi ir spēkā arī čakrā, vai kaut kas mainās ???

    1.    KZKG ^ Gaara teica

      Cilvēka vispār nav 😀
      Šīs darbības ir gandrīz standarts visos rajonos, taču nav 100% pārliecināts, ka šīs VIENMĒR ir veicamās darbības. Tāpēc iesaku vienmēr kaut ko izlasīt instrukciju failā (README parasti).

    2.    pienācīgs teica

      kā saka @ KZKG ^ Gaara, tas ne vienmēr notiek, tas ir standarts, kas darbosies visos apgabalos, kamēr programma ir rakstīta C / C ++

  11.   Karloss-Xfce teica

    Kad atkal saskaros ar .tar.gz no šiem, es atgriezīšos pie šī raksta. Kā es ienīstu šādus iepakojumus!

    1.    Drosme teica

      Sasodīts, ka esat pietiekami vecs, lai instalētu šīs paketes HAHAHAHAHA

  12.   VulkHead teica

    Atvainojiet, ka man trūkst zināšanu, šī instalēšanas metode darbojas arī Debian. Jo es cenšos un mēģinu, un tas man rada kļūdu.

  13.   Laura Tejera teica

    Tāpēc neviens nelieto Linux, kaut ko stulbu darīt ir triks

    1.    elav teica

      Cik ziņkārīgi, dažas no šīm stulbajām lietām, kuras jūs pieminējat, "super apdāvinātie" Windows un OS X lietotāji to nevar izdarīt vai no tām baidās.

      1.    Laura Tejera teica

        smieklīgākais ir tas, kā tādi cilvēki kā tu var sekot šādai slēgtai OS.

        1.    KZKG ^ Gaara teica

          Vai esat izvairījies atbildēt uz jautājumu? ... Vai Windows lietotāji vai OS X ģēniji ar savu sistēmu var izdarīt tik daudz lietu, cik mēs rādām šajā vietnē? 🙂

          Starp citu, jūs izmantojat Ubuntu, tāpēc ... par ko mēs runājam?

          1.    Laura Tejera teica

            seko līdzi viduvējai mangai

            1.    KZKG ^ Gaara teica

              Vai mēs esam viduvēji? … Uff ... LOL!


      2.    Pepe teica

        Mēs esam 2015. gadā!
        Es domāju, ka nav nepieciešams tērēt tik daudz laika mācībām, lai strādātu no konsoles.
        Kāpēc šim nolūkam neizmantot automatizētas lietojumprogrammas?
        Jebkurā gadījumā tie, kuriem "patīk" rakstīt komandas no tur esošās konsoles, ļaujiet viņiem to turpināt darīt, taču paralēli būtu nepieciešamas tās pašas automatizētās komandas. Es nelūdzu nosūtīt raķeti uz Mēnesi.

    2.    Santjago Luiss Bazāns teica

      Brīvās programmatūras izmantošanas iemesli ir morālā ētika. Nekad neļaujiet nevienam liegt viņu brīvības

      1.    Pepe teica

        Patiesība, ka “brīvības” sanata programmās man ir apnikusi. Vai viņi nevarētu beigt slavēt neesošu dievu un būt nedaudz pazemīgāki?

    3.    Pepe teica

      Tev taisnība Laura, šie puiši ar savu Linux sarežģī to līdz kaulam. Put0 logos viss ir vienkāršāk. Es nepazemoju Linux, bet nevar būt, ka, lai instalētu pel0tudes, jūs stundām stundām ilgi pētāt, kā darbojas darva un visas meresundas, lai dienas beigās jūs aizķertos ar šo "Linux iesācēju ...".

      Esmu iecerējis izmantot stabilu operētājsistēmu, bet neņemt stundas no darba, jo man ir jāstrādā, man nav vēlmes kļūt par "Linux absolventu".

  14.   Thanatos teica

    Kaut kas vienmēr pietrūkst ... kad es dodu ./configure I get: configure: error: Jūsu intoltool ir pārāk vecs. Jums ir nepieciešams starpinstruments 0.35.0 vai jaunāks.

    Pēc tam atgriežas make instrukcija: Netika norādīts mērķis un netika atrasts makefile. Augsts.

    veikt instalēšanu: Nav noteikuma, lai izveidotu mērķi “instalēt

    Es esmu iesācējs, un ir labi veikt pētījumus, lai mācītos, bet FUCK, vai jūs to nevarat izskaidrot ar krāsainiem oļiem tiem no mums, kas ir jauni Linux?

    1.    Pončus teica

      Thanatos man bija līdzīga problēma, un es piekrītu savam iznākumam:
      (Pirmkārt, lai precizētu, ka arī es esmu neofits Linux pasaulē, un mani piedzīvojumi šajā kontekstā ar "garšu" (distro) uz Ubuntu ir viena nedēļa).
      Pieņemot, ka tas nonāk manā mapē «Lejupielādes» ar komandu «cd», kur terminālā vai konsolē tika atrasta mana programmas «SoulSeek» pakete ar beigām «.tgz»:
      "./Configure" man deva kļūdu, ka fails vai direktorijs neeksistē
      "Make" man iemeta to pašu kļūdu kā jūs ... tāpēc es neturpināju komandu "sudo make install" (sudo ir tāpēc, ka Ubuntu šīs komandas izpildei ir nepieciešams "Super User un viņa parole", citiem vārdiem sakot, veiciet instalēšanu ).
      Izpētot iepriekš saspiestu failu, es sapratu kaut ko tādu, kas ar jums var notikt, proti, ka saspiestais fails bija "izpildāmā faila" tips (labā klikšķa īpašības) un tā izpildei bija nepieciešami 2 klikšķi.
      Jūsu problēmu «./configure» var atrisināt, atjauninot jūsu Distro instalētās paketes vai krātuves (šie vārdi mani nedaudz mulsina), jo tas jums saka, ka «intItooI» ir vecs un jums ir nepieciešams jaunāks, un es domāju, ka varbūt šī pakete ir tā, kas apkopo jūsu distro. Ubuntu jūs to darāt tajā pašā terminālī, ierakstot "sudo apt-get update" un atjauninot visas sistēmas paketes.
      Es ceru, ka esmu bijis noderīgs.

    2.    Pepe teica

      Kā es teicu Laurai, šī Linux lieta prasa ilgu laiku. Tas man deva tādu pašu kļūdas ziņojumu kā jūsējais, un es esmu kā Kantervilas spoks no vienas vietas uz otru un vispār neko.

      Mans priekšnieks man teica: "Jums ir 2 dienas laika, lai atrastu risinājumu, pretējā gadījumā mēs atgriezīsimies pie logiem."

  15.   Jonathan teica

    Gracias

  16.   ivan teica

    sveiki, man ir tā pati problēma, es gribu instalēt skype 4.0. uz sava pclinuxOS es lejupielādēju darvu, gz2 un atspiestu, un, kamēr es tur nokļuvu, kad es to daru ./configure tas man saka, ka fails nepastāv .. kur es pazudu vai ko? pasaki man, pclinuxOS (pēdējā izlaistajā versijā) ir instalēta skype, bet tā ir versija 2.2, un es gribu instalēt 4,
    Vai man ir jāizdara kāds triks, lai to beidzot instalētu? kaut kas sinaptisks, ko nezinu ???
    Esmu jauns šajā sistēmā, iepriekš esmu izmēģinājis citus distros un līdz šim viss ir kārtībā, izņemot šo ..

    vēlējumiem

    1.    Pepe teica

      Vai tas esmu es, vai es nedomāju, ka kāds zina šos jautājumus.

    2.    f7eo teica

      Sveiki, ir pagājis ilgs laiks kopš jūsu jautājuma.

      Iesaku lejupielādēt jaunāko Skype versiju Windows (R)
      un ka jūs izmantojat Wine, lai to palaistu savā GNU-Linux izplatītājā.

  17.   no teica

    Sveiki! Man ir tā pati problēma: es lejupielādēju jaunāko centra programmatūras versiju ar paplašinājumu tar.gz un, nokļūstot instancē "./configure", es saņēmu kļūdu, tāpat kā "make". KAS TAS IR"?? PALDIES!! Bez tam programmatūras centrs ir bloķējis iespēju instalēt !!!

  18.   Karloss Rivera teica

    Paldies, tas man ļoti palīdzēja !!!!

  19.   michael teica

    kā izveidot palaišanas programmu

  20.   ANGI teica

    Viens jautājums, vai pirms ./configure palaišanas varat pārbaudīt tar.gz faila atkarības ???

  21.   joseluis teica

    Esmu jauns Linux, šķiet, ka ir ļoti grūti uzstādīt tar gz gz2 tabletes, un, ja man parādās deb, tam nav atkarību un ar apgriezieniem minūtē tas pats, ja tas ir i586 vai i686 vai i386, un vissliktākais ir tas, ka man nav internets manā mājā. Redzot tik daudz komentāru, kas ir pretrunā, jūs sajaucat vēl sliktāk.

  22.   Gabriella Jamamoto teica

    laba informācija, bet dažas * .tar.bz2 paketes jau ir apkopotas, un, lai tās instalētu, tās vienkārši jāatsaiņo jebkurā mapē (vēlams / opt, lai tā būtu pieejama visiem lietotājiem) un jāveic tieša piekļuve binārajam failam / usr / local / bin

  23.   Gonzalo teica

    Ļoti labs paskaidrojums par to, kā izmantot tar.gz failus. Liels paldies par informāciju. Sveiciens visai komandai

  24.   juancuyo teica

    Man tas neder
    cd / home / ju / downloads / icecat-24.0 ——-> Atbild uz mani
    bash: cd: home / ju / downloads / icecat-24.0: fails vai direktorijs neeksistē
    ko es daru nepareizi ??? Operētājsistēma ir Voyager 14.04 LTS (xubuntu) Xfce desktop Gdebi nav satura izvēlnē un neviena no tām nav sinaptiska, bet atrodas sākuma izvēlnē, pat ja jūs tās atverat, mapes tās neatpazīst, it kā būtu neeksistē. Es to atspiedu tajā pašā lejupielādes mapē. Vai tas ir nepareizi izvilkts?

  25.   Claudio teica

    Šī apmācība darbojas arī domēnā .tgz?

    1.    joakoej teica

      Nē, .tgz ir formāts, ko izmanto Slackware, un tie jau ir apkopoti, neatkarīgi no tā, vai esat to lejupielādējis vai apkopojis no slackbuild

    2.    joakoej teica

      Lai to instalētu, jāizmanto installpkg "package name".

  26.   asdf teica

    Atvainojiet, bet tas man daudz problēmu neatrisina, kad jūs sakāt ./configure un mēs to konfigurējam, jums vajadzētu norādīt vairāk, vai ne? ja es vienkārši ievietoju ./konfigurēt, tas man saka
    bash: ./configure: Fails vai direktorijs nepastāv

    tad tu saki "mēs darām"
    Kods:
    Padarīt
    Mans rezultāts:
    make: *** Nav norādīts mērķis un nav atrasts neviens makefails. Augsts.

    Veiciet instalēšanu
    make: *** Nav nekāda noteikuma mērķa "instalēt" konstruēšanai. Augsts.

    Un tad jūs sakāt "mēs vadām programmu"
    Kods:
    Programmas nosaukums

    Kā es varu zināt, kurš ir nosaukums vai kurš ir izpildāms? Tas ir ļoti abstrakti, varbūt jūs uztverat par pašsaprotamu vairākas lietas, kuras jūs zināt, bet tie, kas nāk apskatīt apmācību, var nezināt

    1.    Damian teica

      asdf.

      Es izmeklēju, un kļūda, kas rodas, piešķirot ./configure, ir saistīta ar kompilācijas programmas trūkumu (kā mēs varētu apkopot bez programmas, kas to dara?). komanda, lai instalētu kompilatoru, lai ievadītu, ir:

      sudo aptitude instalēt build-essential

      Kad tas ir instalēts, mēs dodamies uz mapi, kurā atrodas saspiežamais fails, un izpildām:

      tar -zxvf programmas_nosaukums.tar.gz

      Tad mēs IEVADIET neizpakoto programmas mapi un, ja tur izpildām ./configure un pēc tam sudo make install

      Es ceru, ka esmu palīdzējis!

      Sveicieni.

      1.    Damian teica

        Atvainojiet, es aizmirsu precizēt, manā gadījumā, lai veiktu "make" un "sudo apt-get install program", man bija jāievada mapē "base", kas atrodas izvilktā mapē, tieši tur es paņēmu komandas kompilēšanai (make ) un instalējiet.

      2.    Carlos teica

        Tas man sagādā problēmas, kad lietoju, liekot teikt, ka tas neko neatrod, lai izveidotu augstu

  27.   Brenda teica

    Diemžēl man ir šī problēma. Es palaidu šo komandu, un tā parāda kļūdu, un es nevaru izveidot makefile
    darbvirsma: ~ / Lejupielādē $ tar -jxvf iReport-4.1.3.tar.bz2
    darva (bērns): iReport-4.1.3.tar.bz2: Nevar atvērt: Fails vai direktorijs neeksistē
    darva (bērns): Kļūdu nevar atgūt: tagad izeju
    darva: Bērnam atgriezts statuss 2
    darva: Kļūdu nevar atgūt: tagad izeju
    lūdzu =)

  28.   Ārons teica

    Labas dienas draugi,
    Esmu jauns Linux lietojumprogrammā, tomēr man ir bijušas nedaudz neērtības, atpazīstot ierīci, kas ir digitāls biometriskais lasītājs, es vienkārši googlē un acīmredzot to atradu, tomēr tas tika lejupielādēts ar paplašinājumu .tar.gz, mēģiniet to noņemt mapē vairāki faili tika atsprausti, bet es nezinu, vai pēc tam man ir jāpalaiž kaut kas cits vai jāielīmē šie nesaspiestie faili sistēmas mapē, es nezinu, ja jūs man palīdzat, lūdzu, palaist labi, es būtu ļoti pateicīgs, man OS ir instalēta Linux Debian 7. Sveicieni un liels paldies.

  29.   Rufo Lopess Retortillo teica

    Es izmantoju gan Linex 2011, gan Linex 2013, un lielākā problēma, ko atrodu, instalējot lietojumprogrammas, ir tā, ka tās nav ielādētas viņu grupas lietojumprogrammu sarakstā (grafika, birojs, multivide utt.) Un ja es vēlos izveidot palaišanas programmu I nezinu, kur man jāiet, lai atrastu lietojumprogrammu palaidēja failu. Kurā mapē jūs to izveidojat? Kā to izdarīt?
    Kad palaišanas ierīces ir instalētas no krātuvēm, tās tiek ievietotas savā grupā, vai to var izdarīt, instalējot tar.gz, kā aprakstīts šajā tīmeklī?
    Paldies par palīdzību

  30.   Carlos teica

    Lūdzu, palīdziet man, ka man ir cita operētājsistēma ar nosaukumu lps 1.5.5, un es nevaru atjaunināt programmu

  31.   Carlos teica

    Lūdzu, sakiet vēlreiz, ka es nevaru atvienot tar.bz2 failu. Man ir operētājsistēma ar nosaukumu lps 1.5.5, un es nezinu, kā to izmantot, lūdzu, palīdziet man, es jums pateicos ...

  32.   joscastel teica

    pēc faila bz2 izpakošanas komanda ./configure NEDRĪKST, jo tās NAV

    1.    joscastel teica

      Man ir ubuntu 14.04LTS

  33.   jūs zināt teica

    Es to nesaprotu, slaxā .tar.gz iet uz kino, bet ubuntu man nav iespēju sastādīt

  34.   Raul teica

    Kāda ir labākā OS? labākā OS ir tā, ka tā atrisina jūsu problēmas.

  35.   Huanzito teica

    Linux cilvēki ir pārsteidzoši. Esmu mēģinājis instalēt ZinjaI savā nesen instalētajā LinuxMint izplatītājā vismaz 5 stundas.
    Es eju cauri visiem atrastajiem forumiem un visos (bet visos, ieskaitot šo), tie sniedz jums pusi informācijas.
    Piemēram, es jau atvēru termināli, bet es nevaru ievietot adresi, kur atrodas lejupielādētais fails (kas ir / home / user / Downloads / zinjai).
    Es saņemu tikai kļūdu: "bash: cd: user: Nav šāda faila vai direktorija.
    Es saprotu, ka viņi vēlas izplatīt un izplatīt operētājsistēmas lietošanu, taču, noliedzot informāciju vai paskaidrojot visu pa daļām, vienīgais, ko viņi panāks, ir tas, ka tādi lietotāji kā es, kuriem bija stingrs nodoms pāriet no Windows uz Linux, padodies un paliec pie sava W7, slikta, bet noderīga un vadāma.

    Priekā…

    PS: Ko viņiem izmaksāja nožēlojams uzstādītājs ar grafisko saskarni? Kāpēc šodien XXI gadsimtā viņiem vajadzētu turpināt izmantot kaut ko līdzīgu DOS, lai instalētu nožēlojamu mazo programmu? Zēni ... lai redzētu, vai viņi mazliet dzīvo ....

    1.    Ocelot teica

      cd ~ / Lejupielādes / instalācijas skripta ceļš.

      Viens padoms: pielīmējiet logus. Katra operētājsistēma ir paredzēta vienam cilvēka tipam. Windows ir paredzēts cilvēkiem, kuri vēlas, lai viņiem viss tiktu piešķirts un ar pēc iespējas mazākām pūlēm, un es uzskatu, ka tas ir jūsu gadījums. Ir cilvēki, kuri nevar vai nevēlas tiekties pēc kaut kā vairāk kā nākamā, nākamā, nākamā ... pieņemt. Tas nav slikti, mums vienkārši ir jāzina savi ierobežojumi un jāpielāgojas tiem.

      Vēl viens padoms: ja jūs tikai zinātu, cik daudz lietu panāk ar pazemību un izmantojot divus vārdus, piemēram, "lūdzu". Tas jūs pārsteigtu. Dariet to bieži.

      1.    Knarijs teica

        Sveiki Linuxeros.
        Liels paldies par apmācību, tas man palīdzēja instalēt wifi adaptera dwa-131 draiverus.
        Man ir nelielas šaubas, es esmu izdarījis visu, kā saka iepriekš.
        Pārejiet uz faila ceļu, dariet darījumu ... un pēc tam Make, pagaidiet, līdz tas būs pabeigts, un pēc tam veiciet instalēšanu.
        Līdz šim solim tas man nedeva nekādas kļūdas.
        Man ir jāzina, vai man jau ir instalēti draiveri, vai man jādara kaut kas cits.
        Juanzito .. dodieties uz priekšu un dodiet Linux iespēju neatkarīgi no izplatīšanas, es nolēmu pamest Windows 7 pirms nedēļas, un es esmu vairāk pazudis nekā ellē, hahaha, bet, lasot šeit un tur, jūs atrodat informāciju, kas jums dažreiz ir grūti saproti, viss ir atkarīgs no katra centiena vēlēties mācīties un izkļūt no monopola, kurā Windows tevi iegremdē (tas ir mans viedoklis).
        Viena lieta ... Linux terminālī skaitās lielie burti. 😉

        PS: Pēc Kame instalēšanas man ir jādara kaut kas cits. ??

        Liels paldies.
        Liels paldies un sveicieni no Kanāriju salām.

      2.    Loki teica

        un kas tu esi, lai pateiktu lietotājam atgriezties X sistēmā? Vai jūs domājat, ka Ričards stallman?

        Es piekrītu tam, ko viņi saka dažos komentāros, ka vislabākā OS ir tā, kuru sistēma pielāgo lietotājam, un NAV otrādi.

        Man personīgi patīk Windows .exe, jo, kā jūs sakāt, jums nav jābūt datora ģēnijam, lai instalētu kaut ko ļoti vienkāršu, piemēram, vienkāršu piezīmju bloku; salīdzinot šeit linux, ka, ja tas nav paredzētajās programmatūras lietojumprogrammās, ar planšetdatoru turaties pie gadsimta samezglotajiem.

        Es šeit nokļuvu meklējot un organizējot informāciju, lai instalētu programmas Linux, jo es gatavojos instalēt naudas kaltuvi produktīvā mašīnā un es zinu, ka, ja es to nesagatavošu, es nevarēšu neko instalēt, ja tas nav glabātavās.

        Tagad "lūdzu", visi jautā, problēma ir tā, ka neviens viņiem neatbild, tāpēc dažreiz cilvēkiem ir jābūt agresīviem, tāpēc nesakiet blēņas.

      3.    Pablo teica

        atvainojiet .. bet es vienmēr esmu aizstāvējis brīvas un atvērtas programmatūras izmantošanu .. Datorus izmantoju jau 30 gadus .. un man ir 37 ..
        problēma ir tā, ka kopumā Linux ir ideāli tas, ka tas, kurš vēlas vai kuram vajadzētu "zināt" nedaudz vairāk par kaut ko vienkāršu, piemēram, programmas, atjauninājuma vai jebkura cita instalēšanu ... problēma rodas tajā, ka daudziem cilvēkiem ir jāstrādā un jāizmanto pc (ar jebkuru operētājsistēmu), lai veiktu savu konkrēto darba uzdevumu .. tātad pat tad, ja .gz lejupielāde un instalēšana prasa 10 minūtes .. vai ja, kā parasti notiek, paies stundas .. tās ir minūtes vai stundas, kad neesat spēj darīt savu darbu, un tur gandrīz visiem pietrūkst pacietības ..
        Manā gadījumā .. darbā es izmantoju tikai Ubuntu, kas pēc noklusējuma ir instalēts datoros, jo tas ir zinātnes centrs, bet tas man liek pavadīt vairāk stundu, mēģinot instalēt vai pat atšķetināt, kā izveidot mīkstu specifisku (piemēram, Es esmu ģeogrāfs) tas darbojas .. vai arī pēc tā atjaunināšanas .. atgūstiet visus rīkus, jo puse pārtrauc darbu programmas ietvaros.
        šajā konkrētajā gadījumā .. Man vajadzēja redzēt vebināru / forumu darbā .. un, tā kā viņi izmanto java, man pietrūkst zīmes, ka man tas būtu jāatjaunina .. labi .. dodieties uz java vietni .. atrodiet failu savai OS , 14.04 .. apskatiet lejupielādes un instalēšanas "" instrukcijas "" .. lejupielādējiet .gz un no turienes .. unzip .. labi, un ... tas saka "instalēt" .. un voila .. tikai nekas nevarēja dari ar šī amata informāciju .. ko man darīt, kad atvienoju «dzīves mūža jre-blablabla.gz»?

  36.   Karloss Fabians Ferra teica

    tas man nekad nedarbojās nevienā distro

    1.    Jukiteru teica

      Ja tas jums nedarbojās, tas ir tīrs 8. slānis.

      1.    Jank Karloss teica

        Ģēnijs!

  37.   Ignācijs Navarro teica

    Tā kā es to ļoti bieži lietoju, katru reizi, kad šeit ieeju, lai redzētu, kā tas tiek darīts.
    Liels paldies, ka esat to uzrakstījis un pēc tik ilga laika neizdzēsāt.

  38.   Ramon teica

    kā sinaptiski var redzēt jauno instalēto pakotni, ja tā parāda vecāko (stabils saskaņā ar distro) ¿?

  39.   Jorge teica

    viss notiek, kad ierodaties ./configure, nav neviena, kurš labi izskaidro, kad saka, ka fails neeksistē

    1.    Elvis teica

      Es nemēģinu instalēt wifi no Broadcom, ne ./configure, ne padarīt, ne padarīt instalēšanas darbu.

      loģiskā secība ir 1. izpildīt ./configure, bet acīmredzot šī instrukcija attiecas tikai uz konfigurēšanas direktoriju un izpilda kādu tur ievietotu failu. Tam vajadzētu būt paketē, kas tiek lejupielādēta no Broadcom, bet manā gadījumā šī direktorija nav, tas ir paredzēts veikt konfigurēšanu, ir pārbaude un Makefile faila izveide, bet, izpakojot paketi, es saprotu, ka Makefile ir iekļauts, pārējās divas komandas make and make install man nedarbojas, tas būtu tāpēc, ka elementārā OS jaunākā versija neatbalsta to freya, pamatojoties uz ubuntu 14.04

    2.    Alehandro TorMārs teica

      Patiesība? Šī metode man nekad nav strādājusi, un es vienmēr izvēlos .deb paketes vai komandas no termināla ... Žēl, ka nav nekas skaidrs, kā instalēt .tar.gz

  40.   Elvis teica

    Es nemēģinu instalēt wifi no Broadcom, ne ./configure, ne padarīt, ne padarīt instalēšanas darbu.

    loģiskā secība ir 1. izpildīt ./configure, bet acīmredzot šī instrukcija attiecas tikai uz konfigurēšanas direktoriju un izpilda kādu tur ievietotu failu. Tam vajadzētu būt paketē, kas tiek lejupielādēta no Broadcom, bet manā gadījumā šī direktorija nav, tas ir paredzēts veikt konfigurēšanu, ir pārbaude un Makefile faila izveide, bet, izpakojot paketi, es saprotu, ka Makefile ir iekļauts, pārējās divas komandas make and make install man nedarbojas, tas būtu tāpēc, ka elementārā OS jaunākā versija neatbalsta to freya, pamatojoties uz ubuntu 14.04

  41.   Alehandro TorMārs teica

    Patiesība? Šī metode man nekad nav palīdzējusi, un es vienmēr izvēlos .deb paketes vai komandas no termināla ... Žēl, ka nav nekas skaidrs, kā instalēt .tar.gz

  42.   Alehandro TorMārs teica

    Kāpēc šī apmācība netiek atjaunināta? Vai arī viņi izgatavo jaunu?
    Visi šeit sūdzas, ka tas viņiem nav kalpojis un tam jau ir gadi ...

  43.   HEKTORS MATOS teica

    Sveiki, es gribu palīdzību, lai instalētu paketes .. Man ir Ubuntu versija 15 .. kaut kas .. Es gribu instalēt Adobe flash spraudni, jo to ir ļoti noderīgi instalēt, jo ar Adobe flash es varu ievadīt dažas tīmekļa lapas , kur var redzēt televizoru un arī klausīties radio .. lūdzu, vai varat atsūtīt man soli pa solim sniegtu apmācību .. Man nav lielas pieredzes komandrindā, proti, izmantot termināli.

    Palīdzi..paldies

  44.   Abraham teica

    Sveiki visiem !!! Pēc gandrīz visu komentāru izlasīšanas es meklēju Linux rokasgrāmatu un voila ..
    Draugs OCELOTE, pieņem šo kritiku no mana pazemīgā un nenozīmīgā viedokļa, kuru es kopīgoju ar miljoniem Windows lietotāju:

    Es labprāt pārietu uz Linux! bet daudziem no mums tas šķiet neiespējami, kāpēc? jūs varētu brīnīties ... jo man dators ir līdzeklis, ar kuru man jāpaveic savs darbs, tas nav beigas ... Es nezinu, vai jūs saprotat to, ko mēs visi vēlamies (un JUANZITO jums ir labi teicis) tā ir stabila operētājsistēma, kas palīdz mums paveikt mūsu darbu, man nav laika iemācīties no konsoles iemācīties darīt tādas pamatlietas kā instalēt programmu, visam jābūt intuitīvākam un vieglākam ... Es kā uzņēmējs es pateiks jums, ka vadība, kuru veicat ar Linux, ir katastrofāla, tā vietā, lai palīdzētu cilvēkiem veikt operētājsistēmas maiņu, jūs uzstājat, lai cilvēki melotu ar lietām, kas viņus neinteresē, un jūs pats bloķējat izmaiņas ... Tas, kurš ieprogrammēja assembler, java, javascript, html, php un xbase jums to saka ... un tas aizskar manu degunu, jo gandrīz visam ir jāatver konsole.

    Sveiciens

  45.   defcon teica

    Izturība DOS 6.22 veca !!

  46.   izvirdums teica

    Lieciet mācīties un atstājiet to wuendos sūdu, kas darbojas dažiem, jo ​​viņi liek likt kā atslēgas, viņiem nemaksā, lai aizskartu traumu, tie, kas izgatavoja šīs atslēgas, ir linux ģēniji, un viņiem vajadzētu Pārrunājot mamahuevadas, uzņēmējiem, ko es saku, turpiniet maksāt viņu licenci un, ja tas, ko viņi vēlas, ir stabils, viņi uzvar laiku, ko pie velna viņi dara, rakstot assholes šajos tutos, tas ir paredzēts tiem no mums, kuriem patīk linux assholes. pirksts po ace

  47.   GENDA teica

    Iesācējiem lietotājiem tas nav ļoti skaidrs. Piemēram, jūs sakāt:
    «Vispirms dodamies uz mapi, kur mums ir fails, ja mapē ir vairāki vārdi, mums tie ir jāliek ar" "vai ja tā nemeklē mapes ar katru vārdu" ...
    jebkurš lietotājs ievadīs šīs mapes ar «explorer» un pārdēvēs, nezinot mapes nosaukumu, kurā tā atrodas ar pēdiņām. Tas no tā viedokļa, ka jūs to lasījāt, «no iesācēja lietotāja viedokļa.

    Tad jūs ievietojat:
    CD mape, kur atrodas fails

    cd "mape, kurā atrodas fails"
    No šī brīža lietotājs jau ir devies uz mākoņiem vai kur, jo no šī brīža viņš ir pazudis kompaktdiskā ar iniciāļiem, jūs neskaidrojat, kā jūs tur nokļūt, soli pa solim, sākot ar visu to. .. vispirms atver konsoli.

  48.   GENDA teica

    HEKTORA MATOS: Adobe, Java un citu spraudnis nav jādara manuāli, jums tikai kādu laiku jābūt savienotam ar internetu, un atjauninājumu pārvaldniekā tas parādīsies automātiski, no turienes tas tiks atjaunināts automātiski, Firefox uz Opera, un pārējie neatkarīgi ... parasti palaidējs atrodas blakus pulkstenim sākuma joslā, vairākos rajonos es redzēju, ka pēc noklusējuma tas bija tur, es nezinu, vai tas tā būs visos tajos.

  49.   Max teica

    Lūdzu, norādiet precīzāk, trūkst daudz informācijas

  50.   Mary teica

    mēģiniet atjaunināt python uz 3.x un veicot instalēšanu pēc pabeigšanas, man ir kļūda:
    zipimport.zipimporterror nevar atspiest datus zlib nav pieejams make *** install kļūda

  51.   f_leonar teica

    Pēc atvienošanas, lai palaistu ./configure, ir jāievada saspiestais direktorijs, pretējā gadījumā tas nedarbojas. Es izmantoju KDE, un es grafiski ievadīju mapi, kuru nošifrēju, un tur es atvēru termināli, lai izpildītu "make", bet tas nedarbojas ...

  52.   anonīms teica

    Man ir jautājums, es to uztveru:
    manolo @ mxlolo-satellite-c655d: ~ / Desktop $ ./configure –help
    bash: ./configure: Nav šāda faila vai direktorija
    ko es daru…?

  53.   KATSODA teica

    Viss labs, līdz iznāca bumbiņu ./konfigurācija.
    KO TU AR TO DOMĀ !? Viņi to nepaskaidro, es tikai gribu instalēt otro jāšanās dzīvi xddd
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Lejupielādes / Second_Life_5_0_4_325124_i686 / configure: Fails vai direktorijs neeksistē »» »
    Es labāk lejupielādēju Windows 10 un paņemu pakaļu. (?)
    Nē. Bet šī ir viena no lietām, ko es ienīstu Linux. Instalēt un lūgt, lai jūsu iecienītās programmas būtu šeit saderīgas, ir diezgan liels izaicinājums.

    1.    Gatoo_ teica

      Neuztraucieties, kungi, bet apmācības veidotājs lieliski izskaidro, kā rīkoties, ja rodas kļūda ar ./configure. Jums vienkārši jāpabeidz pārējā apmācības (kas ir 4 rindas) lasīšana.

      Man šķiet neticami, ka tik daudzi cilvēki sūdzas, ka tas nepaskaidro lietas, ja jūs pat neesat apstājies lasīt.

  54.   piektdiena teica

    Nu, es oficiāli pasludinu sevi par nespējīgu attiecībā uz šāda veida failiem. Es mēģinu instalēt Java, un tas ir tas, kas tas ir;
    javier @ loft: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    darva (bērns): jre-8u151-linux-x64.tar.gz: Nevar atvērt: Fails vai direktorijs neeksistē
    darva (bērns): Kļūdu nevar atgūt: tagad izeju
    darva: Bērnam atgriezts statuss 2
    darva: Kļūdu nevar atgūt: tagad izeju

  55.   Rodžers deku teica

    Linux ubuntu 18.04.01 lts jums vienkārši jāievada programmas ./name tajā pašā mapē pēc tās izpakošanas un voila !!!

  56.   jia teica

    Ļoti labi, tas bija ļoti noderīgi.

  57.   emersona Gonkalesa teica

    av linux tas nedarbojas
    Es nezinu, kas man ir dīvaini, vai katru reizi, kad instalējat distro, sākat krusta ceļu
    jūs redzat, kā notiek tastatūra

  58.   Hosē Felikss Paisano Morales teica

    Sveiki, visi, es izmantoju Ubunto 20, un es apmeklēju šo lapu, lai instalētu Epson L4150 skeneri (diskus lejupielādēju no http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Es izpildīju soļus un izmantoju 'tar -zxvf filename.tar.gz', kad atvienoju, es to izmantoju
    '$ cd imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb', kas ir izveidotā mape.
    Iekš mapes, kuru izmantoju './install.sh', kas līdzinās './configure' lietošanai, sistēma man prasīja paroli un viss instalētais bija kārtībā.
    Es izmēģināju savu skeneri, un tas bija lieliski, paldies, ka devāt man norādījumus, es varēju izmantot savu skeneri