AppImageLauncher: viegli palaidiet un integrējiet lietojumprogrammas Appimage

AppImageLauncher

Pirms dažiem Gnu / Linux pasaulē mums bija universāla metode jebkuras lietojumprogrammas instalēšanai neatkarīgi no attiecīgā izplatīšanas, un šī metode bija, apkopojot lietojumprogrammu no tā pirmkoda.

Šī metode joprojām tiek izmantota, mēdz būt mazliet par vēluPapildus tam lietotājiem, kuri ir jauni Linux, un pat starpposma lietotājiem, tas var būt nedaudz sarežģīts.

Jau mazliet konkrētāks lielākajā daļā izplatījumu tiek izmantots kāds pakotņu pārvaldnieks ar kurām tie tiek atbalstīti lietojumprogrammu instalēšanai, teiksim, piemēram, Debian vai Ubuntu ar apt un deb vai Fedora pakotnes ar yum un rpm pakotnēm.

Ar kuru palīdzību mēs jau atrodam lietojumprogrammas vispopulārākajos pakotņu formātos, un tie mums ietaupa daudz laika ar instalēšanu, jo mums tas nav jāapkopo mūsu sistēmā.

Pirms neilgu laiku sāka parādīties jauna veida paketes lai instalētu, piemēram, lietojumprogrammas, Snap, Appimage vai Flatpak.

Dažu no tiem galvenā pievilcība ir tā, ka tie darbojas vidē, kas ir pilnībā izolēta no sistēmas, un ar to mums nebūs problēmu sabojāt sistēmu vai to sabojāt.

Par AppImageLauncher

Šoreiz mēs koncentrēsimies uz pakotnēm AppImage formātā ko pat daudzi lietotāji nezina, kā tos instalēt un pat kā tos integrēt mūsu sistēmā.

Kad mēs lejupielādējam AppImage pakotni lai to instalētu, mums jāpiešķir instalēšanas atļaujas un jāizpilda šāda komanda, lai to instalētu:

./paquete.appimage

Kas apstiprinās, ka mēs instalēsim lietojumprogrammu, tā beigās mums tiek jautāts, vai mēs vēlamies, lai lietojumprogramma tiktu integrēta mūsu lietojumprogrammu izvēlnē, vai arī mēs vēlamies izveidot saīsni.

Tur, kur daudzi lietotāji mēdz pateikt nē, nezinot vai kļūdoties. Lai vēlāk palaistu lietojumprogrammu, tas jādara no lejupielādētā faila.

Bet Mums ir arī rīks, kas to var atvieglot, šo rīku sauc AppImageLauncher.

appimagelauncher_1

Iesniegums ļauj ērti palaist AppImage failus, nepadarot tos izpildāmus.

Pagaidām AppImageLauncher Tam ir tikai atbalsts Ubuntu, Linux Mint, Debian, Netrunner, un tas nesen ir pievienojis atbalstu openSUSE.

Bet visinteresantākā iezīme ir viegli integrēt AppImages ar savu sistēmu: AppImageLauncher var automātiski pievienot saīsni AppImage lietojumprogrammai darbvirsmas vides izvēlnē / lietojumprogrammu palaidējā (ieskaitot lietojumprogrammas ikonu un atbilstošu aprakstu).

Kā darbojas AppImageLauncher?

Kad Mēs lejupielādējam lietojumprogrammu appimage, vienkārši veiciet dubultklikšķi uz tā, lai palaistu AppImageLauncher un tas mums piedāvās vairākas iespējas.

Pirmie, kas jums tiks parādīti, kad pirmo reizi instalējat lietojumprogrammu, ir:

Palaidiet vienreiz vai integrējiet un palaidiet.

Noklikšķinot uz integrēt un palaist, AppImage lietojumprogramma tiek kopēta mapē ~ /.bin / un pievienota izvēlnei, pēc tam programma tiek startēta.

Citas iespējas, ko tā piedāvā, kad lietojumprogramma jau ir instalēta, ir:

Dzēsiet vai atjauniniet lietojumprogrammu.

Ja mēs vēlamies noņemt lietojumprogrammu, tā ir tikpat vienkārša, ja vien jūsu izmantotā darbvirsmas vide ir saderīga ar darbvirsmas darbībām.

Lai atjauninātu, jums jāpiedāvā opcija, vēlreiz palaižot AppImageLauncher atjauninātā lietojumprogrammā, kuru jau esat instalējis sistēmā.

Piemēram, Gnome Shell, vienkārši ar peles labo pogu noklikšķiniet uz programmas ikonas darbību pārskatā un atlasiet Noņemt no sistēmas:

Kā Linux instalēt AppImageLauncher?

Tā kā es jau minēju AppImageLauncher savietojamību, lai arī to var izmantot arī atvasinājumos, mums jāņem vērā, ka tā savietojamība ir atkarīga no darbvirsmas vides, kur vispiemērotākā ir Gnome Shell vai Cinnamon.

Solamente jums jādodas uz šo saiti y lejupielādējiet paketi savai izplatīšanai Linux.

Debian, Ubuntu un atvasinājumu gadījumā, lai to instalētu, mums vienkārši jānovieto mapē, kurā pakotne tika lejupielādēta un jāizpilda:

sudo dpkg -i appimagelauncher*.rpm

Kamēr jo īpaši Ubuntu 18.04 mums ir pakete:

sudo dpkg -i appimagelauncher*.rpm

Par openSUSE:

sudo rpm -i appimagelauncher*.rpm


Raksta saturs atbilst mūsu principiem redakcijas ētika. Lai ziņotu par kļūdu, noklikšķiniet uz šeit.

3 komentāri, atstājiet savus

Atstājiet savu komentāru

Jūsu e-pasta adrese netiks publicēta. Obligātie lauki ir atzīmēti ar *

*

*

  1. Atbildīgais par datiem: Migels Ángels Gatóns
  2. Datu mērķis: SPAM kontrole, komentāru pārvaldība.
  3. Legitimācija: jūsu piekrišana
  4. Datu paziņošana: Dati netiks paziņoti trešām personām, izņemot juridiskus pienākumus.
  5. Datu glabāšana: datu bāze, ko mitina Occentus Networks (ES)
  6. Tiesības: jebkurā laikā varat ierobežot, atjaunot un dzēst savu informāciju.

  1.   Domāju teica

    Tas dod kļūdu: kļūda, ielādējot koplietojamas bibliotēkas: libQt5DBus.so.5: nevar atvērt koplietojamā objekta failu: Nav šāda faila vai direktorija
    Viņiem vajadzētu pateikt, kādas atkarības tai ir vai no kuras krātuves to lejupielādēt, lai tas visu paveiktu pats, put *, kas jums deva tūkstoš dzimšanas.

    1.    Gonzalo teica

      Neviens nevar jums paziņot par visām katrai programmai nepieciešamajām atkarībām

  2.   Transpēle teica

    Viņi var parādīt, kā to izdarīt no antix linux, izmantot icewm, un, lūdzu, es uzskatu, ka tas ir mazliet sarežģīts.