Kā instalēt AceStream Linux un nemirst, mēģinot

Tie no mums, kas mīl sportu un kuriem nav piekļuves visiem pašreizējiem sporta kanāliem, parasti saskaras ar problēmu, ka, lai to izbaudītu, mums jāizmanto dažādas lapas, kas pārraida tiešsaistes spēles, lielākā daļa no viņiem pieprasa instalējiet AceStream, kas parasti ir mazliet sarežģīti instalējams Linux.

Šajā ceļvedī mēs iemācīsim, kā instalējiet AceStream uz Linux nemirstot mēģinājumā, piedāvājot risinājumus mūsdienās visbiežāk sastopamajām problēmām. Tās izmantošana un saturs, kuram piekļūstat, ir jūsu kopējā atbildība.

Kas ir AceStream?

AceStream ir multivides platforma diezgan novatorisks, kas audiovizuālo materiālu reproducēšanu internetā ir pacēlis augstākā līmenī. Šim nolūkam tā ir ieviesusi universālu multivides failu ielādēšanas pārvaldnieku, kurā tiek izmantotas vismodernākās P2P tehnoloģijas, garantējot efektīvu datu glabāšanas un pārraides procesu.

Ace Stream programmatūra mums piedāvā virkni priekšrocību, kurās mēs varam uzsvērt:

  • Iespēja skatīties tiešsaistes pārraides (TV, personalizētas straumes, filmas, karikatūras utt.), Ar augstu audio un attēla kvalitāti.
  • Klausieties mūziku tiešsaistē tādā formātā, kas nezaudē nekādu kvalitāti.
  • Skatiet straumes tiešsaistē, negaidot, līdz tā tiks pilnībā lejupielādēta.
  • Skatiet saturu attālās ierīcēs (Apple TV, Chromecast utt.), Izmantojot tādus saziņas protokolus kā AirPlay, Google Cast un citus.
  • Ļauj integrēt ar dažādām lietojumprogrammām. Instalējiet AceStream operētājsistēmā Linux

Kā instalēt AceStream uz Linux

Lai instalētu AceStream operētājsistēmā Linux, mums ir jāveic dažādas darbības atkarībā no izmantotā distro, mēs koncentrēsimies uz Arch Linux un Ubuntu, taču mēs ceram, ka nākotnē varēsim to instalēt citos distros.

Instalējiet AceStream uz Arch Linux un atvasinājumiem

Galvenais iemesls, kāpēc es izveidoju šo rakstu, ir tāpēc, ka daudziem ir bijušas problēmas ar AceStream instalēšanu Arch Linux, Antergos, Manjaros un atvasinājumos. Galvenais iemesls ir spraudņa pkgbuild spraudnis acestream-mozilla Instalējot tas rada kļūdu, risinājums ir ārkārtīgi vienkāršs.

Mēs gatavojamies instalēt spraudnis acestream-mozilla kas mūs arī instalēs acestream-dzinējs y acestream-player-data kādi ir iepakojumi, kas nepieciešami pavairošanai AceStream no Firefox.

Vispirms mums jāatver termināls un jāizpilda šāda komanda:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Tas novērsīs verifikācijas problēmu, kas neļauj instalēt nepieciešamo atkarību spraudnis acestream-mozilla.

Tad mēs izpildām šādu komandu

yaourt -S acestream-mozilla-plugin

Atkārtotos gadījumos mums tiks jautāts, vai mēs vēlamies instalēt dažādas atkarības, mums visiem jāsaka jā.

Instalējiet AceStream uz Ubuntu un atvasinājumiem

Instalējiet AceStream uz Ubuntu 14.04 un atvasinājumiem

Lietotājiem ubuntu un atvasinājumiem līdz versijai 14.04 AceStream instalēšana būs diezgan vienkārša, viņiem no termināļa ir jāizpilda tikai šādas komandas:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Instalējiet AceStream uz Ubuntu 16.04 un atvasinājumiem

Tie, kuriem būs jācīnās nedaudz vairāk, ir Ubuntu 16.04 un to atvasinājumu lietotāji, jo acestream nav šīs versijas atbalsta, taču pateicoties tam artículo, Man izdevās to instalēt.

Pirmā lieta, ko mēs darīsim, ir lejupielādēt un instalēt dažas atkarības, kuras nevarēsiet lejupielādēt no oficiālajiem krātuvēm, pārliecinieties, vai esat instalējis atbilstošās sava izplatītāja arhitektūrai:

64 bitu arhitektūra:

  1. Lejupielādējiet un instalējiet libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb to var izdarīt, izmantojot šo saiti: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Lejupielādējiet un instalējiet secībā, kādā tiek parādītas šādas atkarības:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Katru no tiem varat lejupielādēt no šīs saites: https://drive.google.com/folderview?id= … e_web#list

32 bitu arhitektūra:

  1. Lejupielādējiet un instalējiet libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb to var izdarīt, izmantojot šo saiti: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Lejupielādējiet un instalējiet secībā, kādā tiek parādītas šādas atkarības: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Katru no tiem varat lejupielādēt no šīs saites: https://drive.google.com/folderview?id= … e_web#list

Tālāk mums ir jāturpina parastā AceStream instalēšana, tāpat kā 14.04 versijā, atveriet termināli un izpildiet:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Dažos gadījumos ir nepieciešams sākt pakalpojumu acestream-engine.service, tam mēs izpildām šādas komandas no termināla:

startctest startēt acestream-engine.service systemctl iespējot acestream-engine.service

Izmantojot šo apmācību, mēs ceram, ka jūs varat izbaudīt šo lielisko multivides pārraides protokolu, kas izmanto visu P2P tehnoloģijas jaudu.


Raksta saturs atbilst mūsu principiem redakcijas ētika. Lai ziņotu par kļūdu, noklikšķiniet uz šeit.

41 komentāri, atstājiet savus

Atstājiet savu komentāru

Jūsu e-pasta adrese netiks publicēta. Obligātie lauki ir atzīmēti ar *

*

*

  1. Atbildīgais par datiem: Migels Ángels Gatóns
  2. Datu mērķis: SPAM kontrole, komentāru pārvaldība.
  3. Legitimācija: jūsu piekrišana
  4. Datu paziņošana: Dati netiks paziņoti trešām personām, izņemot juridiskus pienākumus.
  5. Datu glabāšana: datu bāze, ko mitina Occentus Networks (ES)
  6. Tiesības: jebkurā laikā varat ierobežot, atjaunot un dzēst savu informāciju.

  1.   Hulio Cēzars Kamposs teica

    Labi ziņa, bet vismaz archlinux, un tas bija mans gadījums, kas jums nepieciešams: "systemctl start acestream-engine.service" un "systemctl enable acestream-engine.service", lai tas darbotos.

    1.    ķirzaka teica

      Vai jūs to testējāt no Firefox, vai arī izmantojāt citu pārlūkprogrammu?

  2.   UserDebian teica

    Vai kāds zina, kā panākt, lai tas darbotos Debian 9?

  3.   Hulio Cēzars Kamposs teica

    Firefox pārlūkprogrammā archlinux

  4.   gecoxx teica

    Es nezinu, vai mans iepriekšējais komentārs tika publicēts ... Es atkārtoju! Es nezinu, cik stundas nepieciešams, lai palaistu sasodīto komandu terminālā, un ka es ieliku –noconfirm, un galu galā tas nedarbojas !!
    vēl viens bezjēdzīgs ieraksts!

    instalēšanas mēģinājums Manjaro

    1.    ķirzaka teica

      Dārgais, ka tas nedarbojās jums, tas man darbojās perfekti, tomēr mēģiniet izpildīt šīs 2 komandas:
      "Systemctl start acestream-engine.service" un "systemctl iespējot acestream-engine.service"

  5.   José teica

    labi

    Man izdevās veikt visas darbības bez problēmām. Bet, mēģinot sākt pakalpojumu no termināļa, tas man sagādāja divas neveiksmes;
    systemctl start acestream-engine.service
    Neizdevās palaist acestream-engine.service: Vienība acestream-engine.service nav atrasta.
    systemctl iespējot acestream-engine.service
    Neizdevās izpildīt darbību: Nav šāda faila vai direktorija

    1.    Gustavo teica

      Tieši tas pats notika ar mani. termināls atmet man šīs komandas ar šīm neveiksmēm.

  6.   Huans M teica

    Liels paldies par ierakstu! Gadījumā, ja izmantojat Ubuntu 16.10 64 bitus, jūs nevarēsit instalēt "acestream-player-data_3.0.2-1.1_amd64.deb". Vispirms viņiem ir jāielādē un jāinstalē šīs paketes:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Iespējams, ir nepieciešama kāda cita atkarība, kas atrodas repos.
    Sveicieni!

  7.   Km teica

    Labi.
    Tāpat kā daudzi citi NPAPI spraudņi, pārlūkprogrammā Firefox 52 pārstāj darboties spraudnis acestream-mozilla-spraudnis.

  8.   darko teica

    Vēl viena ļoti laba un vienkārša iespēja ir izmantot dokeri un kļūt par savas operētājsistēmas agnostiķi. Izmantojot aceproxy, jūs varat to reproducēt-

    Esmu uzrakstījis nelielu apmācību un skriptu, lai atvieglotu izpildi.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   Deivids Martins teica

    Kā jūs to instalējat no Ubuntu 16.04, sakot, lejupielādējiet un instalējiet šos failus, kā tos instalēt? Kad es tos lejupielādēju un izvelku, daži ir tikai libreoffice fails, bet citi, es nezinu, kā "instalēt"
    Paldies jau iepriekš un sveicieni.
    David.

  10.   vafe teica

    Vai nu atslēgas vairs nedarbojas, vai arī paketēs ir kāda kļūda, bet arch un manjaro to nav iespējams instalēt.
    Mēģinot instalēt atkarību (qwebquit) vai kaut ko tamlīdzīgu, tas nonāk cilpā, un tā nav.
    Vai kāds ir atradis risinājumu?
    Gracias

    1.    Alexander teica

      Labdien! Lai instalētu Arch linux, jums jāveic šādas darbības:
      - Instalējiet paketi “acestream-launcher” no yaourt ar “yaourt -S acestream-launcher” (pakotne, kuru mēs iespējosim tālāk, tiks automātiski lejupielādēta jums)
      -Iespējot acestream-engine.service, mēs ieejam terminālī un sakņu režīmā mēs ievietojam sekojošo
      -sistēma iedarbina straumes dzinēju. pakalpojums
      -systemctl iespējo acestream-engine.service
      Pēc tam es restartēju aprīkojumu, nezinu, vai tas būs vajadzīgs, bet tikai gadījumā
      -Tam vajadzētu būt pietiekami, bet jaunākajos Arch atjauninājumos viņi kaut ko ir ieskrūvējuši, un tas nedarbojas, tāpēc viņi ir meklējuši pagaidu risinājumu, kas ir faila lejupielāde, un tas ir šāds:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      Fuente: https://aur.archlinux.org/packages/acestream-launcher/ (par komentāriem)
      pēc lejupielādes mēs ejam uz termināli un dodamies uz mapi, kurā to esam lejupielādējuši,
      Mēs turpinām to instalēt ar 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz', un viss, tam vajadzētu iet, pirmo reizi tas nekad nedarbojas, tāpēc es noklikšķinu otro reizi, pirmo reizi vienmēr dod kļūdu, tas arī viss

      PS: paskaidrojiet, ka sudo pacman -U un nevis -S, jo tas ir vietējais pakotne, kas iegūta no makepkg

      1.    vafe teica

        Liels paldies par jūsu interesi.
        Esmu mēģinājis tik daudz reižu, ka jau zinu atkarības un instalācijas pakotņu komentārus ar sirdi. Es sekošu jūsu palaidēja ieteikumiem un redzēšu, vai man paveicas. ES tev pateikšu.
        Es atkārtoju savu pateicību

        Felipe

        1.    vafe teica

          Vienā vai otrā veidā tas nedarbojas. Esmu mēģinājis ar saiti, kuru jūs ievietojāt komentāros, bet tas to neatrisina, tas atpazīst saiti, dod man iespēju izvēlēties programmu, es izvēlos acestream-launcher, bet VLC netiek atvērts.
          Konsolē tas man sniedz šādu atbildi.

          Fails «/usr/lib/python3.6/site-packages/psutil/init.py », 1231 rinda, _send_signal
          os.kill (self.pid, sig)

          Mums būs jāgaida jauni atjauninājumi.
          Paldies par jūsu palīdzību.

  11.   vafe teica

    Pēc jaunā atjauninājuma atbilde konsolē ir šāda.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Acestream motors darbojas.
    2017-07-28 18: 16: 59,615 XNUMX | MainThread | acestream | kļūda startēšanas laikā
    Traceback (pēdējais zvans pēdējais):
    Fails «core.c», 1590. rinda, in
    Fails «core.c», 144. rinda, in
    Fails «core.c», 2. rinda, in
    ImportError: nevar importēt vārdu __m2crypto
    Autentificējot Acestream, radās kļūda.
    Multivides atskaņotājs nedarbojas ...

    Mēs uzlabojamies, tagad tā atzīst straumi, bet libcrypto turpina cīņu.

    1.    vafe teica

      Esmu mēģinājis instalēt pakotni, kuru jūs iesakāt man nosūtītajā saitē.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      Un tas efektīvi novērš problēmu, atveras vlc un darbojas Acestream.
      Liels paldies par jūsu palīdzību-

      1.    Alexander teica

        Sveiki, atvainojiet par kavēšanos, bija ļoti dīvaini, ka tas jums nedarbojās, kad tas darbojās. Es esmu Arch plazmā, es priecājos, ka tas jums ir palīdzējis, tas ir tas, par ko mēs esam

        Citā man piederošajā izplatīšanā, kas ir Fedora, man ir vīns, kas atdarina acestream operētājsistēmai Windows xD, ja jūs dodaties uz citu distro vai pašā Arch, mani pārsteidz tas, ka pat Debian viņiem nav šo pakotņu ...

      2.    delikateses veidotājs01 teica

        Sveiki, un fails ir tā instalēšanas veids. Es joprojām esmu iesācējs, sveiciens

        1.    vafe teica

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Viņš to ievieto iepriekš komentārā

  12.   ķimikālijas teica

    Vakar es to instalēju kā snap paketi Kde Neon 5.8, un es biju pārsteigts, cik vienkārši un ātri tas man darbojās. Būtu jauki, ja atjauninātu rakstu, jo nav salīdzināšanas, process ir daudz vienkāršots.

    sudo apt install snapd → instalējiet snap pakotņu pārvaldības sistēmu (ja jums tā vēl nav instalēta)
    snap find acestream → lai pārbaudītu, vai mums ir programma krātuvēs (visiem ubuntu atvasinājumiem vajadzētu būt)
    sudo snap instalēt acestreamplayer

    Sveicieni

    1.    Antonio Manzano teica

      Tev taisnība. Es tikko instalēju to kubuntu 17.10, jo šeit redzamā metode ir pilnīgi neiespējama. Liels paldies

      1.    Tēt teica

        nav derīgs i386 arhitektūrai

    2.    sie9k teica

      Tas ir vienīgais veids, kā to var instalēt Lubuntu 16.04.4, taču man nav iespējas saglabāt konfigurācijas failu, un man ir jākonfigurē parametrs darbam blakus Serviio. Vai ir kādas idejas to labot?

  13.   José Antonio teica

    Ļoti labs ieraksts. Obligāti jāizlasa vietne Linux iesācējiem.

  14.   pīters debitants teica

    Kā jūs to instalētu AntiX 16 (tas ir Linux izplatīšana)?

    Esmu mēģinājis, piemēram, Arch Linux un atvasinājumus, bet esmu tik iesācējs, ka man tas ir nepareizi

  15.   Alexander teica

    Labdien, ar sna pakotnēm, kuras iepriekš komentētais kolēģis komentē, ir kļuvis vieglāk ne tikai šiem izplatījumiem, bet arī daudziem. Sadalījumi, kas ir saderīgi ar šīm paketēm, ir šeit:
    https://snapcraft.io/

    Debianā tas būtu šāds:
    -sudo apt instalēt snapd
    -sudo snap instalēšanas kodols
    -sudo snap instalēt acestreamplayer
    Arkā un atvasinājumos:
    -sudo pacman -S snapd
    -sudo systemctl iespējojiet tagad snapd.socket
    -sudo snap instalēt acestreamplayer

    Arch (plazmā) man nācās restartēt, lai parādās instalētās paketes, ja tas neparādās, jūs jau zināt, ko darīt.

    Es domāju, ka Ubuntu un atvasinājumos tas būs līdzīgs partnerim, kurš to instalēja iepriekš komentāros ar KDE neon.

    Interesanti, ka Gnome ar Debian tas izskatās diezgan neglīts un labi neintegrējas ar GTK, bet Arch plazmā tas diezgan labi integrējas, svarīgi ir tas, ka tas tiek redzams ārpus estētikas.

    1.    william teica

      vai tas instalē jūsu acestream motoru?
      ES nē

      1.    Alexander teica

        Sveiki, nē, jūs to neinstalējat un arī nevajag, jo ar snap pakotnēm visas aptvertās atkarības jau nāk, tai ir jāstrādā jā vai jā.

    2.    txuber teica

      Sveiks, Alehandro, uzzini, vai vari man palīdzēt
      [txuber @ manjaro ~] $ sudo systemctl iespējojiet tagad snapd.socket
      Neizdevās iespējot vienību: Vienības fails \ xe2 \ x80 \ x93now.service neeksistē.
      uz manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander teica

        Sveiki, Manjaro ir tas, ka tā nav tīra Arka, un lietas var nedaudz mainīties, iespējams, ka tā jau ir iespējota un tas nav jādara. Es domāju, ka jūs jau esat mēģinājis izlaist šo soli ...

  16.   Debian teica

    Pēc instalēšanas ko darīt? Tā kā ace-player nav instalēts, es nezinu, kā to panākt.
    Lūdzu, kāds man palīdzēs?

    1.    vafe teica

      Ja instalētais ir acestream-launcher, noklikšķinot uz saites, acestream jautās, ar kuru lietojumprogrammu vēlaties atvērt saiti, jūs to sakāt ar VLC, un tas ir tas, kurš veiks ace-player funkcijas

      1.    Debian teica

        Sveiki. Pirmkārt, liels paldies par palīdzību. Es komentēju. Debian 9 ar gnome esmu instalējis acestream snap pakotni. Kad atrodos arenavisión, tieši tam es to vēlos, es noklikšķinu uz acestream saites un parādās logs, kas dod man divas iespējas. Pirmais ir acestreamengine, ka, ja es noklikšķinu uz šī, tas neko nedara, bet otrais ir izvēlēties citu lietojumprogrammu, es to dodu izvēlēties, bet instalētās lietojumprogrammas netiek atvērtas, tiek atvērta mana mājas mape, tāpēc es nezinu, kā izvēlēties vlc.

        Sveiciens.

        1.    Alexander teica

          Ar acestream-launcher tas nedarbojas diezgan labi, labāk instalēt ar Snap pakotni, kā es paskaidroju iepriekš komentārā.

  17.   pīters debitants teica

    Es mēģinu instalēt snapd pakotni, taču tas man neļaus:

    sudo apt instalēt snapd
    Notiek paku saraksta lasīšana ... Gatavs
    Atkarības koka izveidošana
    Notiek informācijas par statusa lasīšanu ... Gatavs
    E: snapd pakotni nevarēja atrast

    ko es daru?

  18.   Alf teica

    Liels paldies, tā ir viena no programmām, kuru es izmantoju Windows, un es gribēju, lai tā būtu Linux

  19.   oscar teica

    Paldies Chemabs un Alejandro! Lieliski piemērots Ubuntu 17.10
    sudo apt instalēt snapd
    snap atrast straumi
    sudo snap instalēt acestreamplayer
    Un viss!
    Neticami ir tas, ka jūs apmeklējat oficiālo vietni, un viņi no 2014. gada jums nosūta ziņojumu savā forumā! Un kurā viņi min tikai līdz Ubuntu 13.04!

  20.   Marko Barria teica

    labi, kā saka iepriekšējos komentāros, tas lieliski darbojas ar snapd in arch:

    sudo pacman -S snapd
    sudo systemctl iespējojiet snapd.socket
    atsāknēšana
    sudo snap instalēt acestreamplayer
    atsāknēšana

    un gatavs:

  21.   mčavess teica

    sveiki, un vai ir kāds veids, kā instalēt ace straumi bez nepieciešamības būt programmētājam ... kā tas tiek darīts ar Windows