Kā ArchLinux izmantot jaunāko Choqok versiju

Kā daudzi zina, Twitter mainīja savu API, un tas ietekmēja daudzas lietojumprogrammas. Tie, kurus mēs izmantojam GNU / Linux, un pāri visam KDE, mēs zinām, ka tiek saukts labākais Microblog klients Čokoks, daudzu iemeslu dēļ, kas šobrīd nav aktuāli, taču arī šī lietojumprogramma cieta API izmaiņu nelaimi.

Problēma

Ne tik sen Es viņiem komentēju ka par ļoti maz Čokoks Atbalsts tam beigsies, taču, pateicoties OpenSource filozofijai, kāds cits pieņēma projektu, un tas nemirs, vismaz ne tagad.

Jaunākā Čokoks , kas darbojas ar čivināt, vēl nav vietnes ArchLinux, tāpēc mums tas ir jāielādē no tā GIT repozitorija un jāapkopo. Lai to izdarītu, mēs darām nākamo:

Mēs atveram termināli (mums ir jābūt instalētam git Arch vai git-core Debian) un mēs ievietojam:

git clone git://anongit.kde.org/choqok

Vai kas ir tas pats:

git clone http://anongit.kde.org/choqok

Mēs gaidām, līdz jūs pabeigsit nepieciešamo failu lejupielādi, ieskaitot README, kurā ir norādītas sekojošās darbības:

$ cd choqok / $ mkdir build $ cd build / $ cmake -DCMAKE_INSTALL_PREFIX = `kde4-config --prefix` ..

Parasti pietiek ar nepieciešamajām atkarībām, taču tas man iemeta šo kļūdu:

CMake Error at CMakeLists.txt:1 (include):
  include could not find load file:

    DBusMacros

CMake Error at config/behavior/CMakeLists.txt:17 (kde4_add_ui_files):
  Unknown CMake command "kde4_add_ui_files".

CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

should be added at the top of the file.  The version specified may be lower
if you wish to support older CMake versions for this project.  For more
information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

Es gandrīz iemetu dvieli, bet Arch forumos man ieteica izmantot PKGBUILD, aprakstošs šī izplatīšanas pakotnes veidošanas fails.

Solution

Tātad, ko es darīju, bija piekļuve https://aur.archlinux.org/packages/choqok-git/ un lejupielādējiet tarball ar nepieciešamajiem failiem. Šim patērētājam ir divi faili: PKGBUILD y choqok-git.install, kas tiek izmantoti ar makepkg lai iesaiņotu lietojumprogrammu, un to var viegli instalēt ar Pacman.

Nu, mēs nojaucam tarball un caur termināli mēs piekļūstam mapei, kurā atrodas šie divi faili. Viss, kas mums jādara, ir palaist:

$ makepkg

Un burvība ir izdarīta. Pēc vairākām minūtēm (atkarībā no mūsu aparatūras jaudas) fails tiks izveidots choqok-git-20130619-1-x86_64.pkg.tar.xz, kuru mēs varam instalēt, ierakstot:

$ sudo pacman -U choqok-git-20130619-1-x86_64.pkg.tar.xz

Un tas ir puiši. Tagad mēs varam atkal baudīt Twitter ar Čokoks.

Actualizado: Kā man saka kompa Gregorio Espadas, ja esam instalējuši jogurts mums vienkārši jāskrien:

yaourt -S choqok-git

Debian un atvasināto lietotāju neuztraucieties, KZKG ^ Gaara drīz parādīs, kā to izdarīt šajā izplatīšanā.

Raksta saturs atbilst mūsu principiem redakcijas ētika. Lai ziņotu par kļūdu, noklikšķiniet uz šeit.

13 komentāri, atstājiet savus

Atstājiet savu komentāru

Jūsu e-pasta adrese netiks publicēta. Obligātie lauki ir atzīmēti ar *

*

*

  1. Atbildīgais par datiem: Migels Ángels Gatóns
  2. Datu mērķis: SPAM kontrole, komentāru pārvaldība.
  3. Legitimācija: jūsu piekrišana
  4. Datu paziņošana: Dati netiks paziņoti trešām personām, izņemot juridiskus pienākumus.
  5. Datu glabāšana: datu bāze, ko mitina Occentus Networks (ES)
  6. Tiesības: jebkurā laikā varat ierobežot, atjaunot un dzēst savu informāciju.

  1.   Gregorio Espadas teica

    yaourt -S choqok -git

    un gatavs! 😉

    1.    Lolo teica

      Sveiciens Gespadas.

      Kas notika ar jūsu emuāru? Jūs jau sen neko tajā neesat publicējis.

      Vai jūs veltījāt sevi citam projektam?

  2.   yoyo teica

    Es gaidu savu dārgo turpialu jaunajā versijā 1.0 ar atbalstu jaunajam čivināt api ... ..

    Nav ilgi jāgaida, kamēr libturpial 1.0 ir gatavs.

    1.    Gregorio Espadas teica

      Visi viņu gaida 🙂

    2.    elav teica

      Kad es pametu Choqok, es dodos uz Hotot, bet uz Turpial? Nekad vairs U_U

  3.   yoyo teica

    Turpial 1.0 būs repanocha !!! 😛

    1.    elav teica

      Ja jūs tā sakāt ... Vai jums ir vairāku kontu? Vai jums ir Qt versija?

  4.   TUDz teica

    Ubuntu 12.04, mēģinot nosūtīt čivināt xD, es pastāvīgi saņemu kļūdu. Pat manas pieminēšanas paplātes netiek atjauninātas, Sākums utt.

  5.   Emilio teica

    Bez jūsu puses varat izmantot komandu 'makepkg -si', kurā varat lejupielādēt atkarības un instalēt pakotni

  6.   Makss JRB teica

    Es izmantoju Polly, un tas darbojas ļoti labi, ļoti viegli un bez problēmām. Viņi to atrod AUR.

  7.   Cronos teica

    Cik lieliskas ziņas, par laimi kāds varēja pieņemt projektu, es joprojām gaidu Hotot un / vai Turpial.

    PS izņem psihedēlisko ķeceri 😛

  8.   Squawk teica

    Viņiem jāpārbauda Birdie: 3

  9.   3000 teica

    Es ceru, ka arī Hotot Stable iznāks. Man ir slikti par piekļuvi ne Twitter, ne Identi.ca (jo viņi pārgāja uz pump.io, un es joprojām neredzu viņu API).