Tagad ir iespējams skatīties Netflix uz Linux, izmantojot HTML 5

Netflix html5

Strīds: DRM HTML 5

Tagad ir iespējams atskaņot Netflix video saturu Linux darbvirsmā dabiski, kaut arī tikai jaunākajās Google Chrome pārlūkprogrammas izstrādes versijās. Kāpēc? Kas mainījās?

Šī gada sākumā tīmekļa standartu institūcija, “World Wide Web Consortium (parasti pazīstams kā W3C), pretrunīgi virzīja savus plānus ieviest HTML5 aizsargāta satura (“ DRM ”) atbalstu, izmantojot specifikāciju. izsaukt multivides šifrēšanu Šifrēts multivides paplašinājums (EME).

Google apraksta EME kā "JavaScript API, kas ļauj interneta lietojumprogrammām mijiedarboties ar DRM sistēmām, lai ļautu atskaņot šifrētu multivides informāciju". Tas darbojas bez nepieciešamības instalēt īpaši smagus un sarežģītus trešo pušu spraudņus, piemēram, Silverlight vai Adobe flash.

Savukārt Netflix pagājušā gada jūnijā paziņoja, ka nodrošinās atbalstu HTML5 video atskaņošanai operētājsistēmās Windows 8.1 un Safari (tikai Yosemite), izmantojot EME. Tā kā Google ir viens no galvenajiem DRM atbalsta atbalstītājiem bez spraudņiem, Chrome dabiski atbalsta EME.

Veicamās darbības, lai skatītos Netflix (HTML 5) operētājsistēmā Linux

1. - Lejupielādējiet jaunāko Google Chrome beta versija vai hroms (versija 38).

2. - Mainiet lietotāja aģentu uz kaut ko līdzīgu: Mozilla / 5.0 (Windows NT 6.3; Win64; x64)

3. - Netflix kontā atlasiet opciju “Priekšroka HTML5” (sadaļā “Atskaņošanas iestatījumi”).

netflix uz Linux

4. - Atveriet Netflix.

Tikai Ubuntu 14.04 LTS

Ja izmantojat Ubuntu 14.04 LTS, bibliotēka libnss3 ir jāatjaunina arī uz jaunāku versiju.

libnss3 priekš Ubuntu 14.04 LTS (32bit)
libnss3 priekš Ubuntu 14.04 LTS (64 bitu)

Kad fails, kas atbilst jūsu Ubuntu versijai, ir lejupielādēts, jums tas tikai jāizvelk un jāinstalē .deb fails, izmantojot šādu komandu:

sudo dpkg -i * libnss3

Raksta saturs atbilst mūsu principiem redakcijas ētika. Lai ziņotu par kļūdu, noklikšķiniet uz šeit.

27 komentāri, atstājiet savus

Atstājiet savu komentāru

Jūsu e-pasta adrese netiks publicēta. Obligātie lauki ir atzīmēti ar *

*

*

  1. Atbildīgais par datiem: Migels Ángels Gatóns
  2. Datu mērķis: SPAM kontrole, komentāru pārvaldība.
  3. Legitimācija: jūsu piekrišana
  4. Datu paziņošana: Dati netiks paziņoti trešām personām, izņemot juridiskus pienākumus.
  5. Datu glabāšana: datu bāze, ko mitina Occentus Networks (ES)
  6. Tiesības: jebkurā laikā varat ierobežot, atjaunot un dzēst savu informāciju.

  1.   Ben teica

    Ceru, ka stabilajā Chrome ir iekļauta šī funkcija ...

  2.   Šini-kire teica

    Un Firefox; -; Es turpināšu lietot piperlight 77. gadā, es nekad neizmantošu Chrome \ hromu: '(

    1.    3000 teica

      Šeit mans komentārs attiecībā uz Firefox un žurku nūja MPAA W3C.

  3.   Federiko Manuels Echeverri Choux teica

    Tas man nederēja, viņš man saka

    Instalējiet Microsoft Silverlight spraudni tūlīt; aizņem tikai minūti.

    Sveicieni

    1.    izmantosim linux teica

      Šis padoms ir paredzēts Linux, šķiet, ka jūs izmantojat Win (kā redzams komentāra augšējā labajā stūrī).
      Apskāviens! Pāvils.

      1.    3000 teica

        Nesen šodien es to izmēģināju ar Windows ar Chromium katru nakti, un patiesība ir tāda, ka tas darbojas ar HTML5, lai gan manā gadījumā, tā kā Chromium neietver H.264 vai MPEG-4 kodekus, piemēram, Chrome beta / canary [vai dev], tas atlec kļūda, norādot, ka trūkst patentētu kodeku.

  4.   uzvarētājs teica

    Labi paskaidrojiet, ka tas ir ar Chrome un 38 Chromium beta versijām. Un tam jābūt patiesam, jo ​​Chromium 34 nedarbojas, iznāk sasodītais plakāts: Instalējiet Microsoft Silverlight papildinājumu tūlīt; Nepieciešama tikai minūte.
    Tāpēc pagaidām es gaidīšu mazliet ilgāk, līdz Chromium vai Firefox nāks klajā ar sasodīto EME. Bet tas ir lielisks jaunums ... un beidzot es varēšu formatēt savas vecās sievietes datoru, hehe. (Viņai ir par daudz atcerēties atvērt vīnu hehe).

  5.   Fernando teica

    Ar cauruļvadu gaismu es nekad neesmu spējis redzēt augstas izšķirtspējas. Es ticu, ka šī metode darbosies labāk.

  6.   Fernando teica

    Ar cauruļvadu gaismu es nekad nevarēju skatīties HD, cerams, ka šī metode darbojas labāk.

  7.   nē Domingess teica

    Es jau izdarīju visu norādīto, un tas nedarbojas.
    Man 38 versija ir nestabila, un jūsu nodrošinātais lietotāju aģents, vai jūs to pārbaudījāt?

    1.    izmantosim linux teica

      Jā. Man tas der ... 🙂

  8.   3000 teica

    Es to izmēģināšu, bet vispirms jums jābrīdina par sekojošo.

    Netflix prasa šādas prasības: H.264 kodeku (vai MPEG-4), un DRM EME. Bez viņiem šāda Netflix baudīšana HTML5 formātā nebūtu iespējama.

    Tagad ir žēl, ka mums ir tikai 3 pārlūkprogrammas, kas spēj apmierināt šīs cerības: Internet Explorer (diemžēl), Google Chrome (nevis Chromium, pateicoties atteikumam no iepriekš minētajiem kodekiem, neskatoties uz DRM) un Opera Blink .

    Jebkurā gadījumā, ja neesat pārliecināts, ieskatieties vietnē html5test.com un pārliecinieties, vai jūsu pārlūkprogrammā ir šādas prasības, lai pārbaudītu Netflix HTML5. Attiecībā uz linuxer, visticamāk, tikai HTML darbosies ar HTML5 Netflix.

    Gracias, MPAA līdz uzmākties Mozilla fondam liekot jums šaubīties par tā filozofiju un misiju.

  9.   Gonzalo trujillo teica

    Esiet uzmanīgs ar lietotāja aģentu, kas man bija problēma, tam jābūt:
    Mozilla / 5.0 (Windows NT 6.3, Win64, x64) AppleWebKit / 537.36 (KHTML, piemēram, Gecko) Chrome / 38.0.2114.2 Safari / 537.36

    Izmantojiet lietotāja aģenta pārslēdzēja spraudni. Veiksme!

  10.   ognomirs teica

    Tagad tas ir tik vienkārši, kā vienkārši instalēt Netflix:
    http://ricardo.monroy.tk/watch-netflix-on-linux

  11.   Fernando Diazs teica

    Es tikko to pārbaudīju, un tas lieliski darbojas ar Chrome, bet ne ar Chromium, bez nepieciešamības modificēt lietotāja aģentu.

    1.    Roberto Ribeiro teica

      Bet viņi nesaka, kuru versiju viņi izmanto.
      Manā gadījumā bez panākumiem mēģiniet divos veidos:
      Pirmajā Debian 7 ar Chrome versiju 39.0.2171.71 (64 bitu), otrajā - ar cauruļvadu un aģenta slēdzi.

      Arī manā netflix profilā tas neļauj man izvēlēties HTML

      1.    Jair teica

        Darbojas ar xubuntu ar koronu 39 (64 bitu)

        ????

  12.   megakseso teica

    Man tas nedarbojās, kā es varu to izdarīt? Šis ir tests

    1.    megakseso teica

      Tas darbojās, Lietotāja aģenta lieta, bet HTML5 opcija neparādās

    2.    megakseso teica

      Joprojām nespēju būt, es daru UA testus

  13.   Saglabājiet Bacosqui teica

    Man ir detalizēta informācija par šo ierakstu, jums jāinstalē stabilā Chrome versija, manā gadījumā man jau ir 44 versija 64 bitu formātā; Es salauzu galvu, kopš jūs publicējāt šo rakstu, un, izlasot vairākus emuārus un apmēram trīs mēnešus maksājot par Netflix pakalpojumu, mana neapmierinātība bija tāda, ka es grasījos instalēt jāšanās Windows 7, lai tikai skatītos Netflix (mana ģimene to mīl skatīties seriālu tur un būsim godīgi Nikaragvas Claro tv pamata kabeļtelevīzijas pakalpojumā. Pēc šī visa šodien es mēģināju, kad es jums teicu instalēt stabilu Chrome versiju, un bija skaisti redzēt, kā tas darbojas bez vajadzības pēc kaut kā cita. Sveiciens visiem, un es ceru, ka tas jums darbosies tāpat kā man.

    1.    izmantosim linux teica

      Paldies par ieguldījumu!
      Apskāviens! Pāvils

  14.   CRIS teica

    Mēģinot instalēt bibliotēkas, tiek parādīta kļūda
    vai jūs zināt, kādas atkarības trūkst?
    paldies
    dpkg: kļūda apstrādājot pakotni libnss3-1d: i386 (–install):
    atkarības jautājumi - atstāti nekonfigurēti
    Apstrādes laikā radās kļūdas:
    libnss3
    libnss3-nssdb
    libnss3: i386
    libnss3-1d: i386

    1.    izmantosim linux teica

      Sveiki! Pirmkārt, atvainojiet par atbildes kavēšanos.
      Es iesaku jums izmantot mūsu pakalpojumu Ask Linux (http://ask.desdelinux.net) veikt šāda veida konsultācijas. Tādā veidā jūs varat saņemt visas sabiedrības palīdzību.
      Apskāviens! Pāvils

  15.   Jonatan teica

    🙂 Hahaha es nesaprotu

  16.   david teica

    Esmu gājis uz askdelinux un neko neesmu teicis, nedz arī atbildējis ... raudu un tamlīdzīgi. 3 mēnešus bez iespējas skatīties netflix
    Man ir kubuntu 14.04 no 32, un tā nav.
    Jebkurā gadījumā

  17.   anonīms teica

    Man ir Firefox Quantum 57.0 (64-bit) Linux mint 18.3 kde, 64 bitiem, un es varu skatīties Netflix, neko neinstalējot, jums vienkārši jāaktivizē DRM preferenču izvēlnē