Fandaharana fototra miaraka amin'ny pseint (fizarana 3)

Ity dia tohin'ny tutorial Fandaharana fototra miaraka amin'ny pseint (fizarana 2), amin'ity indray mitoraka ity dia hanazava izay ilaina amin'ny programa aho.

ANDRAIKITRA

Ny fanendrena dia dingan'ny famoronana miovaova sy / na ovaina, manondro azy amin'ny alàlan'ny famantarana azy hahafahantsika miditra ao amin'ny habaky ny fitadidiany.

ny syntax an'ny andraikitra dia:

[variable]<- [expresion];
[variable]=[expresion];

Aiza [variable] no miovaova izay mahazo ny sandan'ny fanombanana [expression]. Samy mitombina avokoa ka tsy maninona izay ampiasaina (raha toa ka namboarin'izy ireo tsara ny PSeInt), fa raha ny hevitro dia izaho no mamorona ilay voalohany ho marina.

Raha tsy nisy ny [variable] talohan'ny nanendrena azy dia noforonina ny [variable], raha nisy izy io dia potika ny sanda teo aloha ary apetraka amin'ny toerany ilay iray vaovao. Noho io antony io dia heverina ho asa manimba ny fanaovana sarintany.

FAMAKIANA

Ny famakiana dia ny dingana izay angatahana angona na angona avy amin'ny mpampiasa mba hitahiry ireo angon-drakitra voalaza ao anaty variable.

ny dikan'izany dia:

Leer variable_1,variable_2,...,variable_n;

izay [variable_ {1,2, n}] no miovaova na miova izay mahazo ny sanda nomen'ny mpampiasa, raha sanatria ka mihoatra ny iray ny fiangaviana angatahina, dia hangataka voalohany izy, avy eo ny faharoa ary toy izany mandra-pahatongan'ny nahazo ny soatoavina rehetra.

Io koa dia asa manimba.

MANORATRA

Ny fanoratana no fizotran'ny tarehin-tsoratra sy / na fiovana iray na maromaro voasoratra eo amin'ny efijery

ny syntax dia:

Escribir expresion_1,expresion_2,...,expresion_n;

aiza ny [expersion_ {1,2, n}] misy ny tadin'ny toetra amam-panahy sy / na miovaova haseho.

Ny fanoratana ankoatry ny fahazoana ny angona hapetraka eo amin'ny efijery dia mandray koa ny torolàlana "Tsy mandingana" na "Tsy misintona" izay manalavitra ny tsipika mitsambikina.

Ny soratra dia tsy manampy elanelana misy eo amin'ny tohan-kevitra, izany hoe raha apetrakao:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

amin'ity tranga ity dia hasehony ny «olamundo» satria eo anelanelan'ny «a» sy «b» dia tsy misy tarehin-tsoratra manondro ny elanelana misy eo a sy b, ka aseho azy tsara dia voasoratra toy izao:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

Amin'ity tranga ity dia ampio »» izay tarehin-tsoratra manana ny habaka izay eo anelanelan'ny «onja» sy «izao tontolo izao» ary avy eo dia hasehony «izao tontolo izao onja» miaraka amin'ilay habaka.

RAHA IZAO DIA

Ity dia fehezan-teny manombana fepetra iray ary manamarina ny maha-marina sy / na lainga ny voalaza voalaza, izany hoe, raha feno na tsia ny fepetra.

Ny fandikana azy dia:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Ny fehezan-dalàna "Else" dia tsy voatery, amin'ity tranga ity, raha diso ny fepetra dia aza raharahanao ny torolalana ary manohiza toa tsy nisy ny fehezan-teny, dia hijanona amin'ity tranga ity:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Na miankina amin'ny filan'io programa io na tsia ny fehezan-dalàna hoe "Tsy fahombiazana".

ARAKA

Ny fehezan-teny rehefa manombatombana isa miovaova isa izay manome safidy mihoatra ny 2 ho safidy iray, io no mahasamihafa ny "Raha-Avy" satria ilay teo aloha dia afaka manome safidy 2 fotsiny.

Ny syntax dia:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Araka ny hitanao aorian'ny «isa1» dia misy «:» ary aorian'izany ny torolàlana hotanterahina dia apetraka amin'ny tranga «variable numerika = isa1», amin'ny ohatra faharoa dia «isa2, isa3» izany dia midika fa raha «variable numeric = number2 na number3" dia "torolalana" no hovonoina, mahasoa izany raha toa ka misy fampiasa 2 tsy maintsy manatanteraka torolàlana mitovy.

Misy ihany koa ny fehezan-teny "In Another Way" izay tanterahina raha toa ka tsy misy tanteraka ny fahafaha-manao.

NA

Izy io dia fiasa miverimberina izay manombatombana aloha ny fepetra iray ary avy eo raha tanteraka dia manatanteraka andian-torolalana, avy eo mamerina mandinika ny fepetra ary raha marina izany dia manatanteraka torolàlana mitovy ihany ary mitohy toy izao mandra-pahatongan'ny fepetra diso.

raha diso ny toe-javatra hatramin'ny voalohany dia tsy ho tanterahina mihitsy ary raha marina foana dia hapetraka ao anaty loop tsy manam-petra, mba hisorohana ny farany amin'ny torolàlana dia tsy maintsy misy zavatra izay mandiso ny toe-javatra indraindray afaka mamarana ny loop.

ny dikan'izany dia:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

Avereno-mandra-pahatongany

Io dia fiasa iray nitovy tamin'ny teo aloha, fa tsy toy ilay teo aloha, ity dia manamarina ny toe-javatra any am-parany, izany hoe, ny didy dia hovonoina farafahakeliny in-1, ary koa tsy hanatanteraka ny torolàlana rehefa marina izany, manatanteraka azy io raha toa ka tsy feno ny fepetra, fa raha tianao hovonoina izany rehefa feno ny fepetra dia ampiasao ny "raha" fa tsy "mandra-pahatongan'ny".

ny dikan'izany dia:

Repetir
[Instrucciones] hasta que [condicion]

HO AN'NY

Ity fanambarana ity dia mampihatra torolàlana famaritana isa imbetsaka ho an'ny miovaova, tsy toy ireo teo aloha, ity tsingerina ity dia manova ny lanjan'ilay miova ho fanontaniana ary koa manana syntax mahery vaika.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

Ny "Variable" dia ilay variable izay mahazo "sanda voalohany" ary mampihatra ny torolàlana avy eo manampy "variable" miampy "dingana" ary manatanteraka ny torolàlana indray mandra-pahatongan'ny "variable" dia mitovy amin'ny "sanda farany".

Raha esorina ny "miaraka amin'ny [dingana]" dia ho fantany fa ny "dingana" dia mitovy amin'ny 1, raha tsy voatondro koa ny [dingana] ary ny "sanda voalohany" dia lehibe noho ny "sanda farany" dia hamakivaky azy ao filaharana mifamadika, izany hoe "Dingana" dia -1

SUBPROCESS / FUNCTION

Ny kofehy na ny asany dia programa ao anatin'ny iray hafa ary ity subprogram ity dia mahazo sanda iray na maromaro, mampandeha azy ireo ary mamerina iray hafa. Ny fandikana azy dia

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

izay "variable variable" dia ilay miovaova izay misy ny sandan'ny fiverenan'ny "function name" izay nahazo ny masontsivana "arg_1, arg_2, arg_n" hanatanterahana an'io

OTHER

Ireo dia fiasa izay mifameno fotsiny amin'ny hafa ary tsy manana syntax sarotra satria asa mifameno fotsiny izy ireo.

Clear Screen

Io asa io dia mamafa ny efijery misy zavatra ao amin'ny mpandika teny

Wait Key

Miandry ny mpampiasa hanery fanalahidy hanohy ny programa ilay fiasa

manantena x {Faharoa, Milliseconds}

ity fiasa ity dia miandry fotoana afaka segondra na millisecond mba hanohizana ilay programa

PS: azafady amin'ny fanemorana fa sahirana tamin'ny raharaha hafa aho ka tsy afaka nanoratra


Ny atin'ny lahatsoratra dia manaraka ny fitsipiky ny etika fanonta. Raha hitatitra tsindry diso eto.

10 hevitra, avelao ny anao

Avelao ny hevitrao

Ny adiresy email dia tsy ho namoaka. Mitaky saha dia marika amin'ny *

*

*

  1. Tompon'andraikitra amin'ny data: Miguel Ángel Gatón
  2. Tanjon'ny angona: Control SPAM, fitantanana hevitra.
  3. Legitimation: Ny fanekenao
  4. Fifandraisana momba ny angona: Tsy hampitaina amin'ny antoko fahatelo ny angona raha tsy amin'ny adidy ara-dalàna.
  5. Fitehirizana angona: Database nomen'ny Occentus Networks (EU)
  6. Zo: Amin'ny fotoana rehetra, azonao atao ny mametra, mamerina ary mamafa ny mombamomba anao.

  1.   Guille dia hoy izy:

    Tsy manana andraikitra hisamborana fanalahidy raha tsy mampiato ny fanatanterahana azy? Ho an'ny fanaovana zavatra miaraka amin'ny hetsika izay mahasarika kokoa ny zaza 9 taona, na dia lalao mahafinaritra aza ny lalao hangman.

    Mandrosoa zavatra_digo
    a <-1;
    sisiny <-30;
    midina <-5;
    Raha a = 1 Do
    Clear Screen;
    c <-1;
    tsipika <- "";
    Avereno
    tsipika <-line + "";
    c <-c + 1;
    Mandra-pahatongan'ny c = lateral
    tsipika <-line + "X";
    c <-1;
    Avereno
    Manoratra " ";
    c <-c + 1;
    Mandra-pahatongan'ny c = ambany-1
    Soraty andalana;
    Avereno
    Manoratra " ";
    c 2 Avy eo
    midina <-down-1;
    Tapitra eny
    "s":
    Raha eto ambany <15 Dia
    midina 2 Avy eo
    sisiny <-lateral-1;
    Tapitra eny
    "d":
    Raha lateral <50 Avy eo
    sisiny <-lateral + 1;
    Tapitra eny
    "0":
    a <-2;
    Faran'ny segondra
    Tapitra Mandritra ny
    EndProcess

  2.   Guille dia hoy izy:

    Eny ary, mahomby raha miakatra ianao dia ovao ny andalana 23 sy 28
    -23 Mandra-p = 15
    +23 Mandra-pahatongan'ny c = 18
    y
    -28 Raha midina> 2 Avy eo
    +28 Raha midina> 3 Avy eo

    1.    xnmm dia hoy izy:

      Misaotra tamin'ny fandraisana anjara fa misy olana vitsivitsy toa anao manokatra fehezanteny iray ao anatin'ny iray hafa saingy tsy maintsy mifarana ao anatin'ny fehezanteny nanombohany izany, tiako holazaina fa tsy azo apetraka

      Manamboatra zavatra
      a <- 0;
      vakio amin'ny;
      raha tsy mitovy amin'ny 25 ny a dia avy eo
      raha ny a dia tsy mitovy amin'ny 0 atao
      vakio amin'ny;
      Tapitra eny
      mifarana mandritra

      rehefa hitanao ny loop rehefa manomboka ao anaty ilay fanambarana hoe "raha avy eo" fa mifarana ivelan'io dia tsy azo atao ny zavatra toa an'io.

      Mbola mankasitraka ny fandraisana anjara aho
      Famaranana dingana

      1.    Guille dia hoy izy:

        Misaotra, saingy heveriko fa olana bebe kokoa amin'ny fametrahana ny kaody eto, ny tsy fahafantarako mametraka azy amin'ny karazana kaody ary mivoaka izy io nefa tsy miondrika.

        Mety tsara ny programa. Ilay variable "a" dia ampiasaiko fotsiny hivoahana ny loop rehefa manoratra aotra ny mpampiasa. Azonao atao ny mametraka fivoahana () na fiatoana; amin'ny fepetra misy azy dia mijery azy io ary mamonjy ilay miovaova. Safidy izy ireo.

        Fiarahabana.

      2.    Guille dia hoy izy:

        Hiezaka aho hanova takelaka ho an'ny habaka sy ny marika por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille dia hoy izy:

        Feno lesoka fanafarana avy amin'ny kaodiko, hanandrana indray aho miaraka amin'ny kiheba:
        Ity no rakitra algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille dia hoy izy:

        Mahaliana fa ny fanehoan-kevitra miaraka amin'ny kaody marika dia nohanina, voafafa, na inona na inona manelanelana azy, ohatra eo anelanelan'ny tsipika
        Avereno
        Manoratra " ";
        c
        aorian'ny c misy a
        ary avy eo dia mitohy amin'ny 3 Avy eo
        midina
        Amin'ny ankapobeny, tsy atokisana apetraka araka ny kaody inona.

  3.   Guille dia hoy izy:

    Manova ny marika aho amin'ny fanendrena ho = hahitako azy.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille dia hoy izy:

      Mihazona ny fihinanana ampahany amin'ny kaody izy io, tsy mandeha ny kaody kaody, tokony avelany hanoratra toy ny taloha.

      1.    xnmm dia hoy izy:

        Salama azafady fa tsy nahita anao namaly teo aloha fa tsara
        satria tsy afaka mamoaka tsara ilay kaody ianao satria tsy alefanao amiko amin'ny alàlan'ny mailaka ka tsy dia mihodina be loatra ianao manoloana ny raharaha.