Пакети за поддршка на развој на софтвер на DEBIAN 10

Пакети за поддршка на развој на софтвер на DEBIAN 10

Пакети за поддршка на развој на софтвер на DEBIAN 10

Овој пост е продолжение (трет дел) од вежби посветен на DEBIAN GNU / Linux Distro, верзија 10 (Бастер), што служи како основа на многу други како на пр MX-Linux 19 (Грдо пајче).

Во овој трет дел ќе го покажеме основни пакети (апликации) се препорачува да се обезбедат потребните поддршка основно за развој, тестирање и извршување на некои софтвер (апликации) за нашата убава и одлична Distros DEBIAN 10 и MX-Linux 19.

Ажурирајте ги и оптимизирајте ги MX-Linux 19.0 и DEBIAN 10.2 по инсталирањето

Ажурирајте ги и оптимизирајте ги MX-Linux 19.0 и DEBIAN 10.2 по инсталирањето

Претходните 2 објави во оваа серија се:

ДЕБИЈАН 10: Кои дополнителни пакети се корисни по инсталирањето?

ДЕБИЈАН 10: Кои дополнителни пакети се корисни по инсталирањето?

Запомнете и имајте на ум дека:

"Запомнете дека акциите и пакетите препорачани тука за извршување и инсталирање се токму тоа, "пакети се препорачува" и на секој е да ги изврши и инсталира сите или некои од нив, зошто се тие потребно или корисно, на краток или среден рок, да ги знаеме и користиме, со тоа што веќе се извршени или инсталирани.

И имајте на ум дека овие активности и / или пакети беа претходно тестиран на двата Distros, и тие не бараат да ги деинсталираат пакетите инсталирани по дифолт во овие. Понатаму, тие не ја зголемуваат потрошувачката на меморија или процесорот бидејќи тие стандардно не вчитуваат процеси или демони (услуги) во меморијата. За да знаете однапред за што се користи секој пакет, кликнете овде."

Ажурирајте MX-Linux и DEBIAN: Содржина

Пакети за поддршка на развој на софтвер

Поддршка за Java апликации

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

Objetivo: Инсталирајте основна поддршка за компатибилност со Java апликации.

Поддршка за QT5 апликации

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

Objetivo: Инсталирајте основна поддршка за компатибилност со апликации изградени со QT5.

Поддршка за апликации за дигитално рударство

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

Objetivo: Инсталирајте ја основната поддршка за апликации, двигателите и библиотеките потребни за инсталација и управување со апликациите за дигитално рударство.

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

Objetivo: Инсталирајте основна библиотечна поддршка за програми што ја користат библиотеката со бази на податоци Berkeley v5.3, широко користена од современите апликации за дигитално рударство што треба да се соберат и / или да се извршат.

Поддршка за веб апликации

Apache-то

apt install apache2

Objetivo: Инсталирајте основна поддршка за веб-апликации оптимизирани или компатибилни за Apache2.

Nginx

apt install nginx

Objetivo: Инсталирајте основна поддршка за веб-апликации оптимизирани или компатибилни со Nginx.

PostgreSQL

apt install postgresql

Objetivo: Инсталирајте основна поддршка за команди и функции за управување со бази на податоци базирани на Postgresql.

apt install pgadmin3 y phppgadmin

Objetivo: Инсталирајте ја основната поддршка на апликациите за управување со базите на податоци базирани на Postgresql.

MySQL,

apt install mysql-server mysql-client

Objetivo: Инсталирајте ја основната поддршка за команди и функции за управување со бази на податоци базирани на MySQL.

apt install phpmyadmin y mysql-workbench

Objetivo: Инсталирајте основна поддршка за апликации за управување со бази на податоци базирани на MySQL.

MariaDB

apt install mariadb-server mariadb-client

Objetivo: Инсталирајте ја основната поддршка за команди и функции за управување со базите на податоци базирани на MariaDB.

PHP

apt install php

Objetivo: Инсталирајте ја основната поддршка за команди и функции за ракување со апликации базирани на PHP.

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

Objetivo: Инсталирајте ја основната поддршка на природните библиотеки за управување со апликации базирани на PHP.

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

Objetivo: Инсталирајте ја основната поддршка за не-мајчин библиотека за ракување со апликации базирани на PHP.

ПЕРЛ

apt install perl

Objetivo: Инсталирајте ја основната поддршка за команди и функции за ракување со апликации базирани на PERL.

apt install libapache2-mod-perl2 y perlbrew

Objetivo: Инсталирајте ја основната библиотечна поддршка за ракување со апликации базирани на PERL.

Пајтон

apt install python-all-dev python-pip

Objetivo: Инсталирајте основна поддршка за команди и функции за управување со апликации базирани на Python.

apt install python3-setuptools python3-pyqt5 python3-pip

Objetivo: Инсталирајте ја основната поддршка за команди и функции за ракување со апликации засновани на Python3.

Општа слика за заклучоци на статии

Заклучок

Се надеваме дека esta "корисен мал пост" за кои суштински пакети се потребни за да се обезбеди потребната поддршка за правилно  «instalación y gestión» на одредени случувања во софтверот, за Дистрос «DEBIAN y MX-Linux», да биде од голем интерес и корисност, за целата «Comunidad de Software Libre y Código Abierto» и од голем придонес кон дифузијата на прекрасниот, гигантски и растечки еко-систем на апликации на и за «GNU/Linux».

И за повеќе информации, секогаш не двоумете се да посетите која било Интернет библиотека како ОпенЛибра y једит да чита книги (PDF) на оваа тема или други области на знаење. Засега, ако ви се допадна ова «publicación», не престанувај да го споделуваш со другите, во твоето Омилени веб-страници, канали, групи или заедници на социјалните мрежи, по можност бесплатни и отворени како Мастодон, или безбеден и приватен како Телеграма.

Или едноставно посетете ја нашата почетна страница на Од Линукс или придружете се на официјалниот канал Телеграма од DesdeLinux да читаат и да гласаат за оваа или друга интересна публикација на «Software Libre», «Código Abierto», «GNU/Linux» и други теми поврзани со «Informática y la Computación», и на «Actualidad tecnológica».


Содржината на статијата се придржува до нашите принципи на уредничка етика. За да пријавите грешка, кликнете овде.

2 коментари, оставете ги вашите

Оставете го вашиот коментар

Вашата е-маил адреса нема да бидат објавени.

*

*

  1. Одговорен за податоците: Мигел Анхел Гатон
  2. Цел на податоците: Контролирајте СПАМ, управување со коментари.
  3. Легитимација: Ваша согласност
  4. Комуникација на податоците: Податоците нема да бидат соопштени на трети лица освен со законска обврска.
  5. Складирање на податоци: База на податоци хостирани од Occentus Networks (ЕУ)
  6. Права: Во секое време можете да ги ограничите, вратите и избришете вашите информации.

  1.   Твикзер dijo

    Поправи ме ако грешам, но .. на дебијан, тие не го отстранија phpmyadmin од складиштата?
    и за да инсталирате php, не мора да наведете (на пример) php7.3 или php7.3-curl

  2.   Инсталирајте пост на Linux dijo

    Поздрав Twikzer! Ви благодариме за вашиот коментар Секако phpmyadmin не е во складиштата DEBIAN 10 (стабилни), но е во складиштата DEBIAN 11 (тестирање) од она што претпоставувам, дека во одреден момент тие ќе го вклучат како и другите пакети во стабилните, но може или може да се изостави тоа, без Сепак, затоа го оставив таму. Во однос на второто, не е потребно, бидејќи тековните верзии во складиштето се нарекуваат со нивното генеричко име.