Псейнттэй үндсэн програмчлал (3-р хэсэг)

Энэ бол хичээлийн үргэлжлэл юм Псейнттэй үндсэн програмчлал (2-р хэсэг), энэ удаад програмчлахад юу шаардлагатай байгааг тайлбарлах болно.

ДААЛГАВАР

Даалгавар гэдэг нь хувьсагчийг үүсгэж, өөрчилсөн бөгөөд түүний санах ойн зайд нэвтрэх боломжтой танигчаар дамжуулан иш татсан үйл явц юм.

даалгаврын синтакс нь:

[variable]<- [expresion];
[variable]=[expresion];

Энд [хувьсагч] нь [илэрхийлэл] -ийг үнэлэх утгыг хүлээн авах хувьсагч юм. Аль аль нь хүчинтэй тул аль нь ашиглагдах нь хамаагүй (хэрэв тэд PSeInt-ийг зөв тохируулсан бол), гэхдээ миний бодлоор би эхнийхийг нь зөв болгож үүсгэдэг.

Хэрэв [хувьсагч] хуваарилалтаас өмнө байхгүй байсан бол [хувьсагч] үүсгэгдсэн, хэрэв байсан бол өмнөх утгыг устгаж, оронд нь шинэ утгыг байрлуулна. Энэ шалтгааны улмаас зураглалыг хор хөнөөлтэй ажиллагаа гэж үздэг.

УНШИХ

Унших гэдэг нь тухайн өгөгдлийг хувьсагч дотор хадгалахын тулд хэрэглэгчээс өгөгдөл эсвэл өгөгдөл шаардах үйл явц юм.

түүний синтакс нь:

Leer variable_1,variable_2,...,variable_n;

Энд [хувьсагч_ {1,2, n}] нь хэрэглэгчийн өгсөн утгыг хүлээн авах хувьсагч буюу хувьсагчууд бөгөөд нэгээс илүү хувьсагч шаардсан тохиолдолд эхлээд эхнийх нь, дараа нь хоёр дахь нь гэсээр байх болно. бүх үнэ цэнийг хүлээн авсан.

Энэ нь бас хор хөнөөлтэй функц юм.

БИЧИХ

Бичих нь дэлгэцэн дээр тэмдэгт мөрүүд ба / эсвэл нэг буюу хэд хэдэн хувьсагчуудыг бичих үйл явц юм

синтакс нь:

Escribir expresion_1,expresion_2,...,expresion_n;

Энд [expersion_ {1,2, n}] нь гарч ирэх тэмдэгт мөрүүд ба / эсвэл хувьсагчууд юм.

Бичих нь дэлгэцэн дээр тавигдах өгөгдлийг хүлээн авахаас гадна мөр үсрэхээс зайлсхийх "Алгасахгүй" эсвэл "Татаж авахгүйгээр" гэсэн зааврыг хүлээн авдаг.

Бичих нь аргументуудын хоорондох зайг нэмэхгүй, өөрөөр хэлбэл:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

Энэ тохиолдолд "olamundo" -г харуулах болно, учир нь "a" ба "b" хооронд a ба b-ийн хоорондох зайг харуулсан тэмдэгт мөр байхгүй тул үүнийг зөв харуулахын тулд дараах байдлаар бичнэ:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

энэ тохиолдолд "долгион" ба "ертөнц" хоёрын хоорондох зай бүхий зайны тэмдэгт мөрийг "» нэмээд дараа нь "долгион ертөнц" -ийг орон зайн хамт харуулах болно.

Хэрэв тэгвэл

Энэ бол тухайн нөхцлийг үнэлж, тухайн нөхцөл байдлын үнэн ба / эсвэл худлыг шалгаж байгаа, өөрөөр хэлбэл болзол хангагдсан эс биелсэн бол өгүүлбэр юм.

Түүний синтакс нь:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

"Бусад" гэсэн заалт заавал байх албагүй бөгөөд хэрэв энэ нөхцөл нь худал бол зааврыг үл тоомсорлож, өгүүлбэр байхгүй мэт үргэлжлүүлээрэй, энэ тохиолдолд энэ нь хэвээр байх болно:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

"Алдаа" гэсэн заалтыг байрлуулсан эсэх нь тухайн програмын хэрэгцээнээс хамаарна.

ҮНДСЭН

2-оос дээш сонголтыг сонголт болгон өгдөг хатуу тоон хувьсагчийг үнэлдэг тул өгүүлбэр нь өмнөх хувилбар нь зөвхөн 2 сонголт өгөх боломжтой тул "If-then" -ээс ялгаатай байна.

Синтакс нь:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

"Number1" -ээс хойш ":" байгаа бөгөөд үүнээс хойш "тоон хувьсагч = тоо1" гэсэн тохиолдолд зааврыг байрлуулсан байхыг харж байгаа бол хоёр дахь жишээнд "тоо2, тоо3" гэсэн үг бөгөөд энэ нь " тоон хувьсагч = number2 or number3 "дараа нь" зааврыг "гүйцэтгэх болно, энэ нь 2 боломж ижил зааврыг гүйцэтгэх ёстой тохиолдолд хэрэг болно.

Боломжуудын аль нь ч биелээгүй тохиолдолд гүйцэтгэдэг "Өөр аргаар" гэсэн заалт бас бий.

Хэзээ

Энэ нь нөхцөлийг эхлээд үнэлдэг бөгөөд дараа нь биелсэн бол цуврал зааврыг гүйцэтгэдэг, дараа нь нөхцөл байдлыг дахин үнэлдэг бөгөөд хэрэв үнэн бол дахин ижил зааврыг хэрэгжүүлж, нөхцөл худал болох хүртэл энэ байдлаар үргэлжилдэг функц юм. .

Хэрэв нөхцөл нь эхнээсээ хуурамч бол түүнийг хэзээ ч биелүүлэхгүй бөгөөд хэрэв энэ нь үргэлж үнэн байвал хязгааргүй гогцоонд байрлуулах бөгөөд зааврын сүүлчийн хувилбараас зайлсхийхийн тулд гогцоог дуусгаж чадах нөхцлийг хэзээ нэгэн цагт хуурамчаар үйлдсэн зүйл байх ёстой.

түүний синтакс нь:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

ДАХИН ХИЙХ

Энэ нь өмнөхтэй маш төстэй функц боловч өмнөхөөсөө ялгаатай нь энэ нөхцөлийг эцэст нь шалгана, өөрөөр хэлбэл командыг дор хаяж 1 удаа гүйцэтгэх болно. энэ нь үүнийг гүйцэтгэж байхад гүйцэтгэдэг Хэрэв нөхцөл хангагдаагүй, гэхдээ та нөхцөл биелэгдэж байх үед үүнийг гүйцэтгэхийг хүсвэл "хүртэл" гэхийн оронд "while" -г ашиглаарай.

түүний синтакс нь:

Repetir
[Instrucciones] hasta que [condicion]

МӨНГӨ

Энэхүү мэдэгдэл нь хувьсагчийн хувьд хэд хэдэн удаа тодорхойлогдох зааврыг хэрэгжүүлдэг бөгөөд өмнөх хувиас ялгаатай нь энэ мөчлөг нь тухайн хувьсагчийн утгыг өөрөө өөрчилдөг бөгөөд маш хүчтэй синтакс агуулдаг.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Хувьсах хэмжигдэхүүн" нь "анхны утга" хүлээн авч, зааврыг хэрэгжүүлж, дараа нь "хувьсагч" нэмэх "алхам" -ыг нэмж, "хувьсагч" нь "эцсийн утга" -тай тэнцэх хүртэл дахин зааврыг гүйцэтгэдэг хувьсагч юм.

Хэрэв "хамт [алхам]" устгагдсан бол "алхам" нь 1-тэй тэнцүү болохыг, мөн хэрэв "алхам" -ыг заагаагүй бөгөөд "анхны утга" нь "эцсийн утга" -аас их байвал үүнийг дамжуулж өгнө. урвуу дараалал, өөрөөр хэлбэл "Алхам" -1 байна

АЖИЛЛАГАА / ҮЙЛ АЖИЛЛАГАА

Утас буюу функц нь өөр програмын програм бөгөөд энэ дэд програм нь нэг буюу хэд хэдэн утгыг хүлээн авч тэдгээрийг ажиллуулаад өөр утгыг буцаана. Түүний синтакс нь

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

Энд "буцах хувьсагч" нь үүнийг гүйцэтгэх "arg_1, arg_2, arg_n" параметрүүдийг хүлээн авсан "функцын нэр" функцээс буцаж ирсэн утгыг агуулсан хувьсагч юм.

Бусад

Эдгээр нь зөвхөн бусдыг нөхөх функц бөгөөд зөвхөн нэмэлт функц учраас цогц синтаксгүй байдаг.

Дэлгэцийг цэвэрлэх

Энэ функц нь орчуулагч дахь аливаа объектын дэлгэцийг цэвэрлэдэг

Хүлээх түлхүүр

Энэ функц нь програмыг үргэлжлүүлэхийн тулд хэрэглэгч товчлуур дээр дарахыг хүлээнэ

Хүлээгээрэй х {Хоёрдугаарт, миллисекунд}

энэ функц нь програмыг үргэлжлүүлэхийн тулд секунд эсвэл миллисекундээр цаг хүлээх болно

Жич: Хойшлосонд уучлаарай, гэхдээ би бусад зүйлд завгүй байсан тул бичиж чадахгүй байв


Нийтлэлийн агуулга нь бидний зарчмуудыг баримталдаг редакцийн ёс зүй. Алдааны талаар мэдээлэхийн тулд товшино уу энд байна.

10 сэтгэгдэл, үлдээгээрэй

Сэтгэгдэлээ үлдээгээрэй

Таны и-мэйл хаяг хэвлэгдсэн байх болно. Шаардлагатай талбарууд нь тэмдэглэгдсэн байна *

*

*

  1. Мэдээллийг хариуцах: Мигель Анхель Гатан
  2. Мэдээллийн зорилго: СПАМ-ыг хянах, сэтгэгдлийн менежмент.
  3. Хууль ёсны байдал: Таны зөвшөөрөл
  4. Мэдээллийн харилцаа холбоо: Хуулийн үүргээс бусад тохиолдолд мэдээллийг гуравдагч этгээдэд дамжуулахгүй.
  5. Өгөгдөл хадгалах: Occentus Networks (ЕХ) -с зохион байгуулсан мэдээллийн сан
  6. Эрх: Та хүссэн үедээ мэдээллээ хязгаарлаж, сэргээж, устгаж болно.

  1.   Гуиль гэж хэлэв

    Гүйцэтгэлийг зогсоохгүйгээр түлхүүрүүдийг авах функц танд байхгүй юу? 9 настай хүүхдүүдэд илүү тааламжтай хөдөлгөөн хийхийн тулд, гогцоо тоглоом нь програмчлахад хөгжилтэй байдаг.

    Нэг зүйлийг боловсруул
    a <-1;
    хажуугийн <-30;
    доош <-5;
    A = 1 Do байхад
    Дэлгэцийг цэвэрлэх;
    c <-1;
    мөр <- "";
    Давтах
    мөр <-шугам + "";
    c <-c + 1;
    C = хажуу хүртэл
    мөр <-шаар + "X";
    c <-1;
    Давтах
    Бичих " ";
    c <-c + 1;
    C = доош-1 хүртэл
    Мөр бичих;
    Давтах
    Бичих " ";
    в 2 Дараа нь
    доош <-давах-1;
    Тийм ээ
    "s":
    Хэрэв доор <15 Дараа нь
    доош 2 Дараа нь
    хажуугийн <-тал-1;
    Тийм ээ
    "d":
    Хэрэв хажуу <50 Дараа нь
    хажуугийн <-тал + 1;
    Тийм ээ
    "0":
    a <-2;
    Төгсгөлийн секунд
    Дуусах
    Төгсгөлийн процесс

  2.   Гуиль гэж хэлэв

    Хэрэв та дээшээ гарсан бол бүтэлгүйтсэн бол 23, 28-р мөрийг солих нь дээр
    -23 c = 15 хүртэл
    +23 c = 18 хүртэл
    y
    -28 Хэрэв доош> 2 байвал
    +28 Хэрэв доош> 3 Дараа нь

    1.    хнмм гэж хэлэв

      Оруулсан хувь нэмрээ оруулсанд баярлалаа, гэхдээ нэг өгүүлбэрийг нөгөө өгүүлбэр дотор нээх гэх мэт бэрхшээлтэй тулгараад байгаа боловч эхэлсэн өгүүлбэр дотор дуусах ёстой.

      Аливаа зүйлийг боловсруулах
      a <- 0;
      унших;
      хэрэв a нь 25-тай тэнцэхгүй бол
      харин a нь 0-той тэнцэхгүй байна
      унших;
      Тийм ээ
      дуусах

      "if then" мэдэгдлийн дотор эхэлж, харин гадна нь дуусч байх үед гогцоог харах үед иймэрхүү зүйл боломжгүй юм.

      Би оруулсан хувь нэмрийг нь үнэлсээр байна
      Процессийг дуусгах

      1.    Гуиль гэж хэлэв

        Баярлалаа, гэхдээ кодыг энд оруулахад илүү төвөгтэй асуудал гэж бодож байна, би үүнийг кодын төрөлд хэрхэн яаж оруулахаа мэдэхгүй, ямар ч догол мөргүй гарч ирдэг.

        Хөтөлбөр сайн ажилладаг. "A" хувьсагч нь хэрэглэгчид тэг гэж бичихэд би гогцооноос гарахын тулд ашигладаг. Та гарц () эсвэл завсарлага тавьж болно; нөхцөлт байдлаар үүнийг хардаг бөгөөд би хувьсагчийг хадгалдаг. Эдгээр нь сонголтууд юм.

        Сайн байцгаана уу.

      2.    Гуиль гэж хэлэв

        Би зай болон шошгоны табыг өөрчлөхийг хичээх болно por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Гуиль гэж хэлэв

        Энэ нь миний кодын импортын алдаануудаар дүүрэн байна, би табуудтай дахин оролдох болно:
        Энэ нь algo.psc файл байх болно

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Гуиль гэж хэлэв

        Сонирхолтой нь, кодын шошготой тайлбарыг хооронд нь хамаагүй иддэг, устгадаг
        Давтах
        Бичих " ";
        c
        с-ийн дараа а байна
        дараа нь 3 Дараа нь үргэлжлүүлнэ
        доошоо
        Ерөнхийдөө энэ нь ямар кодын дагуу тавихад найдвартай биш юм.

  3.   Гуиль гэж хэлэв

    Би тэмдэглэгээг = оноосон болгож өөрчилж, энэ нь хэрхэн байгааг харах болно.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Гуиль гэж хэлэв

      Энэ нь кодын хэсгийг идсээр байдаг, кодын шошго бүтэлгүйтдэг, бичээсийг хэвээр нь үлдээх хэрэгтэй.

      1.    хнмм гэж хэлэв

        Таныг өмнө нь хариулж байснаа хараагүйдээ уучлаарай
        Учир нь та кодыг надад сайн илгээх боломжгүй тул шуудангаар надад илгээгээгүй тул энэ асуудалд тийм олон эргэлт өгөхгүй.