डेबियन 10 वर सॉफ्टवेअर डेव्हलपमेंट समर्थनासाठी पॅकेजेस

डेबियन 10 वर सॉफ्टवेअर डेव्हलपमेंट समर्थनासाठी पॅकेजेस

डेबियन 10 वर सॉफ्टवेअर डेव्हलपमेंट समर्थनासाठी पॅकेजेस

हे पोस्ट सुरू आहे (तिसरा भाग)) या शिकवण्या समर्पित डेबीयन जीएनयू / लिनक्स डिस्ट्रो, आवृत्ती 10 (बस्टर), जे अशा इतर अनेकांसाठी आधार म्हणून काम करते एमएक्स-लिनक्स 19 (कुरुप डकलिंग).

या तिसर्‍या भागात आपण हे दाखवू आवश्यक पॅकेजेस (अनुप्रयोग) आवश्यक प्रदान करण्याची शिफारस केली समर्थन मूलभूत साठी विकास, चाचणी आणि अंमलबजावणी काही सॉफ्टवेअर (अनुप्रयोग) आमच्या सुंदर आणि महान डिस्ट्रॉस बद्दल देबीयन 10 आणि एमएक्स-लिनक्स 19.

स्थापित केल्यानंतर एमएक्स-लिनक्स 19.0 आणि डेबियन 10.2 अद्यतनित करा आणि ऑप्टिमाइझ करा

स्थापित केल्यानंतर एमएक्स-लिनक्स 19.0 आणि डेबियन 10.2 अद्यतनित करा आणि ऑप्टिमाइझ करा

या मालिकेतील मागील 2 पोस्ट्सः

  • स्थापित केल्यानंतर एमएक्स-लिनक्स 19.0 आणि डेबियन 10.2 अद्यतनित करा आणि ऑप्टिमाइझ करा (प्रविष्टी पहा)
  • डेबियन 10: स्थापित केल्यानंतर कोणती अतिरिक्त पॅकेजेस उपयुक्त आहेत? (प्रविष्टी पहा)
डेबियन 10: स्थापित केल्यानंतर कोणती अतिरिक्त पॅकेजेस उपयुक्त आहेत?

डेबियन 10: स्थापित केल्यानंतर कोणती अतिरिक्त पॅकेजेस उपयुक्त आहेत?

लक्षात ठेवा आणि लक्षात ठेवा:

"लक्षात ठेवा येथे चालविण्यासाठी आणि स्थापित करण्यासाठी येथे शिफारस केलेल्या क्रियांची व पॅकेजेस फक्त अशाच आहेत, "पॅकेजेस शिफारस केली" आणि सर्व किंवा त्यापैकी काही अंमलात आणणे आणि स्थापित करणे हे प्रत्येकावर अवलंबून आहे की ते का आहेत आवश्यक किंवा उपयुक्त, अल्प किंवा मध्यम मुदतीत, त्यांना जाणून घेण्यासाठी आणि वापरण्यासाठी, त्यांना आधीपासून चालू किंवा स्थापित करून.

आणि लक्षात ठेवा की या क्रिया आणि / किंवा पॅकेजेस होते यापूर्वी दोन्ही डिस्ट्रोजवर चाचणी केली, आणि यामध्ये डीफॉल्टनुसार स्थापित पॅकेजेस विस्थापित करण्यास सांगत नाहीत. पुढील, ते मेमरी किंवा सीपीयूचा वापर वाढवत नाहीत पासून, ते डीफॉल्टनुसार मेमरीमध्ये प्रक्रिया किंवा डिमन (सेवा) लोड करत नाहीत. प्रत्येक पॅकेज कशासाठी वापरला जातो हे आधीच जाणून घेण्यासाठी क्लिक करा येथे."

एमएक्स-लिनक्स आणि डेबीआयन अद्यतनित करा: अनुक्रमणिका

सॉफ्टवेअर डेव्हलपमेंट समर्थन करीता संकुले

जावा अनुप्रयोगांसाठी समर्थन

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

उद्दिष्ट: जावा अनुप्रयोगांसह सुसंगततेसाठी मूलभूत समर्थन स्थापित करा.

क्यूटी 5 अनुप्रयोगांसाठी समर्थन

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

उद्दिष्ट: क्यूटी 5 सह तयार केलेल्या अनुप्रयोगांसह सुसंगततेसाठी मूलभूत समर्थन स्थापित करा.

डिजिटल मायनिंग अनुप्रयोगांसाठी समर्थन

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

उद्दिष्ट: डिजिटल मायनिंग ofप्लिकेशन्सच्या स्थापना आणि व्यवस्थापनासाठी आवश्यक असणारी मूलभूत अनुप्रयोग समर्थन, ड्रायव्हर्स आणि लायब्ररी स्थापित करा.

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

उद्दिष्ट: बर्कले v5.3 डेटाबेस लायब्ररी वापरणार्‍या प्रोग्राम्ससाठी मूलभूत लायब्ररी समर्थन स्थापित करा, आधुनिक डिजिटल खनन अनुप्रयोगांकडून मोठ्या प्रमाणात वापरले जाणारे संकलित आणि / किंवा चालवावे.

वेब अनुप्रयोग समर्थन

अपाचे

apt install apache2

उद्दिष्ट: वेब अ‍ॅप्लिकेशन्ससाठी ऑप्टिमाइझ केलेले किंवा अपचे 2 साठी सुसंगत मूलभूत समर्थन स्थापित करा.

Nginx

apt install nginx

उद्दिष्ट: वेब अनुप्रयोगांसाठी ऑप्टिमाइझ केलेले किंवा एनजीन्क्ससाठी सुसंगत वेब अनुप्रयोगांसाठी मूलभूत समर्थन स्थापित करा.

पोस्टग्रे एसक्यूएल

apt install postgresql

उद्दिष्ट: पोस्टग्रीस्क्ल-आधारित डेटाबेस व्यवस्थापित करण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

apt install pgadmin3 y phppgadmin

उद्दिष्ट: पोस्टग्रीस्क्लवर आधारित डेटाबेसच्या व्यवस्थापनासाठी अनुप्रयोगांचे मूलभूत समर्थन स्थापित करा.

, MySQL

apt install mysql-server mysql-client

उद्दिष्ट: MySQL- आधारित डेटाबेस व्यवस्थापित करण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

apt install phpmyadmin y mysql-workbench

उद्दिष्ट: मायएसक्यूएल-आधारित डेटाबेसच्या व्यवस्थापनासाठी मूलभूत अनुप्रयोग समर्थन स्थापित करा.

मारिया डीबी

apt install mariadb-server mariadb-client

उद्दिष्ट: मारियाडीबीवर आधारित डेटाबेस व्यवस्थापित करण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

कृपया PHP

apt install php

उद्दिष्ट: पीएचपी-आधारित अनुप्रयोग हाताळण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

उद्दिष्ट: पीएचपी-आधारित अनुप्रयोगांचे व्यवस्थापन करण्यासाठी मूळ ग्रंथालयांचे मूळ समर्थन स्थापित करा.

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

उद्दिष्ट: पीएचपी-आधारित अनुप्रयोग हाताळण्यासाठी मूलभूत नॉन-नेटिव्ह लायब्ररी समर्थन स्थापित करा.

पर्ल

apt install perl

उद्दिष्ट: पीईआरएल-आधारित अनुप्रयोग हाताळण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

apt install libapache2-mod-perl2 y perlbrew

उद्दिष्ट: पीईआरएल-आधारित अनुप्रयोग हाताळण्यासाठी मूलभूत लायब्ररी समर्थन स्थापित करा.

python ला

apt install python-all-dev python-pip

उद्दिष्ट: पायथन-आधारित अनुप्रयोग व्यवस्थापित करण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

apt install python3-setuptools python3-pyqt5 python3-pip

उद्दिष्ट: पायथॉन 3-आधारित अनुप्रयोग हाताळण्यासाठी बेसिक कमांड आणि फंक्शन समर्थन स्थापित करा.

लेखाच्या निष्कर्षांसाठी सामान्य प्रतिमा

निष्कर्ष

आम्ही आशा करतो की आहे "उपयुक्त छोटी पोस्ट" कोणत्या योग्य पॅकेजेसस योग्य आवश्यक समर्थन प्रदान करण्यासाठी आवश्यक आहे  «instalación y gestión» विशिष्ट सॉफ्टवेअर विकास, डिस्ट्रोज बद्दल «DEBIAN y MX-Linux», सर्वांसाठी अत्यंत रुची आणि उपयुक्तता आहे «Comunidad de Software Libre y Código Abierto» आणि अनुप्रयोगांच्या अद्भुत, अवाढव्य आणि वाढत्या परिसंस्थेच्या प्रसारास मोठा वाटा आहे «GNU/Linux».

आणि अधिक माहितीसाठी, कधीही कोणालाही भेट देण्यास संकोच करू नका ऑनलाइन लायब्ररी कसे ओपनलिब्रा y जेडीआयटी वाचणे पुस्तके (पीडीएफ) या विषयावर किंवा इतरांवर ज्ञान क्षेत्र. आत्तासाठी, जर आपल्याला हे आवडले असेल «publicación», ते सामायिक करणे थांबवू नका आपल्यासह इतरांसह आवडत्या वेबसाइट, चॅनेल, गट किंवा समुदाय सामाजिक नेटवर्कचे, शक्यतो विनामूल्य आणि म्हणून मुक्त मॅस्टोडन, किंवा सुरक्षित आणि खाजगी सारखे तार.

किंवा आमच्या मुख्य पृष्ठास येथे भेट द्या फर्मलिनक्स किंवा अधिकृत चॅनेलमध्ये सामील व्हा डेस्डेलिन्क्सकडून तार यावर किंवा इतर मनोरंजक प्रकाशने वाचण्यासाठी आणि त्यांना मत देण्यासाठी «Software Libre», «Código Abierto», «GNU/Linux» आणि संबंधित इतर विषय «Informática y la Computación», आणि «Actualidad tecnológica».


लेखाची सामग्री आमच्या तत्त्वांचे पालन करते संपादकीय नीति. त्रुटी नोंदविण्यासाठी क्लिक करा येथे.

2 टिप्पण्या, आपल्या सोडा

आपली टिप्पणी द्या

आपला ई-मेल पत्ता प्रकाशित केला जाणार नाही. आवश्यक फील्ड चिन्हांकित केले आहेत *

*

*

  1. डेटा जबाबदार: मिगुएल Áन्गल गॅटन
  2. डेटाचा उद्देशः नियंत्रण स्पॅम, टिप्पणी व्यवस्थापन.
  3. कायदे: आपली संमती
  4. डेटा संप्रेषण: कायदेशीर बंधन वगळता डेटा तृतीय पक्षास कळविला जाणार नाही.
  5. डेटा संग्रहण: ओकेन्टस नेटवर्क (EU) द्वारा होस्ट केलेला डेटाबेस
  6. अधिकारः कोणत्याही वेळी आपण आपली माहिती मर्यादित, पुनर्प्राप्त आणि हटवू शकता.

  1.   ट्विकझर म्हणाले

    मी चूक असल्यास मला दुरुस्त करा, परंतु .. डेबियनवर, त्यांनी रेपॉजिटरीजमधून phpmyadmin काढले नाही?
    आणि पीएचपी स्थापित करण्यासाठी, आपल्याला निर्दिष्ट करणे आवश्यक नाही (उदाहरणार्थ) php7.3, किंवा php7.3-curl

  2.   लिनक्स पोस्ट इंस्टॉल म्हणाले

    ग्रीटिंग्ज ट्विकझर! आपल्या टिप्पणीबद्दल धन्यवाद. निश्चितपणे phpmyadmin डेबियन 10 (स्थिर) रिपॉझिटरीजमध्ये नाही परंतु माझ्या गृहित्राच्या अनुसार ते डेबियन 11 (टेस्टिंग) रेपॉजिटरीजमध्ये आहे, की काही ठिकाणी ते स्थिर पॅकेजमध्ये इतर पॅकेजेसप्रमाणे समाविष्ट करतील, परंतु आपण त्याशिवाय किंवा त्यास वगळू शकता. तथापि, म्हणूनच मी ते तिथेच सोडले. दुसर्‍या संदर्भात, हे आवश्यक नाही, कारण रेपॉजिटरीतील सध्याच्या आवृत्त्यांना त्यांच्या सामान्य नावाने संबोधले जाते.