योग्य- * किंवा योग्यता, कोणता वापरायचा?

योग्य (Advanced Pkक्केजिंग Tool) मुळात मध्ये संकुल स्थापित आणि विस्थापित करण्यासाठी वापरले जाते जीएनयू / लिनक्स. आम्ही वापरू डेबियन आणि डेरिव्हेटिव्ह्ज, आम्ही सामान्यपणे वापरतो, जरी आपण ते वापरू शकतो योग्यता.

त्या दोघांमध्ये काय फरक आहे हे तुम्हाला माहिती आहे का? मी त्यांना एकतर ओळखतही नाही, म्हणून मी काही संशोधन आणि प्रयोग करणे सुरू केले. मी येथे परिणाम दर्शवितो.

योग्यता

असे म्हटले जाते योग्यता ची सुधारित आवृत्ती आहे योग्य आणि पॅकेज अवलंबितांचे व्यवस्थापन बरेच चांगले करते आणि त्याद्वारे देखील शिफारस केली जाते डेबियन. योग्यता पेक्षा बरेच पर्याय समाविष्ट आहेत योग्य, योग्यतेच्या मदतीनुसार सर्वात जास्त वापरले जाणारे आणि त्यांचे वर्णन पाहू या.

स्थापित करा : एक किंवा अधिक पॅकेजेस स्थापित करा. "इन्स्टॉल" आदेशानंतर पॅकेजेस दिसतील.
काढून टाका, पुरीज करा, धरून ठेवा, अनहोल्ड करा, ठेवा, पुन्हा स्थापित करा : हे आदेश "इन्स्टॉल" प्रमाणेच करतात, परंतु या प्रकरणात नामित कृती कमांड लाइनवरील सर्व पॅकेजेस प्रभावित करते जे ती अवैध करत नाहीत.
सुधारणा : योग्य स्रोतांकडून उपलब्ध पॅकेजेसची यादी अद्यतनित करा ("apt-get update" च्या समतुल्य).
सेफ-अपग्रेड : स्थापित पॅकेजेस त्यांच्या नवीनतम आवृत्तीवर अद्यतनित करा. स्थापित पॅकेजेस वापरली जात नाहीत तोपर्यंत काढून टाकली जातील.
पूर्ण-अपग्रेड : स्थापित पॅकेजेस त्यांच्या नवीनतम आवृत्तीवर अद्यतनित करा, आवश्यक असल्यास पॅकेज स्थापित करा किंवा काढून टाका. ही आज्ञा सेफ-अपग्रेडपेक्षा कमी पुराणमतवादी आहे आणि म्हणूनच अवांछित क्रियांना जास्त धोका आहे. तथापि, ही पॅकेजेस अद्ययावत करण्यात सक्षम आहे जी सेफ-अपग्रेड अद्ययावत करण्यात अक्षम आहे. ऐतिहासिक कारणांमुळे, कमांडला मूलतः डिस्ट-अपग्रेड म्हटले जाते आणि योग्यता अद्याप डिस्ट-अपग्रेड पूर्ण-अपग्रेडचे प्रतिशब्द म्हणून ओळखते.
शोध : कमांड लाइनवर प्रविष्ट केलेल्या नमुन्यांपैकी एकशी जुळणारी पॅकेजेस शोधा.
शो : Or शोध »आदेशानुसार सूचीबद्ध एक किंवा अधिक पॅकेजशी संबंधित तपशील माहिती दर्शवा.

योग्यता आणि त्यावरील पर्यायांबद्दल अधिक माहिती पाहण्यासाठी, आम्ही कन्सोलमध्ये ठेवून मदत शोधण्याचा एक उत्तम मार्ग वापरू शकतो:

pt मनुष्य योग्यता

योग्य

आप्टच्या बाबतीत, हे आदेशांद्वारे वापरले जाते: योग्य कॅशे, योग्य-मिळवा, apt.conf, apt_preferences, योग्य-सुरक्षित, पहिला 2 सर्वात जास्त वापरला जात आहे. समाविष्ट केलेले पर्याय खालीलप्रमाणे आहेत:

सुधारणा : अद्यतन त्यांच्या स्रोत पासून संकुल निर्देशांक समक्रमित करण्यासाठी वापरले जाते.
श्रेणीसुधार करा : अपग्रेडचा वापर प्रणालीवर स्थापित केलेल्या सर्व पॅकेजेसची नवीनतम आवृत्ती /etc/apt/sources.list मध्ये सूचीबद्ध केलेल्या कोणत्याही स्रोतवरून स्थापित करण्यासाठी केला जातो.
डिस्ट-अपग्रेड : अपग्रेड क्रिया करण्याव्यतिरिक्त, नवीन पॅकेज आवृत्त्यांमुळे हे निर्भरतेवर अवलंबून बदल हाताळते. apt-get मध्ये एक "स्मार्ट" विरोधाभास निराकरण प्रणाली आहे आणि आवश्यक असल्यास ती सर्वात महत्वाच्या पॅकेजेस कमी महत्वाच्या खर्चावर अद्यतनित करण्याचा प्रयत्न करेल.
स्थापित करा : "स्थापित करा" या शब्दाचे अनुसरण करणारे पॅकेजेस स्थापित किंवा अद्यतनित करा.
दूर : हे पॅकेज स्थापित करण्याऐवजी काढून टाकण्याऐवजी फरक असलेल्या इन्स्टॉल प्रमाणेच वर्तन करते. लक्षात घ्या की पॅकेज काढून टाकताना, त्यातील फाइल्स सिस्टमवरच राहतात. पॅकेजच्या नावाच्या आधीचे चिन्ह असल्यास (दोघांमधील पांढर्‍या जागेशिवाय), प्रश्न असलेले पॅकेज काढण्याऐवजी स्थापित केले जाईल.
कोठा साफ : पॅकेजेस काढून टाकून शुद्ध केल्या जातील (कॉन्फिगरेशन फाइल्सही काढून टाकल्या जातील) या फरकानुसार हे हटविणे समान आहे.

योग्यता आणि त्यावरील पर्यायांबद्दल अधिक माहिती पाहण्यासाठी, आम्ही कन्सोलमध्ये ठेवून मदत शोधण्याचा एक उत्तम मार्ग वापरू शकतो:

$ man apt-get.

मग काय फरक आहे?

वास्तविकतेत हे सर्व प्रत्येक व्यक्तीने दिलेला उपयोग आणि त्यांना काय करण्याची आवश्यकता यावर अवलंबून असते. विशेषत: मी नेहमीच योग्यता वापरतो, कारण त्यात आणखी बरेच पर्याय आहेत, परंतु जर मला शोध घ्यावा लागला असेल तर, ptप्ट-कॅश माझ्यासाठी अधिक मनोरंजक आहे. तसेच, योग्यतेमध्ये कन्सोल इंटरफेस आहे:

मी काही ठिकाणी वाचले आहे योग्यता हे सुचविलेले अवलंबन स्थापित करते आणि ते उपयुक्त फक्त शिफारस केलेले स्थापित करा. तथापि, उदाहरणार्थ जर आम्ही ऑडियसियस स्थापित करण्याचा प्रयत्न केला तर आपण ती समान पॅकेजेस स्थापित केल्याचे पाहू.

सह निर्भय स्थापित करताना ते पाहू योग्यता:

sudo योग्यता स्थापित करा
खालील नवीन पॅकेजेस स्थापित केली जातील:
  दुराचारी ऑडियस-प्लगइन्स {ए} लिबाउडक्लियंट 2 {ए} लिबाउडकोर 1 {अ} लिबबिनो 1 एलडीबीएल {अ} लिबक्यू 1 {ए} लिब्फ्लुइड्सेंट 1 {ए} 
  libmcs1 {a b libmowgli2 {a} libreid-builder0c2a {a} libsidplay2 {a} unzip {a 
0 अद्ययावत पॅकेजेस, 12 नवीन स्थापित केले, 0 काढण्यासाठी आणि 0 अद्यतनित केले नाही. मला 3494 केबी फायली डाउनलोड करण्याची आवश्यकता आहे. अनपॅक केल्यावर, 11,0 एमबी वापरला जाईल.

आणि आता सह उपयुक्त:

sudo apt-get इंस्टॉर ऑडियियस
पॅकेज सूची वाचन करीत आहे ... अवलंबन वृक्ष तयार करणे स्थिती माहिती वाचत आहे ... पूर्ण झाले खालील अतिरिक्त पॅकेजेस स्थापित होतील:
  ऑडियसियस-प्लगइन
  libsidplay2 अनझिप
सूचित पॅकेजेस:
  libmcs-backend-gconf libmcs-utils झिप
खालील नवीन पॅकेजेस स्थापित केली जातील:
  दुराचारी ऑडियस-प्लगइन्स लिबाउडक्लिएंट 2 लिबाडकोर 1 लिबबिनो 1 एलडीबीएल लिबक्यू 1 लिबफ्लूइड्सिएंट 1 लीबएमसीएस 1 लिबमोवगली 2
  libreid-builder0c2a libsidplay2 अनझिप
0 अद्यतनित केले, 12 स्थापित केले जातील, 0 काढण्यासाठी 0 आणि अद्यतनित केले नाही. मला 3494 केबी फायली डाउनलोड करण्याची आवश्यकता आहे. या ऑपरेशननंतर 11,0 MB अतिरिक्त डिस्क स्पेस वापरली जाईल.

आणखी एक फरक पाहण्यासाठी आपण शोध घेऊ शकतो. उदाहरणार्थ, टर्मिनल उघडा आणि टाइप करा:

योग्यता शोध आयपॉड

आणि नंतर

ptप्ट-कॅशे शोध आयपॉड

आपण यासह शोधाचे कौतुक करू शकता एपीटी-कॅशे हे सर्वात समाधानकारक होते. च्या बाबतीत योग्यतातथापि, ते केवळ पॅकेज नावानेच शोधले गेले, तथापि, एपीटी-कॅशे आयपॉड शब्दाशी संबंधित सर्व प्रोग्राम्स किंवा पॅकेजेस तुम्ही शोधल्या आहेत, बहुधा प्रत्येक पॅकेजच्या वर्णनातून.

निष्कर्ष

आपल्यासाठी सर्वात सोयीस्कर असा एक वापरा. हे वापरणे माझ्यासाठी सोपे आहे योग्यता कारण ही एकच कमांड आहे योग्य मला वापरायचं आहे उपयुक्त o एपीटी-कॅशे केस त्यानुसार. आपणास अन्य कोणत्याही फरक माहित असल्यास, त्या टिप्पण्यांमध्ये सोडा 😀


लेखाची सामग्री आमच्या तत्त्वांचे पालन करते संपादकीय नीति. त्रुटी नोंदविण्यासाठी क्लिक करा येथे.

12 टिप्पण्या, आपल्या सोडा

आपली टिप्पणी द्या

आपला ई-मेल पत्ता प्रकाशित केला जाणार नाही. आवश्यक फील्ड चिन्हांकित केले आहेत *

*

*

  1. डेटा जबाबदार: मिगुएल Áन्गल गॅटन
  2. डेटाचा उद्देशः नियंत्रण स्पॅम, टिप्पणी व्यवस्थापन.
  3. कायदे: आपली संमती
  4. डेटा संप्रेषण: कायदेशीर बंधन वगळता डेटा तृतीय पक्षास कळविला जाणार नाही.
  5. डेटा संग्रहण: ओकेन्टस नेटवर्क (EU) द्वारा होस्ट केलेला डेटाबेस
  6. अधिकारः कोणत्याही वेळी आपण आपली माहिती मर्यादित, पुनर्प्राप्त आणि हटवू शकता.

  1.   योयो म्हणाले

    मी नेहमीच योग्यतेनुसार विश्वासू असतो 😉

    1.    elav <° Linux म्हणाले

      आम्ही आधीच 2 are आहोत

  2.   mcder3 म्हणाले

    पॅकेज + अवलंबन + पॅकेज कॉन्फिगरेशन (रूट पातळी) काढण्यासाठी "योग्यता शुद्धीकरण पॅकेजनाव" गहाळ आहे

    ब्लॉगवर खूप चांगली नोंद आणि अभिनंदन 😛

    कोट सह उत्तर द्या

    1.    mcder3 म्हणाले

      मी आधीच हे पाहिले आहे ... "योग्यता पुंज" गोष्ट एक्सडी लावल्याबद्दल क्षमस्व

      1.    केझेडकेजी ^ गारा म्हणाले

        काहीही नाही, काळजी करू नका ^ - ^
        आपल्या टिप्पण्यांसाठी धन्यवाद, कारण मला खात्री आहे की हेतू मदत करणे 😉
        शुभेच्छा आणि इथून थांबत रहा 🙂

      2.    elav <° Linux म्हणाले

        काही हरकत नाही .. मदत करू इच्छित असल्याबद्दल धन्यवाद .. 😀

  3.   जिझस बॅलेस्टेरोज म्हणाले

    जेव्हा मी डेबियन वापरतो तेव्हा मी योग्यतेस देखील प्राधान्य देतो, यामुळे मला अधिक आत्मविश्वास मिळतो :). परंतु मी आपल्याशीसुद्धा सहमत आहे की जेव्हा शोध घेण्याची वेळ येते तेव्हा -प्ट-गेट अधिक प्रभावी होते. योग्यता एक दिवस ptप्ट-कॅशे सारखे काहीतरी वापरेल की नाही हे मला माहित नाही किंवा कदाचित भविष्यात ते ptप्ट-गेट काढून योग्यता आणि ptप्ट-कॅशे सोडतील: पी ...

  4.   जुलै म्हणाले

    आतापर्यंत मी एपीटी-जीईटी वापरत होतो, मी हे पाहण्यासाठी एपीटीट्यूड मंजूर करणार आहे ...

  5.   जोस लुइस मॅन्टीला म्हणाले

    नक्कीच एक अतिशय सहज लक्षात येणारा फरक आहे !!

    योग्य: आपण आवश्यक लायब्ररीत पॅकेज स्थापित करा

    योग्यता: ते आवश्यक, सुचवलेले स्थापित करते आणि स्थापित करण्यापूर्वी हे सत्यापित करते की यामुळे इतर आवृत्त्यांच्या लायब्ररी सामायिक करणारे दुसरे पॅकेज खराब होत नाही, स्थापित करण्यापूर्वी ते समान पोर्ट चालविणार्‍या किंवा त्यांच्या कॉन्फिगरेशनमध्ये काहीतरी गडबड असलेल्या अनुप्रयोगांमधील विद्यमान संघर्ष सोडवते. आणि आपण त्यास त्यांच्या संबंधित सूचना आणि स्पष्टीकरणासह त्याचे निराकरण कसे करावे हे विचारता आणि शेवटी योग्यतेसह आपल्याकडे कोणतीही संकुले मोडलेली नसतील (आपल्याला ती दुरुस्त करण्यासाठी स्वच्छ किंवा ऑटोक्लिन किंवा -प्ट-एफ इंस्टॉलची आवश्यकता नाही), हे असे कार्य करते 6,5 आणि 7 !!

    सुप्रभात आणि तुमची सेवा (कोलंबियाच्या शुभेच्छा)

  6.   चॅनेल अज्ञात म्हणाले

    नमस्कार!
    एपीटी इन्स्टॉल कमांड म्हणजे काय? ते माझ्या वेबसाइटवर लिनक्स मिंटच्या पीडीएफ ट्यूटोरियलमध्ये नमूद करतात.
    आणि त्याचे लेखक टर्मिनलनुसार अपडेट्सचे अपग्रेड अपग्रेड न करण्याची शिफारस करतात कारण ते कोणत्या प्रकारचे स्थिरतेचे स्तर फिल्टर करीत नाहीत, जसे की मिंटच्या ग्राफिकल इंटरफेससह अपडेटरमध्ये उपलब्ध आहे.

  7.   विमा म्हणाले

    जरी हे माहित आहे, मी योग्यतेपेक्षा अधिक वेळा अ‍ॅप्ट-गेट वापरतो. परंतु मला माहित आहे की जेव्हा प्रत्येक वेळी आपण ग्राफिकल मोडमध्ये काही स्थापित करता तेव्हा Synaptic पॅकेज व्यवस्थापक योग्यता वापरतो.

  8.   पेपो म्हणाले

    बर्‍याच वर्षांपासून, एपीटी कमांडमध्ये -प्ट-गीन आणि ptप्ट-कॅशे फंक्शन्लिटीज समाविष्ट आहेत, जेणेकरून आम्ही "installप्ट-गेट इंस्टॉल पॅकेज" आणि "-प्ट-कॅशे" ऐवजी "searchप्ट पॅकेज" आणि "searchप्ट सर्च पॅकेज" बनवू शकतो. अनुक्रमे शोध पॅकेज.