Menjelaskan keraguan: LMDE repositori

Semasa kami menerbitkan pada 21 Oktober 2011, kami telah memutuskan untuk membuat bahagian yang disebut: Pendapat anda penting <° Linux, di mana kami akan menerbitkan e-mel yang telah dihantar oleh beberapa pengguna yang mencadangkan topik menarik borang hubungan.

Nah, bahagian lain baru saja dilahirkan disebut: Menjelaskan keraguan <° Linux, di mana kami akan menjawab beberapa soalan pengguna yang datang kepada kami, dengan sebarang pertanyaan secara umum.

Kami akan menerbitkan di sini yang kami percaya semestinya menarik bagi semua orang, seperti halnya yang disebut oleh pengguna: Erithrym.

Erithrym menulis:

Halo, saya telah mengikuti blog selama beberapa hari, dan sangat lengkap, tetapi saya mempunyai soalan.
Saya telah menjadi pengguna LMDE secara praktikal sejak ia keluar, kerana ia kelihatan lebih menarik daripada Linux Mint, yang merupakan distro yang saya gunakan sebelum ini. Satu-satunya perkara yang saya tidak suka ialah kebanyakan pakej tidak dikemas kini.
Bolehkah anda mengesyorkan senarai repositori yang stabil dan dikemas kini?
Adakah itu kali terakhir saya mencuba pakej SID, ketika saya mengemas kini xorg saya akhirnya mengacaukan antara muka grafik ...
Terima kasih banyak dan maaf atas kesulitan!
Dan pertama sekali tahniah di blog hebat ini!

<° Linux jawab semula:

Terima kasih banyak atas pujian anda, kami sangat gembira kerana usaha kami untuk mengekalkan blog ini berguna untuk pengguna lain.

Walaupun merupakan kelebihan untuk memiliki repositori khusus di LMDE, pada masa yang sama kita (sebagai penghalang) bergantung pada kemas kini yang dilakukan oleh pasukan Linux Mint menggabungkan mereka.

Pertama sekali, anda harus ingat bahawa LMDE tidak menggunakan repositori Sid, tetapi yang Ujian Debian y Debian Squeeze. Diandaikan bahawa di repositori Masuk, mereka mesti memasukkan pakej baru setiap hari dari cermin dari Ujian Debian, tetapi ini tidak selamat.

Anda boleh menggunakan repositori secara langsung dari Debian, tetapi kemungkinan besar apabila berlaku kesalahan ralat dengan pakej yang disertakan LMDE.

Anda mempunyai dua pilihan: Sama ada anda berisiko menggunakan repositori Pengujian Debian untuk mempunyai pakej yang lebih baru, atau anda menunggu dengan sabar untuk kemas kini dari repositori LMDE. Anda bebas memilih. Saya meninggalkan anda repositori Debian:

deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free


Kandungan artikel mematuhi prinsip kami etika editorial. Untuk melaporkan ralat, klik di sini.

8 komen, tinggalkan komen anda

Tinggalkan komen anda

Alamat email anda tidak akan disiarkan. Ruangan yang diperlukan ditanda dengan *

*

*

  1. Bertanggungjawab atas data: Miguel Ángel Gatón
  2. Tujuan data: Mengendalikan SPAM, pengurusan komen.
  3. Perundangan: Persetujuan anda
  4. Komunikasi data: Data tidak akan disampaikan kepada pihak ketiga kecuali dengan kewajiban hukum.
  5. Penyimpanan data: Pangkalan data yang dihoskan oleh Occentus Networks (EU)
  6. Hak: Pada bila-bila masa anda boleh menghadkan, memulihkan dan menghapus maklumat anda.

  1.   Alexander Nova kata

    AFAIK Linux Mint Debian Edition, menurut dokumentasinya sendiri, 100% serasi dengan Debian Testing. Dengan apa yang tidak berlaku iaitu dengan Ubuntu; LMDE memberi amaran bahawa repositori Ubuntu tidak akan berfungsi di sana.

  2.   emrithry kata

    Terima kasih atas jawapannya! Saya harus mengatakan bahawa saya fikir saya sudah menjalani ujian, tetapi nampaknya tidak, kerana setelah menambahkan repositori banyak kemas kini muncul, walaupun mereka memberi saya masalah tertentu, kerana mereka memaksa saya untuk menyahpasang pakej seperti mint-meta-common atau mint-meta-debian, yang saya rasa tidak wajar untuk membuangnya. Sebagai tambahan kepada ini, sebelum mengemas kini xorg, saya telah mengacaukan antara muka grafik, jadi sekarang saya agak takut sekiranya saya mengacaukannya semula. Ia tidak boleh memberi saya masalah, bukan?

    1.    elav <° Linux kata

      Tepat. Sekiranya anda ingin agar LMDE anda berjalan dengan lancar, saya cadangkan anda menggunakan repositori LMDE. Mungkin jika anda mempunyai Ujian, tetapi LMDE bukan Debian seperti itu.

      1.    Erithrym kata

        Saya tidak keberatan mempunyai masalah lain selagi saya mempunyai jalan keluar, sebenarnya ia adalah salah satu sebab mengapa saya lebih suka Linux daripada Windows, untuk dapat menghadapi mesin dan belajar bagaimana memperbaiki kesilapan yang mungkin berlaku telah, tetapi saya juga tidak mahu menyebabkan kerosakan tidak dapat dipulihkan dan perlu memasang semula sistem operasi setiap dua hingga tiga ...
        Bagi bungkusan yang saya nyatakan sebelumnya, adakah ia relevan? Kerana kemas kini libreoffice juga memberitahu saya untuk membuangnya ...

        1.    elav <° Linux kata

          Pakej tersebut adalah pakej meta, yang seterusnya (atau mungkin tidak) menyahpasang pakej lain. Saya menyahpasangnya tanpa masalah besar.

  3.   Carlos-Xfce kata

    Hai Elav. Hebat, saya suka bahagian baru dan menjawab soalan khusus ini: repositori LMDE. Namun (dan semoga Keberanian memaafkan saya!), Saya belum menjadi pengguna yang pakar dan saya tidak tahu apa yang harus dilakukan dengan repositori yang anda letakkan di sini. Saya takut menyentuhnya kerana saya sudah menghadapi masalah yang memaksa saya memasang semula semuanya dari awal. Bagaimanapun, terima kasih banyak.

    1.    elav <° Linux kata

      Jangan risau. Mari lihat. Repositori yang saya masukkan ke dalam pos adalah yang perlu anda gunakan sekiranya anda tidak mahu mendapatkan pakej anda dari repositori LMDE dan kemas kini mengikut irama Debian. Dengan kata lain, jika yang anda mahukan ialah sistem tidak rosak dan terus berfungsi sebagaimana mestinya (walaupun tidak kerap dikemas kini), anda harus pakai ini. Sekiranya yang anda mahukan sentiasa dikemas kini (walaupun ada beberapa pakej yang berkaitan dengan LMDE masuk neraka) maka anda gunakan yang saya masukkan dalam catatan.

  4.   David kata

    ujian apt-get -t pasang banshee
    Senarai pakej membaca ... Selesai
    Membuat pokok pergantungan
    Membaca maklumat status ... Selesai
    Tidak boleh memasang beberapa pek. Ini mungkin bermaksud
    anda meminta keadaan yang mustahil atau, jika anda menggunakan pengedaran
    tidak stabil, bahawa beberapa pakej yang diperlukan belum dibuat atau dibuat
    dipindahkan daripada Masuk.
    Maklumat berikut dapat membantu menyelesaikan keadaan:

    Pakej berikut mempunyai kebergantungan yang belum dipenuhi:
    libc6-dev: Pecah: gcc-4.4 (<4.4.6-4) tetapi 4.4.5-8 akan dipasang
    dan ia berlaku kepada saya dengan semua pakej yang ingin saya pasangkan dari ujian. Bagaimana saya boleh menyelesaikannya ?, Terima kasih terlebih dahulu dan salam