Penyelesaian untuk masalah memasang aplikasi 32-bit pada Linux Mint 14 RC 64-bit

Saya baru sahaja menyiarkan berita yang sudah saya ketahui Linux Mint 14 RC ada, dan Clem baru sahaja diumumkan bahawa dalam versi 64-bit terdapat masalah yang tidak memungkinkan untuk memasang aplikasi seperti Skype, Google Earth atau pakej 32-bit lain.

Keupayaan untuk memasang aplikasi 32-bit dalam lingkungan 64-bit biasanya disebut sebagai "Multiarch". Rupanya ada perubahan dengan dpkg di Debian, yang membuat konfigurasi berbilang gerbang menjadi usang di Ubuntu. Anda dapat melihat lebih banyak maklumat mengenai masalah ini di sini: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

Penyelesaian

Untuk mengaktifkan Multiarch, buka terminal dan ketik arahan berikut:

sudo dpkg --add-arquitectura i386
apt update

Masalah ini akan diperbaiki secara manual dalam versi stabil linux pudina 14.


Kandungan artikel mematuhi prinsip kami etika editorial. Untuk melaporkan ralat, klik di sini.

12 komen, tinggalkan komen anda

Tinggalkan komen anda

Alamat email anda tidak akan disiarkan.

*

*

  1. Bertanggungjawab atas data: Miguel Ángel Gatón
  2. Tujuan data: Mengendalikan SPAM, pengurusan komen.
  3. Perundangan: Persetujuan anda
  4. Komunikasi data: Data tidak akan disampaikan kepada pihak ketiga kecuali dengan kewajiban hukum.
  5. Penyimpanan data: Pangkalan data yang dihoskan oleh Occentus Networks (EU)
  6. Hak: Pada bila-bila masa anda boleh menghadkan, memulihkan dan menghapus maklumat anda.

  1.   Orang Willians kata

    @MonitoLinux terlalu banyak kerja anda. Saya tidak pasti akan menjumpainya di kawasan belakang yang stabil. Tetapi saya dapat menjamin bahawa di Sid, dan kemungkinan besar sekarang di repositori Wheezy [1] anda akan dapati maklumat itu tersedia.

    [1] http://www.debian.org/News/2011/20110726b

    Sokongan multiarch adalah sesuatu yang membuat banyak kebisingan. Saya bertembung dengannya seperti pada bulan Jun dan dia sudah lama berguling.

    1.    monitolinux kata

      @Willians adalah bahawa saya berasal dari zaman dahulu, di mana tidak ada begitu banyak repositori dengan aplikasi yang diperlukan, di mana salah satu yang paling banyak dijumpainya adalah kod sumber.

  2.   Orang Willians kata
  3.   rafagcg kata

    Saya agak tersesat (banyakale banyak) dengan ini. Saya menggunakan Xubuntu 12.10 64Bit (tembakan berbanding ubuntu 12.10 yang leeeento) dan yang mengejutkan saya ketika memasang KompoZer adalah bahawa ia tidak muncul ... pada akhirnya saya menyimpulkan bahawa kerana ia tidak wujud untuk 64bit, ia adalah tidak di repositori ... walaupun sampai sekarang selalu dipasang (dengan apt-get install Kompozer) tetapi kali ini ia tidak muncul. Setelah berfikir banyak, saya menjumpai DeB 64 bit dan memasangnya. Tetapi keraguan saya dan akhirnya saya sampai ke titik. Sekiranya saya memasang ini, anda memberi komen pada siaran ini. Adakah pakej 32bit akan muncul di repositori untuk memasang program 32bit jika 64bit tidak tersedia? Adakah Kompozer 32-bit telah muncul untuk saya pasangkan di repositori? Adakah baik saya melakukannya untuk program masa depan yang saya perlukan?

  4.   Pembunuh sampah kata

    elav saya katakan, bukan itu sebabnya saya berada di Debian sid 😛

    sebenarnya masalah ini yang dikemukakan oleh pudina, Debian sid telah mengemukakannya sekitar 2 bulan yang lalu, walaupun secara sinaptik mengatakan bahawa sebelum memasang ia32-lib dan ia32-libs-gtk, ia mengesyorkan agar anda menambahkan dpkg –add-architecture: i386 kemudian jalan kemas kini dan siap.

    1.    meriah kata

      Bilakah anda memberitahu saya? Saya tidak ingat 😛

      1.    Pembunuh sampah kata

        tepatnya 2 bulan yang lalu, ketika saya mengalami masalah yang serupa tetapi kerana pakej ia32-libs-gtk adalah yang usang, dan masih belum keluar untuk menyelesaikan ia32-lib baru, sehingga saya ingat apa yang anda katakan dan mengapa adakah saya akan menambah senibina dpkg –add-: i386 😛

        1.    meriah kata

          Hahaha itu melalui IRC kan?

  5.   MonitoLinux kata

    jalan penyelesaiannya ialah memuat turun kod sumber dan menyusunnya, kemudian menghasilkan pakej deb dan memberikannya kepada masyarakat

  6.   Sergio Esau Arámbula Duran kata

    Hebat 🙂

  7.   Mari gunakan Linux kata

    Sangat bagus! Menarik…
    Mari harap mereka menyelesaikan masalah sebelum versi akhir keluar.
    Ceria! Paul.

  8.   mfcollf77 kata

    Saya memasang linux mint 14 64 bit dan saya tidak menghadapi masalah untuk memasang Skype, hanya versi 4.0 yang dipasang

    Saya akan melihat apa lagi masalah saya