Hoe gstreamer0.10-plugins-bad te updaten in LMDE RC 201108

In onderhoud

Na de installatie van LMDE RC 201108 er was een enkel pakket dat me een fout gaf bij het updaten: gstreamer0.10-plugins-bad.

Gelukkig is de oplossing voor dit probleem heel eenvoudig en vrij snel. We openen een terminal en loggen in als wortel of we gebruiken sudo, zoals het geval is met LMDE, met het volgende commando.

$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

En we zouden zoiets als dit moeten krijgen:

(Database lezen ... 158926 bestanden en mappen die momenteel zijn geïnstalleerd.) Voorbereiden om gstreamer0.10-plugins-bad 0.10.22-2 te vervangen (met ... / gstreamer0.10-plugins-bad_0.10.22-3_i386.deb). .. Uitpakken vervangende gstreamer0.10-plugins-bad ... dpkg: waarschuwing: overheersend probleem omdat --force ingeschakeld: probeert '/usr/lib/gstreamer-0.10/libgstxvid.so' te overschrijven, dat ook in pakket gstreamer0.10 zit .0.10.22-plugins-echt-slecht 0.1-0.10 Gstreamer0.10.22-plugins-bad (3-2.0) instellen ... Verwerkingstriggers voor libglib0-XNUMX ...

Klaar. We hebben gstreamer geïnstalleerd en bijgewerkt 😀

 


De inhoud van het artikel voldoet aan onze principes van redactionele ethiek. Klik op om een ​​fout te melden hier.

5 reacties, laat de jouwe achter

Laat je reactie achter

Uw e-mailadres wordt niet gepubliceerd.

*

*

  1. Verantwoordelijk voor de gegevens: Miguel Ángel Gatón
  2. Doel van de gegevens: Controle SPAM, commentaarbeheer.
  3. Legitimatie: uw toestemming
  4. Mededeling van de gegevens: De gegevens worden niet aan derden meegedeeld, behalve op grond van wettelijke verplichting.
  5. Gegevensopslag: database gehost door Occentus Networks (EU)
  6. Rechten: u kunt uw gegevens op elk moment beperken, herstellen en verwijderen.

  1.   Dario Freijé zei

    Heel erg bedankt! Het werkte uit 10.
    Ik zat vast in dat pakket toen ik wilde updaten en ging niet verder met de andere 418-updates.

    1.    elav <° Linux zei

      Ik ben blij dat het je gediend heeft 😀

  2.   aciguembre zei

    Nou, dit lijkt mij….

    (Leyendo la base de datos ... 152219 ficheros o directorios instalados actualmente.)
    Preparando para reemplazar gstreamer0.10-plugins-bad 0.10.22-2 (usando .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
    Desempaquetando el reemplazo de gstreamer0.10-plugins-bad ...
    dpkg-deb (subproceso): datos: error interno de lectura de gzip `: data error'
    dpkg-deb: error: el subproceso devolvió el código de salida de error 2
    dpkg: error al procesar /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--install):
    el subproceso dpkg-deb --fsys-tarfile devolvió el código de salida de error 2
    Procesando disparadores para libglib2.0-0 ...
    Se encontraron errores al procesar:
    /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
    portatil@portatil ~ $

    Kan ik iets doen om het te corrigeren?
    Bedankt voor je blog. Ik hoop veel van je te leren !!

  3.   krik zei

    Ik installeerde lmde 201109 en toen ik de eerste update deed, kreeg ik een foutmelding voor kapotte pakketten, dus ik heb vanaf terminal bijgewerkt met sudo apt-get update en sudo apt-get dist-upgrade en alles ging uiteindelijk perfect.Ik gebruikte sudo apt-get - f installeren na een paar dagen had ik problemen (dat was mijn fout) en ik moest opnieuw installeren toen ik probeerde de update opnieuw uit te voeren. Ik kreeg een fout met gstreamer en probeerde het op veel manieren te repareren en ik kon sudo dpkg -i –force niet gebruiken -overwrite en toch ging ik niet weg, al wanhopig deed ik iets heel doms maar het werkte! Update het vinkje bij gstreamer aan het einde installeer de gstreamer en markeer de fout niet meer, zelfs vanaf terminal gebruik sudo pat-get -f install, ik hoop dat dat helpt

  4.   OlimasterX zei

    Muchas gracias!

bool (waar)