Hoe u de User Agent in SRWare Iron kunt wijzigen

Ya we zagen de voordelen van gebruik SRWare Iron in plaats van Chroom / Chroom en zoals ik in dat artikel al zei, verander de User Agent IJzer is heel eenvoudig.

We hoeven alleen maar een terminal als root te openen en met onze favoriete teksteditor een bestand in / Opt / met de naam UA.ini.

$ sudo nano /opt/UA.ini

We voegen dit bestand toe:

Mozilla / 5.0 (X11; Linux i686) AppleWebKit / 535.2 (KHTML, zoals Gecko) Debian Iron / 15.0.900.2 Safari / 535.2

En klaar.


De inhoud van het artikel voldoet aan onze principes van redactionele ethiek. Klik op om een ​​fout te melden hier.

71 reacties, laat de jouwe achter

Laat je reactie achter

Uw e-mailadres wordt niet gepubliceerd. Verplichte velden zijn gemarkeerd met *

*

*

  1. Verantwoordelijk voor de gegevens: Miguel Ángel Gatón
  2. Doel van de gegevens: Controle SPAM, commentaarbeheer.
  3. Legitimatie: uw toestemming
  4. Mededeling van de gegevens: De gegevens worden niet aan derden meegedeeld, behalve op grond van wettelijke verplichting.
  5. Gegevensopslag: database gehost door Occentus Networks (EU)
  6. Rechten: u kunt uw gegevens op elk moment beperken, herstellen en verwijderen.

  1.   Gadi zei

    Ik kan het bevestigen, het werkt.

    1.    Gadi zei

      Ok, in de opmerking verschijnt het logo van de distro niet, maar in de koptekst van de blog wel. Het is trouwens Chakra.

      1.    elav <° Linux zei

        Ik weet niet waarom dat logo eruit komt hahaha. Ik had het in mijn leven gezien. Misschien komt het origineel eruit als u ijzer vervangt door SRWare-ijzer 😀

  2.   Gadi zei

    Laten we het opnieuw proberen. Ik heb hierboven in een andere opmerking van mij gekeken, zonder deze wijziging, en ja, het juiste is om SRWare Iron. Mijn lijn is:

    Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Chakra SRWare Iron/15.0.900.2 Safari/535.2

    Wat er gebeurt, is dat het Chakra-logo niet in de commentaren verschijnt. Zoals ik al zei, verschijnt het in de koptekst.

    1.    Moed zei

      Hetzelfde is niet toegevoegd aan het logo van Chakra maar de browser werkt tenminste perfect

    2.    KZKG ^ Gaara <"Linux zei

      Dat is de schuld van de commentaar-plug-in, die nog geen Chakra-ondersteuning heeft 🙁
      Ik beloof dat ik de plug-in zal aanpassen als ik de kans heb, dus ik voeg ondersteuning toe voor Chakra, Pardus, Tuquito en een andere distro 🙂

    3.    Erithrym zei

      Nou, ik heb die lijn, natuurlijk veranderend Chakra voor LMDE, en het vreemde pictogram blijft verschijnen ...: S

      1.    KZKG ^ Gaara <"Linux zei

        Wat als u "Linux Mint" probeert?

        1.    Erithrym zei

          Als ik Linux Mint zet, geeft het me wat er nu is

        2.    Erithrym zei

          Wat me vreemd lijkt, is dat het me erboven steeds vertelt dat ik LMDE: S heb

          1.    Erithrym zei

            Ok, nu heb je XD al bijgewerkt
            Het zegt me al dat ik Mint heb en ook in de reacties, maar in het browsersymbool blijft dat vreemde pictogram verschijnen

          2.    Moed zei

            Laat me de hele lijn zien

          3.    Erithrym zei

            De complete lijn is Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Linux Mint SRWare Iron/15.0.900.2 Safari/535.2

            1.    KZKG ^ Gaara <"Linux zei

              Ik denk dat het lelijke pictogram gewoon is omdat dat het pictogram is dat de plug-in voor Iron brengt 🙁 ... verdomme, ik moet echt wat tijd besteden aan het aanpassen van de plug-in die ¬¬


          4.    Moed zei

            Zal die Mozilla geen invloed hebben?

          5.    Erithrym zei

            Ik weet het niet, ik heb de code gekopieerd zoals Elav het uitdrukte en ik heb de wijzigingen aangebracht zodat het, zogenaamd, de browser en het besturingssysteem correct zou tonen ... aangezien Iceweasel me het besturingssysteem niet goed laat zien in de commentaren, maar dat komt door de plug-in, waaraan nog geen LMDE is toegevoegd

          6.    Moed zei

            Nou elav om te zien of het gebeurt, want ik denk dat het Mozilla / 5.0 zou kunnen zijn

            1.    elav <° Linux zei

              Het kan zijn dat ik de regel die standaard in Iron kwam, heb gekopieerd en er alleen Debian aan heb toegevoegd. Waar ik Debian plaatste, stond Chrome / 15.xx.xxxx


          7.    Erithrym zei

            Ok, mijn nieuwe regel is de volgende:
            Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) LMDE Chrome/15.0.900.2 Safari/535.2
            Zou het zo goed zijn, elav?

          8.    Erithrym zei

            Ok, nu detecteert het besturingssysteem me niet in de reacties, maar Chrome maakt me een browser ... laten we kijken of ik alleen Iron achterlaat ...

  3.   Gadi zei

    Sorry dat ik de opmerkingen heb verdreven. Nieuwe test.

    1.    Moed zei

      Je hebt het geladen

    2.    Gadi zei

      Niets, de enige manier waarop het juiste browserlogo wordt weergegeven, is zonder de wijziging. Dus maakte ik de opmerking dat Courage antwoordde (ik merkte niet dat opnieuw opstarten).

    3.    KZKG ^ Gaara <"Linux zei

      Niets man, maak je geen zorgen 😉

      1.    elav <° Linux zei

        Geen probleem!!!

  4.   isar zei

    Ik heb een probleem met waar het distro-logo in de koptekst wordt weergegeven. Het laat me zo zien:

    1.    isar zei

      Schotel, de link is nog niet eerder verdwenen Zo

      1.    isar zei

        Fuck, laten we eens kijken of ik de derde keer op xD raakte http://i42.tinypic.com/2lmw175.png

        1.    elav <° Linux zei

          We zijn bezig dat probleem op te lossen 😀

  5.   jhals zei

    Sorry voor de overstroming, maar probeer xD

    1.    jhals zei

      Blijkbaar toont het alleen de Iron only xD, ik zou graag de plug-in-code willen zien om te zien of deze kan worden opgelost of om te zien of ze dit al kunnen oplossen 😀

      1.    isar zei

        Ik denk dat het probleem is dat de Chrome-string niet in de User-Agent verschijnt, als ik het nu goed heb, plaats ik mijn User-Agent

        1.    isar zei

          Oké, voeg Chrome / 15.0.900.2 toe na Iron / 15.0.900.2 en het zou voor jou moeten werken.

  6.   ppsalama zei

    Het volgen van dezelfde instructies werkt voor mij, nietwaar? ... verzenden ...

    1.    ppsalama zei

      Nou nee ... sorry om te proberen commentaar te geven ...

      1.    ppsalama zei

        niets?

  7.   ppsalama zei

    Nou, ik wil niet meer botsen. Ik heb mijn user-agent weer op deze manier aangepast (voordat het alleen Iron plaatste)

    Mozilla / 5.0 (X11; Linux i686) AppleWebKit / 535.2 (KHTML, zoals Gecko) Archlinux SRWare Iron / 15.0.900.2 Safari / 535.2
    als het niet uitkomt ... is er een website waar ik het kan proberen (zonder hier commentaar te hoeven geven)?
    bedankt

  8.   diazepam zei

    Testen

    1.    KZKG ^ Gaara zei

      Overigens isar heeft ook een correctie aangebracht in de herkenning van Iron 😀

      1.    jamin samuël zei

        mijn opdrachtregel is dit:

        Mozilla / 5.0 (X11; Linux i686) AppleWebKit / 535.2 (KHTML, zoals Gecko) Linux Mint SRWare Iron / 15.0.900.2 Safari / 535.2

        1.    jamin samuël zei

          En er gebeurt niets ahahahaha, hier ga ik gek van worden, ik heb de spijker op de kop niet kunnen slaan 😀

  9.   jamin samuël zei

    Bewijzen wat er gebeurt 🙂

    1.    jamin samuël zei

      ahaha nou, er is niets gebeurd, alles is hetzelfde: en de opdrachtregel is deze:

      Mozilla / 5.0 (X11; Linux i686) AppleWebKit / 535.2 (KHTML, zoals Gecko) Debian Iron / 15.0.900.2 Chrome / 15.0.900.2

      Enige suggesties?

  10.   diazepam zei

    Prueba

    1.    diazepam zei

      Test2

      1.    diazepam zei

        3-test

  11.   Wolf zei

    Test1

    1.    Wolf zei

      Test2

  12.   Leper_Ivan zei

    Oké, ik heb het eindelijk ...

    Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.2 (KHTML, zoals Gecko) ArchLinux Iron / 15.0.900.2 Safari / 535.2

    Dat is de UA.ini-lijn voor ArchLinux ..

    1.    Handleiding van de Bron zei

      Volgens UserAgentString.com is het verkeerd, het zou als volgt moeten zijn:

      Mozilla / 5.0 (X11; boog Linux x86_64) AppleWebKit / 535.2 (KHTML, zoals Gecko) Iron / 15.0.900.2 Chrome / 15.0.900.2 Safari / 535.2

      Alleen op die manier staat er dat je "Arch Linux distribution" gebruikt. Maar hij herkent het nog steeds in de commentaren en het logo van de sidebar, dus als je het leuk vindt, blijf bij die.

  13.   Rots87 zei

    probando

  14.   Rayonant zei

    UA testen

    1.    Rayonant zei

      Opnieuw testen

  15.   Helena zei

    toets 1

  16.   Helena zei

    toets 2

    1.    Helena zei

      test 3 * hoe gênant *

  17.   Helena zei

    probeer 4 en ik weet niet waarom het Apple-logo verschijnt: /, ik gebruik arch

    1.    Helena zei

      laten we eens kijken of dit de laatste test is

  18.   charlie_sunday zei

    Prueba

  19.   charlie_sunday zei

    uitstekend het werkte bedankt! 😀

  20.   downloads zei

    Testen 1

  21.   downloads zei

    Testen 2 en 3

  22.   Ferran zei

    -test 1

  23.   Ferran zei

    -test 2

  24.   Ferran zei

    -test 3

  25.   Bosje zei

    Uitstekend

    1.    Bosje zei

      2

      1.    Bosje zei

        3

        1.    Bosje zei

          4

          1.    Bosje zei

            5

  26.   Bosje zei

    6