Laten we Synaptic ontmoeten in LMDE <° Linux

Een van de meest voorkomende vragen bij gebruikers die beginnen met GNU / Linux, is hoe u programma's installeert of verwijdert en wat voor soort pakketten kunnen worden geïnstalleerd. We laten u een van de gemakkelijkste manieren zien om deze taak uit te voeren, met behulp van Synaptic, en we zullen u ook in het kort vertellen wat het is en hoe we het kunnen gebruiken.

Normaal gesproken in Windows, om een ​​programma te installeren een bestand met de extensie .exe en we moeten gewoon de Volgende »Volgende met een of ander serienummer en voor het omgekeerde proces (de-installatie) gaan we naar Configuratiescherm »Programma's toevoegen / verwijderen.

Bij GNU / Linux, er zijn ook wat we onze zouden kunnen noemen .exe maar ze hebben natuurlijk een andere naam en structuur. Meestal zitten de meeste pakketten in GNU / Linux Ze zijn ondergebracht in repositories en er worden verschillende tools gebruikt om ze te beheren. Misschien wel de meest populaire of bekende zijn de . Deb en . Rpm en beide kunnen worden beheerd door Synaptic, die aanvankelijk een interface was voor APT.

Synaptic: interface voor APT

Werk met Synaptic het is erg makkelijk. De interface is niet ingewikkeld en zelden hoeft een nieuwe gebruiker al zijn opties te gebruiken of te wijzigen. Over het algemeen kunnen de meest voorkomende taken worden uitgevoerd.

Synaptic is zoals hij geweest Programma's toevoegen / verwijderen de Windows. Voor de werking ervan moeten we hebben geconfigureerd (in het geval van Debian en zijn afgeleiden) de paden naar de repositories waar de te installeren pakketten zich in het bestand bevinden / Etc / apt / sources.list. Uit dat bestand, Synaptic krijgt het pad dat nodig is om toegang te krijgen tot de pakketten.

De interface kennen.

Het is goed om toe te voegen dat de interface van Synaptic en linuxmint, is verschillend van Debian. Om de een of andere reden in linuxmintknop niet inbegrepen Controleer alle updates. Maar laten we teruggaan naar de interface.

Bovenaan hebben we de Menubalk waarvan we later enkele opties zullen zien. Iets verderop de volgende knoppen:

  • Herladen: Werk de pakketlijst bij.
  • Van toepassing zijn: Wanneer we een pakket markeren om te installeren of verwijderen, gebruiken we deze knop om de wijziging toe te passen.
  • propiedades: Het toont de kenmerken van het pakket, de beschrijving en afhankelijkheden.
  • Zoeken: Het toont een dialoogvenster met verschillende opties om te zoeken naar pakketten volgens bepaalde parameters.

Snelle toegangsknoppen

Hieronder hebben we de interface verdeeld in twee kolommen. Aan de linkerkant staan ​​de opties volgens de sectie die we selecteren. Roep het knoppengedeelte op: Secties, status, herkomst, filters en zoekresultaten.

  • Secties: Toont pakketten geordend op categorieën. Als we willen zoeken naar een pakket gerelateerd aan het Gnome Desktop-omgevingwe hoeven bijvoorbeeld alleen maar naar de sectie te gaan Kabouter.
  • Status: In dit gedeelte zullen we zien welke pakketten kunnen worden opgewaardeerd, verouderd, geïnstalleerd of overgebleven.
  • herkomst: Toont de oorsprong (repositories) van de pakketten. Met andere woorden, waar ze vandaan komen.
  • filters: In dit gedeelte kunt u bepaalde filters toepassen om verschillende soorten informatie te verkrijgen. Het is belangrijk om te weten dat de kapotte pakketten hier verschijnen.
  • Zoekresultaten: Wat het precies doet, is zoals de naam aangeeft, het toont zoekresultaten in Synaptic.

Synaptische secties

Aan de andere kant hebben we de lijst met pakketten die we via Synaptic kunnen installeren. Als we een van deze selecteren en met de rechtermuisknop klikken, kunnen we bepaalde opties kiezen, zoals:

  • Vink uit: Schakel het pakket uit als we het eerder hebben geselecteerd.
  • Controleer om te installeren: Controleer het pakket dat u wilt installeren.
  • Markeren om opnieuw te installeren: Selecteer het pakket en installeer het opnieuw.
  • Markeer om te updaten: Als het pakket een update heeft, selecteren we deze met deze optie.
  • Markeer om te verwijderen: Verwijder alleen het geselecteerde pakket.
  • Controleer om volledig te verwijderen: Verwijder het geselecteerde pakket met de aanbevolen afhankelijkheden. De voorgestelde afhankelijkheden gaan naar de resterende configuratie.
  • eigenschappen: Doet hetzelfde als de knop bovenaan.
  • Markering aanbevolen voor installatie: Selecteer de aanbevolen afhankelijkheden van het te installeren pakket.
  • Markeer aanbevolen voor installatie: Selecteer de voorgestelde afhankelijkheden van het pakket dat u wilt installeren.

Lijst met beschikbare pakketten

Andere opties.

Dit wetende kunnen we al werken Synaptic, maar we kunnen andere dingen doen, zoals bijvoorbeeld de bronnen van de repositories wijzigen. Iets nuttigs als de spiegels die we gebruiken traag of traag zijn. Hiervoor zullen we Configuratie »Repository.

In het optievenster dat we krijgen, hoeven we maar 3 tabbladen te kennen om onze repositories te kunnen beheren. In de eerste krijgen we de takken die we gebruiken linuxmint (Main, Upstream, Import, Backport en Romeo). Door het bestand alleen aan / uit te vinken, wordt het bestand bewerkt / Etc / apt / sources.list.

Oorsprong van de software

Op het tweede tabblad nemen we de repositories op die dat niet zijn Mint, dat is de Pakketten van derden als Debian, PPA de Ubuntu of elke bron die compatibel is met LMDE.

Derde partij software

En op het derde tabblad kunnen we de automatische updates activeren en elke keer dat we willen dat ze worden uitgevoerd.

Automatische updates

Nog meer?

Als je het nodig hebt, Synaptic moet ook de Netwerkproxy en Distributie die we standaard willen gebruiken. Hiervoor zullen we Instellingen »Voorkeuren.

Om een ​​beetje uit te leggen over de Distributie, als we naar het bestand kijken / Etc / apt / sources.list, we kunnen twee lay-outs gebruiken (let op de gekleurde tekst):

deb http://packages.linuxmint.com/ debian belangrijkste upstream-import
deb http://ftp.debian.org/debian het testen van hoofdbijdrage niet gratis
deb http://security.debian.org/ het testen van/ updates hoofdbijdrage niet gratis
deb http://www.debian-multimedia.org het testen van belangrijkste niet-gratis

Standaard, Synaptic neemt altijd de hoogste distributie, wat betekent dat als het pakket binnenkomt pidgin 2.8 in de repo's van Munt (debian) en versie 2.9 in Debian (het testen van), zal het programma voorstellen om versie 2.9 te installeren.

Dit kan natuurlijk worden gewijzigd als we handmatig de distributie kiezen die we willen gebruiken met behulp van de optie: Geef de voorkeur aan versies van:

Kies voor distributie
En als we een proxy gebruiken om verbinding te maken via http, hebben we ook de mogelijkheid om deze handmatig in te stellen:

Netwerkproxy

Er zijn andere tools om onze pakketten te beheren, bij te werken en te installeren. Ubuntu omvat nu bijvoorbeeld uw Software CenterEn LMDE heeft een zeer vergelijkbare, maar op een bepaalde manier Synaptic Het is completer.


De inhoud van het artikel voldoet aan onze principes van redactionele ethiek. Klik op om een ​​fout te melden hier.

2 reacties, laat de jouwe achter

Laat je reactie achter

Uw e-mailadres wordt niet gepubliceerd.

*

*

  1. Verantwoordelijk voor de gegevens: Miguel Ángel Gatón
  2. Doel van de gegevens: Controle SPAM, commentaarbeheer.
  3. Legitimatie: uw toestemming
  4. Mededeling van de gegevens: De gegevens worden niet aan derden meegedeeld, behalve op grond van wettelijke verplichting.
  5. Gegevensopslag: database gehost door Occentus Networks (EU)
  6. Rechten: u kunt uw gegevens op elk moment beperken, herstellen en verwijderen.

  1.   Jonathan zei

    Heel erg bedankt, de waarheid is dat ik net met linux begin en deze tool is van vitaal belang. Het is goed haar beter te leren kennen

  2.   Wis zei

    Ik moet weten hoe ik kan voorkomen dat Linux mint 17 Quiana probeert de repo vanaf de officiële site bij te werken
    En opgenomen in mijn sources.list een nieuw update-adres dat al is getest in Ubuntu 14.04 en compatibel is met Mint, maar wanneer (apt-get update) het volgende wordt getoond:

    Dwalen http://ubuntu.mes.edu.cu betrouwbaar voorgestelde InRelease

    Dwalen http://packages.linuxmint.com qiana InRelease

    Dwalen http://archive.ubuntu.com betrouwbare InRelease

    Dwalen http://archive.ubuntu.com betrouwbare updates van InRelease

    Dwalen http://security.ubuntu.com betrouwbare beveiliging InRelease

    Dwalen http://ubuntu.mes.edu.cu betrouwbare beveiliging InRelease

    Dwalen http://ubuntu.mes.edu.cu betrouwbare updates van InRelease

    Dwalen http://ubuntu.mes.edu.cu betrouwbare InRelease

    Dwalen http://archive.ubuntu.com betrouwbare Release.gpg
    Kan "archive.ubuntu.com" niet oplossen
    Dwalen http://security.ubuntu.com trusty-security Release.gpg
    Kan "security.ubuntu.com" niet oplossen
    Dwalen http://ubuntu.mes.edu.cu betrouwbare voorgestelde release.gpg
    Kan "ubuntu.mes.edu.cu" niet oplossen
    Dwalen http://packages.linuxmint.com qiana Release.gpg
    Kan "packages.linuxmint.com" niet oplossen
    Dwalen http://ubuntu.mes.edu.cu trusty-security Release.gpg
    Kan "ubuntu.mes.edu.cu" niet oplossen
    Dwalen http://ubuntu.mes.edu.cu betrouwbare updates Release.gpg
    Kan "ubuntu.mes.edu.cu" niet oplossen
    Dwalen http://archive.ubuntu.com betrouwbare updates Release.gpg
    Kan "archive.ubuntu.com" niet oplossen
    Dwalen http://ubuntu.mes.edu.cu betrouwbare Release.gpg
    Kan "ubuntu.mes.edu.cu" niet oplossen
    Dwalen http://extra.linuxmint.com qiana InRelease

    Dwalen http://extra.linuxmint.com qiana Release.gpg
    Kan "extra.linuxmint.com" niet oplossen
    Dwalen http://archive.canonical.com betrouwbare InRelease

    Dwalen http://archive.canonical.com betrouwbare Release.gpg
    Kan "archive.canonical.com" niet oplossen
    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/InRelease

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/InRelease

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/InRelease

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/InRelease

    W: Kan niet krijgen http://packages.linuxmint.com/dists/qiana/InRelease

    W: Kan niet krijgen http://extra.linuxmint.com/dists/qiana/InRelease

    W: Kan niet krijgen http://archive.ubuntu.com/ubuntu/dists/trusty/InRelease

    W: Kan niet krijgen http://archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease

    W: Kan niet krijgen http://security.ubuntu.com/ubuntu/dists/trusty-security/InRelease

    W: Kan niet krijgen http://archive.canonical.com/ubuntu/dists/trusty/InRelease

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/Release.gpg Kan "ubuntu.mes.edu.cu" niet oplossen

    W: Kan niet krijgen http://packages.linuxmint.com/dists/qiana/Release.gpg Kan "packages.linuxmint.com" niet oplossen

    W: Kan niet krijgen http://archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg Kan "archive.ubuntu.com" niet oplossen

    W: Kan niet krijgen http://archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg Kan "archive.ubuntu.com" niet oplossen

    W: Kan niet krijgen http://security.ubuntu.com/ubuntu/dists/trusty-security/Release.gpg Kan "security.ubuntu.com" niet oplossen

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/Release.gpg Kan "ubuntu.mes.edu.cu" niet oplossen

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/Release.gpg Kan "ubuntu.mes.edu.cu" niet oplossen

    W: Kan niet krijgen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/Release.gpg Kan "ubuntu.mes.edu.cu" niet oplossen

    W: Kan niet krijgen http://extra.linuxmint.com/dists/qiana/Release.gpg Kan "extra.linuxmint.com" niet oplossen

    W: Kan niet krijgen http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg Kan "archive.canonical.com" niet oplossen

    W: Sommige indexbestanden kunnen niet worden gedownload. Ze zijn genegeerd of in plaats daarvan zijn oude gebruikt.
    E: Kon / var / lib / dpkg / lock - open niet vergrendelen (11: bron tijdelijk niet beschikbaar)
    E: Kon de admin-directory (/ var / lib / dpkg /) niet vergrendelen, misschien is er een ander proces dat het gebruikt?

    *************** Hoe dit probleem oplossen? **************************
    Ik smeek je me alsjeblieft te helpen

bool (waar)