Linux 3.1-kjernen, nå med bedre støtte for AMD, Intel og Nvidia GPUer

Linus Torvalds annonse tilgjengeligheten av Linux 3.1 (Jeg mener logisk sagt kjernen), og dette har som sitt sterke punkt at støtten til AMD, Intel og Nvidia GPUer ble forbedret, så vel som for OpenRISC-arkitektur (når jeg sier AMD refererer vi åpenbart til Ati).

Men ikke bare dette, denne versjonen har også støtte for Nintendo Wii, så du vet ... hva du enn vil våge og installere Linux på Wii, kan du 🙂

I sin uttalelse nevner han at basene for Linux v3.2 allerede er etablert, siden de ulike versjonene (3.1, 2.3, 2.7, osv.) Vanligvis er utviklingsversjoner, det vil si versjoner som skal brukes til neste versjon ( med partall) har forbedret det nye som ble lagt til i odd-versjonen.

Men hehe, dette vil ikke gjøre distros ser skremt ut og ikke inkluderer denne versjonen (3.1) for å få stabilitet, og dermed vente til versjon 3.2, faktisk ... Jeg vil satse på at i morgen i ArchLinux har jeg den allerede tilgjengelig, spørsmål om en "pacman -Syu"og klar, Linux Kernel v3.1 installert ????

Muligens Fedora 16, som skal utgis neste måned inkluderer denne versjonen av kjernen, men hei ... hver distro har sine særegenheter, det er det som er bra med denne verdenen 😀

Uansett, vent på oppdateringer 😉


Innholdet i artikkelen følger våre prinsipper for redaksjonell etikk. Klikk på for å rapportere en feil her.

32 kommentarer, legg igjen dine

Legg igjen kommentaren

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Kontroller SPAM, kommentaradministrasjon.
  3. Legitimering: Ditt samtykke
  4. Kommunikasjon av dataene: Dataene vil ikke bli kommunisert til tredjeparter bortsett fra ved juridisk forpliktelse.
  5. Datalagring: Database vert for Occentus Networks (EU)
  6. Rettigheter: Når som helst kan du begrense, gjenopprette og slette informasjonen din.

  1.   Courage sa

    Du gir Elav flammenes ønske haha.

    Wii synes jeg er interessant, selv om jeg ikke er en spiller

    1.    KZKG ^ Gaara <° Linux sa

      Nei HAHA, det handler ikke om å starte et flammekrig langt fra det, han kan godt si noe sånt som «Ja, du vil ha den nyeste versjonen av kjernen, men du kan ha X-problem«, Eller noe sånt hehe.

      1.    Courage sa

        har forbedret det nye som ble lagt til i jevn versjon.

        Er du sikker på at det ikke er den rare?

        1.    KZKG ^ Gaara <° Linux sa

          HEY klar, korrigerte dette og en skrivefeil som jeg hadde 😉

  2.   fer sa

    Vil du fikse problemer med nvidias "optimus" -teknologi?

    1.    KZKG ^ Gaara <° Linux sa

      Beklager, jeg vet ikke dette ... generelt når de sier "støtteforbedring", betyr de oppdateringer de lager i drivere, faste feil, kanskje ytelsesforbedringer, men jeg vet ikke ... du bør prøve det og se om de nåværende problemene dine er løst.
      Jeg beklager at jeg ikke kan hjelpe deg mer.

  3.   De er Link sa

    La oss se hvordan de nye forbedringene for NVIDIA.
    Når det gjelder Wii, hvis den hadde en, ville den installere Arch med LXDE.
    Når det gjelder pacman -Syu trenger jeg ikke det, det er derfor jeg har min [spam] pacsyu [/ spam]: 3

    1.    KZKG ^ Gaara <° Linux sa

      Først av alt, VELKOMMEN til vår side 😀
      Et alias ikke sant? haha, jeg pleide å bruke pacmansearch til pacman -Ssen oppgradering til pacman -SyuJeg har allerede skrevet alt uten aliaser, jeg vet ikke ... latskap å konfigurere dem HAHA.

      Hilsen

      1.    Courage sa

        Med 21 år lat? Jævla, vi må se deg noen år eldre haha.

        Alias-tingen virker litt korra for meg

      2.    De er Link sa

        Hvilke aliaser eller hvilken melk?
        For å unngå å bli beskyldt for nettsøppel, sjekk forumet til Arch Hispanic Community eller AUR

  4.   pepe sa

    La oss se om jeg med denne versjonen allerede kan laste, at jeg må starte med 2.6

    1.    KZKG ^ Gaara <° Linux sa

      Siden 2.6? Faen !!! Jeg håper du er heldig i dette ...

      Velkommen til bloggen forresten 😉

  5.   pepe sa

    takk, du gjør en god jobb.

    Vel, det er den som fulgte med den siste utgivelsen av lmde, kjerneoppdateringspakke 3, mislykkes.

    1.    KZKG ^ Gaara <° Linux sa

      Takk, du gjør det du kan 🙂
      Jeg er ikke den mest erfarne eller kunnskapsrike om LMDE, men jeg tror ... Jeg tror de allerede har kernel 3.0 i repoer.

      1.    pepe sa

        Og den starter ikke opp 😀

    2.    elav <° Linux sa

      Hvilke arkiver brukte du for å oppdatere den siste utgaven av LMDE? Fordi det fungerte for meg uten problemer med LMDE repos og med dem fra Debian Testing.

      1.    pepe sa

        Disse de.
        Kjernen har en viss inkompatibilitet med sandbroene, jeg trekker frem det fra det øyeblikket den henger.

        I det minste, ved å bruke den forrige, fungerer det for meg, at suspendering / dvalemodus er ikke mulig og mer av det samme for å konfigurere berøringsplaten

  6.   Eduar2 sa

    Han er beskjeden og ønsket ikke å spam, fordi han er skaperen av applikasjonen som snakker, eller i det minste har lignende kallenavn.

    Jeg har ikke noe imot spamming, irriterende eller trolling.

    http://www.archlinux-es.org/foros/viewtopic.php?f=9&t=4617

    1.    KZKG ^ Gaara <° Linux sa

      Ah, unnskyldningene mine da, er at jeg ikke kjente denne applikasjonen ^ _ ^ U

  7.   Eduar2 sa

    Forresten, Son Link, hvordan går prosjektet? Rapporter for å se, selv om jeg forteller deg at en Pacman -Syy og -Su eller -Syu ikke gidder for nah, men det ser interessant ut.

    1.    De er Link sa

      Det er ikke likt, DET ER DET JEG ER.
      Prosjektet går som det står i forumet, selv om jeg i disse dager har lagt det til side for andre forhold.
      I bloggen min (klikk på kallenavnet) er det også all info. Hvis jeg er beskjeden, er jeg ikke en av dem som er dedikert til å bruke kommentarene til en blogg for å spamme XD

      1.    KZKG ^ Gaara <° Linux sa

        Venn ingen har sagt at du gjør spam langt fra det 😉
        av Eduar2 y Courage ikke bekymre deg ... ikke ta mye hensyn til dem, de er offisielt trollene til nettstedet vårt HAHAHA, så ikke vær oppmerksom på dem, ok 😀

        Uansett, en virkelig glede å ha deg her, vi vil prøve å legge inn artikler som er interessante for deg, fordi hver leser teller og det er viktig for oss 😉

        Hilsen og vi leser.

  8.   Eduar2 sa

    Forresten, gode nyheter om støtten, men å sette noen utgivelsesmerknader ville ha vært bra, denne grusomme, den mister kontakten.

    1.    KZKG ^ Gaara <° Linux sa

      Wow, du har rett ... Jeg glemte å forklare tekniske detaljer som de aller fleste ikke ville forstå ... nei, jeg burde ha satt lenken til en vekslelogg, her lar jeg den være: http://kernelnewbies.org/Linux_3.1 Jeg antar at du kan engelsk, ellers vil dette nettstedet hjelpe deg mye: http://translate.google.com/
      ????

      HAHA seriøst, du vet ikke hvor mye, eller den fjerneste ideen du har om hvor mye erfaring jeg har med troll, varmeovner, brukere osv. Etc hehe.

      1.    Courage sa

        Jeg tror Google-oversetteren villeder mer:

        http://www.guitarristas.info/foros/james-hetfield-nueva-signature-set-emg/150570#post1046206

        Haha som McAnimes moderator haha, det skremmer deg ikke så noen kan håndtere troll

        1.    KZKG ^ Gaara <° Linux sa

          HEH jepp, tenk deg å være moderator på MCAnime, men av alle de anime-relaterte forumene, aner du hvor mange troll og varmeovner jeg måtte tåle? LOL !!!

          Jeg gjorde en mastergrad med dette emnet 😀

  9.   Eduar2 sa

    Vel, det mest interessante er disse to små tingene cpupowerutils og OpenRISC, men jeg antar at det fortsatt er noe som tullinger ikke ville forstå, du har rett i de tekniske detaljene 😀

    Forresten bruk http://translate.google.com/ (Vel, hvis du kan engelsk, ikke bruk den) og se på denne anmeldelsen som er godt utført som de sier 😀 https://www.linux.com/learn/tutorials/498187-a-look-at-linux-31

  10.   Tretten sa

    Fra min personlige erfaring, når det gjelder grafikkort (og Wi-Fi, forresten), på Linux, virker Intel for meg å være den som har kjørt best på Linux (på forskjellige distroer og uten innstillinger etter installasjonen). Og årsaken er åpenbar: stasjoner har vært gratis i årevis.

    Men det er hyggelig å vite at Nvidia-støtten stadig blir bedre (det samme gjør Ati).

    Og jeg presiserer på forhånd, jeg sier ikke at Intel-grafikkbrikkene er bedre, bare at de i Linux går bedre fra en ren installasjon i flere distroer som jeg har testet.

    Hilsener.

    1.    KZKG ^ Gaara <° Linux sa

      Min bærbare datamaskin er Intel-grafikk, den er en 945, så den har 128 MB innebygd video, og jeg ... gjentar aldri, jeg har aldri hatt et eneste problem, og jeg har brukt GNU / Linux siden da på Ubuntu 7.10 eller kanskje før. Jeg har prøvd flere distroer, og for øyeblikket har grafen aldri sviktet meg langt fra det.

      Imidlertid har jeg hjemme en datamaskin med Ati Radeon 9250 og uff ... umulig å få den til å fungere ganske bra, ikke engang å installere proprietære drivere.

      Men ikke det, det er at Nvidia fungerer bra, jeg har installert Linux på to venners PC-er og de har Nvidia-grafikk, det er fantastisk hvor godt de fungerer, bare å installere driverne fra depotet.

      Uansett, at Ati (AMD) burde jobbe hardere for å forbedre kompatibiliteten, ikke sant?

      1.    Tretten sa

        Dette er akkurat det jeg mener, og dermed fordelene at kontrollerne kan være gratis.

        Hilsener.

  11.   Gammel venn sa

    Loading Linux 3.1.5
    error: invalid magic number
    Loading initial ramdisk ...
    error: you need to load the kernel first.

    Press any key to continue ...

    make[1]: se ingresa al directorio `/usr/src/zaptel-1.4.12.1'
    make -C /lib/modules/2.6.32-5-486/build ARCH=i386 SUBDIRS=/usr/src/zaptel-1.4.12.1/kernel HOTPLUG_FIRMWARE=yes KBUILD_OBJ_M="pciradio.o tor2.o torisa.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o wcusb.o zaptel.o ztd-eth.o ztd-loc.o ztdummy.o ztdynamic.o zttranscode.o wct4xxp/ wctc4xxp/ xpp/ wctdm24xxp/ wcte12xp/" modules
    make[2]: se ingresa al directorio `/usr/src/linux-headers-2.6.32-5-486'
    CC [M] /usr/src/zaptel-1.4.12.1/kernel/pciradio.o
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c: In function ‘pciradio_start_dma’:
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: implicit declaration of function ‘set_current_state’
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: ‘TASK_INTERRUPTIBLE’ undeclared (first use in this function)
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: (Each undeclared identifier is reported only once
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: for each function it appears in.)
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1702: error: implicit declaration of function ‘schedule_timeout’
    make[5]: *** [/usr/src/zaptel-1.4.12.1/kernel/pciradio.o] Error 1
    make[4]: *** [_module_/usr/src/zaptel-1.4.12.1/kernel] Error 2
    make[3]: *** [sub-make] Error 2
    make[2]: *** [all] Error 2
    make[2]: se sale del directorio `/usr/src/linux-headers-2.6.32-5-486'
    make[1]: *** [modules] Error 2
    make[1]: se sale del directorio `/usr/src/zaptel-1.4.12.1'
    make: *** [all] Error 2

    grub.cfg

    if [ -s $prefix/grubenv ]; then
    load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
    set saved_entry="${prev_saved_entry}"
    save_env saved_entry
    set prev_saved_entry=
    save_env prev_saved_entry
    set boot_once=true
    fi

    function savedefault {
    if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
    fi
    }

    function load_video {
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
    }

    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3878592c-fd5d-44d2-8cdb-577de20dbf6b
    if loadfont /usr/share/grub/unicode.pf2 ; then
    set gfxmode=640x480
    load_video
    insmod gfxterm
    fi
    terminal_output gfxterm
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3878592c-fd5d-44d2-8cdb-577de20dbf6b
    set locale_dir=($root)/boot/grub/locale
    set lang=es
    insmod gettext
    set timeout=5
    ### END /etc/grub.d/00_header ###

    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=cyan/blue
    set menu_color_highlight=white/blue
    ### END /etc/grub.d/05_debian_theme ###

    ### BEGIN /etc/grub.d/10_linux ###
    menuentry 'Debian GNU/Linux, with Linux 3.1.5' --class debian --class gnu-linux --class gnu --class os {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3878592c-fd5d-44d2-8cdb-577de20dbf6b
    echo 'Loading Linux 3.1.5 ...'
    linux /boot/vmlinux-3.1.5 root=UUID=3878592c-fd5d-44d2-8cdb-577de20dbf6b ro quiet
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-3.1.5
    }

    00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
    00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
    00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
    00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
    00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
    00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
    00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
    01:00.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface
    01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

    1.    KZKG ^ Gaara <"Linux sa

      Hei og velkommen,
      Hvilken distro bruker du? ... Hvordan installerte du den versjonen 3.1.5?
      Vel, jeg (som bruker Arch) har bare 3.1.3 tilgjengelig.

      Hilsen