Hvordan installere AceStream på Linux og ikke prøve

De av oss som elsker sport og ikke har tilgang til alle nåværende sportskanaler, står generelt overfor problemet med at vi må bruke forskjellige sider som overfører for å kunne glede oss over det online kamper, de fleste av dem ber om installer AceStream, som har en tendens til å være litt komplisert å installere på Linux.

I denne guiden vil vi lære hvordan installer AceStream på Linux uten å dø i forsøket, gi løsninger på de vanligste problemene i dag. Dens bruk og innholdet du får tilgang til er ditt totale ansvar.

Hva er AceStream?

AceStream er en multimedieplattform ganske nyskapende, som har tatt reproduksjonen av audiovisuelle bilder på Internett til et høyere nivå. For å gjøre dette har den implementert en universell manager for lasting av multimediafiler, som bruker de mest avanserte P2P-teknologiene, noe som garanterer en effektiv datalagrings- og overføringsprosess.

Ace Stream-programvaren gir oss en rekke fordeler der vi kan fremheve:

  • Mulighet for visning av online sendinger (TV, tilpassede strømmer, filmer, tegneserier osv.), Med høy lyd- og bildekvalitet.
  • Lytt til musikk online i et format som ikke mister noen kvalitet.
  • Se torrenter online, uten å måtte vente på at den skal lastes ned helt.
  • Vis innhold på eksterne enheter (Apple TV, Chromecast osv.) Via kommunikasjonsprotokoller som AirPlay, Google Cast og andre.
  • Tillater integrering med forskjellige applikasjoner. Installer AceStream på Linux

Slik installerer du AceStream på Linux

For å installere AceStream på Linux må vi følge forskjellige trinn avhengig av distro du bruker, vi vil fokusere på Arch Linux og Ubuntu, men vi håper i fremtiden å kunne installere det på andre distroer.

Installer AceStream på Arch Linux og derivater

Hovedårsaken til at jeg har laget denne artikkelen er fordi mange har hatt problemer med å installere AceStream på Arch Linux, Antergos, Manjaros og derivater. Hovedårsaken er at pkgbuild av plugin acestream-mozilla-plugin Det gir en feil når du installerer, løsningen er ekstremt enkel.

Vi skal installere acestream-mozilla-plugin som også vil installere oss acestream-motor y acestream-player-data hva er pakkene som trengs for å reprodusere AceStream fra Firefox.

Først og fremst må vi åpne en terminal og utføre følgende kommando:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Det løser bekreftelsesproblemet som forhindrer installering av avhengigheten som er nødvendig for å installere acestream-mozilla-plugin.

Deretter utfører vi følgende kommando

yaourt -S acestream-mozilla-plugin

Ved gjentatte anledninger vil vi bli spurt om vi vil installere forskjellige avhengigheter, vi må si ja til alle.

Installer AceStream på Ubuntu og derivater

Installer AceStream på Ubuntu 14.04 og derivater

For brukere av Ubuntu og derivater opp til versjon 14.04, vil installasjonen av AceStream være ganske enkel, de trenger bare å utføre følgende kommandoer fra terminalen:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Installer AceStream på Ubuntu 16.04 og derivater

De som må slite litt mer er brukerne av Ubuntu 16.04 og derivater siden acestream ikke har støtte for denne versjonen, men takket være dette artikkelen, Jeg klarte å installere den.

Det første vi skal gjøre er å laste ned og installere noen avhengigheter som du ikke vil kunne laste ned fra de offisielle arkivene. Sørg for å installere de riktige for distroarkitekturen din:

64-biters arkitektur:

  1. Last ned og installer libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb du kan gjøre det fra følgende lenke: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Last ned og installer i den rekkefølgen følgende avhengigheter presenteres:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Du kan laste ned hver enkelt fra følgende lenke: https://drive.google.com/folderview?id= … e_web#list

32-biters arkitektur:

  1. Last ned og installer libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb du kan gjøre det fra følgende lenke: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Last ned og installer i den rekkefølgen følgende avhengigheter presenteres: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Du kan laste ned hver enkelt fra følgende lenke: https://drive.google.com/folderview?id= … e_web#list

Så må vi fortsette med den vanlige installasjonen av AceStream som vi gjorde for versjon 14.04, åpne en terminal og kjøre:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

I noen tilfeller er det nødvendig å starte tjenesten acestream-engine.service, for dette utfører vi følgende kommandoer fra terminalen:

systemctl start acestream-engine.service systemctl aktiver acestream-engine.service

Med denne opplæringen håper vi at du kan nyte denne flotte multimediaoverføringsprotokollen som bruker all kapasiteten til P2P-teknologi.


Innholdet i artikkelen følger våre prinsipper for redaksjonell etikk. Klikk på for å rapportere en feil her.

41 kommentarer, legg igjen dine

Legg igjen kommentaren

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Kontroller SPAM, kommentaradministrasjon.
  3. Legitimering: Ditt samtykke
  4. Kommunikasjon av dataene: Dataene vil ikke bli kommunisert til tredjeparter bortsett fra ved juridisk forpliktelse.
  5. Datalagring: Database vert for Occentus Networks (EU)
  6. Rettigheter: Når som helst kan du begrense, gjenopprette og slette informasjonen din.

  1.   Julio Cesar Campos sa

    Vel innlegget, men i det minste i archlinux, og dette var mitt tilfelle du trenger: "systemctl start acestream-engine.service" og "systemctl enable acestream-engine.service" for at det skal fungere.

    1.    øgle sa

      Testet du det fra Firefox, eller brukte du en annen nettleser?

  2.   UserDebian sa

    Er det noen som vet hvordan de skal få det til å fungere på Debian 9?

  3.   Julio Cesar Campos sa

    Firefox på archlinux

  4.   gecoxx sa

    Jeg vet ikke om den forrige kommentaren min ble publisert ... Jeg gjentar! Det tar jeg vet ikke hvor mange timer å utføre den jævla kommandoen i terminalen, og at jeg legger –nokonfirm, og til slutt fungerer det ikke !!
    et annet innlegg som er ubrukelig!

    installasjonsforsøk på Manjaro

    1.    øgle sa

      Kjære at det ikke fungerte for deg, det fungerte perfekt for meg, uansett prøv å utføre disse to kommandoene:
      "Systemctl start acestream-engine.service" og "systemctl aktiver acestream-engine.service"

  5.   José sa

    god

    Jeg klarte å gjøre alle trinnene uten problemer. Men da jeg prøvde å starte tjenesten fra terminalen, ga det meg to feil;
    systemctl starter acestream-engine.service
    Kunne ikke starte acestream-engine.service: Unit acestream-engine.service ikke funnet.
    systemctl aktiver acestream-engine.service
    Kunne ikke utføre operasjonen: Ingen slik fil eller katalog

    1.    Gustavo sa

      Nøyaktig det samme skjedde med meg. terminalen spretter disse kommandoene til meg med disse feilene.

  6.   Juan M. sa

    Tusen takk for innlegget! Hvis du bruker Ubuntu 16.10 64 bits, vil du ikke kunne installere "acestream-player-data_3.0.2-1.1_amd64.deb". De må først laste ned og installere disse pakkene:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Sannsynligvis er det behov for annen avhengighet som er i repos.
    Greetings!

  7.   Miles sa

    Bra.
    Acestream-mozilla-plugin har sluttet å fungere i Firefox 52, som mange andre NPAPI-plugins.

  8.   darco sa

    Et annet veldig bra og enkelt alternativ er å bruke docker og bli agnostiker for operativsystemet ditt. Ved hjelp av aceproxy kan du reprodusere det-

    Jeg har skrevet en liten veiledning og et manus, for å lette gjennomføringen.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   David Martin sa

    Når du sier at du laster ned og installerer disse filene, hvordan installerer du dem når det gjelder å installere den fra Ubuntu 16.04? Når jeg laster ned og trekker dem ut, er noen bare en libreoffice-fil og andre, jeg vet ikke hvordan jeg skal "installere" dem.
    Takk på forhånd og hilsener.
    David.

  10.   vafe sa

    Enten fungerer ikke tastene igjen, eller så er det noen feil i pakkene, men i arch og manjaro er det umulig å installere den.
    Når du prøver å installere en avhengighet (qwebquit) eller noe sånt, går det i en løkke og det er ingen måte.
    Har noen funnet løsningen?
    Takk

    1.    Alexander sa

      Hei, for installasjonen i arch linux må du gjøre følgende:
      -Installer pakken 'acestream-launcher' fra yaourt med 'yaourt -S acestream-launcher' (pakken som vi skal aktivere nedenfor blir automatisk lastet ned til deg)
      - Aktiver acestream-engine.service, vi går inn i terminalen og i ROOT-modus setter vi følgende
      -systemctl starte acestream-engine.service
      -systemctl aktiver acestream-engine.service
      Jeg startet datamaskinen på nytt etter dette, jeg vet ikke om det vil være nødvendig, men bare i tilfelle
      -Dette burde være nok, men i de siste Arch-oppdateringene har de skrudd opp noe og det fungerer ikke, så de har sett etter en midlertidig løsning, som er å laste ned en fil, det er følgende:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      Fuente: https://aur.archlinux.org/packages/acestream-launcher/ (på kommentarene)
      en gang lastet ned går vi til terminalen og går til mappen der vi har lastet den ned,
      Vi fortsetter å installere den med 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz' og det er det, det skal gå, første gang det går aldri, så jeg klikker en gang til, første gang gir alltid feil, det er alt

      PS: presiser at sudo pacman -U og ikke -S fordi det er en lokal pakke hentet fra makepkg

      1.    vafe sa

        Tusen takk for interessen din.
        Jeg har prøvd det så mange ganger at jeg allerede kjenner avhengighetene og kommentarene til pakkene utenat når jeg installerer med yaourt. Jeg kommer til å følge rådene dine med bæreraketten og se om jeg er heldig. Jeg vil fortelle deg.
        Jeg gjentar takk

        felipe

        1.    vafe sa

          På en eller annen måte fungerer det ikke. Jeg har prøvd med lenken du la inn i kommentarene, men den løser den ikke, den gjenkjenner lenken, den gir meg muligheten til å velge programmet, jeg velger acestream-launcher men VLC åpnes ikke.
          I konsollen gir det meg følgende svar.

          Fil «/usr/lib/python3.6/site-packages/psutil/init.py », linje 1231, i _send_signal
          os.kill (self.pid, sig)

          Vi må vente på nye oppdateringer.
          Takk for hjelpen.

  11.   vafe sa

    Etter den nye oppdateringen er svaret i konsollen følgende.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Acestream-motoren går.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | feil under oppstart
    Sporing (siste samtale sist):
    Fil «core.c», linje 1590, inn
    Fil «core.c», linje 144, inn
    Fil «core.c», linje 2, inn
    ImportError: kan ikke importere navnet __m2crypto
    Feil ved autentisering til Acestream!
    Media Player kjører ikke ...

    Vi forbedrer oss, nå anerkjenner den acestream, men libcrypto fortsetter å kjempe.

    1.    vafe sa

      Jeg har prøvd å installere pakken du anbefaler i lenken du sendte meg.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      Og det løser effektivt problemet, vlc åpner og Acestream fungerer.
      Tusen takk for hjelpen-

      1.    Alexander sa

        Hei, beklager forsinkelsen, det var veldig rart at det ikke fungerte for deg da det gjorde, jeg er i Arch plasma, jeg er glad for at det har hjulpet deg, det er det vi er for

        I den andre distribusjonen som jeg har som er Fedora, det jeg har er Vinemulering av acestream for Windows xD, i tilfelle du går til en annen distro eller Arch selv, det som overrasker meg er at ikke engang i Debian har de disse pakkene ...

      2.    delikatesse maker01 sa

        Hei, og filen er hvordan den er installert. Jeg er fortsatt en nybegynner, en hilsen

        1.    vafe sa

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Han setter det i kommentaren ovenfor

  12.   kjemikalier sa

    I går installerte jeg den som en snap-pakke i Kde Neon 5.8, og jeg ble overrasket over hvor enkelt og raskt det fungerte for meg. Det ville være fint om du oppdaterer artikkelen fordi det ikke er noen sammenligning, prosessen er mye forenklet.

    sudo apt installer snapd → installer styringssystemet for snap-pakken (hvis du ikke har det installert)
    snap finn acestream → for å sjekke at vi har programmet i repositoriene (alle ubuntu-derivater skal ha det)
    sudo snap installere acestreamplayer

    Hilsen

    1.    Antonio Manzano sa

      Du har rett. Jeg har nettopp installert den i kubuntu 17.10, siden metoden som vises her er helt umulig. Tusen takk

      1.    Pappa sa

        ikke gyldig for i386-arkitektur

    2.    sie9k sa

      Det har vært den eneste måten å installere den på Lubuntu 16.04.4, men det er ingen måte for meg å lagre konfigurasjonsfilen, og jeg må konfigurere en parameter for å fungere sammen med Serviio. Noen ideer for å fikse det?

  13.   José Antonio sa

    Veldig bra innlegg. En må-lese webside for Linux nybegynnere.

  14.   Rookien Pedro sa

    Hvordan vil du installere den for AntiX 16 (det er en Linux-distribusjon)?

    Jeg har prøvd som Arch Linux og derivater, men jeg er så nybegynner at jeg må misforstå

  15.   Alexander sa

    Hei, med sna-pakkene, som kollegaen ovenfor kommenterer i en kommentar, har blitt lettere ikke bare for disse distribusjonene, men for mange. Distribusjonene som er kompatible med disse pakkene er her:
    https://snapcraft.io/

    I Debian vil det være som følger:
    -sudo apt installer snapd
    -sudo snap installere kjerne
    -sudo snap installere acestreamplayer
    I Arch og derivater:
    -sudo pacman -S snapd
    -sudo systemctl aktivere –nå snapd.socket
    -sudo snap installere acestreamplayer

    I Arch (plasma) har jeg måttet starte på nytt slik at de installerte pakkene vises. Hvis det ikke vises, vet du allerede hva du skal gjøre.

    På ubuntu og derivater antar jeg at det vil være som partneren som installerte det ovenfor i kommentarene med KDE neon.

    Det er nysgjerrig at det i Gnome med Debian ser ganske stygt ut og ikke integrerer godt med GTK, men i Arch plasma integreres det ganske bra, det viktigste er at det blir sett utenfor estetikk.

    1.    william sa

      installerer dette acestream-motoren din?
      Ikke meg

      1.    Alexander sa

        Hei, nei, du trenger ikke installere det, og du trenger heller ikke, med snap-pakkene er alle avhengigheter dekket, det må fungere ja eller ja.

    2.    txuber sa

      Hei Alejandro, se om du kan hjelpe meg
      [txuber @ manjaro ~] $ sudo systemctl aktiver - nå snapd.socket
      Kunne ikke aktivere enhet: Enhetsfil \ xe2 \ x80 \ x93now.service eksisterer ikke.
      på manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander sa

        Hei, Manjaro er at det ikke er ren Arch og ting kan endres litt, det kan allerede være aktivert, og det er ikke nødvendig å gjøre det, antar du at du allerede har prøvd å hoppe over det trinnet ...

  16.   Debian sa

    Når du er installert, hva skal jeg gjøre? Fordi ess-spilleren ikke er installert, vet jeg ikke hvordan jeg skal få den til å fungere.
    Hjelp meg noen takk?

    1.    vafe sa

      Hvis det du har installert er acestream-launcher, når du klikker på en lenke vil acestream spørre deg med hvilket program du vil åpne lenken, forteller du det at med VLC, og dette er det som vil gjøre funksjonene til ess-spiller

      1.    Debian sa

        Hei. Først av alt, tusen takk for hjelpen. Jeg kommenterer. Jeg har installert acestream snap-pakken i Debian 9 med gnome. Når jeg er i arenavisión, det er det jeg vil ha det til, klikker jeg på en acestream-lenke og det vises et vindu som gir meg to alternativer, det første er acestreamengine at hvis jeg klikker på dette gjør det ingenting, og det andre er å velge et annet program, jeg det å velge, men de installerte programmene åpnes ikke, hjemmemappen min åpnes, så jeg vet ikke hvordan jeg skal velge vlc.

        En hilsen.

        1.    Alexander sa

          Med acestream-launcher går det ikke bra, bedre å installere med Snap-pakken som jeg forklarer i kommentaren ovenfor.

  17.   Rookien Pedro sa

    Jeg prøver å installere snapd-pakken, men det lar meg ikke:

    sudo apt installer snapd
    Leseliste over pakker ... Ferdig
    Å skape avhengighetstre
    Les statusinformasjonen ... Ferdig
    E: Snapd-pakken kunne ikke bli funnet

    hva jeg gjør?

  18.   Alf sa

    Tusen takk, det er et av programmene jeg brukte i windows, og jeg ønsket å ha det i Linux

  19.   oscar sa

    Takk Chemabs og Alejandro! Perfekt med Ubuntu 17.10
    sudo apt installer snapd
    snap finn acestream
    sudo snap installere acestreamplayer
    Og det er det!
    Det utrolige er at du går til den offisielle nettsiden, og de sender deg et innlegg på forumet deres fra 2014! Og der de bare nevner opp til Ubuntu 13.04!

  20.   Marco Barria sa

    bra, som de sier i forrige kommentarer, det fungerer perfekt med snapd in arch:

    sudo pacman -S snapd
    sudo systemctl aktiver snapd.socket
    omstart
    sudo snap installere acestreamplayer
    omstart

    og klar:

  21.   mchavez sa

    hei, og er det en måte å installere ess-strømmen uten å måtte være programmerer ... som det gjøres med windows