Ikke mer Flash for Linux med mindre du bruker Google Chrome

Adobe foretar en uttak Verden Linux: I fjor sluttet å legge ut oppdateringer til AIR og de neste månedene vil lanseringen av Flash Player 11.2, som vil være den siste versjonen som er tilgjengelig for denne plattformen. På samme måte kan noen alternativer brukes til å utnytte de nye funksjonene som er innlemmet i fremtidige versjoner for andre operativsystemer.


Nyheten ble utgitt i adobe blogg og det står at fra neste versjon kan den bare lastes ned for å installeres direkte på Windows og Mac. I Linux kan du bare ha Flash ved hjelp av Pepper API som vil være tilgjengelig for Google Chrome-nettleseren.

Adobe har jobbet med Google for å erstatte Netscape plugin API, brukt til nå av Adobe Flash Player, med Pepper. PPAPI er kompatibel med de fleste nettlesere og operativsystemer, selv om Mozilla allerede har kunngjort at den ikke er interessert i den, og at den ikke vil implementere den i sin Mozilla Firefox-nettleser. Så Adobe Flash player vil bare være tilgjengelig for Chrome / Chromium fra og med i år.

Adobe vil fortsette å tilby sikkerhetsoppdateringer for ikke-Pepper-baserte versjoner av Flash Player 11.2 for Linux i fem år etter utgivelsen.

Alternatives

  • Ved hjelp av Google Chrome / Chromium gjør de fleste det.
  • Bruk noe gratis alternativ til Flash, selv om de fremdeles er ganske dårlige.
  • Vent til sidene har tatt i bruk HTML5, og vi kan glemme Flash en gang for alle.
  • Få Firefox til å bruke Flash-pluginet innebygd i Google Chrome.

Hvordan få Firefox til å bruke Google Chrome Flash-plugin

Det første og essensielle er å ha Firefox og Google Chrome installert. Når det var gjort, åpnet jeg en terminal og gjorde følgende trinn:

1. - Fjern installerte Flash-plugins.

sudo apt-get remove flashplugin- *

2. - Lag de nødvendige mappene i HOME-katalogen

mkdir -p ~ / .mozilla / plugins

3. - Koble Chrome Flash-pluginet til Firefox.

ln -s /opt/google/chrome/libgcflashplayer.so ~ / .mozilla / plugins /

4. - Åpne Firefox og velg Verktøy - utvidelser. Deaktiver Shockwave Flash.

Hver gang Chrome oppdateres, vil endringene også bli lagt merke til i Firefox.


Innholdet i artikkelen følger våre prinsipper for redaksjonell etikk. Klikk på for å rapportere en feil her.

22 kommentarer, legg igjen dine

Legg igjen kommentaren

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Kontroller SPAM, kommentaradministrasjon.
  3. Legitimering: Ditt samtykke
  4. Kommunikasjon av dataene: Dataene vil ikke bli kommunisert til tredjeparter bortsett fra ved juridisk forpliktelse.
  5. Datalagring: Database vert for Occentus Networks (EU)
  6. Rettigheter: Når som helst kan du begrense, gjenopprette og slette informasjonen din.

  1.   shini-kire sa

    adobes og ctm! og google og ctm ¬ ¬ Jeg bruker ikke krom eller krom, jeg hater det, det er en motbydelig litteralemte, jeg foretrekker Firefox, Midori

    1.    gerdson sa

      du er rett bror jævla selskap som ikke vet noe om brukere, jeg vil dø med firexfox, dette med folket og folket forent vil aldri bli beseiret.

      for alltid firexfox

  2.   Følg linux sa

    Mens Adobe mener at det avviser oss, er det omvendt ...
    De tenker: «Og nå som Linux klarer seg uten oss» tenker vi: «Gi Flash Player jeg går til HTML5», nesten ingenting mangler for at denne endringen skal fullføre prosessen, og jeg kommer til å være der for å le av dem, så lenge i skyggen av Adobe og til slutt vil jeg være fri ...
    Bare vent fordi siden jeg besøker mest (YouTube) nå er tilgjengelig for å teste videoene i HTML5, og det er mye mer behagelig for meg.

  3.   Anthony sa

    Jeg liker ikke et hår som Google tar, og prøver å dekke alt. I tillegg har den nye sikkerhetspolitikken fått meg til å tenke nytt, faktisk allerede, om bruk av andre søkemotorer og andre tjenester utenfor Google. Hva mer, nå, innimellom, utfører jeg søk som ikke har noe å gjøre med mine interesser, for å forvirre robotene som bygger personlige profiler.
    Forresten, Google betalte for ikke så lenge siden Mozilla gode penger for å gjøre Google til standardsøkemotoren i Mozilla-linjen. Mozilla bør være forsiktig fordi det å akseptere slike kontrakter kan bety å grave sin egen grav.
    Nå går de for Adobe ...
    Jeg liker Chrome, den går fort ... men guruer sier at den har flere hull enn Gruyère-ost ...

  4.   Jose Manuel Ramirez Rijo sa

    Som St.

  5.   Jose Manuel Ramirez Rijo sa

    Mmmmmmmmmmmmmmmmm

  6.   gon sa

    Flash var alltid en smerte i rumpa for Linux! Jeg har en hard touch, og det var alltid et problem å spille flash. Hjemme har jeg to tvillingmaskiner praktisk talt: en av mine med Linux og en annen av mine gamle med Windows, i begge er Firefox med Flash!, Og det gir meg sinne at den med Windows-flash er lett og uten drama, det i sin versjon offisiell for Linux går bakover, utover min harde.

    Har du lagt merke til den (store) forskjellen i Flash-kravene på de forskjellige plattformene? For Windows ba det alltid om 128, Mac 256, Linux 512 !! .. det samme hvis du hadde Solaris, ville det be om 1 GB eller noe sånt. Det for meg var en indikator på hvor sta implementeringen på tvers av plattformene var.

    Jeg likte de publiserte alternativene. Og en ekstra, selv om den ikke er like "linuxra" som de du publiserte, er å installere Windows Firefox via Wine (winetricks hjelper mye), jeg har det og det fungerer.

    Hilsen

  7.   Simon sa

    Vel, jeg kan ikke teste det fordi verken i versjon 17 eller i 18 av Chromium eller i den nåværende stallen til Chrome er det pluginet.

  8.   La oss bruke Linux sa

    Prøv det og fortell oss. Hvis det ikke fungerer, er det et spørsmål om å aktivere det på nytt, ikke sant?
    Jubel! Paul.

  9.   krafty sa

    Enten bruker du Chrome, eller så går det tom for blits!

    Det er det disse barna til moren deres vil fortelle oss ... ..?

    hvem vet om google ikke er i ryggen ......

  10.   Makova sa

    Jeg stoler ikke på google lenger, de er allerede redde for makten de når. Nå bruker jeg IceCat og så glad ...

  11.   Simon sa

    Trinn 4 er riktig? Deaktiver Shockwave Flash? Så hvilket plugin vil du bruke?

  12.   Daniel sa

    Du kan bruke YouTube med HTML5, for å aktivere det må du gå til: http://www.youtube.com/html5

  13.   Abel Hinestrosa Rodriguez sa

    For meg vil det ikke være et stort problem siden jeg bruker Google Chrome, så ...

  14.   ENVI sa

    Jeg tror det riktige uttrykket ville være "Jeg liker ikke et hår slik Mozilla tar", for så vidt artikkelen rapporterer, kommer problemet fra Mozilla som ikke er interessert i det eller ønsker å implementere det i nettleseren sin.

    Elsket eller hatet, det virker som et skritt bakover når det gjelder kompatibilitet. Jeg ser allerede en nær fremtid der familien forfølger meg fordi Flash sluttet å jobbe i nettleserne.

  15.   baloo fisk sa

    Gi dem pølser for å blinke, det tjener bare til å spise vær, knuse deg til annonser og snike sikkerhetshull. HTML5 og ajax er alternativer med gratis standarder. De sprakk allerede med flashmobiler, og nå dette. HVIL I FRED

  16.   Francisco sa

    Beklagelig fra Adobe.

  17.   Carlosfg1984 sa

    "Bruk Google Chrome / Chromium, de fleste gjør."

    Beklager, argumentet for dette alternativet er veldig dårlig. Jeg bruker ikke ting fordi jeg bruker de fleste av dem ... Og jeg foretrekker å bruke og fortsette å bruke mest Mozilla Firefox

  18.   Dario sa

    på en gang vil vi si at Adobe Flash Player ble eldgammel historie.

    1.    la oss bruke linux sa

      Forhåpentligvis!

  19.   Enzo Codini (alias enzocodini1342) sa

    Du kan også bruke Pipelight (det er ikke så linuxero), som lar deg installere MS Windows-plugins i Linux, og du kan bruke flash, og på Core 2 Duo er det en perle! Og det lar deg installere flere ting utenfor Linux, som Unity Web Player, det fungerer perfekt!

  20.   dhunter sa

    Jeg har ikke brukt Flash i årevis, faktisk har jeg den blokkert gjennom plugins i Firefox / Iceweasel, hvis jeg går inn på et nettsted og det krever Flash, slår jeg tilbake.