Braketter 1.1 Hva er nytt etter å ha brukt tid?

Husker du Parentes? I FromLinux vi dedikerer flere artikler til denne tekstredigereren åpen kildekode promotert av Adobe og dets fellesskap, og som siden den gang har utviklet seg litt etter litt til den når versjon 1.1 med mange forbedringer og funksjoner. I denne artikkelen vil vi gjennomgå noen av dem, men først, la oss huske noen av alternativene som gjør Parentes noe annerledes.

Nettredigering med braketter

Braketter CSS Editor

En av de mest interessante funksjonene i Brackets er det jeg kaller "Online Editing", som består i å redigere CSS-egenskapene til en eksisterende HTML-tag, eller lage en ny, fra selve filen. . Html uten å måtte åpne stilarkfilen. Vi må bare sette markøren på den tilsvarende etiketten og trykke Ctrl + E.

Vis elementer, farger og bilder i parentes

Braketter_Bilde

Braketter lar oss visualisere bildene som vi kobler til i html-koden vår eller fargen på en eiendom i .css-filen som vist i forrige bilde. I tillegg har du muligheten til å se endringene vi lagrer i html-filen vår Google Chrome automatisk, uten å laste inn siden på nytt.

Dette var noen av de kuleste funksjonene til Brackets den gang, men nye kommer nå.

Del visning i parentes

Parentes

Nå kan vi jobbe mer komfortabelt med to filer samtidig som redigeringsvisningen deles både vertikalt og horisontalt. Den inkluderer støtte for temaer som standard og lar oss velge skrift vi bruker og størrelsen.

Utvidelser, mange utvidelser i parentes

Hvis det er noe der Braketter har forbedret seg mye (takket være fellesskapet), står det i listen over tilgjengelige utvidelser, mange av dem med utmerket kvalitet.

Brackets_Extensions

Jeg bruker noen veldig interessante som:

  • Forskjønne: For å forskjønne JS, CSS og HTML-kode
  • Bootstrap 3 skjelett: Å lage en Boostrap-klar html.
  • Braketter Sammenlign: Et DIFF-verktøy.
  • Liste over gjøremål: Å ha en liste over oppgaver for hånden
  • Git parenteser: En av favorittene mine, det lar meg administrere prosjektet mitt og GIT-arkivet. Jeg legger igjen et skjermbilde i det følgende bildet.
  • Andre, mange andre ..

Braketter_GIT

Braketter og ekstrakt

Med versjon 1.1 av Brackets har vi muligheten til å laste ned en variant som inkluderer Extract, som i utgangspunktet incluye una nueva experiencia de instalación inicial y una característica que le permite colaborar con un diseñador (que use .PSD) y que utilice la nube de Adobe. Jeg kan egentlig ikke fortelle deg hvordan det fungerer av åpenbare grunner, men det virker som et ganske kult alternativ.

Braketter konklusjoner

Oppsummert kan jeg si at på den korte tiden det tar for utvikling, tar Brackets et viktig sted for meg blant alternativene vi har for hånden. Den er ikke perfekt, den har fortsatt en lang vei å gå (og jeg skulle ønske den ville løpe så fort som Sublime Text), men takket være de nye funksjonene og utvidelsene som blir lagt til, viser det seg å være et utmerket alternativ for brukere . Frontender.

Jeg kan ha flere ting å nevne, men det beste er at du prøver det og bedømmer deg selv. Braketter er tilgjengelig fra deres nettside med pakker samlet for Debian / Ubuntu, eller deres kilder. Hvis du er en ArchLinux-bruker, kan du installere den direkte fra AUR.


Innholdet i artikkelen følger våre prinsipper for redaksjonell etikk. Klikk på for å rapportere en feil her.

23 kommentarer, legg igjen dine

Legg igjen kommentaren

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Kontroller SPAM, kommentaradministrasjon.
  3. Legitimering: Ditt samtykke
  4. Kommunikasjon av dataene: Dataene vil ikke bli kommunisert til tredjeparter bortsett fra ved juridisk forpliktelse.
  5. Datalagring: Database vert for Occentus Networks (EU)
  6. Rettigheter: Når som helst kan du begrense, gjenopprette og slette informasjonen din.

  1.   sergio sa

    Jeg har brukt bukseseler siden versjon 0.27, og jeg har vokst mye hele tiden 🙂
    Det er en stein !! Titan!

  2.   kik1n sa

    Jeg venter bare på Debian Testing 😀

  3.   Tanrax sa

    Fantastisk artikkel.
    Er det mulig å flytte med vi / vim snarveier?

  4.   Rafael Mardojai sa

    For tiden er redaktøren jeg utvikler meg med, siden jeg fant at det er mitt standardalternativ xD

  5.   cooper15 sa

    Det er virkelig en imponerende redaktør, jeg har blitt betatt siden jeg prøvde det for første gang. Jeg anbefaler det. Jeg håper at jeg på kort tid vil fjerne hegemoniet fra SublimeText.

    1.    Tanrax sa

      Jeg håper Sublime Text lærer en ting eller to. Han har veldig interessante ideer.

      1.    elav sa

        De må begge lære ..

  6.   ravn291286 sa

    Jeg har brukt den, og der du trykker på tastene "Ctrl + E" vises ingenting, det forteller meg bare at filen ikke eksisterer hvis jeg vil lage en.

  7.   Ariel sa

    Jeg har prøvd å installere den i Antergos (yaourt -S braketter), men dessverre kan jeg aldri fullføre installasjonen på riktig måte. Jeg får alltid følgende feil:

    "Kjører" curl-dir: node-linux64 "(curl-dir) oppgave
    Filer «nedlastinger / node-v0.10.24-linux-x64.tar.gz» opprettet.

    Kjører "node-clean" oppgave

    Kjører "node-mac" oppgave

    Kjører «create-project» oppgave
    Bygg prosjektfiler

    Doner, uten feil.
    CXX (mål) ut / Slipp / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o
    make: g ++: Programmet ble ikke funnet
    libcef_dll_wrapper.target.mk:212: Feil i instruksjonene for mål 'ut / frigjøring / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o'
    make: *** [out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o] Feil 127
    ==> FEIL: Det var en krasj i build ().
    Avbryter ...
    ==> FEIL: Makepkg kunne ikke kompilere parenteser.
    ==> Start brakettkompilering på nytt? [y / n]
    ==> ———————————————–
    ==> »

    Er det noen som vet hva det kan være, eller hvordan kan jeg fikse det for å bruke braketter?

    1.    Tanrax sa

      Hvis du ser at du ikke kan, kan du installere fra en deb.
      Lykke til!

    2.    elav sa

      Jeg fra AUR installerer alltid parentes-bin

      1.    Ariel sa

        Brackets-bin fungerte. Takk skal du ha!

    3.    Alexander sa

      make: g ++: Programmet ble ikke funnet

  8.   Gonzalo sa

    Jeg har prøvd forskjellige redaktører, men til slutt kommer jeg alltid tilbake til Kate. Å redigere CSS på nettet, forhåndsvise bilder eller farger er veldig praktisk og sparer definitivt tid, men tror du dette er nok grunner til å gå over Kate, som til slutt innlemmer nesten alle de nyttige funksjonene som vises i andre redaktører, til Brackets? Jeg vet at jeg vil få det beste svaret ved å prøve det selv, men sannheten er at jeg er litt lei av å prøve dette eller det andre programmet og til slutt ende opp med å gå tilbake til de som har gitt meg gode resultater i årevis.

    Hilsener.

    1.    elav sa

      Det eneste problemet jeg ser med KATE er at den ikke har autofullføring av koder, etiketter og så videre 🙁

      1.    Firefox-bruker-88 sa

        Det ser ut til at autofullføring har: http://kate-editor.org/about-kate/

        1.    elav sa

          Vel, for HTML og CSS har jeg aldri sett det.

      2.    clow_eriol sa

        Autofullføringen som ikke gjør det elav ber om. Det fullfører deg bare automatisk hvis det er et ord som starter det samme i hele dokumentet.

  9.   Martin sa

    Det første alternativet jeg klikker på 'Dynamisk forhåndsvisning' er bare tilgjengelig med Google Chrome…. -> Avinstallerer ...

    Er det en mani med Google Chrome? glemmer de at dette er Linux? Netflix, WhatsApp og nå Braketter ...

    1.    elav sa

      Ja, det er det. Det som skjer er at dette alternativet bare er nyttig hvis du jobber med .html, noe som er bra for layout, men når du oppretter et WordPress-tema, er det ikke lenger nyttig når du jobber med. Php-filer 😀

    2.    blonfu sa

      I denne siste versjonen er det støtte for flere nettlesere for livevisningen, men som standard er den deaktivert. I preferansefilen setter du denne "livedev.multibrowser": sant, jeg bruker den med Firefox og den fungerer.

      1.    Pepe sa

        Hei, og hvordan legger du til det, fordi jeg legger til den koden, og hver gang jeg åpner programmet får jeg en feilmelding: preferansefilen har ikke et gyldig JSON-format.

  10.   heckctor sa

    Hei, hva er temaet du bruker? det er flott 🙂