Przedziały 1.1, co nowego po spędzeniu czasu?

Pamiętasz Wsporniki? W FromLinux poświęcamy kilka artykułów do tego edytora tekstu open source promowane przez firmę Adobe i jej społeczność i od tego czasu ewoluowało stopniowo, aż do osiągnięcia wersji 1.1 z wieloma ulepszeniami i funkcjami. W tym artykule omówimy niektóre z nich, ale najpierw zapamiętajmy niektóre opcje, które sprawiają, że Wsporniki coś innego.

Edycja online za pomocą nawiasów

Edytor nawiasów CSS

Jedną z najbardziej interesujących funkcji nawiasów jest to, co nazywam „edycją online”, która polega na edytowaniu właściwości CSS istniejącego znacznika HTML lub tworzeniu nowego z samego pliku. . Html bez konieczności otwierania pliku arkusza stylów. Wystarczy ustawić kursor na odpowiedniej etykiecie i nacisnąć Ctrl + E.

Przeglądaj elementy, kolory i obrazy w nawiasach

Brackets_Image

Nawiasy pozwalają nam wizualizować obrazy, które łączymy w naszym kodzie html lub kolor właściwości w pliku .css, jak widać na poprzednim obrazku. Ponadto masz możliwość zobaczenia zmian, które zapisujemy w naszym pliku html w formacie Google Chrome automatycznie, bez ponownego ładowania strony.

Były to jedne z najfajniejszych funkcji Brackets w tamtych czasach, ale teraz pojawiają się nowe.

Widok podzielony w nawiasach

Wsporniki

Teraz możemy wygodniej pracować z dwoma plikami jednocześnie, dzieląc widok edytora zarówno w pionie, jak iw poziomie. Obejmuje domyślnie obsługę motywów i pozwala nam wybrać używaną czcionkę i jej rozmiar.

Rozszerzenia, wiele rozszerzeń w nawiasach

Jeśli jest coś, w czym Brackets bardzo się poprawiło (dzięki Społeczności), to znajduje się na liście dostępnych rozszerzeń, wiele z nich o doskonałej jakości.

Brackets_Extensions

Używam bardzo ciekawych, takich jak:

  • Upiększać: Aby upiększyć kod JS, CSS i HTML
  • Szkielet Bootstrap 3: Aby utworzyć plik HTML gotowy do Boostrap.
  • Porównanie wsporników: Narzędzie DIFF.
  • Lista zadań: Aby mieć pod ręką listę zadań
  • Nawiasy Git: Jeden z moich ulubionych, pozwala mi zarządzać projektem i jego repozytorium GIT. Zostawiam zrzut ekranu na poniższym obrazku.
  • Inni, wiele innych ...

Nawiasy_GIT

Nawiasy i wyciąg

W wersji 1.1 Brackets mamy możliwość pobrania wariantu zawierającego Extract, czyli w zasadzie incluye una nueva experiencia de instalación inicial y una característica que le permite colaborar con un diseñador (que use .PSD) y que utilice la nube de Adobe. Z oczywistych powodów nie mogę ci powiedzieć, jak to działa, ale wydaje się, że to całkiem fajna opcja.

Wnioski z nawiasów

Podsumowując, mogę powiedzieć, że w tak krótkim czasie, jaki zajmuje rozwój, Brackets zajmuje dla mnie ważne miejsce wśród alternatyw, które mamy pod ręką. Nie jest doskonały, wciąż ma przed sobą długą drogę (i chciałbym, żeby działał tak szybko jak Sublime Text), ale dzięki nowym funkcjom i rozszerzeniom, które są dodawane, okazuje się doskonałą opcją dla użytkowników. Początek końca.

Może mam więcej rzeczy do omówienia, ale najlepsze jest to, że spróbujesz i osądzisz sam. Brackets jest dostępny na ich stronie internetowej z pakietami skompilowanymi dla Debiana / Ubuntu lub ich źródeł. Jeśli jesteś użytkownikiem ArchLinux, możesz zainstalować go bezpośrednio z AUR.


Treść artykułu jest zgodna z naszymi zasadami etyka redakcyjna. Aby zgłosić błąd, kliknij tutaj.

23 komentarzy, zostaw swoje

Zostaw swój komentarz

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *

*

*

  1. Odpowiedzialny za dane: Miguel Ángel Gatón
  2. Cel danych: kontrola spamu, zarządzanie komentarzami.
  3. Legitymacja: Twoja zgoda
  4. Przekazywanie danych: Dane nie będą przekazywane stronom trzecim, z wyjątkiem obowiązku prawnego.
  5. Przechowywanie danych: baza danych hostowana przez Occentus Networks (UE)
  6. Prawa: w dowolnym momencie możesz ograniczyć, odzyskać i usunąć swoje dane.

  1.   Sergio powiedział

    Używam szelek od wersji 0.27 i przez cały ten czas bardzo się rozwinąłem 🙂
    To jest skała !! Tytan!

  2.   kik1n powiedział

    Czekam tylko na testy Debiana 😀

  3.   Tanrax powiedział

    Cudowny artykuł.
    Czy można poruszać się za pomocą skrótów vi / vim?

  4.   Rafael Mardojai powiedział

    Obecnie edytor, za pomocą którego się rozwijam, odkąd stwierdziłem, że jest to moja domyślna alternatywa xD

  5.   cooper15 powiedział

    To naprawdę imponujący edytor, byłem urzeczony, odkąd wypróbowałem go po raz pierwszy. Polecam to. Mam nadzieję, że w niedługim czasie usunę hegemonię z SublimeText.

    1.    Tanrax powiedział

      Mam nadzieję, że Sublime Text nauczy się czegoś lub dwóch. Ma bardzo ciekawe pomysły.

      1.    elav powiedział

        Oboje muszą się nauczyć ...

  6.   cuervo291286 powiedział

    Używałem go i gdy naciskasz klawisze "Ctrl + E" nic się nie pojawia, tylko mówi mi, że plik nie istnieje, że jeśli chcę go zrobić.

  7.   Ariel powiedział

    Próbowałem zainstalować go w Antergos (wsporniki yaourt -S), ale niestety nigdy nie mogę poprawnie zakończyć instalacji. Zawsze otrzymuję następujący błąd:

    „Uruchomione” zadanie curl-dir: node-linux64 ”(curl-dir)
    Utworzono pliki «pliki do pobrania / node-v0.10.24-linux-x64.tar.gz».

    Uruchamiam zadanie „wyczyszczenia węzła”

    Uruchamiam zadanie „node-mac”

    Uruchamiam zadanie «stwórz projekt»
    Tworzenie plików projektu

    Wpłać bez błędów.
    CXX (cel) out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o
    make: g ++: Program nie został znaleziony
    libcef_dll_wrapper.target.mk:212: Błąd instrukcji dla celu „out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o”
    make: *** [out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o] Błąd 127
    ==> BŁĄD: Wystąpiła awaria funkcji build ().
    Anulowanie ...
    ==> BŁĄD: Makepkg nie mógł skompilować nawiasów.
    ==> Zrestartować kompilację nawiasów? [t / n]
    ==> ———————————————–
    ==> »

    Czy ktoś wie, co to może być lub jak mogę to naprawić, aby użyć nawiasów?

    1.    Tanrax powiedział

      Jeśli widzisz, że nie możesz, zainstaluj z pliku deb.
      Powodzenia!

    2.    elav powiedział

      Ja z AUR zawsze montuję wsporniki-pojemnik

      1.    Ariel powiedział

        Kosz na śmieci działał. Dziękuję Ci!

    3.    Alejandro powiedział

      make: g ++: Program nie został znaleziony

  8.   Gonzalo powiedział

    Próbowałem różnych edytorów, ale w końcu zawsze wracam do Kate. Edytowanie CSS online, przeglądanie obrazów lub kolorów jest bardzo praktyczne i zdecydowanie oszczędza czas, ale czy uważasz, że to wystarczający powód, aby przejść do Kate, która kończy się włączeniem prawie wszystkich przydatnych funkcji, które pojawiają się w innych edytorach, do nawiasów? Wiem, że najlepszą odpowiedź uzyskam, wypróbowując go samemu, ale prawda jest taka, że ​​jestem trochę znudzony próbowaniem tego czy innego programu i ostatecznie wracam do tych, które od lat dają mi dobre wyniki.

    Pozdrowienia.

    1.    elav powiedział

      Jedyny problem jaki widzę z KATE to brak autouzupełniania kodu, etykiet i tak dalej 🙁

      1.    firefox-user-88 powiedział

        Wygląda na to, że autouzupełnianie ma: http://kate-editor.org/about-kate/

        1.    elav powiedział

          Cóż, w przypadku HTML i CSS nigdy tego nie widziałem.

      2.    Clow_eriol powiedział

        Autouzupełnianie, które nie robi tego, o co prosi elav. Autouzupełnianie następuje tylko wtedy, gdy w całym dokumencie występuje słowo, które zaczyna się tak samo.

  9.   jaskółka oknówka powiedział

    Pierwsza opcja, którą kliknę „Podgląd dynamiczny” jest dostępna tylko w przeglądarce Google Chrome…. -> Odinstalowywanie….

    Czy istnieje mania z Google Chrome? zapomnieli, że to jest Linux? Netflix, WhatsApp i teraz Brackets ...

    1.    elav powiedział

      Tak to jest. Dzieje się tak, że ta opcja jest przydatna tylko wtedy, gdy pracujesz z .html, co jest dobre dla układu, ale kiedy tworzysz motyw WordPress, podczas pracy z plikami .php nie jest już przydatna 😀

    2.    blonfu powiedział

      W najnowszej wersji istnieje obsługa wielu przeglądarek dla podglądu na żywo, ale domyślnie jest wyłączona. W pliku preferencji umieściłeś to „livesev.multibrowser”: prawda, używam go z Firefoxem i działa.

      1.    Pepe powiedział

        Witam, a jak to dodać, bo dodaję ten kod i za każdym razem, gdy otwieram program wyskakuje mi błąd że: plik preferencji nie ma prawidłowego formatu JSON.

  10.   heckctor powiedział

    Witam, jakiego motywu używasz? jest super 🙂