Synchronizuj iPoda Nano 6G z Banshee (lub innym odtwarzaczem)

Witajcie przyjaciele, dziękując za wspaniały odbiór, że mój pierwszy pisaćtutaj przedstawiam prosty sposób na zsynchronizowanie iPoda Nano 6G (szóstej generacji) z ulubioną muzyką w Banshee lub dowolnym innym odtwarzaczu kompatybilnym z bibliotekami libgpod.

Kroki, aby zsynchronizować iPoda Nano 6G z Banshee

Ten samouczek jest testowany pod kątem Linux Mint 7, ale w zasadzie powinien działać dla każdej dystrybucji wywodzącej się z Ubuntu. Pierwszą rzeczą, którą zamierzamy zrobić, jest instalacja bibliotek libgpod z repozytoriów, jeśli nie są zainstalowane:

$ sudo apt-get install libgpod4 libgpod-common

Następnie pobierzemy zmodyfikowaną bibliotekę libhashab.so przez zaprzeczyć dni co pozwoli nam na korzystanie z naszego iPoda Nano 6G: (polecam przeczytanie dokumentacji biblioteki)

Ta biblioteka jest przeznaczona do wyłącznego użytku iPoda Nano 6G i nie powinna być używana z żadnym innym iPodem ani iPhonem

$ wget https://github.com/denydias/libhashab/archive/master.zip

$ unzip master.zip

$ cd libhashab-master/

Od teraz bardzo ważne jest, aby wiedzieć, czy Twój system jest 32 bity lub 64 bity w tym celu możesz wypróbować następujące polecenie
$ /bin/uname -m

Jeśli odpowiedź brzmi i686 to twój system 32bits, wręcz przeciwnie, jeśli odpowiedź brzmi x86_64 to twój system 64bits

Jeśli twój system to 32bits, więc

$ sudo sh install_32bit.sh

Wręcz przeciwnie, jeśli twój system jest 64bits, więc

$ sudo sh install_64bit.sh

Teraz wszystko jest gotowe do użycia iPoda Nano 6G ………….

ale….

Jeśli nadal nie możesz używać swojego iPoda Nano 6G to oznacza, że ​​te biblioteki z jakiegoś powodu nie startują razem z systemem (tak było w moim przypadku), więc musimy dodać katalog, w którym jest hostowana zmodyfikowana biblioteka do pliku / etc / environment aby zostały załadowane do systemu, aby gracz mógł je zobaczyć. W tym celu otwieramy ten plik poleceniem

$ sudo gedit /etc/environment

Teraz, gdy mamy otwarty plik, zostanie dodany wiersz w zależności od architektury:

a) Jeśli twój system jest 64-bitowy, dodaj następujący wiersz kodu na końcu pliku:
LD_LIBRARY_PATH = »/ usr / lib64 / libgpod /»

b) Ale jeśli twój system jest 32-bitowy, dodaj następujący wiersz kodu na końcu pliku:
LD_LIBRARY_PATH = »/ usr / lib / libgpod»

W przypadku, gdy mają już katalog dodany do zmiennej LD_LIBRARY_PATH po prostu dodają nowy katalog obok poprzedniego, dodając «dwukropek (:) ». To powinno wyglądać tak:

LD_LIBRARY_PATH =«/ Usr / local / lib /: / usr / lib64 / libgpod /«

Teraz z plikiem / etc / environment zmodyfikowany musimy załadować go do systemu, aby móc używać naszego odtwarzacza (kompatybilnego z libgpod) do synchronizacji naszego iPoda 6G, i przeproś firmę Apple za nieużywanie iTunes

$ source /etc/environment

I to wszystko..


Treść artykułu jest zgodna z naszymi zasadami etyka redakcyjna. Aby zgłosić błąd, kliknij tutaj.

20 komentarzy, zostaw swoje

Zostaw swój komentarz

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *

*

*

  1. Odpowiedzialny za dane: Miguel Ángel Gatón
  2. Cel danych: kontrola spamu, zarządzanie komentarzami.
  3. Legitymacja: Twoja zgoda
  4. Przekazywanie danych: Dane nie będą przekazywane stronom trzecim, z wyjątkiem obowiązku prawnego.
  5. Przechowywanie danych: baza danych hostowana przez Occentus Networks (UE)
  6. Prawa: w dowolnym momencie możesz ograniczyć, odzyskać i usunąć swoje dane.

  1.   Helena powiedział

    wspaniały post! Czy przypadkiem nie wiedziałbyś, jak zsynchronizować się z iPhonem4 bez umierania podczas próby?

    1.    Koprotk powiedział

      Myślę, że to zależy od tego, co chcesz zrobić z iPhonem, jeśli chcesz skopiować do niego muzykę, może da się to zrobić, ale jeśli chcesz przywrócić iPhone'a, wykonując kopię zapasową danych, zainstaluj ponownie iOS i przywróć go później jest bardzo prawdopodobne, że nie możesz. Polecę użycie maszyny wirtualnej dla tych hostów. Twoje zdrowie

      1.    helena_ryu powiedział

        tak!!! To iPhone4 i tylko muzyka, podcasty i zdjęcia, którymi chcę zarządzać (najważniejsza jest muzyka), podobnie jak proces, używam Archlinux z kde.

  2.   Eliotime3000 powiedział

    Lepiej trzymam się iTunes w systemie Windows.

    1.    koprotka powiedział

      Jest to zdecydowanie przeszkoda, której nie możemy rozwiązać w przypadku niektórych urządzeń Apple. Ale jeśli możesz zsynchronizować iPoda w systemie Linux, ten jest o wiele szybszy, mówię ci, ponieważ w moim przypadku mój iPod Nano 6G kopiuje muzykę szybciej w Banshee / Linux niż iTunes / Windows, a nawet iTunes / OSx.

      1.    Eliotime3000 powiedział

        A może spróbujesz użyć systemu plików HFS?

      2.    koprotka powiedział

        Teraz używam iPoda w formacie iTunes w systemie Windows. Próbowałem formatu pliku Apple i nie synchronizował się

  3.   tux powiedział

    przyjacielu myślę, że miałeś na myśli linux mint 17

    1.    koprotka powiedział

      Dokładnie to samo hahahahahahaha

  4.   Matthews powiedział

    Bardzo dobry post, gdzie mogę znaleźć coś podobnego do nano 7G?

    1.    Koprotk powiedział

      Przyjacielu Google, ale trudno mi coś znaleźć, ponieważ biblioteki libgpod, które pomagają nam z naszymi iPodami, nie docierają do Nano 6G i jest to modyfikacja, którą użytkownik bezinteresownie uruchomił dla społeczności, ale jeśli znajdziesz coś, nie wahaj się nam powiedzieć

  5.   Marcos powiedział

    Świetnie działało na mnie na fedorze 20
    Znowu mogłem używać porzuconego iPoda przez rok.
    Biblioteka libgpod była już zainstalowana, więc musiałem tylko wykonać poniższe czynności.
    Dziękuję bardzo za wkład.

  6.   perik powiedział

    tak !! dpm !! niezłe wyzwanie komputerowe hahahah, odkąd mam ipoda, mogłem być tylko w systemie Windows, ponieważ Linuks nie mógł tego zrobić. teraz mam to na komputerze kolegi i na razie zainstaluję Linuksa. rekomendacja dla mnie ... ubuntu czy linux mint? Nie jestem nowicjuszem w Linuksie. Byłem od wielu lat w tych, w których linux był jeszcze z crackami, ale nie wiem, co umieścić.

    krótko mówiąc, że jesteś meisterem; D.

    1.    Koprotk powiedział

      Ubolewając z powodu opóźnienia, mięta jest lepsza niż ubuntu według mojego gustu, ponieważ osobiście ubuntu nie ma żadnej przewagi nad miętą, a mięta jest „instalowana-użytkowa”

      pozdrowienia

  7.   energia powiedział

    Świetny!!! Po ponad 3 latach… .. Wąchaj, będę płakać ze wzruszenia. Mój niezbyt nowy-iPodNano6G działający w systemie Linux z gtkpod. Dziękuję bardzo 😀

  8.   Saul powiedział

    Witam, dzień dobry, mam problem z moim ipodem nano piątej generacji, próbowałem wszystkiego nawet z plaonlinux i nie pozwala mi zainstalować iTunes… Ten poradnik może mi pomóc z ipodem nano, bo nie znalazłem rozwiązania , Miałem nadzieję, że możesz mi pomóc, dzięki / ,, /

    1.    Koprotk powiedział

      Czytanie http://www.gtkpod.org/wiki/Home Mówi się, że iPoda Nano 5th można zsynchronizować bez wykonywania tego samouczka, o ile przynajmniej jeden utwór jest wstępnie zsynchronizowany z iTunes. W podsumowaniu:
      1. - zainstaluj biblioteki gtkpod, jeśli ich nie masz
      2. - zsynchronizuj przynajmniej jedną piosenkę z iPodem Nano 5th za pomocą iTunes
      3. - teraz możesz zsynchronizować się ze swoim ulubionym programem, który obsługuje gtkpod, na przykład: rythmbox lub banshee

      1.    Carlota powiedział

        Bardzo dziękuję za artykuł !!
        Prawda jest taka, że ​​mi to nie wyszło. W tej chwili nienawidzę snobizmu Apple. Mam iPoda nano 5. generacji i to, co zaleca gtkpod, też mi nie działa. Zrobiłem wszystko dla forów.
        W każdym razie ... zobaczmy, co się stanie.
        Pozdrowienia!

  9.   Koprotk powiedział

    Carlota, naprawdę nie wiem jak ci pomóc, jeśli wypróbowałeś ten samouczek, będziesz musiał usunąć wszystkie zmiany, ten poradnik dotyczy tylko iPoda Nano 6G z drugiej strony, pamiętaj, że nie wszyscy gracze obsługują biblioteki libgpod , Banshee działa bardzo dobrze i rhythmbox również z tymi bibliotekami, również polecam sformatować ipoda Nano za pomocą iTunes w Windows, przekazać piosenkę, która jest w obu bibliotekach (Windows i Linux) i kontynuować synchronizację w Linuksie. Czy sprawdziłeś, czy wersja libgpod jest najnowsza? Szczęście.

    pozdrowienia

  10.   reberamon powiedział

    Cześć, mam iPoda 7G nano i komputer z systemem Linux Mint 18. Był już dostarczony z wbudowanym Banshee i działa dobrze, z wyjątkiem sytuacji, gdy podłączyłem iPoda i próbowałem usunąć stare utwory i odtworzyć nowe, nie mogłem nie rób tego. Te, które usunąłem, pozostały na iPodzie, chociaż nie brzmią. A te, które próbowałem umieścić, po prostu nie pojawiają się lub nie istnieją. Masz jakiś pomysł, jak mogę to rozwiązać?
    Z góry dzięki.