Wątpliwości wyjaśniające: repozytoria LMDE

Jak opublikowaliśmy 21 października 2011 roku, postanowiliśmy stworzyć sekcję o nazwie: Twoja opinia się liczy <° Linux, gdzie będziemy publikować e-maile wysłane przez niektórych użytkowników z propozycjami interesujących tematów formularz kontaktowy.

Cóż, właśnie narodziła się kolejna sekcja o nazwie: Wyjaśnianie wątpliwości <° Linux, gdzie odpowiemy na niektóre pytania użytkowników, którzy do nas przychodzą, wraz z ogólnymi pytaniami.

Opublikujemy tutaj te, które naszym zdaniem powinny zainteresować wszystkich, tak jak w przypadku tego, który użytkownik nazwał: Erytryma.

Erytryma napisał:

Witam, od kilku dni śledzę bloga i jest bardzo kompletny, ale mam pytanie.
Byłem użytkownikiem LMDE praktycznie od momentu jego pojawienia się, ponieważ wydawał się znacznie bardziej atrakcyjny niż Linux Mint, który był dystrybucją, z której korzystałem wcześniej. Jedyne, co mi się nie podoba, to fakt, że większość pakietów nie jest zaktualizowana.
Czy mógłbyś polecić stabilną i aktualną listę repozytoriów?
Czy to ostatni raz, kiedy próbowałem z pakietami SID, kiedy zaktualizowałem xorg, popsułem interfejs graficzny ...
Bardzo dziękujemy i przepraszamy za niedogodności!
I przede wszystkim gratuluję tego fantastycznego bloga!

<° Linux Odpowiedz:

Bardzo dziękujemy za pochwałę, cieszymy się, że nasze starania o prowadzenie tego bloga są przydatne dla innych użytkowników.

Chociaż posiadanie niestandardowych repozytoriów w plikach LMDE, jednocześnie mamy (jako barierę) polegać na aktualizacjach, które zespół Linux Mint włącz je.

Przede wszystkim musisz o tym pamiętać LMDE nie korzysta z repozytoriów Sida, ale te z Testowanie Debiana y Debian Squeeze. Zakłada się, że w repozytoriach Przybywający, muszą codziennie wprowadzać nowe pakiety z serwerów lustrzanych Testowanie Debiana, ale to nie jest bezpieczne.

Możesz bezpośrednio użyć repozytoriów Debian, ale jest bardzo prawdopodobne, że podczas wykonywania tej czynności wystąpi jakiś błąd zależności z pakietami, które zawiera LMDE.

Masz dwie możliwości: albo ryzykujesz, że będziesz używać repozytoriów Debian Testing, aby mieć bardziej zaktualizowane pakiety, albo cierpliwie czekasz, aż aktualizacje nadejdą z repozytoriów LMDE. Masz wolny wybór. Zostawiam Ci repozytoria Debiana:

deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free


Treść artykułu jest zgodna z naszymi zasadami etyka redakcyjna. Aby zgłosić błąd, kliknij tutaj.

8 komentarzy, zostaw swoje

Zostaw swój komentarz

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *

*

*

  1. Odpowiedzialny za dane: Miguel Ángel Gatón
  2. Cel danych: kontrola spamu, zarządzanie komentarzami.
  3. Legitymacja: Twoja zgoda
  4. Przekazywanie danych: Dane nie będą przekazywane stronom trzecim, z wyjątkiem obowiązku prawnego.
  5. Przechowywanie danych: baza danych hostowana przez Occentus Networks (UE)
  6. Prawa: w dowolnym momencie możesz ograniczyć, odzyskać i usunąć swoje dane.

  1.   Alexander Nova powiedział

    AFAIK Linux Mint Debian Edition, zgodnie z własną dokumentacją, jest w 100% kompatybilny z testowaniem Debiana. To, co się nie dzieje, dotyczy Ubuntu; LMDE ostrzega, że ​​repozytoria Ubuntu nie będą tam działać.

  2.   Emrytry powiedział

    Dziękuję za odpowiedź! Muszę powiedzieć, że myślałem, że mam już testy, ale najwyraźniej nie, ponieważ po dodaniu repozytoriów dostałem dużo aktualizacji, chociaż dają mi pewne problemy, ponieważ zmuszają mnie do odinstalowania pakietów takich jak mint-meta-common lub mint-meta-debian, których nie sądzę, aby były zalecane. Oprócz tego, przed aktualizacją xorg-a spieprzyłem interfejs graficzny, więc teraz trochę się boję, gdybym znowu to schrzanił. To nie powinno sprawiać mi kłopotów, prawda?

    1.    elav <° Linux powiedział

      Dokładny. Jeśli chcesz, aby Twoje LMDE działało płynnie, polecam korzystanie z repozytoriów LMDE. Może jeśli masz Testowanie, ale LMDE nie jest Debianem jako takim.

      1.    Erytryma powiedział

        Nie mam nic przeciwko innym problemom, o ile mam rozwiązanie, w rzeczywistości jest to jeden z powodów, dla których lubię Linuksa bardziej niż Windows, aby móc zmierzyć się z maszyną i nauczyć się poprawiać błędy, które mogą mam, ale też nie chcę powodować nieodwracalnych uszkodzeń i konieczności ponownej instalacji systemu operacyjnego co dwa, trzy ...
        W przypadku wspomnianych wcześniej pakietów, czy są one istotne? Ponieważ aktualizacja libreoffice mówi mi również, żebym je usunął ...

        1.    elav <° Linux powiedział

          Te pakiety są metapakietami, które z kolei mogą (ale nie muszą) odinstalowywać inne pakiety. Odinstalowałem je bez większych problemów.

  3.   Carlos-Xfce powiedział

    Cześć Elav. Fantastycznie, podoba mi się nowe sekcje i odpowiadam na to konkretne pytanie: repozytoria LMDE. Jednak (i ​​niech Courage mi wybaczy!), Nie jestem jeszcze ekspertem i nie wiem, co zrobić z repozytoriami, które tu umieściłeś. Boję się tego dotknąć, ponieważ miałem już problemy, które zmuszają mnie do ponownej instalacji wszystkiego od zera. W każdym razie bardzo dziękuję.

    1.    elav <° Linux powiedział

      Nie martw się. Zobaczmy. Repozytoria, które umieściłem w poście, to te, z których musisz korzystać, jeśli nie chcesz pobierać swoich pakietów z repozytoriów LMDE i aktualizuj w rytmie Debian. Oznacza to, że jeśli chcesz, aby system nie został uszkodzony i nadal działa tak, jak powinien (chociaż nie aktualizuje się tak często), musisz nosić te. Jeśli chcesz stale aktualizować (chociaż niektóre pakiety są związane z LMDE idź do diabła), to używasz tych, które umieściłem w poście.

  4.   David powiedział

    apt-get -t testing install banshee
    Czytanie listy pakietów ... Gotowe
    Tworzenie drzewa zależności
    Czytanie informacji o stanie ... Gotowe
    Nie można zainstalować pakietu. Może to oznaczać
    poprosiłeś o niemożliwą sytuację lub, jeśli używasz dystrybucji
    unstable, że niektóre niezbędne pakiety nie zostały utworzone lub mają
    został przeniesiony z Incoming.
    Poniższe informacje mogą pomóc w rozwiązaniu problemu:

    Następujące pakiety mają niespełnione zależności:
    libc6-dev: Breaks: gcc-4.4 (<4.4.6-4), ale 4.4.5-8 zostanie zainstalowany
    i przytrafiło mi się to ze wszystkimi pakietami, które chcę zainstalować z testów. Jak mogę to rozwiązać ?, Z góry dziękuję i pozdrawiam