¿Problemas con FlashPlayer y Firefox 21+? Acá la solución

Como muchos saben uso Debian, y la instalación de Firefox la hago de forma manual por muchos motivos siguiendo estos pasos.

Sucede que con la salida de Firefox 21, FlashPlayer comenzó a presentar problemas, no de errores, sino de que el navegador no lo encontraba.

Normalmente se podía usar FlashPlayer en Firefox como se explica en este artículo. Pero ya no.

Esto se debe a que con Firefox 21, ya no se usa la carpeta ~/.mozilla/plugins/ para FlashPlayer, sino que la ruta cambió. Ahora la carpeta plugins se encuentra dentro del directorio donde se encuentra instalado Firefox.

Por ejemplo, en mi caso, yo cuando descomprimo el .tar.gz, copio la carpeta firefox en ~/.local/apps/, por lo tanto ahora los pasos a seguir son los siguientes:

1- Descargo la última versión de FlashPlayer para 64Bits:

cd ~
$ wget http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.285/install_flash_player_11_linux.x86_64.tar.gz

2- Descomprimo el .tar.gz:

$ tar xfv install_flash_player_11_linux.x86_64.tar.gz

Esto nos extrae 2 ficheros y una carpeta:

  • readme.txt
  • libflashplayer.so
  • usr/

4- Creamos la carpeta plugins dentro del directorio donde está instalado Firefox, en mi caso sería:

$ mkdir ~/.local/apps/firefox/plugins

En algunos foros he visto que la carpeta plugins si no funciona en esa ruta, debe estar en ~/.local/apps/firefox/browser/plugins

Para que no haya problemas con esto, creamos un enlace simbólico:

$ ln -s ~/.local/apps/firefox/plugins ~/.local/apps/firefox/browser/plugins

5- Copiamos el fichero libflashplayer.so:

$ cp libflashplayer.so ~/.local/apps/firefox/plugins

6- Copiamos el contenido de la carpeta /usr  al directorio /usr:

$ sudo cp -Rv usr/* /usr

Con esto debe ser suficiente. Si por algún motivo sigue sin funcionar, abrimos una nueva pestaña, tecleamos about:config y buscamos el parámetro:

plugins.load_appdir_plugins

Y si está en false lo ponemos en true.

Listo. Siguiendo estos pasos ya tengo funcionando de nuevo FlashPlayer, aunque casi no lo use 😛


30 comentarios

  1.   unodetantos dijo

    Mmm ¿Qué problema hay en usar iceweasel 21 con el paquete flashplayer-nonfree?

    A fin de cuentas es el Firefox 21 con estilo Debian y de esa manera no hay ningun problema.

    1.    eliotime3000 dijo

      Dirás flashplugin-nonfree.

      En iceweasel no hy problemas.

      1.    unodetantos dijo

        Cierto 🙂 es que se me fue la olla ja,ja,ja.

  2.   eliotime3000 dijo

    Dafuq?!
    Yo instalo el flash player usando el script que tiene Debian en el repo contrib, y hasta ahora, no he tenido problemas con el flash player.

    En fin, con Iveweasel me va de maravillas el flash player

  3.   anubis_linux dijo

    Eso no pasa en Chrome jejeje, por eso me gusta tanto jeje

    1.    pandev92 dijo

      el flash de chrome es horrible…

      1.    gato dijo

        lo apoyo

        1.    Krlos dijo

          Yo tambien estoy de acuerdo.

      2.    eliotime3000 dijo

        También yo, por eso es que voy a about:plugins y desactivo el pepper flash player y dejo activo el flash player.

    2.    percho dijo

      yo utilizaba chrome porque me iba mucha mejor flash, pero en la última actualización (estoy en wheezy) comenzó a funcionar mal.
      Por lo menos me terminó de inclinar la balanza hacia iceweasel (con la prueba de youtube html5 me va bastante bien)

  4.   eliotime3000 dijo

    El pepper flash de Google Chrome es pesado al ver videos en Youtube, por lo que prefiero mil veces usar Chromium en vez de usar el Google Chrome (los plugins que tiene integrado son pesados en sí y ralentizan el rendimiento del navegador).

  5.   eliotime3000 dijo

    Y añadiendo que el flashplugin-nonfree es simplemente un script que descarga el flash player de adobe.com a Debian en base a la arquitectura que se haya instalado.

    De todas formas, la gracia está en cómo instalar el flash player de forma manual (probé el firefox 21 y con el flash player instalado desde el script de Debian no hay problema alguno.

  6.   Aarón dijo

    Es extraño que eso no me pasó en fedora cuando actualice de firefox 20 a 21 extraño, pero ahora uso Web de GNOME y en su versión 3.8 soporta flash así que no tengo ese problema, los invito a probarlo, es muy rápido.

  7.   gustawho dijo

    Entonces, ¿este problema aplica sólo para Debian? porque yo no tengo ningún problema.

    1.    gustawho dijo

      Uso Chromium, no GC x)

      1.    eliotime3000 dijo

        Te creo, porque yo también uso Chromium (el nightly build para Windows) y muchas distros no se toman la molestia de modificar el User Agent de Chromium (por defecto, el user agent de chromium siempre dice chrome, ya que es una versión experimental de Google Chrome propiamente dicha).

  8.   tavo dijo

    Yo lo instalo siempre en /usr/lib/mozilla/plugins incluso en esta versión 21…aclaro que uso iceweasel

    1.    eliotime3000 dijo

      Yo soy más flojo, pues uso el paquete “flashplugin-nonfree” de la rama contrib de los repos de Debian y tengo el flash player directamente descargado de Adobe listo para usarse en todos los navegadores.

  9.   eldebiandepepe dijo

    Si tienes un equipo de 32bits con copiar el archivo “libflashplayer.so” en /usr/lib/mozilla/plugins/ debería ser suficiente… Supongo que en un equipo de 64 será igual, pero si mal no recuerdo, en la lista de debian en español leí que alguien tuvo problemas con la instalación de Flash en Wheeze con este último… No se, sería cuestión de mirarlo.

    1.    eliotime3000 dijo

      Yo instalé el flash player de Adobe a través del paquete “flashplugin-nonfree” que se encuentra dentro de los repos oficiales de Debian (específicamente, en contrib). De tener problemas no los tuve, así que pueda ser que a la hora de instalarlo manualmente no haya usado el directorio que se usa para que todos los navegadores (incluyendo el Mozilla Firefox).

      De todas formas, no he tenido problemas con instalar el flash player ni en Iceweasel ni en Firefox.

  10.   Mario dijo

    En firefox 21 hubo un rerdenamiento de los archivos que estan en el tar.bz2. Se creo la carpeta browser y ahora la carpeta “chrome” (no confundir con el navegador) y archivos como mozicon128.png cambiaron su ubicacion a dentro de esa carpeta… obviamente pueden haber problemillas (esta mañana no tenia icono mi acceso directo :P). Igual es extraño poner ejecutables en .local… los tutoriales que he leido apuntaban casi siempre a /opt y ubuntu apunta a /usr/lib, pueda ser esa la causa de error, ya que los plugins siempre andan por lib

  11.   sieg84 dijo

    pues en Fedora y openSUSE no tuve problemas.

  12.   Petercheco dijo

    Es curioso, porque yo no tuve ningún problema con Flash en mi Firefox 21.
    En concreto uso el paquete disponible en los repos de Debian:

    Shockwave flash 11.2.202.285
    Icedtea-web plugin 1.3.2

    Firefox lo instalo fácilmente con:

    Descargo el paquete, descomprimo y copio el contenido a /opt. Después creo el enlace simbólico de /opt/firefox/firefox a usr/bin/firefox y creo el lanzador en el menu de KDE y listo 🙂

    1.    eliotime3000 dijo

      No tuve problemas con instalar “flashplugin-nonfree” en Debian, ya que usando el Flash Player no he tenido problemas a la hora de usar Iceweasel y Chromium.

      A ver si con el OpenJDK y el IcedTea me resulta útil para bajar videos con keepvid.com

      1.    eliotime3000 dijo

        Off topic:

        En la instalación del ZPanel, he cometido el grave error de no haber activado las opciones de web server, SQL Server, DNS Server, file server, mail server y ssh server, ya que el script funciona si están instalados esos componentes (apache, MariaDB…) y a la hora de emularlo en la máquina virtual, se debe usar el adaptador puente para poder así ingresar al panel sin tener que sufrir consecuencias posteriores (como era mi caso).

        1.    eliotime3000 dijo

          PD: Instalen el PHP o si no, les va a descargar un archivo sin extensión. Háganlo.

  13.   jony127 dijo

    Pues no entiendo mucho esto, yo tengo mi firefox en wheezy instalado de forma manual /opt y el flashplugin-nonfree de los repos y todo perfecto después de actualizar a firefox 21.

  14.   juancuyo dijo

    No se porque esa mania de actualizar a cada rato todo, tengo instalado Nero 7 desde el año 2006, el VLC me funcionaba espectacular… hasta que lo actualice, ahora a cada rato me dice que no encuentra el RML (o algo así) y no puede abrir el DVD. Cada día le tengo más bronca a las actualizaciones. Yoono en Firefox era un balazo ahora no se porque cada tanto tengo que volver a cargar los usuarios. Por las dudas Thunderbird y Firefox no los actualizo ni en joda. Estoy deseando poder instalar Debian 7 (Debo comprar otro HD) y tener todo software libre y sin actualizar por años….

    1.    jony127 dijo

      Hombre si no eres de actualizar siempre a la última debian estable te puede venir muy bien o incluso centos. Pero tener software actualizado te proporciona nuevas funcionalidades, mejoras de rendimiento supuestamente, soporte de nuevas características, corrección de bugs esto último para mí muy importante en navegadores web, bueno y en general.

      No tienes porqué tener exactamente la última versión, por ejemplo, en un software para grabar pues no me parece importante o incluso para vlc si las versiones que tienes te van bien, pero para otro tipo de software, como un navegador web, sí es importante.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.