Soluție la eroare: „nu se poate deschide afișajul :: 0.0”

Există mai multe ocazii când vrem să folosim sudo pentru a rula aplicații grafice cu permisiuni administrative, de exemplu: sudo gparted ó sudo delfin

Și mulți vor fi văzut această eroare:

kzkggaara @ geass: ~ / Downloads $ sudo gparted
Nu este specificat niciun protocol

(gpartedbin: 6547): Gtk-AVERTISMENT **: nu se poate deschide afișajul :: 0

Ceea ce împiedică deschiderea aplicației (în acest caz gparted), un pas simplu va rezolva problema this

Trebuie să deschidem un terminal (consolă, bash, shell, oricum vor să-l numească ...) și să introducem următoarele:

echo "" >> $HOME/.bashrc && echo "export XAUTHORITY=$HOME/.Xauthority" >> $HOME/.bashrc && cd $HOME && . .bashrc

Împingem [Introduce] și voila, se va rezolva 🙂

Simplu nu? HAHA.

În ceea ce priveşte


Conținutul articolului respectă principiile noastre de etică editorială. Pentru a raporta o eroare, faceți clic pe aici.

17 comentarii, lasă-le pe ale tale

Lasă comentariul tău

Adresa ta de email nu va fi publicată.

*

*

  1. Responsabil pentru date: Miguel Ángel Gatón
  2. Scopul datelor: Control SPAM, gestionarea comentariilor.
  3. Legitimare: consimțământul dvs.
  4. Comunicarea datelor: datele nu vor fi comunicate terților decât prin obligație legală.
  5. Stocarea datelor: bază de date găzduită de Occentus Networks (UE)
  6. Drepturi: în orice moment vă puteți limita, recupera și șterge informațiile.

  1.   Oscar el a spus

    Mulțumesc prieten, sfat bun și practic.

  2.   alez el a spus

    Nu sunt sigur, dar cred că această eroare va apărea dacă se folosește „sudo gparted” în loc de „gksudo gparted” sau „kdesudo dolphin”, care trebuie să fie ...

    1.    Curaj el a spus

      Cei pe care îi folosiți în Alt + F2, în afară de kdesudo cred că nu este, este kdesu

      1.    Curaj el a spus

        Ca și gksu

    2.    KZKG ^ Gaara <"Linux el a spus

      Da, într-adevăr, apare doar dacă se face cu sudo, dacă este folosit gksu o kdesudo nu va apărea, problema este că cel puțin în Arch nu am opțiunea de a folosi kdesudo, cel puțin nu l-am găsit 🙁

  3.   alez el a spus

    http://aur.archlinux.org/packages.php?ID=14357 😉 Aveți grijă ca comentariile să fie vechi, astfel încât PKGBUILD este foarte depășit. Nu căutați să vedeți dacă se află în depozite.
    Nu este același lucru cu lansarea gksu ca gksudo, deși în scopuri practice este. Este ca și cum ai folosi su sau sudo, operațiunea este diferită; într-una vă conectați la administrator și în cealaltă pur și simplu acordați drepturi unui utilizator. În orice caz, important este să nu-l lansați niciodată ca o transpirație uscată.

    1.    KZKG ^ Gaara <"Linux el a spus

      Nu-mi place să folosesc pachete din AUR hehe, ca să nu mai spun că de multe ori nu pot (vina ISP-ului meu) 😀
      Mulțumesc oricum prieten 😉

  4.   Rafael Laverde el a spus

    Dar a face acest lucru nu este cel mai corect, este mai bine să utilizați kdesu, kdesudo, gksu sau gksudo după caz ​​appropriate
    aici o mică explicație care mi-a venit în minte http://www.kubuntu-es.org/wiki/sistema/por-que-se-debe-usar-kdesu-o-kdesudo-ejecutar-aplicaciones-graficas-terminal-vez-usar-s

    1.    KZKG ^ Gaara <"Linux el a spus

      Salut Rafael, bine ai venit pe site-ul nostru 😀
      Problema cu utilizarea gksu sau kdesudo este că în Arch nu le am, așa că trebuie să apelez la sudo.
      Salutări și sper să vă placă articolele noastre 🙂

  5.   David el a spus

    Am o problemă, dar este atunci când rulez Google Chrome !!
    Există o soluție similară !! ???

    =S

    1.    KZKG ^ Gaara el a spus

      Rulați [Alt] + [F2] și deschideți Google Chrome și primiți această eroare? O_O

  6.   elhui2 el a spus

    Excelent după doi ani m-ați salvat noaptea, în alte site-uri au spus că este necesar să întoarceți sistemul pentru ca Gparted să funcționeze ca superutilizator. : 3

    Mulţumesc.
    Salutări.

  7.   Dante el a spus

    Aceeași eroare mi se pare, dar când încerc să instalez grafic din orice cd bian, cineva îmi poate spune cum să o rezolv?

    Mulţumiri

  8.   Arantxa el a spus

    Ce ar trebui să facă asta? Am aceeași eroare și cred că am greșit lucrurile de la început, am executat următoarele: user @ machine: $ rm -rf /tmp/.X0-lock și când am executat user @ machine: $ Xorg -configure am primit o eroare: /

    Nu știu ce să fac!!

  9.   anz el a spus

    Va multumesc foarte mult!
    În cazul meu, eroarea a apărut când am lansat sudo synaptic.
    Exact acest lucru a apărut:
    Nu este specificat niciun protocol
    Imposibil de inițiat server: Nu s-a putut conecta: Conexiunea a fost refuzată
    (sinaptic: 10216): Gtk-AVERTISMENT **: nu se poate deschide afișajul :: 0

    Și înainte de această eroare aveam probleme care .Xauthority nu exista.
    Debian 9 + Gnome3.

  10.   Gonzalo el a spus

    HAHAAJ vă mulțumesc foarte mult. Dar se dovedește că dacă nu aveți autoritatea .X este inutil.
    Dar tu m-ai îndrumat.

  11.   Edward v. el a spus

    Aveți posibilitatea să utilizați

    «„
    atinge $ HOME / .bashrc
    «„

    în loc de

    «„
    ecou "" >> $ HOME / .bashrc
    «„

    touch creează un fișier gol pentru dvs. dacă nu există sau actualizează marca de timp a fișierului în caz contrar (când există), dar nu modifică conținutul în niciun caz, ci doar data de modificare a acestuia.