Tutorial: Instalați pachetele .tar.gz și .tar.bz2

La început, când începem în Linux și căutăm un program, este normal să găsim un .deb sau .rpm și în multe cazuri găsim programe cu extensia .tar.gz y .tar.bz2Aceste fișiere sunt comprimate și conțin de obicei instrucțiuni pentru instalarea acestuia în afară de program.

Instalarea pentru aceste două tipuri de pachete este exact aceeași

Mai întâi mergem la folderul unde avem fișierul, dacă folderul are mai multe cuvinte trebuie să le punem cu „” sau dacă nu caută foldere cu fiecare cuvânt

folder cd unde se află fișierul cd "folder unde se află fișierul"

În interior dezarhivăm fișierul

tar -zxvf nume de fișier.tar.gz tar -jxvf nume de fișier.tar.bz2

Configurăm

. / Configurare

Facem (compilăm)

face

Acum faceți instalarea

make install

Uneori ne poate da o eroare în ./configure, în acest caz nu are nevoie de compilare și cu executarea avem o mulțime, într-un terminal facem

Cum să
Articol asociat:
Comenzi pentru cunoașterea sistemului (identificarea hardware-ului și a unor configurații software)
numele programului

Sau creăm un lansator.


Conținutul articolului respectă principiile noastre de etică editorială. Pentru a raporta o eroare, faceți clic pe aici.

102 comentarii, lasă-le pe ale tale

Lasă comentariul tău

Adresa ta de email nu va fi publicată.

*

*

  1. Responsabil pentru date: Miguel Ángel Gatón
  2. Scopul datelor: Control SPAM, gestionarea comentariilor.
  3. Legitimare: consimțământul dvs.
  4. Comunicarea datelor: datele nu vor fi comunicate terților decât prin obligație legală.
  5. Stocarea datelor: bază de date găzduită de Occentus Networks (UE)
  6. Drepturi: în orice moment vă puteți limita, recupera și șterge informațiile.

  1.   moskosov el a spus

    wow, +1

  2.   adecvat el a spus

    de fapt, corectul de a dezarhiva este
    tar -zxvf file.tar.gz
    tar -jxvf file.tar.bz2

    iar pentru configurare există o infinitate de opțiuni (în funcție de software) pentru a personaliza instalarea

    ./configure --help

    Cu aceasta vor vedea diferitele opțiuni suplimentare la instalarea unui program.
    Nu toate distribuțiile folosesc / usr / local pentru a instala programe, care ar trebui menționate și.

    Ați uitat să menționați cum să dezinstalați un program instalat în acest fel. Pe lângă definirea optimizărilor pentru fiecare arhitectură.

    Oricum, inițiativă bună, dar ți-a scăpat multe ... prea multe informații pentru a le împărtăși.

    În ceea ce priveşte

    1.    Curaj el a spus

      Este un lucru pe care nu l-am folosit niciodată, majoritatea programelor le găsesc în depozitele oficiale.

      Adevărul despre decomprimare este că a fost întotdeauna bun pentru mine așa.

      L-am scris pentru că mă deranjează pe toți cei care spun „când dezarhivați-l citiți instrucțiunile”.

      Oricum, văd .tar.gz ca fiind ultima soluție, dacă nu există niciunul în pachetul deb / rpm sau în depozite.

      1.    adecvat el a spus

        „Adevărul este că decomprimarea a fost întotdeauna bună pentru mine așa”.
        suntem de acord, nu contest acest lucru, dar nu înseamnă că este un lucru corect de făcut. Nu toate distribuțiile se descomprimă „inteligent”, unele trebuie să adauge mai mulți parametri.

        1.    Curaj el a spus

          Omule, nu e vina mea că există distrosuri subnormale hahahaha

          1.    adecvat el a spus

            SĂRUT omule ... SĂRUT

          2.    Curaj el a spus

            Omule, KISS nu este un idiot, știi deja asta cu Slackware hahahaha

          3.    adecvat el a spus

            xD
            De aceea îți spun asta

            Simplu! = Easy.

  3.   yoyo el a spus

    +1 pentru corect

    1.    Pepe el a spus

      Un tâmpit mai mult decât celălalt. Acești „genii” sunt în afara subiectului.

  4.   Lithos523 el a spus

    Dacă schimbați „make install” la „checkinstall” (îl puteți instala cu aptitude, se află în depozite) va instala programul, dar și:
    -Creați un .deb astfel încât să îl puteți instala în viitoare ocazii
    -Programul instalat va apărea în Synaptic, deci îl puteți dezinstala cu ușurință de acolo

    1.    Curaj el a spus

      Utilizatorii Arch au implicat acest lucru în Aptitude ...

  5.   jelpassenger el a spus

    Îmi pare rău pentru ignoranța mea, dar aplicația extraterestră rezolvă toate aceste probleme?

    1.    adecvat el a spus

      nu, deoarece alien funcționează cu pachetele compilate și tar.gz sau tar.bz2 sunt fișiere comprimate cu codul sursă.

  6.   pandev92 el a spus

    Nu puteți face un tutorial cu privire la acest lucru, de cele mai multe ori, cel puțin pachetele qt sunt compilate în alte moduri, chiar mai ciudate.

    1.    hypersayan_x el a spus

      Exact aveam să spun același lucru.
      Cei care folosesc qmake de la Qt sunt mai mult sau mai puțin așa:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      Și adaug un alt caz care sunt cmakes:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      Sau există altele care trebuie doar să ruleze make && sudo make install.
      Acestea sunt cele mai frecvente cazuri, dar există mult mai multe variante: s

      1.    mcder3 el a spus

        Există uneori când unele aplicații făcute în QT nu aduc makefile-ul. Deci, este timpul să le creați cu următoarea linie:

        qmake -makefile

        În ceea ce priveşte

  7.   jelpassenger el a spus

    Să vedem dacă clarific, când trebuie să folosesc un tar.gz sau un tar.bz2 tot ce fac pentru a genera un .deb sau un all.deb folosind alien este să pun sudo alien install + numele pachetului. Nu este același lucru cu compilarea?

    1.    hypersayan_x el a spus

      Nu, compilarea transformă codul sursă al programului în cod mașină.
      În timp ce ceea ce faceți cu extraterestru este reambalarea, care transformă formatul pachetului unei distribuții în formatul pachetului unei alte distribuții.
      Pentru ao simplifica, este ca și cum ai avea un fișier comprimat în RAR și ai dori să-l convertești în ZIP, ai decomprima fișierul în RAR și l-ai comprima din nou în ZIP, asta face extraterestrul.

  8.   StuMx el a spus

    Compilarea se face în marca, nu în configurare. Fișierul de configurare este un script care verifică dacă sistemul respectă toate dependențele pentru a compila programul, apoi generează fișierul make (care este cel care definește modul în care va fi compilat) în funcție de sistemul nostru.

    1.    Curaj el a spus

      Acum îl elimin deoarece acest articol este deja mult timp de când l-am scris în aprilie sau mai. Nu l-am verificat aproape eliminând un cuvânt rău nimic altceva

  9.   jelpassenger el a spus

    Hi
    Cred că nu mă explic foarte bine. Alien nu numai că transformă un pachet de rpm într-un .deb, dacă luați codul sursă al unui program, fie el gz sau bz2, îl transformă într-un deb autoinstalabil. De aici și întrebarea mea. Sunt pe Linux de scurtă vreme, suportă-mă.

  10.   marca el a spus

    scuză-mi ignoranța, dar acești pași sunt valabili și în Chakra, sau se schimbă ceva ???

    1.    KZKG ^ Gaara el a spus

      Niciun om at
      Ca atare, acești pași sunt aproape un standard în toate distribuțiile, dar nu este 100% sigur că aceștia sunt ÎNTOTDEAUNA pașii de urmat. Așadar, vă recomand să citiți întotdeauna fișierul de instrucțiuni (README de obicei) înainte de a face ceva.

    2.    adecvat el a spus

      așa cum spune @ KZKG ^ Gaara, acest lucru nu este întotdeauna cazul, este un standard care va funcționa pentru toate distribuțiile, atâta timp cât programul este scris în C / C ++

  11.   Carlos-Xfce el a spus

    Când mă voi confrunta cu unul dintre aceste .tar.gz, voi reveni la acest articol. Cât detest astfel de pachete!

    1.    Curaj el a spus

      La naiba, ești suficient de mare pentru a instala aceste pachete HAHAHAHAHA

  12.   VulkHead el a spus

    Vă rog să-mi scuzați lipsa de cunoștințe, această metodă de instalare funcționează și pentru Debian. Pentru că încerc și încerc și îmi dă o eroare.

  13.   Laura Tejera el a spus

    De aceea nimeni nu folosește Linux, pentru a face ceva prost este un truc

    1.    plin de viață el a spus

      Cât de curioși, unele dintre acele prostii pe care le menționezi, utilizatorii „super-dotați” de Windows și OS X nu le pot face sau se tem de ei.

      1.    Laura Tejera el a spus

        ciudat este modul în care oamenii ca tine pot urma un astfel de sistem de operare închis.

        1.    KZKG ^ Gaara el a spus

          Ați evitat să răspundeți la întrebare? … Pot utilizatorii Windows sau genii OS X să facă atâtea lucruri cu sistemul lor pe cât le arătăm pe acest site? 🙂

          Apropo, folosești Ubuntu deci ... despre ce vorbim?

          1.    Laura Tejera el a spus

            păstrează manga-ul mediocru

            1.    KZKG ^ Gaara el a spus

              Suntem mediocri? ... Uff ... LOL!


      2.    Pepe el a spus

        Suntem în anul 2015!
        Cred că nu este necesar să pierzi atât de mult timp studiind pentru a lucra de pe consolă.
        De ce nu folosiți aplicații automatizate pentru acest lucru?
        În orice caz, celor cărora „le place” să scrie comenzile de pe consolă acolo, lasă-i să o facă în continuare, dar în paralel ar fi necesar să existe aceleași comenzi automatizate. Nu vă cer să trimiteți o rachetă pe lună.

    2.    Santiago Luis Bazan el a spus

      Motivele utilizării software-ului liber sunt etica morală. Nu permiteți niciodată ca nimănui să i se refuze libertățile umane

      1.    Pepe el a spus

        Adevărul că sanata „libertății” din programe m-a săturat. Nu ar putea să înceteze să laude un zeu inexistent și să fie puțin mai umili?

    3.    Pepe el a spus

      Ai dreptate Laura, tipii ăștia cu Linux-ul lor o complică până la capăt. În put0 windows lucrurile sunt mai ușoare. Nu degrad Linux, dar nu poate fi faptul că, pentru a instala orice pel0tudes, petreceți ore și ore investigând cum funcționează tar și toată meresunda, astfel încât la sfârșitul zilei să vă blocați cu acel "Linux începător ...".

      Intenționez să folosesc un sistem de operare stabil, dar să nu-mi iau ore libere din producție pentru că trebuie să lucrez, nu am nicio dorință de a deveni „absolvent de Linux”.

  14.   Thanatos el a spus

    Ceva lipsește întotdeauna ... când dau ./configure primesc: configure: error: Intltool-ul dvs. este prea vechi. Aveți nevoie de intltool 0.35.0 sau o versiune ulterioară.

    Ulterior, instrucțiunea make revine: Nu a fost specificată nicio țintă și nu a fost găsit niciun makefile. Înalt.

    make install: Nu există nicio regulă care să construiască ținta `install

    Sunt un începător și este bine să fac cercetări pentru a învăța, dar FUCK, nu poți să-l explici cu pietricele colorate pentru noi dintre noi care suntem noi la Linux?

    1.    ponchu el a spus

      Thanatos am avut o problemă similară și îmi împărtășesc rezultatul:
      (În primul rând, pentru a clarifica că sunt și un neofit în lumea Linux și aventurile mele în acest context cu „aromă” (distro) la Ubuntu este de o săptămână).
      Presupunând că intră în folderul „Descărcări” cu comanda „cd” unde pachetul meu al programului „SoulSeek” cu terminarea „.tgz” se afla în terminal sau consolă:
      „./Configure” mi-a dat o eroare că fișierul sau directorul nu exista
      „Make” a aruncat aceeași eroare ca dvs. ... așa că nu am continuat cu comanda „sudo make install” (sudo se datorează faptului că Ubuntu necesită „Super User și parola lui” pentru a rula această comandă, cu alte cuvinte faceți o instalare) .
      Investigând fișierul dezarhivat anterior, am realizat ceva care ți se poate întâmpla și anume că fișierul dezarhivat era de tipul „fișier executabil” (clic dreapta- proprietăți) și a fost nevoie de 2 clicuri pentru a-l executa.
      Problema dvs. din «./configure» poate fi rezolvată cu o actualizare a pachetelor sau a depozitelor (acești termeni mă încurcă puțin) instalate în Distro, deoarece vă spune că «intItooI» este vechi și aveți nevoie de unul mai nou și cred că că poate acest pachet este cel care se compilează pe distribuția dvs. În Ubuntu o faceți în același terminal tastând „sudo apt-get update” și actualizați toate pachetele din sistem.
      Sper că am fost de ajutor.

    2.    Pepe el a spus

      Așa cum i-am spus Laurei, chestia asta cu Linux durează mult. Mi-a dat același mesaj de eroare ca al tău și sunt ca fantoma din Canterville dintr-un loc în altul și nimic.

      Șeful meu mi-a spus: "Aveți 2 zile pentru a găsi soluția, altfel, ne întoarcem la Windows."

  15.   Jonathan el a spus

    Mulţumiri

  16.   ivan el a spus

    salut, am aceeași problemă, vreau să instalez skype 4.0. În pclinuxOS, am descărcat tar, gz2 și decomprimat și până acolo am ajuns, când fac ./configure îmi spune că fișierul nu există .. unde m-am pierdut sau ce? spune-mi, în pclinuxOS (ultima versiune lansată) este instalat skype, dar este versiunea 2.2 și vreau să instalez 4,
    Trebuie să fac vreun truc pentru a instala în cele din urmă acest lucru? ceva in sinaptic pe care nu il stiu ???
    Sunt nou în acest sistem, am mai încercat alte distribuții și până acum totul este în regulă, cu excepția acestui lucru ..

    salutări

    1.    Pepe el a spus

      Sunt eu sau nu cred că știe cineva aceste întrebări.

    2.    f7eo el a spus

      Bună, a trecut mult timp de la întrebarea ta.

      Vă recomand să descărcați cea mai recentă versiune de Skype pentru Windows (R)
      și că folosiți Wine pentru al rula pe distribuția GNU-Linux.

  17.   ale el a spus

    Salut! Am aceeași problemă: am descărcat cea mai recentă versiune a software-ului central cu extensia tar.gz și când am ajuns la instanța "./configure" am primit o eroare, ca în "make". CE ESTE"?? MULȚUMIRI!! În plus, centrul de software a blocat opțiunea de instalare !!!

  18.   Carlos Rivera el a spus

    Multumesc, m-a ajutat foarte mult !!!!

  19.   michael el a spus

    cum se creează un lansator

  20.   Angi el a spus

    O întrebare, puteți verifica dependențele unui fișier tar.gz înainte de a rula ./configure ???

  21.   joseluis el a spus

    Sunt nou la linux, mi se pare foarte greu să instalez tabletele tar gz gz2 și dacă primesc un deb îi lipsesc dependențele și cu rpm la fel dacă este i586 sau i686 sau i386 și cel mai rău lucru este că nu am internet în casa mea. A vedea atât de multe comentarii contrazicându-te pe unul te încurcă mai rău.

  22.   gabriel yamamoto el a spus

    informații bune, dar unele pachete * .tar.bz2 sunt deja compilate și pentru a le instala trebuie doar să le dezarhivați în orice folder (de preferință / opt, astfel încât să fie disponibil pentru toți utilizatorii) și să faceți un acces direct la binarul din / usr / local / bin

  23.   Gonzalo el a spus

    Foarte bună explicație a modului de utilizare a fișierelor tar.gz. Multumesc foarte mult pentru informatie. Salutări întregii echipe

  24.   juancuyo el a spus

    Nu funcționează pentru mine
    cd / home / ju / downloads / icecat-24.0 ——-> Îmi răspunde
    bash: cd: home / ju / downloads / icecat-24.0: fișierul sau directorul nu există
    ce fac greșit??? Sistemul de operare este Voyager 14.04 LTS (xubuntu) Xfce desktop Gdebi nu se află în meniul de conținut și nici nu sunt sinaptice, dar sunt în meniul de pornire, chiar dacă le deschid, nu recunosc folderele, parcă nu ar exista. L-am dezarhivat în același folder de descărcare. Va fi dezarhivat greșit ????

  25.   claudio el a spus

    Acest tutorial funcționează și pentru .tgz?

    1.    joakoej el a spus

      Nu, .tgz sunt formatul pe care îl folosește Slackware și sunt deja compilate, indiferent dacă l-ați descărcat sau l-ați compilat dintr-un slackbuild

    2.    joakoej el a spus

      Pentru a-l instala trebuie să utilizați installpkg „numele pachetului”.

  26.   asdf el a spus

    Ne pare rău, dar nu rezolvă prea mult problema pentru mine, când spui ./configure și o configurăm, ar trebui să specifici mai multe, nu? dacă doar pun ./configure îmi spune
    bash: ./configure: Fișierul sau directorul nu există

    apoi spui „noi facem”
    Cod:
    Faceți suporterii vedetele spectacolului, evidențiați contribuțiile noilor veniți și distrați-vă! Nu vă fie teamă să colaborați și să acordați credit altor grupuri care se ocupă de probleme similare. Prezentați-vă la cauzele lor, karma este reală!
    Rezultatul meu:
    make: *** Nu s-a specificat nicio țintă și nu s-a găsit niciun makefile. Înalt.

    Faceți instalarea
    make: *** Nu există nicio regulă pentru construirea țintei „instalare”. Înalt.

    Și apoi spui „rulăm programul”
    Cod:
    Numele programului

    De unde știu care este numele sau care este executabil? Este foarte abstract, poate luați de la sine câteva lucruri pe care le veți ști, dar cei care vin să vadă un tutorial s-ar putea să nu știe

    1.    Damian el a spus

      asdf.

      Am investigat și eroarea care apare atunci când dau ./configure se datorează lipsei programului de compilare (cum am putea compila fără a avea un program care să o facă?). comanda de instalare a unui compilator pentru a intra este:

      sudo aptitude install build-essential

      odată instalat, mergem la folderul în care se află fișierul de decomprimat și executăm:

      tar -zxvf nume_program.tar.gz

      Apoi ENTRĂm în folderul de program dezarhivat și dacă acolo executăm ./configure și apoi sudo make install

      Sper că am ajutat!

      Salutări.

      1.    Damian el a spus

        Ne pare rău, am uitat să clarific, în cazul meu pentru a efectua „make” și „sudo apt-get install program” a trebuit să intru în folderul „base” din folderul dezarhivat, tocmai acolo am luat comenzile pentru a compila ( make) și instalarea.

      2.    Carlos el a spus

        îmi dă probleme când folosesc make it spune că nu găsește nimic de construit

  27.   Brenda el a spus

    Îmi pare rău că am această problemă. Execut această comandă, îmi arată o eroare și nu pot crea makefile
    desktop: ~ / Downloads $ tar -jxvf iReport-4.1.3.tar.bz2
    tar (copil): iReport-4.1.3.tar.bz2: Nu se poate deschide: fișierul sau directorul nu există
    tar (copil): Eroarea nu poate fi recuperată: ieșire acum
    tar: copilul a returnat starea 2
    tar: Eroarea nu poate fi recuperată: ieșire acum
    te rog =)

  28.   Aaron el a spus

    Bună ziua prieteni,
    Sunt nou în Linux, totuși, am avut un ușor inconvenient când vine vorba de recunoașterea unui dispozitiv care este un cititor digital biometric, tocmai am căutat pe Google și aparent l-am găsit, totuși, l-am descărcat cu o extensie .tar.gz, încercați Dezarhivați-l într-un dosar, mai multe fișiere au fost dezarhivate dar nu știu dacă după aceea trebuie să rulez altceva sau să lipesc acele fișiere dezarhivate într-un dosar de pe sistem, nu știu, dacă mă ajutați, vă rog, pentru a rula bine procesul, aș fi foarte recunoscător, am instalat Linux Debian 7 pe OS XNUMX. în avans, salutări și vă mulțumesc foarte mult.

  29.   Rufo Lopez Retortillo el a spus

    Folosesc atât Linex 2011, cât și Linex 2013 și cea mai mare problemă pe care o găsesc la instalarea aplicațiilor este că acestea nu sunt încărcate în lista de aplicații din grupul lor (grafică, birou, multimedia etc.) și dacă vreau să creez un lansator nu știu unde Trebuie să merg să găsesc fișierul lansator de aplicații. În ce dosar îl creați? Cum să o facă?
    Când sunt instalate din depozite, lansatoarele sunt plasate în grupul lor, se poate face acest lucru instalând tar.gz așa cum este descris în acest web?
    Multumesc pentru ajutor

  30.   Carlos el a spus

    Vă rog să vă ajut, am un alt sistem de operare numit lps 1.5.5 și nu pot actualiza programul

  31.   Carlos el a spus

    Vă rog să vă spun din nou că nu pot dezarhiva un fișier tar.bz2 Am un sistem de operare numit lps 1.5.5 și nu știu cum să îl folosesc, vă rog să mă ajutați, vă mulțumesc ...

  32.   joscastel el a spus

    după despachetarea fișierului bz2, comanda ./configure NU funcționează deoarece NU există

    1.    joscastel el a spus

      Am ubuntu 14.04LTS

  33.   tu stii el a spus

    Nu înțeleg, în slax .tar.gz merge la cinema, dar în ubuntu nu am cum să compilez

  34.   Raul el a spus

    Care este cel mai bun sistem de operare? cel mai bun sistem de operare este că vă rezolvă problemele.

  35.   Juanzito el a spus

    Oamenii Linux sunt uimitori. Încerc să instalez ZinjaI pe distro-ul LinuxMint nou instalat de cel puțin 5 ore.
    Mă plimb prin toate forumurile pe care le găsesc și, în toate (dar toate, inclusiv acesta), vă oferă jumătate din informații.
    De exemplu, am deschis deja terminalul, dar nu pot pune adresa unde se află fișierul descărcat (care este / home / user / Downloads / zinjai).
    Tot ce primesc este o eroare: "bash: cd: user: Nu există un astfel de fișier sau director.
    Înțeleg că vor să răspândească și să propage utilizarea unui sistem de operare, dar, negând informații sau explicând totul în jumătate, singurul lucru pe care îl vor realiza este că, utilizatori ca mine, care aveau intenția fermă de a trece de la Windows la Linux, renunță și rămâneți cu W7-ul meu, rău, dar util și ușor de gestionat.

    Noroc…

    PS: Ce le-a costat un instalator mizerabil cu o interfață grafică? De ce astăzi, în secolul XXI, ar trebui să continue să folosească ceva similar cu DOS pentru a instala un mic program mizerabil? Băieți ... să văd dacă trăiesc puțin ...

    1.    Ocelot el a spus

      cd ~ / Descărcări / calea scriptului de instalare.

      Un sfat: lipiți cu ferestre. Fiecare sistem de operare este conceput pentru un tip de persoană. Windows este făcut pentru persoanele care preferă să primească totul teren și cu cel mai mic efort posibil și văd că este cazul tău. Există oameni care nu pot sau nu vor să aspire la ceva mai mult decât următorul, următorul, următorul ... acceptă. Nu este rău, pur și simplu trebuie să ne cunoaștem limitările și să ne adaptăm la ele.

      Un alt sfat: dacă ai ști câte lucruri se realizează cu smerenie și folosind două cuvinte precum „te rog”. Te-ar surprinde. Fă-o des.

      1.    Knary el a spus

        Bună Linuxeros.
        Vă mulțumesc foarte mult pentru tutorial, m-a ajutat să instalez driverele pentru adaptorul wifi dwa-131.
        Am o mică îndoială, am făcut totul așa cum se spune mai sus.
        Mergeți la calea fișierului, faceți tar .... și apoi Make, așteptați să se termine și apoi faceți instalarea.
        Până la acel pas nu am primit erori.
        Întrebarea pe care o am este să știu dacă am deja instalate driverele sau trebuie să fac altceva.
        Juanzito .. mergeți mai departe și dați șansa Linux, indiferent de distribuție, am decis să părăsesc Windows 7 acum o săptămână și sunt mai pierdut decât iadul, hahaha, dar citind ici-colo găsești informații care uneori îți sunt dificile Pentru a înțelege, totul depinde de efortul fiecăruia de a dori să învețe și să iasă din monopolul în care Windows te încorporează (este părerea mea).
        Un lucru ... pe terminalul Linux, contează literele mari. 😉

        PS: Trebuie să fac altceva după instalarea Kame. ??

        Mulţumesc mult.
        Vă mulțumesc foarte mult și salutări din Insulele Canare.

      2.    Arcuri el a spus

        Și cine ești tu pentru a spune unui utilizator să revină la sistemul X? Crezi că Richard stallman?

        Sunt de acord cu ceea ce spun în unele comentarii că cel mai bun sistem de operare este cel pe care sistemul îl adaptează utilizatorului și NU invers.

        Personal îmi place Windows .exe pentru că, așa cum spui, nu trebuie să fii un geniu al computerului pentru a instala ceva foarte simplu, cum ar fi un simplu blocnotes; comparat aici în Linux că, dacă nu este în aplicațiile software dedicate, rămâneți la încurcarea secolului cu o tabletă.

        Am ajuns aici căutând și organizând informații pentru a instala programe în Linux, deoarece mă pregătesc să instalez menta pe o mașină productivă și știu că, dacă nu mă pregătesc, nu voi putea instala nimic dacă nu este în depozite.

        Acum „te rog” toată lumea întreabă problema este că nimeni nu le răspunde, de aceea uneori oamenii trebuie să fie agresivi, așa că nu spune prostii.

      3.    Pablo el a spus

        scuze .. dar am apărat întotdeauna utilizarea software-ului gratuit și deschis .. Folosesc calculatoare de 30 de ani .. și am 37 de ani ..
        problema este că, în general, în Linux este perfect ca oricine dorește sau ar trebui să „știe” puțin mai mult pentru ceva simplu, cum ar fi instalarea unui program, o actualizare sau orice altceva ... problema vine în faptul că mulți oameni trebuie să lucreze și să folosească computerul (cu orice sistem de operare) pentru a-și îndeplini sarcina de lucru specifică .. deci chiar dacă durează 10 minute să descarci un .gz și să-l instalezi .. sau dacă așa cum se întâmplă vor trece ore .. sunt minute sau ore de neputință fa-ti treaba si acolo aproape toata lumea ramane fara rabdare ..
        în cazul meu .. la locul de muncă folosesc doar Ubuntu, care este ceea ce este instalat implicit pe PC-uri, deoarece este un centru științific, dar asta mă face să petrec mai multe ore încercând să instalez sau chiar să descifrez cum să fac un soft specific (de exemplu sunt geograf) funcționează .. sau că după orice actualizare a acestuia .. recuperați toate instrumentele deoarece jumătate nu mai funcționează în cadrul unui program ..
        în acest caz specific .. trebuia să văd un webinar / forum la locul de muncă .. și din moment ce folosesc java îmi lipsește semnul că ar trebui să îl actualizez .. ok .. du-te la site-ul java .. găsește fișierul pentru sistemul meu de operare, 14.04 .. uitați-vă la descărcarea și instalarea "" instrucțiunilor "" .. descărcați un .gz și de acolo mai departe .. dezarhivați ... ok, și ... scrie "instalați" .. și voila .. numai că nu s-a putut face nimic cu informatiile acestui post .. ce fac odata ce dezarhivez «jre-blablabla de o viata.gz» ??

  36.   Carlos Fabian Ferra el a spus

    acest lucru nu a funcționat niciodată pentru mine în nici o distribuție

    1.    yukiteru el a spus

      Dacă nu a funcționat pentru tine, este pur Layer 8.

      1.    Yank Carlos el a spus

        Geniu!

  37.   Ignatius Navarro el a spus

    Deoarece îl folosesc foarte ocazional, de fiecare dată când intru aici pentru a vedea cum se face.
    Vă mulțumesc foarte mult pentru că l-ați scris și că nu l-ați șters după atâta timp.

  38.   ramon el a spus

    după cum puteți vedea în synaptic noul pachet instalat dacă vă arată cel mai vechi (stabil în funcție de distro) ¿?

  39.   Jorge el a spus

    totul merge la rahat când ajungi la ./configure nu există cineva care să explice bine pentru când spune că fișierul nu există

    1.    Elvis el a spus

      Încerc să instalez wifi de la broadcom nici ./configure, nici să fac și să nu funcționeze instalarea.

      secvența logică este prima executare ./configure, dar se pare că această instrucțiune se referă doar la un director de configurare și execută un fișier pus acolo, acesta ar trebui să vină în pachetul descărcat de pe broadcom, dar în cazul meu acest director nu este acolo, care ar trebui să efectueze configurarea este o verificare și crearea fișierului Makefile, dar când dezarhivarea pachetului îmi dau seama că Makefile este încorporat, celelalte două comenzi make și make install nu funcționează pentru mine, ar fi pentru că ultima versiune a sistemului de operare elementar nu o acceptă freya bazat pe Ubuntu 1

    2.    Alexandru TorMar el a spus

      Adevarul? Această metodă nu a funcționat niciodată pentru mine și optez întotdeauna pentru pachete .deb sau comenzi de la terminal ... Păcat că nu este nimic clar de instalat .tar.gz

  40.   Elvis el a spus

    Încerc să instalez wifi de la broadcom nici ./configure, nici să fac și să nu funcționeze instalarea.

    secvența logică este prima executare ./configure, dar se pare că această instrucțiune se referă doar la un director de configurare și execută un fișier pus acolo, acesta ar trebui să vină în pachetul descărcat de pe broadcom, dar în cazul meu acest director nu este acolo, care ar trebui să efectueze configurarea este o verificare și crearea fișierului Makefile, dar când dezarhivarea pachetului îmi dau seama că Makefile este încorporat, celelalte două comenzi make și make install nu funcționează pentru mine, ar fi pentru că ultima versiune a sistemului de operare elementar nu o acceptă freya bazat pe Ubuntu 1

  41.   Alexandru TorMar el a spus

    Adevarul? Această metodă nu m-a ajutat niciodată și optez întotdeauna pentru pachete .deb sau comenzi de la Terminal ... Păcat că nu este nimic clar de instalat .tar.gz

  42.   Alexandru TorMar el a spus

    De ce acest tutorial nu este actualizat? Sau fac unul nou?
    Toată lumea se plânge că nu le-a servit și că își are deja anii….

  43.   HECTOR MATOS el a spus

    Bună ziua, vreau ajutor, cu asta pentru a instala pachete .. Am Ubuntu versiunea 15 .. ceva .. Vreau să instalez pluginul Adobe Flash, pentru că este foarte util să îl instalez, deoarece cu Adobe Flash pot intra în câteva pagini web, unde puteți vedea TV și, de asemenea, ascultați radioul .. vă rog, puteți să-mi trimiteți un tutorial pas cu pas .. Nu am multă experiență în linia de comandă, adică folosind un terminal.

    Ajutor..mulțumesc

  44.   Avraam el a spus

    Salut tuturor !!! Dupa ce am citit aproape toate comentariile am cautat un manual Linux si atat ..
    Prietene OCELOTE, acceptă această critică, din punctul meu de vedere umil și nesemnificativ pe care îl împărtășesc cu milioane de utilizatori Windows:

    Mi-ar plăcea să trec la Linux! dar mulți dintre noi ne este imposibil, de ce? s-ar putea să vă întrebați ... pentru că pentru mine computerul este mijloacele pe care trebuie să le realizez, nu este sfârșitul ... Nu știu dacă înțelegeți ce vrem cu toții (și JUANZITO v-a spus bine) este un sistem de operare stabil care ne ajută dezvoltă munca noastră, nu am timp să învăț cum să fac lucruri de bază precum instalarea unui program de pe consolă, totul ar trebui să fie mai intuitiv și mai ușor ... Ca om de afaceri, vă voi spune că managementul pe care îl purtați cu Linux este dezastruos, în loc să ajutați oamenii care fac schimbarea sistemului de operare insistați ca oamenii să mintă cu lucruri care nu îi interesează și blocați singuri schimbarea ... Unul care a programat în asamblare, java, javascript, html, php și xbase vă spune așa ... și îmi atinge nasul trebuind să deschid consola pentru aproape orice.

    Un saludo

  45.   defcon el a spus

    Stamina DOS 6.22 vechi !!

  46.   Erput el a spus

    Te pune să studiezi și să părăsești rahatul ăla de wuendos care funcționează pentru unii, pentru că ei fac puterea ca chei, nu le plătesc, pentru a adăuga insultă celor care au făcut acele chei sunt genii Linux și ar trebui, de aceea Ești ca un tâmpit care discută despre mamahuevadas, oamenilor de afaceri pe care le spun, continuă să-și plătească licența și dacă ceea ce vor este un grajd așa, câștigă timp ce naiba fac scriitori în aceste tutouri, asta este pentru noi dintre cei cărora le plac idioții Linux ... asul

  47.   GENDA el a spus

    Nu este foarte clar pentru utilizatorii începători. De exemplu, spui:
    «Mai întâi mergem la folderul în care avem fișierul, dacă folderul are mai multe cuvinte trebuie să le punem cu" "sau dacă nu caută foldere cu fiecare cuvânt» ...
    orice utilizator va introduce aceste foldere cu «exploratorul» și va redenumi fără să știe numele folderului care îl conține cu ghilimele. Asta din punctul de vedere pe care l-ai citit, «din punctul de vedere al utilizatorului începător.

    Apoi puneți:
    directorul cd unde se află fișierul

    cd "folder unde se află fișierul"
    Din acel moment, utilizatorul a mers deja în nori sau oriunde, pentru că de acum înainte este pierdut în CD-ul cu inițialele, nu clarificați cum ajungeți acolo, un exemplu pas cu pas, începând cu tot ce ... deschideți consola mai întâi .

  48.   GENDA el a spus

    Pentru HECTOR MATOS: pluginul Adobe, Java și altele nu trebuie să fie realizat manual, trebuie să fiți conectat la internet doar o vreme, iar în managerul de actualizare va apărea automat, de acolo va fi actualizat automat, pentru ca Firefox să Opera, iar restul independent ... în mod normal lansatorul este lângă ceasul din bara de start, în mai multe distribuții am văzut că în mod implicit era acolo, nu știu dacă va fi așa în toate.

  49.   max el a spus

    Vă rugăm să fiți mai expliciți, lipsesc multe informații

  50.   mary el a spus

    încercați să actualizați python la 3.x și să faceți make install la finalizare îmi spune că există o eroare:
    zipimport.zipimporterror nu poate decomprima datele zlib nu sunt disponibile face *** eroare de instalare

  51.   f_leonar el a spus

    După dezarhivare pentru a rula ./configure este necesar să introduceți directorul dezarhivat, altfel nu funcționează. Folosesc KDE și am introdus grafic dosarul pe care l-am dezarhivat și acolo am deschis un terminal pentru a executa „make” dar nu funcționează ...

  52.   anonim el a spus

    Am o întrebare, primesc asta:
    manolo @ mxlolo-satellite-c655d: ~ / Desktop $ ./configure –help
    bash: ./configure: Nu există un astfel de fișier sau director
    ce fac…?

  53.   KATSODA el a spus

    Totul bun până când a ieșit ./configurarea bilelor.
    CE VREI SA SPUI CU ASTA !? Nu o explică, vreau doar să instalez a doua viață nenorocită xddd
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Downloads / Second_Life_5_0_4_325124_i686 / configure: Fișierul sau directorul nu există »» »
    Mai bine descarc Windows 10 și iau fundul. (?)
    Ei bine, nu. Dar acesta este unul dintre lucrurile pe care le urăsc despre Linux. Instalarea și rugarea ca programele dvs. preferate să fie compatibile aici este o provocare.

    1.    gatoo_ el a spus

      Nu vă deranjați, domnilor, dar creatorul tutorialului explică perfect ce trebuie să faceți dacă primiți o eroare cu ./configure. Trebuie doar să terminați de citit restul tutorialului (care este de 4 rânduri).

      Mi se pare incredibil că atât de mulți oameni se plâng că nu explică lucrurile când nici măcar nu te-ai oprit să citești.

  54.   vineri el a spus

    Ei bine, mă declar oficial incompetent pentru acest tip de fișiere. Încerc să instalez java și asta este;
    javier @ loft: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    tar (copil): jre-8u151-linux-x64.tar.gz: Nu se poate deschide: fișierul sau directorul nu există
    tar (copil): Eroarea nu poate fi recuperată: ieșire acum
    tar: copilul a returnat starea 2
    tar: Eroarea nu poate fi recuperată: ieșire acum

  55.   Roger deku el a spus

    în linux ubuntu 18.04.01 lts trebuie doar să tastați ./namedelprograma în același folder după ce îl dezarhivați și voila !!!

  56.   jia el a spus

    Foarte bine, a fost foarte util.

  57.   Emerson Goncalez el a spus

    în av linux acest lucru nu funcționează
    Nu știu ce este ciudat; sau de fiecare dată când instalați o distro începeți calea crucii
    vezi cum merge tastatura

  58.   Jose Felix Paisano Morales el a spus

    Bună ziua tuturor, folosesc Ubunto 20 și am consultat această pagină pentru a instala scanerul unui Epson L4150 (am descărcat unitățile de pe http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Am urmat pașii și am folosit „tar -zxvf filename.tar.gz”, când am dezarhivat am folosit
    „$ cd imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb”, care este folderul creat.
    În folderul pe care l-am folosit „./install.sh”, care este ca și cum am folosi „./configure”, sistemul mi-a cerut parola și totul a fost instalat bine.
    Am încercat scanerul meu și a fost minunat, mulțumesc că mi-ați dat instrucțiunile, am putut să-mi folosesc scanerul