Основы программирования с помощью pseint (часть 3)

Это продолжение урока Основы программирования с помощью pseint (часть 2)На этот раз я объясню, что нужно программировать.

ЗАДАНИЕ

Присвоение - это процесс, в котором переменная создается и / или изменяется, ссылаясь на нее с помощью идентификатора, с помощью которого мы можем получить доступ к ее пространству памяти.

синтаксис присвоения:

[variable]<- [expresion];
[variable]=[expresion];

Где [переменная] - это переменная, которая получает значение вычисления [выражение]. Оба действительны, поэтому не имеет значения, какой из них используется (если они правильно настроили PSeInt), но, на мой взгляд, я создаю первый как правильный.

Если [переменная] не существовала до присвоения, [переменная] была создана, если она существовала, предыдущее значение уничтожается, а на его место помещается новое. По этой причине отображение считается деструктивной операцией.

ЧТЕНИЕ

Чтение - это процесс, при котором у пользователя запрашиваются данные или данные для сохранения указанных данных в переменной.

его синтаксис:

Leer variable_1,variable_2,...,variable_n;

где [variable_ {1,2, n}] - это переменные, которые получают значение, указанное пользователем, в случае, если запрашивается более одной переменной, сначала будет запрашиваться первая, затем вторая и так далее. пока не будут получены все значения.

Это тоже деструктивная функция.

ПИСЬМО

Запись - это процесс, при котором на экране записывается строка символов и / или одна или несколько переменных.

синтаксис:

Escribir expresion_1,expresion_2,...,expresion_n;

где [expersion_ {1,2, n}] - символьные строки и / или переменные, которые будут отображаться.

Запись в дополнение к получению данных, которые будут выведены на экран, также получает инструкцию «Без пропуска» или «Не спускаться вниз», которые предотвращают переход строки.

Запись не добавляет пробелов между аргументами, то есть, если вы поставите:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

в этом случае будет отображаться «olamundo», поскольку между «a» и «b» нет символьной строки, указывающей на пробел между a и b, поэтому для правильного отображения она написана следующим образом:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

в этом случае добавить »», которая представляет собой строку символов, в которой есть пробел, который является пространством между «волной» и «миром», а затем он покажет «волновой мир» с пробелом.

ЕСЛИ ТО

Это предложение, которое оценивает данное условие и проверяет правдивость и / или ложность указанного условия, то есть, выполняется ли условие или нет.

Его синтаксис:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Предложение "Else" не является обязательным, в этом случае, если условие ложно, игнорируйте инструкции и продолжайте, как если бы предложение не существовало, в этом случае это будет:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Была ли добавлена ​​фраза «Ошибка» или нет, зависит от потребностей этой программы.

Сегун

Предложение, поскольку оно оценивает строго числовую переменную, которая дает более двух вариантов в качестве опции, это отличается от «Если-то», поскольку предыдущее может дать только 2 варианта.

Синтаксис:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Как вы можете видеть, после «number1» стоит «:» и после этого инструкции, которые необходимо выполнить, помещаются в том случае, если «числовая переменная = number1», во втором примере это «number2, number3», это означает, что если «числовая переменная = число2 или число3», то будут выполняться «инструкции», это полезно, когда две возможности должны выполнять одни и те же инструкции.

Также есть пункт «По-другому», который выполняется в случае, если ни одна из возможностей не реализована.

В ТО ВРЕМЯ КАК

Это повторяющаяся функция, которая сначала оценивает условие, а затем, если оно выполняется, выполняет серию инструкций, затем повторно оценивает условие, и, если оно истинно, снова выполняет те же инструкции и продолжает так, пока условие не станет ложным.

если условие ложно с самого начала, оно никогда не будет выполнено, и если оно всегда истинно, оно будет помещено в бесконечный цикл, чтобы избежать последнего в инструкциях, должно быть что-то, что в какой-то момент фальсифицирует условие, чтобы оно было в состоянии завершить цикл.

его синтаксис:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

ПОВТОР-ДО

Это функция, очень похожая на предыдущую, но в отличие от предыдущей, она проверяет условие в конце, то есть команда будет выполнена как минимум 1 раз, также вместо выполнения инструкции, когда она true, он выполняет его пока. Если условие не выполняется, но если вы хотите, чтобы он выполнялся, пока условие выполняется, используйте «пока» вместо «до».

его синтаксис:

Repetir
[Instrucciones] hasta que [condicion]

ДЛЯ

Этот оператор выполняет инструкцию определенное количество раз для переменной, в отличие от предыдущих, этот цикл изменяет значение рассматриваемой переменной сам по себе, а также имеет очень мощный синтаксис.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

«Переменная» - это переменная, которая получает «начальное значение» и выполняет инструкции, затем добавляет «переменную» плюс «шаг» и снова выполняет инструкции, пока «переменная» не станет равной «конечному значению».

Если удалить «with [step]», то по умолчанию он будет знать, что «step» равен 1, также, если [step] не указан и «начальное значение» больше, чем «final value», он пройдет через обратный порядок, то есть "Шаг" равен -1

ПОДПРОЦЕСС / ФУНКЦИЯ

Поток или функция - это программа внутри другого, и эта подпрограмма получает одно или несколько значений, обрабатывает их и возвращает другое. Его синтаксис

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

где «возвращаемая переменная» - это переменная, которая содержит значение, возвращаемое функцией «имя функции», которая получила параметры «arg_1, arg_2, arg_n» для выполнения этого

ДРУГИЕ

Это функции, которые только дополняют другие и не имеют сложного синтаксиса, поскольку они являются только дополнительными функциями.

Чистый экран

Эта функция очищает экран от любых объектов в интерпретаторе.

Ключ ожидания

Эта функция ожидает, пока пользователь нажмет клавишу, чтобы продолжить выполнение программы.

ожидать Икс {Во-вторых, миллисекунды}

эта функция ожидает время в секундах или миллисекундах, чтобы продолжить выполнение программы

PS: извините за задержку, но я был занят другими делами, поэтому не мог писать


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

10 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Guille сказал

    У вас нет функций для захвата клавиш без остановки выполнения? Для того, чтобы делать что-то с движением, которое более привлекательно для 9-летних детей, хотя игру с палачом тоже может быть интересно запрограммировать.

    Обработать something_digo
    а <-1;
    боковое <-30;
    вниз <-5;
    Пока a = 1 Do
    Чистый экран;
    с <-1;
    строка <- "";
    повторение
    строка <-line + "";
    с <-с + 1;
    Пока c = боковой
    строка <-line + "X";
    с <-1;
    повторение
    Написать " ";
    с <-с + 1;
    Пока c = down-1
    Пишите строку;
    повторение
    Написать " ";
    c 2 Тогда
    вниз <-down-1;
    Конец да
    "s":
    Если ниже <15 Тогда
    вниз 2 Тогда
    латеральный <-lateral-1;
    Конец да
    "d":
    Если боковой <50 Тогда
    латеральный <-боковой + 1;
    Конец да
    «0»:
    а <-2;
    Конец секунд
    Конец пока
    Завершить процесс

  2.   Guille сказал

    Что ж, не получится, если вы пойдете вверх, лучше поменяйте строки 23 и 28
    -23 До c = 15
    +23 Пока c = 18
    y
    -28 Если вниз> 2 Тогда
    +28 Если вниз> 3 Тогда

    1.    xnmm сказал

      Спасибо за вклад, но у него есть некоторые проблемы, такие как то, что вы открываете одно предложение в другом, но оно должно заканчиваться внутри предложения, в котором оно началось, я имею в виду, его нельзя поставить

      Обрабатывать что-то
      а <- 0;
      читать;
      если а не равно 25, то
      пока а не равно 0 делать
      читать;
      Конец да
      конец пока

      поскольку вы видите цикл, начинающийся внутри оператора "if then", но заканчивающийся вне его, что-то подобное невозможно.

      Я все еще ценю вклад
      Завершить процесс

      1.    Guille сказал

        Спасибо, но я думаю, что размещение кода здесь представляет собой большую проблему, потому что я не знаю, как поместить его в тип кода, и он выходит без отступов.

        Программа работает нормально. Переменную «a» я просто использую для выхода из цикла, когда пользователь вводит ноль. Вы можете поставить exit () или break; в условном он смотрит на это, и я сохраняю переменную. Это варианты.

        Привет.

      2.    Guille сказал

        Попробую поменять табуляции на пробелы и метки por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille сказал

        Это полно ошибок импорта из моего кода, я попробую еще раз с вкладками:
        Это будет файл algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille сказал

        Интересно, что комментарий с метками кода съедается, удаляется, все, что находится между ними, например между строками
        повторение
        Написать " ";
        c
        после c идет
        а затем продолжается с 3.
        Абахо
        В целом, ставить по каким кодам ненадежно.

  3.   Guille сказал

    Я меняю символы с присвоения на =, чтобы посмотреть, как это сделать.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille сказал

      Он продолжает поглощать часть кода, тег кода не работает, он должен оставить запись как есть.

      1.    xnmm сказал

        Привет, извини, что не видел, чтобы ты ответил раньше, но хорошо
        так как вы не можете хорошо опубликовать код, потому что вы не отправляете его мне по почте, поэтому вы не так часто обращаетесь к этому вопросу.