Второй шаг по переносу gtk-xfce-engine на Gtk 3 достигнут.

Об этом объявил Ездить Петтер в списке Разработчики Xfce в обширном электронном письме, где он приглашает всех желающих протестировать изменения из его ветки в git (Питер / GTK3).

Я отмечаю некоторые из самых интересных вещей, которые Питер отправил в сообщении, да, оно было переведено мной, поэтому могут быть ошибки.

Второй этап переноса gtk-xfce-engine на Gtk 3 был достигнут. Все текущие темы были перенесены на Gtk версии 3. Они могут быть не на 100% правильными и их можно почистить еще немного. Но цель состояла в том, чтобы получить версию Gtk3 для всех в качестве отправной точки ...

… История говорит нам, что в каждом выпуске у нас появляется новая тема Xfce. Хотя на последнем просто поменяли цвет оконной отделки. Я не создатель тем и не буду пытаться им быть. Может быть, новая тема может быть основана на макете xfce.org…

Без сомнения, это отличная новость. В некотором роде показано, что Xfce Вы можете двигаться к новым технологиям и не останетесь на месте.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

12 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Оскар сказал

    Во время сегодняшнего тестирования Debian он был обновлен до Gtk3, пока без проблем.

  2.   kik1n сказал

    Гениальное.
    Вам просто нужно подождать, чтобы удалить Gnome 3

  3.   Тринадцать сказал

    Как вы отмечали в некоторых своих сообщениях, Xfce уже давно перестал быть легким. В последний раз я использовал его около полутора лет назад, и после входа он потреблял почти столько же ресурсов, что и gnome. Однако верно и то, что многие приложения казались более плавными и быстрыми (особенно при их запуске).

    Если движок Xfce уже работает с библиотеками gtk3, это, несомненно, хорошая новость для его пользователей, поскольку с появлением Gnome3 многие приложения уже нарисованы с помощью этих библиотек, и тем больше и больше (см. Gnome-look). Поздравляю.

    Кстати (для гномеров), при всей шумихе о Unity, Gnome-shell и MSGE-Mute, я думаю, не мешало бы сказать, что если кто-то скучает по «классической» среде Gnome, у меня нет ни малейшего Он сомневается, что Xfce будет его лучшей альтернативой (где, как я помню, Compiz работает очень хорошо).

    привет

  4.   Тринадцать сказал

    Я просто понял, что комментарии уже проходят одобрение (модерацию). Я не знаю, с каких пор блог работал таким образом, но я хотел бы спросить вас о причинах такого решения.

    привет

    1.    КЗКГ ^ Гаара <"Linux сказал

      Комментарии по умолчанию модерируются, по крайней мере, первые 3 или 5 комментариев. То есть, когда пользователь X с данными, никогда ранее не появлявшимися в комментариях сайта, эти комментарии всегда должны быть одобрены, это мера против СПАМА. Например, Eduar2, имеющий большое количество одобренных комментариев, не нуждается в одобрении для других, потому что его комбинация данных (Ник + Электронная почта + Веб-сайт) классифицируется как разрешенная, очевидно, в вашем случае вы изменили некоторые данные, и поэтому WordPress поместил ваш комментарии в модерации, как если бы вы были совершенно другим пользователем, чем «Тринадцать»

      1.    Eduar2 сказал

        😀 да, я не думаю, что у меня так много комментариев. вы преувеличиваете.

  5.   Йойо сказал

    Выносливость XFCE 😉

  6.   Eduar2 сказал

    Не по теме !! Кто-нибудь знает, если страница GSExt https://extensions.gnome.org/ есть проблема или это только я что-то напортачил.

    1.    КЗКГ ^ Гаара <"Linux сказал

      Я думаю, что прочитал кое-что из этого в вашем списке адресов электронной почты, я думаю, что вас забанили за тролль и бейсболист ... ХАХАХА

      1.    Eduar2 сказал

        Нет, я решил сделать новую установку, чтобы попробовать E17, enlightenment 17, о котором я не знаю, но пакеты сообщества несколько забыты (те из e17) имеют некоторые уродливые ошибки, поэтому установите xfce и удалите его, а затем установите gnome .

        И все было идеально, поэтому я сделал это красиво и после того, как все сделал, потому что у меня беспорядок с сайтом расширений, чего несколько дней назад с моей другой установкой со мной не произошло. Чего-то не хватает или что-то меня беспокоит.

        Итак, у меня есть 3 варианта (они оба нравятся мне одинаково), первый из них решит эту проблему >>> ((gnome-shell: 2033): libsoup-WARNING **: не удалось установить учетные данные SSL из '/ etc / ssl / certs /ca-certificates.crt ')
        ((gnome-shell: 2033): GLib-Net-WARNING **: не удалось загрузить базу данных файлов TLS: не удалось открыть файл «/etc/ssl/certs/ca-certificates.crt) Более или менее он у меня уже есть , второй - установить gentoo с E17, а третий - веселиться до нового года; D.

        Третий - тот, который меньше всего привлекает мое внимание pt geek, которого я сделан.

        1.    elav <° Linux сказал

          Это происходит придумывать. Мой босс всегда говорит: Если что-то работает, не трогайте LOL

  7.   Ren сказал

    Хай раз без комментариев 🙂
    Отлично, я считаю, что это очень хорошо, и я лично выделяю способ, которым разработчики xfce управляли проектом, поскольку это постоянный, но не спешный процесс, и под этим я подразумеваю качество программного обеспечения, которое они предоставляют сообществу. Теперь, когда xfce почти перенесен на gtk3, он также проявляет интерес к тому, чтобы быть в курсе новых технологий, которые, несомненно, принесут только пользу проекту.