Как установить AceStream в Linux и не умереть, пытаясь

Те из нас, кто любит спорт и не имеет доступа ко всем текущим спортивным каналам, обычно сталкиваются с проблемой, заключающейся в том, что для получения удовольствия от него мы должны использовать различные страницы, которые передают онлайн-матчи, большинство из них просят установить AceStream, который, как правило, немного сложно установить в Linux.

В этом руководстве мы научим, как установить AceStream в Linux не умирая в попытках, предлагая решения наиболее распространенных сегодня проблем. Вы несете полную ответственность за его использование и доступ к контенту.

Что такое AceStream?

AceStream является мультимедийная платформа довольно новаторский, который поднял воспроизведение аудиовизуальных материалов в Интернете на более высокий уровень. Для этого реализован универсальный менеджер загрузки мультимедийных файлов, в котором используются самые передовые технологии P2P, гарантирующие эффективный процесс хранения и передачи данных.

Программное обеспечение Ace Stream предлагает нам ряд преимуществ, среди которых мы можем выделить:

  • Возможность просмотра онлайн-трансляций (ТВ, кастомные стримы, фильмы, мультфильмы и др.) С высоким качеством звука и изображения.
  • Слушайте музыку онлайн в формате, не теряющем в качестве.
  • Просматривайте торренты онлайн, не дожидаясь полной загрузки.
  • Просматривайте контент на удаленных устройствах (Apple TV, Chromecast и т. Д.) По таким протоколам связи, как AirPlay, Google Cast и другие.
  • Обеспечивает интеграцию с различными приложениями. Установите AceStream в Linux

Как установить AceStream в Linux

Чтобы установить AceStream в Linux, мы должны выполнить различные шаги в зависимости от используемого вами дистрибутива, мы сосредоточимся на Arch Linux и Ubuntu, но мы надеемся, что в будущем мы сможем установить его на другие дистрибутивы.

Установите AceStream в Arch Linux и производных

Основная причина, по которой я написал эту статью, заключается в том, что у многих возникли проблемы с установкой AceStream на Arch Linux, Antergos, Manjaros и производных, основной причиной является то, что pkgbuild плагина acestream-mozilla-плагин Выдает ошибку при установке, решение предельно простое.

Мы собираемся установить acestream-mozilla-плагин который также установит нас acestream-двигатель y acestream-player-data какие пакеты необходимы для воспроизведения AceStream из firefox.

Прежде всего, мы должны открыть терминал и выполнить следующую команду:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Это устранит проблему проверки, которая не позволяет установить зависимость, необходимую для установки. acestream-mozilla-плагин.

Затем выполняем следующую команду

yaourt -S acestream-mozilla-plugin

В многократных случаях нас спрашивают, хотим ли мы установить различные зависимости, мы должны сказать всем «да».

Установите AceStream на Ubuntu и производные

Установите AceStream на Ubuntu 14.04 и производные

Для пользователей ubuntu и производных до версии 14.04 установка AceStream будет довольно простой, им достаточно будет выполнить следующие команды из терминала:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Установите AceStream на Ubuntu 16.04 и производные

Те, кому придется немного побороться, - это пользователи Ubuntu 16.04 и производных, поскольку acestream не поддерживает эту версию, но благодаря этому статья, Мне удалось его установить.

Первое, что мы собираемся сделать, это загрузить и установить некоторые зависимости, которые вы не сможете загрузить из официальных репозиториев, убедитесь, что вы установили те, которые подходят для архитектуры вашего дистрибутива:

64-битная архитектура:

  1. Скачать и установить libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb вы можете сделать это по следующей ссылке: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Скачайте и установите в том порядке, в котором представлены следующие зависимости:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Вы можете скачать каждый из них по следующей ссылке: https://drive.google.com/folderview?id= … e_web#list

32-битная архитектура:

  1. Скачать и установить libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb вы можете сделать это по следующей ссылке: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Скачайте и установите в том порядке, в котором представлены следующие зависимости: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Вы можете скачать каждый из них по следующей ссылке: https://drive.google.com/folderview?id= … e_web#list

Затем мы должны продолжить обычную установку AceStream, как мы делали для версии 14.04, открыть терминал и выполнить:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

В некоторых случаях необходимо запустить службу acestream-engine.service, для этого из терминала выполняем следующие команды:

systemctl start acestream-engine.service systemctl включить acestream-engine.service

Мы надеемся, что с помощью этого руководства вам понравится этот отличный протокол передачи мультимедиа, который использует все возможности технологии P2P.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

41 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Хулио Сезар Кампос сказал

    Хорошо, пост, но, по крайней мере, в Archlinux, и это был мой случай, вам нужно: "systemctl start acestream-engine.service" и "systemctl enable acestream-engine.service" для его работы.

    1.    Lagarto сказал

      Вы тестировали его в firefox или использовали другой браузер?

  2.   UserDebian сказал

    Кто-нибудь знает, как заставить его работать на Debian 9?

  3.   Хулио Сезар Кампос сказал

    Firefox на Archlinux

  4.   gecoxx сказал

    Не знаю, был ли опубликован мой предыдущий комментарий ... Повторяю! Не знаю, сколько часов требуется на выполнение этой проклятой команды в терминале, я поставил –noconfirm, и в конце концов это не сработает !!
    очередной бесполезный пост!

    попытка установки на Манджаро

    1.    Lagarto сказал

      Уважаемый, у вас это не сработало, у меня это сработало отлично, в любом случае попробуйте выполнить эти 2 команды:
      "Systemctl start acestream-engine.service" и "systemctl enable acestream-engine.service"

  5.   Хосе сказал

    хорошо

    Мне удалось сделать все шаги без проблем. Но при попытке запустить службу с терминала я получил два сбоя;
    systemctl start acestream-engine.service
    Не удалось запустить acestream-engine.service: модуль acestream-engine.service не найден.
    systemctl включить acestream-engine.service
    Не удалось выполнить операцию: нет такого файла или каталога

    1.    Густаво сказал

      То же самое произошло и со мной. терминал пересылает мне эти команды с этими ошибками.

  6.   Хуан М сказал

    Большое спасибо за пост! Если вы используете 16.10-битную версию Ubuntu 64, вы не сможете установить «acestream-player-data_3.0.2-1.1_amd64.deb». Они должны сначала загрузить и установить эти пакеты:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Возможно, нужна какая-то другая зависимость, которая есть в репозиториях.
    Привет!

  7.   миль сказал

    Хорошо.
    Плагин acestream-mozilla-plugin перестал работать в Firefox 52, как и многие другие плагины NPAPI.

  8.   Darco сказал

    Еще один очень хороший и простой вариант - использовать докер и не зависеть от вашей операционной системы. Используя aceproxy, вы можете воспроизвести его -

    Я написал небольшой учебник и сценарий, чтобы облегчить выполнение.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   Дэвид Мартин сказал

    В части установки из Ubuntu 16.04, когда вы говорите скачать и установить эти файлы, как вы их устанавливаете? Когда я загружаю и распаковываю их, некоторые из них представляют собой только файл libreoffice, а другие я не знаю, как их «установить»
    Заранее спасибо и привет.
    Давид.

  10.   вафе сказал

    Либо ключи снова не работают, либо в пакетах какая-то ошибка, но в arch и manjaro установить невозможно.
    При попытке установить зависимость (qwebquit) или что-то в этом роде он зацикливается, и выхода нет.
    Кто-нибудь нашел решение?
    спасибо

    1.    Александр сказал

      Здравствуйте, для установки в arch linux необходимо сделать следующее:
      -Установите пакет acestream-launcher из yaourt с помощью yaourt -S acestream-launcher (пакет, который мы собираемся включить в следующий раз, автоматически загружается вам)
      -Включаем acestream-engine.service, входим в терминал и в режиме ROOT ставим следующее
      -systemctl запустить acestream-engine.service
      -systemctl включить acestream-engine.service
      После этого перезагрузил компьютер, не знаю, будет ли это нужно но на всякий случай
      -Этого должно быть достаточно, но в последних обновлениях Arch они что-то облажались, и это не работает, поэтому они искали временное решение, которое заключается в загрузке файла, оно следующее:
      https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      источник: https://aur.archlinux.org/packages/acestream-launcher/ (в комментариях)
      после загрузки мы идем в терминал и переходим в папку, в которую мы его загрузили,
      Мы приступаем к его установке с помощью sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz 'и все, он должен идти, в первый раз он никогда не идет, поэтому я нажимаю второй раз, в первый раз всегда выдает ошибку, вот и все

      PS: поясните, что sudo pacman -U, а не -S, потому что это локальный пакет, полученный из makepkg

      1.    вафе сказал

        Большое спасибо за ваш интерес.
        Я пробовал это так много раз, что уже знаю зависимости и комментарии к пакетам наизусть при установке с помощью yaourt. Я собираюсь последовать твоему совету с лаунчером и посмотреть, повезет ли мне. Я скажу тебе.
        Я повторяю свою благодарность

        Felipe

        1.    вафе сказал

          Так или иначе не работает. Я пробовал использовать ссылку, которую вы указали в комментариях, но она не решает проблему, она распознает ссылку, дает мне возможность выбрать программу, я выбираю acestream-launcher, но VLC не открывается.
          В консоли он дает мне следующий ответ.

          Файл «/usr/lib/python3.6/site-packages/psutil/инициализации.py », строка 1231, в _send_signal
          os.kill (self.pid, сигн)

          Придется ждать новых обновлений.
          Спасибо за вашу помощь.

  11.   вафе сказал

    После нового обновления ответ в консоли следующий.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Двигатель Acestream работает.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | ошибка при запуске
    Traceback (последний последний вызов):
    Файл «core.c», строка 1590, в
    Файл «core.c», строка 144, в
    Файл «core.c», строка 2, в
    ImportError: невозможно импортировать имя __m2crypto
    Ошибка аутентификации в Acestream!
    Media Player не работает ...

    Мы улучшаемся, теперь он распознает acestream, но libcrypto продолжает бороться.

    1.    вафе сказал

      Я пробовал установить пакет, который вы рекомендуете в присланной вами ссылке.

      https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      И это эффективно решает проблему, открывается vlc и работает Acestream.
      Большое спасибо за Вашу помощь-

      1.    Александр сказал

        Здравствуйте, извините за задержку, было очень странно, что у вас не получилось, когда это произошло, я нахожусь в плазме Arch, я рад, что это помогло вам, вот для чего мы

        В другом дистрибутиве, который у меня есть, это Fedora, у меня есть Wine, эмулирующий acestream для Windows xD, на случай, если вы перейдете в другой дистрибутив или в тот же Arch, меня удивляет то, что даже в Debian нет этих пакетов ...

      2.    производитель деликатесов01 сказал

        Здравствуйте а файл как он установлен Я еще новичок, приветствую

        1.    вафе сказал

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Он помещает это в комментарии выше

  12.   Chemabs сказал

    Вчера я установил его как snap-пакет в Kde Neon 5.8 и был поражен тем, насколько просто и быстро он у меня сработал. Было бы неплохо, если бы вы обновили статью, потому что здесь нет сравнения, процесс намного упрощен.

    sudo apt install snapd → установите систему управления пакетами snap (если она у вас не установлена)
    snap find acestream → чтобы убедиться, что у нас есть программа в репозиториях (она должна быть у всех производных ubuntu)
    sudo snap установить acestreamplayer

    привет

    1.    Антонио Манзано сказал

      Вы правы. Я только что установил его в kubuntu 17.10, так как метод, который здесь появляется, совершенно невозможен. Большое спасибо

      1.    папа сказал

        не действует для архитектуры i386

    2.    sie9k сказал

      Это был единственный способ установить его на Lubuntu 16.04.4, но у меня нет возможности сохранить файл конфигурации, и мне нужно настроить параметр для работы вместе с Serviio. Есть идеи, как это исправить?

  13.   Хосе Антонио сказал

    Очень хороший пост, обязательная к прочтению веб-страница для новичков в Linux.

  14.   Питер новичок сказал

    Как бы вы установили его для AntiX 16 (это дистрибутив linux)?

    Я пробовал как Arch Linux, так и производные, но я такой новичок, что, должно быть, ошибаюсь

  15.   Александр сказал

    Здравствуйте, с пакетами sna, которые коллега выше комментирует в комментарии, стало проще не только для этих дистрибутивов, но и для многих. Дистрибутивы, совместимые с этими пакетами, находятся здесь:
    https://snapcraft.io/

    В Debian это было бы так:
    -sudo apt install snapd
    -sudo snap установить ядро
    -sudo snap установить acestreamplayer
    В Arch и производных:
    -sudo pacman -S snapd
    -sudo systemctl enable –now snapd.socket
    -sudo snap установить acestreamplayer

    В Arch (плазма) мне пришлось перезапустить, чтобы появились установленные пакеты, если они не появляются, вы уже знаете, что делать.

    На ubuntu и производных, я думаю, это будет похоже на партнера, который установил его выше в комментариях с KDE neon.

    Любопытно, что в Gnome с Debian он выглядит довольно некрасиво и плохо интегрируется с GTK, но в плазме Arch он интегрируется довольно хорошо, важно то, что это видно за пределами эстетики.

    1.    Уильям сказал

      это установит вам acestream-engine?
      Не я

      1.    Александр сказал

        Привет, нет, он не устанавливает его, и в этом нет необходимости, с пакетами snap все покрытые зависимости уже пришли, он должен работать да или да.

    2.    txuber сказал

      Привет, Алехандро, посмотри, сможешь ли ты мне помочь
      [txuber @ manjaro ~] $ sudo systemctl enable –now snapd.socket
      Не удалось включить модуль: файл модуля \ xe2 \ x80 \ x93now.service не существует.
      на Manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Александр сказал

        Привет, Manjaro в том, что это не чистый Arch, и все может немного измениться, возможно, он уже включен, и в этом нет необходимости, я полагаю, вы уже пытались пропустить этот шаг ...

  16.   Debian сказал

    Что делать после установки? Поскольку ace-player не установлен, я не знаю, как заставить его работать.
    Кто-нибудь, помогите мне, пожалуйста?

    1.    вафе сказал

      Если вы установили acestream-launcher, при нажатии на ссылку acestream спросит вас, с помощью какого приложения вы хотите открыть ссылку, вы скажете, что с помощью VLC, и это то, что будет выполнять функции ace-player.

      1.    Debian сказал

        Привет. Прежде всего, большое спасибо за вашу помощь. Я комментирую. Я установил пакет snap acestream в Debian 9 с помощью gnome. Находясь в arenavisión, чего я и хочу, я нажимаю ссылку acestream, и появляется окно, которое предлагает мне два варианта: первый - acestreamengine, который, если я нажимаю на него, ничего не делает, а второй - выбираю другое приложение, я даю ему выбрать но установленные приложения не открываются, открывается моя домашняя папка, поэтому я не знаю, как выбрать vlc.

        Приветствие.

        1.    Александр сказал

          С acestream-launcher все идет не очень хорошо, вам лучше установить с пакетом Snap, как я объясняю в своем комментарии выше.

  17.   Питер новичок сказал

    Я пытаюсь установить пакет snapd, но мне не удается:

    sudo apt install snapd
    Чтение списка пакетов ... Готово
    Создание дерева зависимостей
    Чтение информации о статусе ... Готово
    E: не удалось найти пакет snapd

    что я делаю?

  18.   Alf сказал

    Большое спасибо, это одна из программ, которые я использовал в Windows, и я хотел, чтобы она была в Linux.

  19.   Оскар сказал

    Спасибо Chemabs и Alejandro! Идеально подходит для Ubuntu 17.10
    sudo apt install snapd
    быстро найти acestream
    sudo snap установить acestreamplayer
    Вот и все!
    Невероятно то, что вы заходите на официальный сайт, и они отправляют вам сообщение на своем форуме с 2014 года! И в котором упоминается только Ubuntu 13.04!

  20.   Марко Барриа сказал

    хорошо, как говорится в предыдущих комментариях, отлично работает со snapd в арке:

    sudo pacman -S snapd
    sudo systemctl включить snapd.socket
    перезагружать
    sudo snap установить acestreamplayer
    перезагружать

    и готово:

  21.   Мчавес сказал

    привет, а есть ли способ установить поток ace, не будучи программистом ... как это делается с окнами