Обновите ядро ​​до OpenSUSE 13.1

Что ж, как многие должны знать, новая версия OpenSUSE поставляется с несколько устаревшим ядром linux-3.11-6, поэтому для обновления его через репозитории вам необходимо выполнить следующие шаги:

Они входят в вашу консоль и входят как суперпользователи.

В той же консоли введите следующее
zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard/Kernel:stable.repo

Стоит отметить, что когда они заканчивают установку репо, они обновляют все с помощью

zypper update

и они дают мне довериться keyrepo, войти в YaSt и перейти в Software Management.

Яст

Когда они вошли, как всегда, они использовали поисковую систему, чтобы найти свое ядро, они увидят, что могут найти несколько версий

Ядро 1

ванильное ядро

Vanilla (оригинальное ядро, оно взято с kernel.org), desktop (не рекомендуется, его название говорит само за себя, но когда я установил его на свой компьютер, он оставил меня без работы всего USB, следовательно, без мыши или клавиатуры) и по умолчанию (это тот, который создается OpenSUSE для любого устройства, и тот, который я рекомендую).

Также этот Xen, который они могут использовать, когда они находятся в уже установленной виртуальной машине, они закрывают все и дают перезагрузить систему.

После перезапуска системы, если вы перейдете к расширенным параметрам, вы увидите, что у вас есть новые параметры ядра linux_3.12.2-1, а когда вы выполните uname -r на своей консоли, вы увидите, что ваш действительно установлено новое ядро:

Uname-р


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

16 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Торзан сказал

    Один вопрос, остается ли новое ядро ​​первым вариантом по умолчанию при загрузке?

    1.    Illukki сказал

      Привет, Торзан, обычно при обновлении до нового ядра он остается при первой загрузке grub. Привет.

      1.    Торзан сказал

        Благодарю вас!

    2.    Freebsddick сказал

      правда в том, что куда бы вы ни поместили новое ядро, у вас есть возможность изменить его вручную. это не так уж сложно правда

  2.   Curefox сказал

    'OpenSUSE поставляется с несколько устаревшим ядром linux-3.11-6'
    Не поймите меня неправильно, но сказать, что это устаревшее ядро, неправильно.
    Теперь оказывается, что если у вас нет последнего ядра из духовки, мы устарели или, как другие говорят, устаревшие.
    Ущерб, который наносит версияит.

    1.    Фега сказал

      И видя, как Ubuntu или другие дистрибутивы приносят версии намного более "устаревшие", потому что предпочтительнее выбирать устаревшие и стабильные перед последним обновлением и сталкиваться с проблемами

    2.    Паблейтор сказал

      Не то чтобы это плохо, но, учитывая стабильность suse и улучшения, которые внесло ядро ​​3.12 за последнее время, не очень безумно думать об его обновлении, я обновляю его, и по умолчанию он работает как шарм

      1.    eliotime3000 сказал

        Лучше, я рекомендую вам использовать Arch, чтобы вы не жаловались на устаревание.

        1.    Паблейтор сказал

          пробная арка, мне, честно говоря, это не нравится, у меня скорость соединения 8 МБ / с, чего должно быть более чем достаточно, чтобы загрузить среду KDE примерно за 20 минут, что два раза, которые я тестировал, я прибыл вовремя, больше, чем если бы он был в w $, и он также очень чувствителен, не говоря уже о том, что я никогда не мог смонтировать лампу, даже с xampp, я всегда выдавал ошибку в базе данных, когда я хотел запустить phpmyadmin, кроме того, что это Дело не в том, что я жалуюсь на устаревание, мне, как и многим пользователям, нравится идея просто обновить ядро, но не более чем ядро, потому что это означает большую безопасность и стабильность в системе, потому что сообщество уделяет больше внимания последнему стабильному ядру, чем предыдущим

          1.    eliotime3000 сказал

            Что ж, в Arch Linux (или в этом блоге) вы также можете взглянуть на установку Arch Liinux. В KDE вы должны использовать метапакет KDE-Meta, так как он позволяет вам выбирать, какие важные компоненты вы хотите установить на свой компьютер. То же самое верно для Debian и / или его преемников.

            Теперь, когда дело касается ядра, я использую ядро ​​3.2 своего Debian Wheezy. В случае возникновения форс-мажорных обстоятельств (эксплойты, вредоносное ПО из преступного мира) я бы обновил его. Для LAMP гораздо проще управлять Debian.

          2.    Freebsddick сказал

            Если вы не можете выполнить необходимые настройки, это не потому, что программное обеспечение, представленное в Arch, неправильное, а скорее потому, что это серьезный случай уровня 8.

          3.    eliotime3000 сказал

            @freebsddick:

            Правдивая история.

  3.   jecale47 сказал

    Спасибо PablEitor, отличный репетитор, моя машина была готова.

  4.   Heribetocha сказал

    Влияет ли это, если у меня установлен виртуальный ящик?

    1.    sieg84 сказал

      да, придется заново переустанавливать.
      то же самое с драйверами NVIDIA / AMD

  5.   Ugerjose сказал

    отличный пост, я уже обновился, но wifi с новым ядром меня не узнает, что мне там делать? с предыдущим да