Установите GIMP 2.8 на Debian Testing (Wheezy)

Благодаря компе Йойо мы можем установить Gimp 2.8 руководствуясь учебником, который мы можем найти в ссылку. Шаги просты:

Установка необходимых зависимостей:

Открываем терминал и ставим:

$ sudo aptitude install intltool libpng12-dev libglib2.0-dev libatk1.0-dev libpango1.0-dev libfontconfig1-dev libcairo2-dev libgtk2.0-dev libtiff4-dev python-gtk2-dev libatk1.0-dev librsvg2-bin libwebkit-dev librsvg2-2.0-cil-dev libjasper-dev liblcms-dev libexif-dev libwmf-dev python2.7-dev

ГЛАЗ: Это установит для нас несколько зависимостей MONO, поэтому, если вам не нравится эта технология, вы можете закончить руководство 😀

Нам нужно скомпилировать Бабл и Гегл потому что версия, которая есть в репозиториях Тестирование ниже этого Gimp 2.8 нуждается в.

Компиляция необходимых библиотек:

$ wget ftp://ftp.gtk.org/pub/babl/0.1/babl-0.1.10.tar.bz2
$ tar -xvf babl-0.1.10.tar.bz2
$ cd babl-0.1.10/
$ ./configure
$ make
$ sudo make install

$ wget ftp://ftp.gimp.org/pub/gegl/0.2/gegl-0.2.0.tar.bz2
$ tar -xvf gegl-0.2.0.tar.bz2
$ cd gegl-0.2.0/
$ ./configure
$ make
$ sudo make install

Удаляем Gimp 2.6

$ sudo aptitude purge libgimp2.0 gimp gimp-help-en gimp-help-common gimp-data libgimp2.0

Компилируем и устанавливаем Gimp 2.8

$ wget ftp://ftp.gimp.org/pub/gimp/v2.8/gimp-2.8.0.tar.bz2
$ tar -xvf gimp-2.8.0.tar.bz2
$ cd gimp-2.8.0
$ ./configure
$ make
$ sudo make install

Готов. Должно работать, хотя если не запускается канитель Используя значок в меню, мы можем решить это так:

Добавляем в наш файл ~ / .bashrc следующие строки:

LD_LIBRARY_PATH=/usr/local/lib
env LD_LIBRARY_PATH="/usr/local/lib" gimp
export LD_LIBRARY_PATH

Хотя, честно говоря, не пробовал. Решение мне дала компа Йойо и они могут глянь сюда.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

46 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Леоделакруз сказал

    Я использую его с новым всплеском и, наконец, в режиме одного окна! 😀

  2.   Жискар сказал

    Улучшения выглядят впечатляюще, но я дождусь PPA. Как новый XFCE 4.10
    ????

  3.   Alba сказал

    у меня проблема

    «Dimentio gimp-2.8.0 # make
    make: *** Цель не указана и make-файл не найден. Высоко."

    ; ТО;

    1.    Alba сказал

      хорошо ... Я думаю, что могу увидеть, что происходит, когда я выполняю шаг gegl-0.2.0, когда я делаю "make", у меня возникает много ошибок и много "выходов из маски фуланы", то есть ... Я не знаю, что происходит, что я не могу установить gegl -0.2.0, говорит что-то подобное, что невозможно создать make-файл или что-то подобное; ^;

  4.   правильный сказал

    elva Я настоятельно рекомендую создавать пакеты и не использовать метод make && make install, потому что apt не может справиться с этими установками, и эта вещь LD_LIBRARY_PATH может в конечном итоге вызвать головокружение у вашего диспетчера пакетов.

    привет

    1.    Мужество сказал

      смешно Эльва хахаха

  5.   Роджертукс сказал

    Он уже есть в репозиториях Arch !!

    1.    КЗКГ ^ Гаара сказал

      Дай мне Бог сил избежать соблазна вернуться в Arch .. LOL !!!

      1.    sieg84 сказал

        Раздел в 10-15 ГБ и у вас уже есть Arch без удаления debian? Почему бы этого не сделать?

        1.    pandev92 сказал

          Мне кажется глупым устанавливать пакет ...

  6.   Лукасматиас сказал

    Какое облегчение режим единого окна, в Unity он был переработан с версией 2.6

  7.   Йойо Фернандес сказал

    Полная версия на моем Debian, тестирующем KDE 4.7.4

    Отметьте, что решение ~ / .bashrc, чтобы Gimp запускался со своего значка, работает отлично 😉

    приветствия

  8.   pandev92 сказал

    Пытаюсь скомпилировать в osx без x11, результат расскажу через несколько часов.

      1.    pandev92 сказал

        Иногда я думаю, что ты скорее засранец, чем кажется xd

        1.    Мужество сказал

          Вы должны кое-что сказать о Mac здесь ... Это только приходит в голову.

          1.    pandev92 сказал

            но он говорил о gimp xd

        2.    КЗКГ ^ Гаара сказал

          ¬_¬ … Без обид, повторяться не буду.

          1.    Мужество сказал

            Меня это не беспокоит

  9.   Йойо Фернандес сказал

    Я не понимаю той вечной войны систем….

    Ну, теперь я собираюсь отправлять сообщения с моего Mac, чтобы это отразилось в пользовательском агенте, аля !!!

    Будем уважать и будем уважать 😉

    1.    pandev92 сказал

      Seeeee xD

      1.    Йойо Фернандес сказал

        pandev92

        Я поддерживаю вас, товарищ, Linuxeros Maqueros, они у нас тоже есть, мы должны объединиться 😉

    2.    sieg84 сказал

      У меня есть мечта…

  10.   Keopety сказал

    pandev92, я заинтересован в том, чтобы скомпилировать его без X11, когда он у вас будет, я был бы признателен, если вы сообщите об этом, спасибо
    А что касается Храбрости, не считайте это, это будет зависть от того, что у вас не будет Mac, или я ошибаюсь?

    1.    pandev92 сказал

      Хорошо, keopety, сегодня я попробовал, но из-за зависимости, я не мог, я разговариваю со скиннерами, чтобы узнать, что они мне скажут, я вам скажу.
      Для gimp 2.6 есть предварительно скомпилированный пакет http://sourceforge.net/projects/gimp-app/files/gimp-app/

      без х11 естественно.

      1.    Keopety сказал

        Хорошо спасибо, буду внимательна.
        приветствие

      2.    Мужество сказал

        У вас есть несколько таких проблем, и вам нужно подождать, пока он будет официально включен в некоторые дистрибутивы, а в других подождать немного

    2.    Мужество сказал

      у меня был один

  11.   opensanctux сказал

    GIMP 2.8 Для чего это нужно?

    1.    Мужество сказал

      Потом кто-нибудь вам скажет и будет как в другом посте

      1.    opensanctux сказал

        немножко спорить, вменяемо, вот так :)

    2.    Keopety сказал

      Вы шутите, да?

      1.    opensanctux сказал

        нет. очевидно, я знаю, что это gimp, и вопрос очень текстовый, я хочу знать, какие приложения можно дать gimp.

          1.    opensantux сказал

            … Самое большее, что я мог увидеть, это пройти путь от новичка до профессионала, используя канитель. Ничего подобного в этой профессиональной сфере нет.

            И скомпилировать ??? Ну, нет, я увидел это через край и отказался от того, что у меня не так много свободного времени, я выбрал простой вариант, установил бета-версию Fedora 17 и загрузил ее из репозиториев.

            Теперь, тестируя его, я могу честно сказать, что он очень стабилен, я не знаю, есть ли у него поддержка gpu, но он очень хорошо обрабатывает большие изображения. То, что они сделали, «хорошо сделано» и правильно организовано лучше, чем krita (который страдает от организационной трагедии kde), и они значительно улучшили обработку цвета, потому что версия 2.6 была очень плохой. И интересная система выбора слоев, которая является одной из сильных сторон Photoshop.

            Любители и новички широко используют ретушь обычных фотографий, фотомонтажи, графический дизайн, иллюстрацию ...

            Профессионал; Веб-дизайн, цифровые носители (видео, мультимедиа) или использование внешних приложений для преобразования файлов ... Это ограничено отсутствием улучшенной поддержки, отсутствием цветовых профилей CMYK для печати, цветовых палитр для иллюстраций и т. Д.

            Короче говоря, до профессионального уровня еще далеко.

          2.    opensantux сказал

            Мой друг? Хахаха нет! Скорее, он наложил вето на мои комментарии за то, что я не согласен с ним или за то, что не сказал ему, что он зол ... ну.

            Тем не менее, для Интернета это хорошо, для печатного станка это не работает, никто не собирается откалибровать компьютер, чтобы рисковать экспортом с помощью плагина.

            То, что Крита выше, я думаю, не оспаривается, но в этом есть свои странные мелочи.

          3.    Windóusico сказал

            Так что этот парень подвергает цензуре комментарии ... Ну, я не удивлен. Как я ответил вам на днях, вам нужно больше клетчатки.

  12.   Алунадо сказал

    Я имею в виду людей, GIMP 2.8 в некоторой степени зависит от MONO ¿. Или вы можете это понять, может это просто случилось, чтобы скомпилировать его при тестировании ...

  13.   solidus_00 сказал

    Я уже установил другим методом но единственное окно не вылезло, посмотрим, хорошо ли с этим методом уже тянет 😀 спасибо

    1.    Литос523 сказал

      По умолчанию запускается в традиционном многооконном режиме.
      Вам нужно перейти в меню «Windows» и активировать опцию одного окна.

  14.   Хосе сказал

    В последний раз, когда я пытался установить версию GIMP, отличную от той, которая предлагается в официальных репозиториях, у меня закончился GIMP. Не было возможности вернуться, или произвести чистку, или что-нибудь вообще…. У меня закончился GIMP до следующей переустановки. В моем LTS я ничего трогать не буду…. он должен быть там до следующего LTS. Если это не займет много времени, чтобы появиться как обновление.

    1.    КЗКГ ^ Гаара сказал

      ХАХАХА со мной подобное случается. Я использую Debian (Тестирование) и… я могу дождаться Gimp 2.8, чего он потребует, я не так тороплюсь компилировать себя 🙂

      1.    комментатор сказал

        Не могли бы вы использовать PPA для тестирования?

        1.    КЗКГ ^ Гаара сказал

          Технически я думаю, что может, на самом деле я думаю, что elav удалось установить его вот так ... но я предпочитаю этого не делать. Я стараюсь поддерживать свою систему на 100% чистой, без оплошностей или каких-либо ошибок или чего-то в этом роде, ха-ха-ха.

          Для того, что я использую Gimp, я не против подождать еще 1 месяц, пока 2.8 не войдет в тестовые тесты репозиториев Debian.

          привет

  15.   Дэвид Пинеда сказал

    Вы должны установить libabl devel, чтобы правильно скомпилировать gegl