Ako nainštalovať naše balíčky LMDE za 3 sekundy

Využívanie výhod posledný článok o čom som písal Zálohovanie mincovne„Chcem vám ukázať tri jednoduché spôsoby preinštalovania balíkov, ktoré používame pri preinštalovávaní našich LMDE.

V skutočnosti, s výnimkou prvej formy, môžu byť ostatné použité ako v debianako v ubuntu.

Inštalácia do 3 sekúnd

Graficky.

Takto sa to páči najviac, všetko je to grafické a bez nutnosti dotýkať sa terminálu. V LMDE y linuxmint, existuje báječný nástroj tzv Zálohovanie mincovne, ktorú okrem iného môžeme použiť na uloženie našich balíkov a ich neskoršiu opätovnú inštaláciu.

V prípade LMDE, ak aktualizujeme balík python-apt na verziu 0.8.0, nebudeme môcť používať Zálohovanie mincovne kvôli problému so závislosťou. Vráti nasledujúcu chybu:

Traceback (most recent call last):
File "/usr/lib/linuxmint/mintBackup/mintBackup.py", line 87, in <module>
class MessageDialog(apt.FetchProgress):
AttributeError: 'module' object has no attribute 'FetchProgress'

Dúfajme, že chlapci z Mäta skor to naprav.

Cez terminál.

Prostredníctvom konzoly to môžeme urobiť dvoma spôsobmi, ktoré boli nakoniec rovnaké.

V 2 krokoch.

dpkg --get-selections | awk '$2 ~ /^install$/ {print $1}' > lista_de_paquetes.txt

Keď už máme prístup do archívov a všetko je nakonfigurované a aktualizované, musíme do toho vložiť toto:

cat lista_de_paquetes.txt | xargs sudo aptitude install -y

V 3 krokoch.

dpkg --get-selections "*" > /home/user/Desktop/lista_de_paquetes.txt

Po preinštalovaní vykonáme toto:

dpkg --set-selections  < /home/user/Desktop/lista_de_paquetes.txt

A potom bežíme:

apt-get -u dselect-upgrade

Myslím si, že nie je potrebné objasňovať, že musíme mať úložiská nakonfigurované správne .. Jednoduché, však?


Obsah článku je v súlade s našimi zásadami redakčná etika. Ak chcete nahlásiť chybu, kliknite na ikonu tu.

8 komentáre, nechajte svoj

Zanechajte svoj komentár

Vaša e-mailová adresa nebude zverejnená. Povinné položky sú označené *

*

*

  1. Zodpovedný za údaje: Miguel Ángel Gatón
  2. Účel údajov: Kontrolný SPAM, správa komentárov.
  3. Legitimácia: Váš súhlas
  4. Oznamovanie údajov: Údaje nebudú poskytnuté tretím stranám, iba ak to vyplýva zo zákona.
  5. Ukladanie dát: Databáza hostená spoločnosťou Occentus Networks (EU)
  6. Práva: Svoje údaje môžete kedykoľvek obmedziť, obnoviť a vymazať.

  1.   Odvaha dijo

    Alebo si tiež zapíšete všetky programy, ktoré ste predtým mali a robíte

    sudo apt-get -y načíta všetky odstránené balíky

    Naozaj neviem, či má LMDE rovnaký cieľ ako Linux MInt, byť po vybalení z krabice

    1.    Odvaha dijo

      * Inštalácia

  2.   hokasito dijo

    Aj keď je to trochu „mimo témy“, chcel som varovať, že kandidáti na vydanie boli vydaní v Linux Mint Debian 201108 pre GNOME a XFCE. Dúfam, že bolo urobených niekoľko vylepšení ... 🙂

    1.    elav <° Linux dijo

      No, áno, čo sa stane, keď vyšla táto vynikajúca správa, boli sme offline .. Ďakujeme.

  3.   mitcoes dijo

    Práve som ťa objavil a ĎAKUJEM.
    Včera som si nainštaloval 64-bitové LMDE a vychádzam spolu dobre, ale musím objaviť dve malé veci -

    1– Prihláste sa ako užívateľ root v grafickom režime

    2. - Nastavte VLC ako predvolený prehrávač videa

    Myslím, že by som to získal z ovládacieho panela preferovaných aplikácií alebo otvorením v inej aplikácii / použitím tejto aplikácie v predvolenom nastavení. Prihlásený ako root.

    Urobil som sudo nautilus pre každý prípad a vôbec nič.

    PS1: V 64 bitoch funguje paketový program dobre.
    PS2: Musím si tiež nainštalovať MAME SDL a nedávny wine64, o ktorom by som chcel, aby existoval ppa, pretože neskoršia konfigurácia programov vás automaticky neaktualizuje.
    PS3: Používam AMD beta driver AMD_Catalyst_Preview_driver_OpenGL_4.2_beta_support_8.88.8-x86.x86_64.run, Cocoon, https://getcocoon.com/, aby ste videli geolokalizované série vo Firefoxe, Chrome - ktorý je potrebné nainštalovať -, Firefox Flash pomôcka so 64-bit Flash, Zindus, Qbittorrent, Opera, rozšírenie aletras.oxt a prijímací skript na kontrolu nadbytočnej medzipamäte RAM úloha, ktorá si zaslúži aj váš komentár.

    Teším sa na piatu časť tutoriálu s týmito a / alebo ďalšími návrhmi

  4.   Comecon dijo

    Dobrý deň!
    Jedna vec, mali by sme zmeniť prvý odkaz, ktorý pošle článok MintBackup na tento: https://blog.desdelinux.net/mintbackup-realiza-un-respaldo-de-tus-paquetes/
    Neviem prečo, odkazuje na podadresár „/ wp-content / themes“ ...

    1.    KZKG ^ Gaara dijo

      Hotovo, opravené 😉

  5.   Nahum dijo

    Dobrý deň, od predchádzajúcej verzie LMDE amd64 som mal problémy s rozbitými balíkmi a chybami pri načítaní úložísk, vyskúšal som veľa riešení a žiadne z nich nefunguje ... Už neviem, čo mám robiť, chcel som si nainštalovať Gnome-shell a nedovolil mi to, pretože balík je rozbitý. Videl som, ako vyriešiť rozbité balíčky príkazmi ako: sudo dpkg –purge –force-remove-reinstreq

    a zobrazí sa mi nasledujúca chyba:

    dpkg: error: –purge vyžaduje ako parameter aspoň jeden názov balíka

    Zadajte príkaz dpkg –help a pomôžte tak s inštaláciou a odinštalovaním balíkov [*];
    Pre priateľskejšiu správu balíkov použite `dselect 'alebo` aptitude';
    Zadajte dpkg -Dhelp pre zoznam ladiacich nastavení pre dpkg;
    Zadaním príkazu dpkg –force-help zobrazíte zoznam možností, ako veci vynútiť;
    Zadajte dpkg-deb –help a pomôžte tak manipulovať so súbormi .deb;

    Možnosti označené [*] vytvárajú dlhý výstup,
    Filtrujte ho podľa výrazu „menej“ alebo „viac“!

    ak mi s tym niekto vie pomoct 🙂