Solución a problemas de audio con motherboard Gigabyte GA-H61M-DS2

Si eres un usuario de Debian 7 y presentas problemas con el audio en motherboard Gigabyte GA-H61M-DS2 o similares esta es la solución.

Esto es válido para los chipsets:

  • Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
  • Intel 7 Series/C210 Series Family High Definition Audio Controller

Si quieren ver otros modelos y posibles configuraciones, pueden acceder a este enlace en el foro de SolydXK.

Abrimos un terminal y ponemos:

sudo apt-get install alsa-base alsa-tools alsa-utils

Luego posteriormente editamos el fichero /etc/modprobe.d/alsa-base.conf y reemplazamos lo que dice:

options snd-hda-intel model=auto

por

options snd-hda-intel model=generic

Reiniciamos y ya está.

Fuente: GUTL

Comparte para difundir

Si te ha gustado nuestro contenido ahora puedes ayudar a difundirlo en las redes sociales de manera sencilla usando los siguientes botones:

Envía
Pinea
Print

17 comentarios

  1.   julian dijo

    Por ese tipo de problemas es que Linux todavía no está preparado como sistema operativo para el escritorio.

    1.    elav dijo

      Tu crees?

    2.    dok dijo

      Creo que es más bien una cuestión de equipos preinstalados. Windows suele venir preinstalado con todo el hardware configurado y compatible en los equipos que se vende. Puedes hacer lo mismo con linux, pero la penetración en el mercado es mucho menor, suele pasar que se compra un equipo con Windows preinstalado sin comprobar si el hardware le dará problemas con linux y pasa lo que pasa.

      Si se comprarán los PC sin Windows preinstalado sin mirar la compatibilidad se verían los mismos problemas y no más sencillos de resolver.

      1.    O_Pixote_O dijo

        Exacto, cuando estube un tiempo trabajando en una tienda nos trajeron un ordenador que habian comprado sin S.O. instalado que le habian instalado W7 y no le funcionaba el bluetooth. Y si no recuerdo mal, no hubo forma de instalarle los drivers.

  2.   ridri dijo

    Si hasta intel que en teoría libera el codigo fuente dá problemas apaga y vámonos. Pero en todo caso las fallas de hardware tambien afectan a windows en muchos casos y las soluciones o no existen o son todavía más complejas.

    1.    eliotime3000 dijo

      En Windows, si los drivers genéricos del Driver Pack Solution no dan resultado, te ves obligado a descargar los drivers de la misma Intel y/o desde la página del fabricante del mainboard.

      1.    pandev92 dijo

        Yo en un pc del 2005 no pude instalar windows 8, porque el driver de audio es para windows vista y en el 8, no parece de hacer ruiditos molestos.., esto en linux no pasa.

        1.    eliotime3000 dijo

          Obvio que se usan los drivers de Windows Vista porque hasta el Windows 8.1 usa el kernel NT 6.

          1.    pandev92 dijo

            nada tiene que ver el kernel, direct audio tiene unos cambios importantes, que hace que los drivers de windows vista no funcionen bien, mínimo deben ser de windows 7..

          2.    eliotime3000 dijo

            Tenían que ser Microsoft.

            En fin, por esa y muchas otras razones más, estoy en contra de Windows 8 (y 7 también, aunque ésta no sea mi computadora).

  3.   Dr. Byte dijo

    Opino lo mismo. Sé que todo se puede resolver investigando un poco, pero para los usuarios que solo quieren usar un sistema operativo sin tener que estar arreglando x o y cosa si es algo molesto. Sé que todos los sistemas operativos tienen fallas o detalles, pero los usuarios dométicos solo quieren usar el equipo y ya jejejeje, para los que nos gusta arreglar una falla está muy bien jajajaja pero no todos piensan lo mismo.

  4.   elav dijo

    Hey chicos.. ¿Por qué no lo ven de la siguiente forma?

    Tienen Windows. Reemplazan su motherboard. Si no tienen los drivers, es muy posible que no puedan tener sonido. ¿Qué pueden hacer? Nada.

    Tienen Windows. Reemplazan su motherboard. El sonido funciona ¿No lo hace? Modifican un fichero. Siguen teniendo audio

    1.    eliotime3000 dijo

      Tienen Windows. Reemplazan su motherboard. Si no tienen los drivers, es muy posible que no puedan tener sonido. ¿Qué pueden hacer? Nada.

      Tienen Windows. Reemplazan su motherboard. El sonido funciona ¿No lo hace? Modifican un fichero. Siguen teniendo audio

      Quisiste decir:

      Tienen Windows. Reemplazan su motherboard. Si no tienen los drivers, es muy posible que no puedan tener sonido. ¿Qué pueden hacer? Nada.

      Tienen Linux. Reemplazan su motherboard. El sonido funciona ¿No lo hace? Modifican un fichero. Siguen teniendo audio

  5.   Rodolfo dijo

    jaja nada tiene que ver Linux, para que compran gigabyte fue claro, dijo gigabyte usen windows OS, para que les sirva su hardware, asi de sencillo, el que compra sin indagar, lo siento ahi estan los problemas, pongo un link para que sepan:
    http://www.phoronix.com/scan.php?page=news_item&px=MTAwMjg

    No vale la pena gastar ni un centavo en ellos.
    Saludos!.

    1.    eliotime3000 dijo

      Bitch Please!

      Eso no tiene nada que ver con el problema que está hablando @Elav. Además, el verdadero problema sería si viniese con secure boot, el cual sí sería un verdadero problema para solucionar.

      Ahora, lo que el artículo indica es una mera solución por el traspié de configuración de los drivers Intel de Debian a la hora de instalarse en mainboards Gigabyte. Hubiera sido un dolor de cabeza si hubiera sido una mainboard Foxconn.

      1.    Rodolfo dijo

        Se nota que no entendiste lo que quise decir, Gigabyte ya ha tenido problemas y tiene un no rotundo de no soportar Linux, es mejor no comprarlo. El Link que puse es para ver como ellos piensan sobre los usuarios que usan linux, sencillo te dicen usa windows. Por cierto para ser redactor más respeto por más que sea una frase de cabecera.
        Saludos!.

  6.   kikee dijo

    Me sucedió lo mismo en una placa Gigabyte distinta a esta, lo solucioné borrando pulseaudio y compilando los drivers de alsa. Los pasos fueron estos -> http://kikefree.wordpress.com/2013/08/03/solucionar-problema-de-sonido-en-debian-7-wheezy/

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.