Solucionar problema de dependencias de Aufs2 en ArchBang

Aufs2 necesita un kernel en concreto y puede darnos un error al intentar actualizar ArchBang

La solución es desinstalar Aufs2:

pacman -Rcs aufs

Mucha gente usa -Rd para eliminar los programas y los paquetes, pero -Rcs nos quita todo, el paquete y las dependencias por lo que recomiendo usar éste.

Ni más ni menos.

Aufs2 es un paquete que usan los LiveCD’s para fusionar directorios, quitarlo no afecta para nada al funcionamiento del sistema yq que es para los LiveCD’s


3 comentarios

  1.   StuMx dijo

    Creo que hay un typo en esta entrada, La operacion Remove (-R) de pacman no tiene opción ‘d’, asi que supongo que te refieres a la opción ‘s’.

    También me gustaria decir que hay que tener extremo cuidado cuando se usa la opcion ‘c’ (cascada) pues esta elimina los paquetes instalados sin importar que sean usados por algún otro paquete, por eso es que se recomienta usar la opción ‘s’ (recursivo) la cual elimina los paquetes solo en caso de que no sean usados por ningún tercero.

    Por último, creo que no tiene caso usar las opciones ‘s’ y ‘c’ pues los paquetes señalados por la opción ‘s’ ya se encuentran contenidos en la opción ‘c’

    1.    Courage dijo

      Me refiero al:

      pacman -Rd

      Que es el que no elimina dependencias, también se usa el pacman -Rsn

      1.    StuMx dijo

        Ya, te refieres al nodeps, igual hay que tener cuidado por que esta opcion hace que ignore la revision de dependencias, asi que se puede eliminar un paquete que es usado por un tercero.

        Yo me quedo con el clasico ‘Rs’

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *