Si të rregulloni çështjet e zërit me ALC888 në Ubuntu12.04 dhe derivatet

Ky artikull lind nga një problem (ironike nga rruga ...) që kam pasur me të Ubuntu 12.04 dhe të gjitha distros bazuar në këtë version të veçantë. Ironia e problemit është se për një LTS, ishte versioni i parë që përdora dhe madje më dha një problem në këtë PC. Në këtë rast, një problem i shëndoshë.

Problemi nuk është në të vërtetë shumë serioz, por bëhet i bezdisshëm në përdorimin e përditshëm. Përbëhet nga kjo: Unë ndez PC me kufje të lidhura, hyj në Ubuntu (ose një derivat i LTS) dhe dëgjoni muzikë. Kur lodhem dhe heq nga kufjet, dhe dua të dëgjoj muzikë përmes altoparlantëve të monitorit, asgjë nuk duket. Nëse e ndez PC-në me kufjet nga priza, mund të dëgjohet nga altoparlantët, por lidh kufjet dhe mund të dëgjohet nga të dy daljet e audios.

Ditët e para të përdorimit kam kërkuar dhe Unë nuk gjeta informacion në lidhje me të, kështu që unë u largova. Tani kam instaluar elementaryOS Luna Beta 2 (dhe natyrisht, është i bazuar në Ubuntu 12.04), dhe për habinë time, problemi ishte akoma atje. Unë kërkova përsëri dhe më në fund gjeta nje zgjidhje në disa forume. Hapat që duhet të ndiqni janë këto:

  1. Hapim mikserin ALSA ekzekutimi i komandës: alsamixer Sapo të kontrollojmë atje ku thotë «Patate të skuqura»Për t'u siguruar që kemi ALC888. Ky çip zakonisht është i integruar në sistemet e zërit Intel HDA.
  2. E mbyllim mikserin me tastin [Esc]. Tjetra, sigurohemi që të kemi një Intel HDA (duhet të jetë një nga këto që hileja të funksionojë) Ne shkruajmë në terminal: lsmod | grep snd Ne kërkojmë disa rreshta që thonë snd_hda_intel. Kjo do të thotë që ne plotësojmë kërkesat.
  3. Ne ekzekutojmë komandën: sudo <editor> /etc/modprobe.d/alsa-base.conf Ata zëvendësojnë nga redaktori juaj i preferuar, të tilla si nano, fletëpalosje ose gedit.
  4. Në fund të skedarit, ne do të shtojmë një rresht të kodit, i cili lexon kështu: options snd-hda-intel model=auto Nëse kjo nuk funksionon për ju, provoni options snd-hda-intel model=auto probe_mask=1 Kjo i thotë ALSA të identifikojë automatikisht dhe përgjithësisht kartën e zërit, në vend që të përpiqet të krijojë një model të saktë.
  5. Ne e ruajmë skedarin dhe rifillojmë. Pastaj provojmë.

Në rast të problemeve ...

Possibleshtë e mundur që kur ndiqni këto hapa të mund të keni një problem, të lë disa me zgjidhjen tuaj:

  • «Skedari që duhet të redaktoj nuk është në rrugën që komentoni« Ndoshta është në një rrugë tjetër, mund të provoni ta instaloni paketën mlocate dhe ta ekzekutoni: cd / më pas lokalizoni alsa-base.conf për të gjetur skedarin. Nëse jo, provoni ta krijoni nga e para dhe shtoni linjën e kodit.
  • «Shtova një nga linjat, ruajta, rebootoj dhe tani nuk kam zë. Paneli i zërit më thotë 'Dal për ngathët'« Ky kod mund të mos jetë i saktë. Mundohuni ta ndryshoni atë për një tjetër, ose në çdo rast fshini atë. Pastaj reboot dhe voila.
  • «Asnjëra nga linjat nuk funksionoi për mua« Possibleshtë e mundur që tingulli juaj i integruar të jetë disi i ndryshëm, në çdo rast duhet të provoni të ndryshoni modelin = automatik për një model më të saktë bazuar në Çipin tuaj.

Kjo është e gjitha, diçka shumë e thjeshtë, shpresoj t'ju ketë shërbyer. Nëse keni ndonjë pyetje ose problem, më poshtë janë komentet


Përmbajtja e artikullit i përmbahet parimeve tona të etika editoriale. Për të raportuar një gabim klikoni këtu.

19 komente, lini tuajën

Lini komentin tuaj

Adresa juaj e emailit nuk do të publikohet.

*

*

  1. Përgjegjës për të dhënat: Miguel Ángel Gatón
  2. Qëllimi i të dhënave: Kontrolloni SPAM, menaxhimin e komenteve.
  3. Legjitimimi: Pëlqimi juaj
  4. Komunikimi i të dhënave: Të dhënat nuk do t'u komunikohen palëve të treta përveç me detyrim ligjor.
  5. Ruajtja e të dhënave: Baza e të dhënave e organizuar nga Occentus Networks (BE)
  6. Të drejtat: Në çdo kohë mund të kufizoni, rikuperoni dhe fshini informacionin tuaj.

  1.   pandev92 dijo

    I njëjti gabim është i pranishëm në ALC 887 dhe zgjidhet në të njëjtën mënyrë. (Unë kam një realtek të tyre)

    1.    auroszx dijo

      Seriozisht? Gjëja e habitshme është se ata nuk donin ta rregullonin atë në paketim ose në instalimin ALSA, nëse është vetëm një rresht për të shtuar ...

      1.    st0rmt4il dijo

        Si po ia dilni në elementaryOS? - e qëndrueshme?, ndonjë problem në kohën kur e keni përdorur këtë shpërndarje?!

        Përshëndetje!

        1.    auroszx dijo

          Oh mirë, disa aplikacione më kanë detyruar të mbyllem ose të var. E para që e rregullova duke instaluar azhurnime, e dyta është për shkak të procesorit tim të vjetër mendoj: / Mbajtja e ngarkesës së Panteonit, Gala dhe aplikacionet e tyre nuk është e lehtë ...

  2.   Paul dijo

    Unë kam një problem tjetër me çipin AMD 780g. Tingulli është i ngopur dhe me cilësi të dobët herë pas here. Me skype, gtalk, murmuritje. etj.
    Mund ta zhbllokoj duke rregulluar opsionet në murmuritje, por për momentin nuk kam gjetur një zgjidhje përfundimtare

  3.   eliotime3000 dijo

    Me audion në kompjuterin tim HP me chipset Intel nuk e kisha problem të isha në Debian përveç kur hapja Ardor, pasi ai automatikisht e mbylli gojën kompjuterin tim pa ndonjë shpjegim dhe vendosjen e drejtuesit të zërit në ALSA.

  4.   pandev92 dijo

    Unë në funtoo me kernel 3.10, nëse jo unë vendos vijën e Intel, nuk kam asnjë tingull, në Ubuntu 13.04, unë duhet të rregulloj disa parametra pulseaudio, por tingulli është i tmerrshëm, dhe në ato duhet të pulseyudio dis një katastrofë… ., Të paktën në rastin tim.

    1.    eliotime3000 dijo

      Gjë e mirë që nuk e azhurnova kernelin 3.04 që kam në Debian Wheezy tim.

  5.   st0rmt4il dijo

    Faleminderit për këshillën Auros

    Përshëndetje!

  6.   Lojra dijo

    Shok i pabesueshëm, kam vuajtur nga problemi, por vetëm kur kam vendosur zërin në 5.1 në sistem.

    Çipi që kam është VIA VT1708S.

    Thashë më lejoni të provoj, pasi kjo funksionon me kornizën snd-hda-intel.

    Tani mund të përdor dy daljet e pasme dhe të përparme.

    Faleminderit për këshillën.

  7.   Lojra dijo

    Përshëndetje, vij të komentoj, që zgjidhja e propozuar këtu funksionoi shumë mirë për mua, por unë e lë audion e kamerës sime pa kapje.

    Camshtë një Webcam C270 e Logitech, Inc.
    Duke hetuar, pashë që zgjidhja ishte, masa e hetimit = -1

    Me këtë njoha kapjen audio të kamerës dhe funksionon edhe për t'u lidhur nga përpara dhe nga prapa.

    Thjesht doja ta thoja atë.

    Faleminderit përsëri për këshillën

  8.   kutia përsëri dijo

    Përshëndetje si jeni, së pari falënderoj shumë AurosZx, edhe pse ka kohë që nuk është publikuar ky postim, ishte një ndihmë e madhe për mua për të zgjidhur një problem me daljen në kufje.

    Po përdor Ubuntu 14.04 në një ASUS K55A dhe çipi që më shfaqet në alsamixer është Intel PantherPoint HDMI dhe funksionoi herën e parë. Pershendetje

  9.   Baphomet dijo

    Nuk është e nevojshme të rifilloni: sudo alsa-ringarkoni forcën

bool (e vërtetë)