Zgjidhja e problemit të instalimit të aplikacioneve 32-bit në Linux Mint 14 RC 64-bit

Sapo postova lajmet që tashmë i di Linux Mint 14 RC është në dispozicion, dhe Clem sapo u njoftua që në versionin 64-bit ekziston një problem që nuk lejon instalimin e aplikacioneve si p.sh. Skype, Google Earth ose ndonjë paketë tjetër 32-bitëshe.

Aftësia për të instaluar aplikacione 32-bit në një mjedis 64-bit zakonisht quhet "Multiarch". Me sa duket ka pasur një ndryshim me dpkg në Debian, i cili bëri konfigurimin Shumëharësh vjetrohen në Ubuntu. Ju mund të shihni më shumë informacion në lidhje me këtë problem këtu: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

Zgjidhje

Për të mundësuar Multiarch, hapni një terminal dhe shtypni komandat e mëposhtme:

sudo dpkg --add-arquitectura i386
apt update

Ky problem do të rregullohet manualisht në versionin e qëndrueshëm të Linux Mint 14.


Përmbajtja e artikullit i përmbahet parimeve tona të etika editoriale. Për të raportuar një gabim klikoni këtu.

12 komente, lini tuajën

Lini komentin tuaj

Adresa juaj e emailit nuk do të publikohet.

*

*

  1. Përgjegjës për të dhënat: Miguel Ángel Gatón
  2. Qëllimi i të dhënave: Kontrolloni SPAM, menaxhimin e komenteve.
  3. Legjitimimi: Pëlqimi juaj
  4. Komunikimi i të dhënave: Të dhënat nuk do t'u komunikohen palëve të treta përveç me detyrim ligjor.
  5. Ruajtja e të dhënave: Baza e të dhënave e organizuar nga Occentus Networks (BE)
  6. Të drejtat: Në çdo kohë mund të kufizoni, rikuperoni dhe fshini informacionin tuaj.

  1.   vullnetet dijo

    @MonitoLinux punojnë shumë tuajat. Nuk jam i sigurt se do ta gjej në backportet e qëndrueshme. Por unë mund të garantoj që në Sid, dhe ka shumë të ngjarë deri tani në repot e Wheezy [1] do ta gjeni në dispozicion.

    [1] http://www.debian.org/News/2011/20110726b

    Mbështetja multiarch është diçka që ka bërë shumë zhurmë. Unë u përplasa me të si në qershor dhe ai tashmë ishte rrotulluar për një kohë të gjatë.

    1.    monitolinux dijo

      @Willians është se unë vij nga kohërat më të vjetra, ku nuk kishte aq shumë depo me aplikacionet që duheshin, ku një nga më të shumtët që gjeti ishte kodi burimor.

  2.   vullnetet dijo
  3.   RafaGCG dijo

    Unë jam pak i humbur (vaaale shumë) me këtë. Unë jam duke përdorur Xubuntu 12.10 64Bit (një e shtënë krahasuar me ubuntu 12.10 e cila është leeeento) dhe befasia ime kur shkova për të instaluar KompoZer është se ajo nuk u shfaq ... në fund të fundit unë nxora që pasi nuk ekzistonte për 64bit ishte jo ne depo ... megjithese deri tani gjithmone e kishte instaluar (me Kompozer-in e instaluar apt-get) por kesaj here nuk u shfaq. Pas shumë mendimesh gjeta një DeB 64 bit dhe e instalova. Por dyshimi im dhe më në fund arrij në pikë. Nëse e instaloj këtë, ju komentoni mbi këtë postim. A do të shfaqen pako 32bit në depo për të instaluar programe 32bit nëse ato 64bit nuk janë të disponueshme? A do të më ishte shfaqur Kompozer 32-bitësh për ta instaluar në depo? A është mirë që e bëj për programet e ardhshme që më duhen?

  4.   Plehra_Killer dijo

    elav të thashë, kjo nuk është arsyeja pse isha në Debian sid

    në fakt këtë problem që paraqet nenexhiku, Debian sid tashmë e ka prezantuar atë rreth 2 muaj më parë, madje në sinaptik thotë se para se të instaloni ia32-libs dhe ia32-libs-gtk, ju rekomandon që të shtoni dpkg –add-arkitekturë: i386 pastaj ekzekutoni një azhurnim dhe gati.

    1.    elav dijo

      Kur me the? Nuk mbaj mend

      1.    Plehra_Killer dijo

        pikërisht 2 muaj më parë, kur pata një problem të ngjashëm, por kjo ndodhi sepse paketa ia32-libs-gtk ishte e vjetëruar, dhe akoma nuk doli për të kompletuar ia32-libs të reja, derisa të kujtoj se thatë dhe pse po shkoj për të shtuar arkitekturën dpkg - shtoni: i386

        1.    elav dijo

          Hahaha që ishte përmes IRC apo jo?

  5.   MonitoLinux dijo

    zgjidhja është të shkarkoni kodin burimor dhe të përpiloni, pastaj të gjeneroni paketën deb dhe t'ia jepni atë komunitetit

  6.   Sergio Esau Arámbula Duran dijo

    Madhe

  7.   Le të përdorim Linux dijo

    Shume mire! Interesante
    Shpresojmë që ata ta rregullojnë problemin para se të dalë versioni përfundimtar.
    Gëzuar! Paul.

  8.   mfcollf77 dijo

    Kam instaluar linux mint 14 64 bit dhe nuk kam pasur problem të instaloj Skype, është instaluar vetëm versioni 4.0

    Do të shoh me çfarë tjetër kam një problem