АппИмагеЛаунцхер: лако покретање и интегрисање апликација у Аппимаге

АппИмагеЛаунцхер

Пре неки дан у свету Гну / Линука имали смо универзални метод инсталирања било које апликације без обзира на дистрибуцију о којој је реч и овај метод је био компајлирањем апликације из изворног кода.

Ова метода се и даље користи, тежи да буде мало касноПоред тога за кориснике који су нови у Линуку, па чак и средње кориснике, рад на овоме може бити мало компликован.

Већ мало прецизније већина дистрибуција обично користи неки менаџер пакета са којима су подржани за инсталирање апликација, рецимо на пример Дебиан или Убунту са апт и деб или Федора пакети са иум и рпм пакетима.

Помоћу којих већ проналазимо апликације у најпопуларнијим форматима пакета и они нам штеде пуно времена приликом инсталације, јер не морамо да их компајлирамо на нашем систему.

Хаце нису дуго почеле да се појављују нове врсте пакета да инсталирате апликације, на пример, Снап, Аппимаге или Флатпак.

Тамо где је главна атракција неких од њих то што раде у окружењу потпуно изолованом од система, с којим нећемо имати проблема да корумпирају систем или га угрозе.

О АппИмагеЛаунцхер-у

Овом приликом фокусираћемо се на пакете у АппИмаге формату које чак и многи корисници не знају како да их инсталирају, па чак ни како да их интегришу у наш систем.

Када преузмемо пакет АппИмаге да бисмо га инсталирали морамо му дати дозволе за инсталацију и извршити следећу команду да бисмо га инсталирали:

./paquete.appimage

Што ће потврдити да ћемо инсталирати апликацију, на крају овога ћемо бити питани да ли желимо да апликација буде интегрисана у наш мени апликације или желимо да креирамо пречицу.

Тамо где многи корисници имају тенденцију да кажу не, не знајући или грешком. Да бисмо касније покренули апликацију, то морамо урадити из датотеке коју смо преузели.

Крушка Такође имамо алат који то може да олакша, овај алат се зове АппИмагеЛаунцхер.

аппимагелаунцхер_1

Апликација омогућава вам лако покретање АппИмаге датотека, без потребе да их учините извршним.

АппИмагеЛаунцхер за сада Подржава само Убунту, Линук Минт, Дебиан, Нетруннер и недавно је додао подршку за опенСУСЕ.

Али његова најзанимљивија карактеристика је лака интеграција АппИмагес са вашим системом: АппИмагеЛаунцхер може аутоматски додати пречицу до апликације АппИмаге у мени / покретач апликација на вашем радном окружењу (укључујући икону апликације и одговарајући опис).

Како АппИмагеЛаунцхер ради?

Када Преузимамо апликацију у аппимаге, само двапут кликните на њу да бисте покренули АппИмагеЛаунцхер и ово ће нам представити неколико опција.

Први који ће вам бити представљени када ћете први пут инсталирати апликацију су:

Покрените једном или Интегришите и покрените.

Кликом на интеграцију и покретање, апликација у АппИмаге се копира у директоријум ~ /.бин / и додаје у мени, а затим се апликација покреће.

Остале опције које вам представља када је апликација већ инсталирана су:

Избришите или ажурирајте апликацију.

Ако желимо да елиминишемо апликацију, она је једнако једноставна, све док је окружење радне површине које користите компатибилно са радњама радне површине.

Иако за ажурирање, требало би да вам се прикаже опција када поново покренете АппИмагеЛаунцхер на ажурираној слици апликације коју сте већ инсталирали на систему.

На пример, у Гноме Схелл, кликните десним тастером миша на икону апликације у Прегледу активности и одаберите Уклони из система:

Како инсталирати АппИмагеЛаунцхер на Линук?

Као што сам споменуо компатибилност АппИмагеЛаунцхер, иако се такође може користити у изведеницама, морамо узети у обзир да његова компатибилност зависи од радне околине у којој су Гноме Схелл или Циннамон најпогоднији.

Соламенте морате ићи на следећу везу y преузмите пакет за дистрибуцију Линук.

У случају Дебиана, Убунту-а и деривата, да бисмо га инсталирали, само се морамо поставити у директоријум у који је пакет преузет и извршити:

sudo dpkg -i appimagelauncher*.rpm

Иако посебно за Убунту 18.04 имамо пакет:

sudo dpkg -i appimagelauncher*.rpm

За опенСУСЕ:

sudo rpm -i appimagelauncher*.rpm


Садржај чланка се придржава наших принципа уређивачка етика. Да бисте пријавили грешку, кликните овде.

3 коментара, остави свој

Оставите свој коментар

Ваша емаил адреса неће бити објављена.

*

*

  1. За податке одговоран: Мигуел Ангел Гатон
  2. Сврха података: Контрола нежељене поште, управљање коментарима.
  3. Легитимација: Ваш пристанак
  4. Комуникација података: Подаци се неће преносити трећим лицима, осим по законској обавези.
  5. Похрана података: База података коју хостује Оццентус Нетворкс (ЕУ)
  6. Права: У било ком тренутку можете ограничити, опоравити и избрисати своје податке.

  1.   Денк дијо

    Даје грешку: грешка приликом учитавања заједничких библиотека: либКт5ДБус.со.5: не може се отворити датотека заједничког објекта: Нема такве датотеке или директоријума
    Требали би вам рећи које зависности има или из којег спремишта да га преузму, тако да све ради сам, пут * који вам је родио хиљаду порода.

    1.    Гонзало дијо

      Немогуће је да вас ико обавести о свим зависностима које су потребне сваком програму

  2.   Тротанплаи дијо

    Они могу показати како се то ради из антик линука, користити ицевм и сматрам да је то мало компликовано, молим вас.