Како Федори: Све што сте желели да знате о ИУМ-у, а нисте се усудили да питате (И део)

ИУМ (Ажурирање жутог пса, измењено): То је управљач софтвером командне линије (ПГ) за ажурирање, инсталирање и деинсталирање пакета са аутоматском резолуцијом зависности. Написано је у Питон, што омогућава проширење његових функционалности путем додатака. Иум је такође доступан на Дебиану.

Иум нуди сигурно управљање пакетима јер подржава систем за проверу потписа ГПГ (ГНУ Приваци Гуард, познат и као ГнуПГ). Када је омогућена верификација потписа, Иум ће одбити да инсталира све пакете који нису потписани исправним ГПГ кључем за то спремиште. То значи да можете веровати тим пакетима обртаја да сте преузели и инсталирали на свој систем из поузданог извора и нису измењени током преноса.

У овоме Како (подељено у неколико делова) видећемо како максимално искористити овај моћан и флексибилан софтверски менаџер који је, по мом личном мишљењу, један од најбољих који постоји поред Пацман (Арцхлинук);). Видећемо практично све опције које има, додатке и како да га конфигуришемо према сопственим потребама: Д.

Да бисте користили било коју од опција приказаних у наставку, потребно је само да приступите као корен или употреба судо и писати:

yum [opciones] comando {paquete1} {paquete2} {...}

Пример:

yum -y install clementine

Напомена: Параметри садржани између [] су опционални, параметри садржани између {} зависиће од наредбе која ће се користити.

Списак наредби које иум има је:

  • инсталирати пакет1 [пакет2] […]
  • ажурирање [пакет1] [пакет2] […]
  • упдате-то [пакет1] [пакет2] […]
  • провери - ажурирај
  • надоградња [пакет1] [пакет2] […]
  • надоградити на [пакет1] [пакет2] […]
  • дистрибуција-синхронизација [пакет1] [пакет2] […]
  • уклонити | обриши пакет1 [пакет2] […]
  • листа […]
  • инфо […]
  • пружа | шта пружа особину1 [особину2] […]
  • очистити [пакете | метаподаци | екпире-цацхе | рпмдб | додаци | све]
  • макецацхе
  • групе […]
  • тражи стринг1 [стринг2] […]
  • љуска [име датотеке]
  • ресолведеп деп1 [деп2] […]
  • (одржава се само из старих разлога - користите поновни захтев или иум пружа)
  • лоцалинсталл рпмфиле1 [рпмфиле2] […]
  • (одржава се само из старих разлога - користите инсталацију)
  • лоцалупдате рпмфиле1 [рпмфиле2] […]
  • (одржава се само из старих разлога - користите ажурирање)
  • поново инсталирајте пакет1 [пакет2] […]
  • надоградити пакет1 [пакет2] […]
  • деплист пакет1 [пакет2] […]
  • реполист [све | омогућено | онемогућено]
  • верзија [све | инсталиран | доступно | група- | ногроупс | гроуплист | гроупинфо]
  • историја [инфо | листа | листа пакета | пакети-инфо | резиме | аддон-инфо | редо | поништавање | враћање | ново | синхронизација | статистика)
  • лоад-трансакција [ткфиле]
  • проверити
  • помоћ [наредба]

опис наредби

инсталирати

Користи се за инсталирање најновије верзије пакета или групе пакета, истовремено осигуравајући да су све зависности задовољене. Ако се ниједан пакет не подудара са датим именом пакета, тада се подударања инсталирају. Ако име започиње знаком "@", остатак имена користи се као да је извршена наредба гроупинсталл. Ако име започиње знаком "-", претрага се врши унутар трансакције и уклања се сва подударања. Ако је име датотека, инсталација се врши као да је извршена путем лоцалинсталл.

ажурирање

Ако се покрене без употребе назива пакета, упдате ажурира све пакете који су тренутно инсталирани на систему. Ако је наведен један или више пакета, иум ће ажурирати само назначене пакете. Иум ће се побринути да су све зависности задовољене током ажурирања.

упдате-то

Ова наредба ради као „упдате“, али увек одредите верзију пакета на који желите да ажурирате.

провери - ажурирај

Примењен је тако да можете знати да ли ваша машина има ажурирања на чекању, а да не морате интерактивно покретати ажурирање. Такође враћа листу пакета које треба ажурирати у формату листе. Када се покреће у опширном режиму, такође приказује застареле пакете.

надоградња

То је исто као наредба за ажурирање са заставицом --obsoletes.

дистрибуција - синхронизација o дистро - синхронизација

Синхронизујте инсталирани пакет са најновијим доступним пакетима, што се ради или због застарелости, ажурирања или застарелости, према потреби. Ако наведете опционални аргумент "пун", наредба ће такође поново инсталирати пакете у којима се контролна сума инсталације и доступна контролна сума не подударају. И уклоните старе пакете (може се користити за синхронизацију верзија рпмдб). Необавезни аргумент "различит" може се користити за одређивање задате операције. Ова наредба неће изводити операције над групама, локалним пакетима или негативним селекцијама.

уклонити o Ерасе

Користе се за уклањање наведених пакета из система, као и уклањање пакета који зависе од пакета који се уклања.

Напомена: не можете случајно сами уклонити њам.

листа

Користи се за приказ различитих информација о доступним пакетима. Комплетан скуп опција за ову команду је детаљно описан у наставку:

  • њам листа [све | покровитељ1] [покровитељ2] […]

Приказује све доступне и инсталиране пакете.

  • иум листа доступна [покровитељ1] […]

Прикажи све пакете у иум спремиштима доступним за инсталирање.

  • њам ажурирања листе [покровитељ1] […]

Приказује све пакете са исправкама доступним у иум спремиштима.

  • иум листа инсталирана [покровитељ1] […]

Наведите пакете који се сматрају аргументима. Ако се аргумент не подудара са именом доступног пакета, подударања се исписују.

  • иум лист додаци [покровитељ1] […]

Наводи пакете инсталиране на систему који нису доступни ни у једном иум спремишту и који се појављују у конфигурационој датотеци.

  • њам листа застарела [покровитељ1] […]

Наводи пакете инсталиране на систему који су застарели у било којем иум спремишту и који се појављују у конфигурационој датотеци.

  • њам листа недавно [покровитељ1] […]

Наведите пакете који су недавно додати у спремишта. Ово обично није корисно, али ако заиста желите можете да користите додатак иум лист-упдатеинфо како следи: "иум лист-упдатеинфо нев".

Напомена: можете заменити параметар «паттерн1«,«паттерн2', Итд., Са именом пакета који желите да проверите. Имајте на уму да опције означене између [] нису обавезне.

Тренутно је први део овде да се не би превише продужио;).

Садржај чланка се придржава наших принципа уређивачка етика. Да бисте пријавили грешку, кликните овде.

16 коментара, остави свој

Оставите свој коментар

Ваша емаил адреса неће бити објављена. Обавезна поља су означена са *

*

*

  1. За податке одговоран: Мигуел Ангел Гатон
  2. Сврха података: Контрола нежељене поште, управљање коментарима.
  3. Легитимација: Ваш пристанак
  4. Комуникација података: Подаци се неће преносити трећим лицима, осим по законској обавези.
  5. Похрана података: База података коју хостује Оццентус Нетворкс (ЕУ)
  6. Права: У било ком тренутку можете ограничити, опоравити и избрисати своје податке.

  1.   рогертук дијо

    Безбедност самоубиства
    Напомена: Не можете случајно сами да уклоните иум.

  2.   азавеном дијо

    врло добре информације, нека питања КСД која се такође могу инсталирати у убунту? и ако можете да користите дебиан репо у убунту-у?

    1.    Персео дијо

      Можете користити иум као менаџер пакета као алтернативу апт-гет или аптитуде, нисам сигуран да ли бисте могли да користите дебиан пакет у Убунтуу и да ли ради исправно, било би питање тестирања :).

  3.   роцкандролео дијо

    Створили сте за мене егзистенцијалну сумњу ... Њам на Дебиану! (и да, јесте; поткријепио сам то провјером спремишта). Да ли то значи да се .рпм пакети могу инсталирати на дебиан (да ли морам да додам и спремишта?) Или да могу искористити иум-ове команде и ГУИ за инсталирање .деб пакета? Извините ако кажем грозно, али изненађен сам прочитаним.
    Поздрав.

    1.    пандев92 дијо

      Претпоставља се да .деб пакете можете инсталирати с иум-ом, баш као и у пцлинук ос-у, рпм пакете са синаптиц и апт кД

    2.    прави дијо

      Гледајући са логичке тачке гледишта, нормална ствар би била да са иум-ом можете инсталирати .деб пакете, па уместо да пишете "апт-гет инсталл фирефок", напишете "иум инсталл фирефок"

      1.    Хуан Карлос дијо

        И то би требало бити тако, јер је инсталатер једно, а пакет друго.

  4.   ЈУЛИО дијо

    Истина је да схватам да сви користимо оперативни систем, али нико од нас нема ни најмању представу о томе како он функционише.

    http://www.mylifeUnix.org

    1.    Персео дијо

      Ви сте врло прави пријатељ, многи од нас мисле да знамо много ствари о нашем дистро-у, али када мало истражимо, испоставило се да је оно што знамо мали КСД.

  5.   Хуан Карлос дијо

    А кад смо већ код иум-а, да ли сте схватили да Федораши већ директно саветују инсталирање на 64-битним системима?

    1.    прави дијо

      Нисам имао појма, ионако су предности 64-битних система много 🙂

    2.    Персео дијо

      Шта кажете на брате, као што сте истакли, топло се препоручује употреба 64-битне верзије. Према ономе што сам прочитао, Федора к86_64 користи пакете за 64 што је више могуће и само ако не постоје, комбинује их са 32. заиста је супер јер се увек жалимо на лошу компатибилност између 32-битних и 64-битних система.

      Живели :).

  6.   Царлос Емилио дијо

    ИУМ у Дебиану ме не изненађује, будући да је Федора језгра користила апт-гет као менаџера, чак сам креирао верзију 7 или нешто слично, јер волим да комбинујем управитеље пакета, пуно гледам о њима, а недавно сам зезнуо федора 17 за стављање Пацмана (да, АрцхЛинук менаџера) и све је функционисало док нисам поново покренуо КСД

    1.    Персео дијо

      Вау, пацман у Федори *. *, Штета што вам није пошло за руком :(. Оно што сте рекли о промени менаџера пакета између дистрибуција је нешто о чему многи од нас не знају, зато ме је учинило добрим идеја да укажем на податке :).

      Хвала на коментару и на посети, поздрав брате;).

  7.   емилиано дијо

    Федору к86_64 користим око две године.
    Нисам имао проблема.
    Ради много боље од 32-битне верзије.
    Иум је један од најбољих програма за инсталирање.
    Одавно сам престао да користим команду „рпм“ за
    извршити инсталацију преузетих пакета и то
    нису у спремиштима. Ако га комбинујете са «Иумеком»,
    графички интерфејс, они су врло моћни алати.
    У овој најновијој верзији Федоре, „аппер“ ради веома добро,
    бар колико сам покушао, инсталирајући пакете
    урађено из Фирефока, јер је једна од радњи његово инсталирање помоћу
    аппер.

    Срдачан поздрав,

    емилиано
    Бадајоз

    1.    пишкити дијо

      D: